emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* org-latex preview on Windows
@ 2022-08-06 16:11 Jeremie Juste
  0 siblings, 0 replies; 3+ messages in thread
From: Jeremie Juste @ 2022-08-06 16:11 UTC (permalink / raw)
  To: emacs-orgmode

Hello everyone,

I have had difficulties using  org-latex-preview to run properly on Windows.
The main issue seems to be that the user name on windows gets abbreviated
with ~. As far as I understand this generate problems as the temporary
folder cannot be found.

see for instance these posts
https://emacs.stackexchange.com/a/70119

and an old post from Vincente Vera
https://list.orgmode.org/CAMfbzvDPLS1eqXJ=7TZH1035Z3Vq4q4-yJMqsVBcGxzP8kDUjw@mail.gmail.com/

Vincente, suggests altering the temporary environment variable
(setenv "TEMP" "C:\Temp"). I have tried this option and place it in my
.init file but the Temporary file in org-mode uses does not change. 


As a work around I modified the function org-compile-file in lisp/org/
org-macs.el
by adding altering the source variable as such

 (let* ((source (replace-regexp-in-string "JEREMI~1" "JeremieJuste"
source))

This is obviously not an ideal solution but I cannot find any other
solution immediately. Have someone else come across the same issue on
Windows? Do you have any suggestions?

Best regards,
Jeremie
Org mode version 9.5.4
GNU Emacs 28.1 



^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-latex preview on Windows
  2022-08-07 18:05 ` Ypo
@ 2022-08-09 20:12   ` Jeremie Juste
  0 siblings, 0 replies; 3+ messages in thread
From: Jeremie Juste @ 2022-08-09 20:12 UTC (permalink / raw)
  To: Ypo; +Cc: emacs-orgmode

Hello Ypo,

Many thanks for sharing.

On Sunday,  7 Aug 2022 at 20:05, Ypo wrote:
> Hi Jeremie
>
> In my emacs it works great. Even org-fragtog that allows you to edit in
> an interactive manner.
Org impatient is also pretty nice :-)
https://github.com/yangsheng6810/org-latex-impatient

>
> - Just in case it could be helpfult, these are the lines in my init file
> that I can find related to LaTeX:

I manage to solve the problem just by updating the temporary-file-directory
(setq temporary-file-directory
"c:/Users/JeremieJuste/AppData/Local/Temp/")



Best regards,
Jeremie


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: org-latex preview on Windows
       [not found] <mailman.43.1659888009.25095.emacs-orgmode@gnu.org>
@ 2022-08-07 18:05 ` Ypo
  2022-08-09 20:12   ` Jeremie Juste
  0 siblings, 1 reply; 3+ messages in thread
From: Ypo @ 2022-08-07 18:05 UTC (permalink / raw)
  To: emacs-orgmode, jeremiejuste

[-- Attachment #1: Type: text/plain, Size: 2097 bytes --]

Hi Jeremie

In my emacs it works great. Even org-fragtog that allows you to edit in 
an interactive manner.

- Just in case it could be helpfult, these are the lines in my init file 
that I can find related to LaTeX:

(custom-set-variables

  '(org-preview-latex-image-directory "~/borrar/ltximg/")

  '(preview-TeX-style-dir "~/.emacs.d/elpa/auctex-13.0.11/latex" t))


- I installed LaTeX following these instructions:

https://ikaruga2.wordpress.com/2011/06/14/latex-emacs-and-orgmode-in-windows/


- I have edited the Windows System Variable "Path" and added to it:

C:\Program Files\MiKTeX\miktex\bin\x64\


I hope that helps




El 07/08/2022 a las 18:00, emacs-orgmode-request@gnu.org escribió:
> Date: Sat, 06 Aug 2022 18:11:46 +0200
> From: Jeremie Juste<jeremiejuste@gmail.com>
> To:emacs-orgmode@gnu.org
> Subject: org-latex preview on Windows
> Message-ID:<87h72pwdvh.fsf@gmail.com>
> Content-Type: text/plain
>
> Hello everyone,
>
> I have had difficulties using  org-latex-preview to run properly on Windows.
> The main issue seems to be that the user name on windows gets abbreviated
> with ~. As far as I understand this generate problems as the temporary
> folder cannot be found.
>
> see for instance these posts
> https://emacs.stackexchange.com/a/70119
>
> and an old post from Vincente Vera
> https://list.orgmode.org/CAMfbzvDPLS1eqXJ=7TZH1035Z3Vq4q4-yJMqsVBcGxzP8kDUjw@mail.gmail.com/
>
> Vincente, suggests altering the temporary environment variable
> (setenv "TEMP" "C:\Temp"). I have tried this option and place it in my
> .init file but the Temporary file in org-mode uses does not change.
>
>
> As a work around I modified the function org-compile-file in lisp/org/
> org-macs.el
> by adding altering the source variable as such
>
>   (let* ((source (replace-regexp-in-string "JEREMI~1" "JeremieJuste"
> source))
>
> This is obviously not an ideal solution but I cannot find any other
> solution immediately. Have someone else come across the same issue on
> Windows? Do you have any suggestions?
>
> Best regards,
> Jeremie
> Org mode version 9.5.4
> GNU Emacs 28.1

[-- Attachment #2: Type: text/html, Size: 3546 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-08-09 20:13 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-08-06 16:11 org-latex preview on Windows Jeremie Juste
     [not found] <mailman.43.1659888009.25095.emacs-orgmode@gnu.org>
2022-08-07 18:05 ` Ypo
2022-08-09 20:12   ` Jeremie Juste

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).