unofficial mirror of guix-patches@gnu.org 
 help / color / mirror / Atom feed
* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
@ 2020-12-24 13:21 Michael Rohleder
  2020-12-24 21:51 ` Leo Famulari
  2020-12-25 11:02 ` Jonathan Brielmaier
  0 siblings, 2 replies; 8+ messages in thread
From: Michael Rohleder @ 2020-12-24 13:21 UTC (permalink / raw)
  To: 45405

* gnu/packages/xfce.scm (libxfce4util): Update to 4.16.0.

* gnu/packages/xfce.scm (xfconf): Update to 4.16.0.
[arguments]: Remove failing custom-check phase. Disabled tests.

* gnu/packages/xfce.scm (libxfce4ui): Update to 4.16.0.
[inputs]: Remove unneeded gtk+-2.

* gnu/packages/xfce.scm (exo): Update to 4.16.0.
[arguments]: Remove wrap-exo-compose-mail phase.
[inputs]: Remove unneeded gtk+-2 and perl-uri.

* gnu/packages/xfce.scm (garcon): Update to 0.8.0.
[inputs]: Remove unneeded gtk+-2.

* gnu/packages/xfce.scm (tumbler): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-panel): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-xkb-plugin)[arguments]: Add phase to
make it build against 4.16.

* gnu/packages/xfce.scm (xfce4-appfinder): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-session): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-settings): Update to 4.16.0.

* gnu/packages/xfce.scm (thunar): Update to 4.16.0.

* gnu/packages/xfce.scm (thunar-volman): Update to 4.16.0.

* gnu/packages/xfce.scm (xfwm4): Update to 4.16.0.

* gnu/packages/xfce.scm (xfdesktop): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-power-manager): Update to 4.16.0.
---
Tested with some vm-images and xfce-plugins.  As far as I can tell, it looks good ;)

I couldn't get the test for xfconf run, so I disabled it.  If someone(TM) wants
to take a look... (I'm a bit exhausted)

Random Thoughts/Notes:
Sooner or later we need the xfce-dev-tools packaged, because I tried building
xfce4-xkb-plugin from upstream master and noticed it needs it.
(Maybe the xfconf test is also supposed to run with it).

Also, I noticed that debian sid has added a new pkg xfce4-helper yesterday.  Maybe
something like this could be a good idea for us too...

 gnu/packages/xfce.scm | 111 +++++++++++++++++-------------------------
 1 file changed, 44 insertions(+), 67 deletions(-)

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 3b0ff54308..bf90a01e87 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -100,7 +100,7 @@
 (define-public libxfce4util
   (package
     (name "libxfce4util")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -108,7 +108,7 @@
                                   "/" name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "093338faqqsrlc8dkmzr7qv411ysxczg1wlg7s3gvhrfk6vpkb9j"))))
+                "10svnpc8ggasym1pfgh24bfr0ndqs6lc7v1wmpsizj0zbms8snb0"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -126,7 +126,7 @@ Xfce Desktop Environment.")
 (define-public xfconf
   (package
     (name "xfconf")
-    (version "4.14.4")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -134,22 +134,11 @@ Xfce Desktop Environment.")
                                   "xfconf-" version ".tar.bz2"))
               (sha256
                (base32
-                "0wszp93z64112jq5wm4133s64in2ndvnzbgsbn8dh7p5xhp64dyc"))))
+                "09al5bkq89b8pb3xyxnw0cnz6crxj8678ymwq2k9nzf60y812ak5"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
-       ;; Run check after install phase to test dbus activation.
-       (modify-phases %standard-phases
-         (add-after 'install 'custom-check
-           (lambda _
-             (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
-             ;; Run test-suite under a dbus session.
-             (setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
-                     (string-append %output "/share"))
-             ;; For the missing '/etc/machine-id'.
-             (setenv "DBUS_FATAL_WARNINGS" "0");
-             (invoke "dbus-launch" "make" "check")))
-         (delete 'check))))
+     '(#:tests? #f ;; TODO
+       ))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
@@ -172,7 +161,7 @@ storage system.")
 (define-public libxfce4ui
   (package
     (name "libxfce4ui")
-    (version "4.14.1")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -180,7 +169,7 @@ storage system.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1npjhznmnckhnylsv3l7p1zvhckhmp9d7vifs8w12kdfmrg0fjf4"))))
+                "1anfj3n28abv9kbcpybs7q3k5g3c3d0r4xf4hyfqms2b9zlwj1lb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -191,14 +180,11 @@ storage system.")
        ("gobject-introspection" ,gobject-introspection)))
     (propagated-inputs
      `(("gtk+-3" ,gtk+)    ; required by libxfce4ui-2.pc
-       ;; libxfce4kbd-private-2.pc refers to all these.
+       ;; libxfce4kbd-private-3.pc refers to all these.
        ("libxfce4util" ,libxfce4util)
        ("xfconf" ,xfconf)))
     (inputs `(("libsm" ,libsm)
               ("libice" ,libice)
-              ;; FIXME: required by libxfce4ui-1.pc, so should be propagated,
-              ;; but will lead to a conflict with gtk+.
-              ("gtk+-2" ,gtk+-2)
               ("startup-notification" ,startup-notification)))
     (home-page "https://www.xfce.org/")
     (synopsis "Widgets library for Xfce")
@@ -303,7 +289,7 @@ upstream occasionally.")
 (define-public exo
   (package
     (name "exo")
-    (version "0.12.11")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -311,21 +297,8 @@ upstream occasionally.")
                                   "exo-" version ".tar.bz2"))
               (sha256
                (base32
-                "1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
+                "1k5sfm9cmg8k5zzzv0wb2cciqwwklnpfzcpak7wa32lsxl7b0x8r"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; exo won't find URI::Escape otherwise
-         (add-after 'install 'wrap-exo-compose-mail
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (perl5lib (getenv "PERL5LIB")))
-               (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
-                 `("PERL5LIB" ":" prefix
-                   (,(string-append perl5lib ":" out
-                                    "/lib/perl5/site_perl")))))
-             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
@@ -334,10 +307,7 @@ upstream occasionally.")
      `(("gtk+-3" ,gtk+)
        ("libxfce4util" ,libxfce4util)))
     (inputs
-     `(;; FIXME Referred to in exo-1.pc but conflict with gtk+-3.
-       ("gtk+-2" ,gtk+-2)
-       ("libxfce4ui" ,libxfce4ui)
-       ("perl-uri" ,perl-uri)))
+     `(("libxfce4ui" ,libxfce4ui)))
     (home-page "https://www.xfce.org/")
     (synopsis "Extension library for Xfce")
     (description
@@ -350,7 +320,7 @@ development.")
 (define-public garcon
   (package
     (name "garcon")
-    (version "0.7.0")
+    (version "0.8.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -358,14 +328,12 @@ development.")
                                   "garcon-" version ".tar.bz2"))
               (sha256
                (base32
-                "08r4dfvdvl178cjajm7ww16lwb7jsfqh3yz614mn84c0a0dvdhw2"))))
+                "1fx19953fnrk93lak66y3zqbn4n1qvpc77ynzzgdnj5wwngdh4a8"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
        ("glib:bin" ,glib "bin")))
-    (inputs
-     `(("gtk+-2" ,gtk+-2)))             ; required by garcon-gtk2-1.pc
     (propagated-inputs
      `(("gtk+-3" ,gtk+)                 ; required by garcon-gtk3-1.pc
        ("libxfce4ui" ,libxfce4ui)))     ; required by garcon-gtk3-1.pc
@@ -381,7 +349,7 @@ merging features essential for loading menus modified with menu editors.")
 (define-public tumbler
   (package
     (name "tumbler")
-    (version "0.2.9")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -389,7 +357,7 @@ merging features essential for loading menus modified with menu editors.")
                                   "tumbler-" version ".tar.bz2"))
               (sha256
                (base32
-                "1dh7h0jcbf8brvv9vwq4amnk6zgldl2ipdq3clzsx9p50dpr0235"))))
+                "0rmga1l7da0pjrs6jlyq1nfn513r543v7cchshrif1341knpy2wv"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -420,7 +388,7 @@ management D-Bus specification.")
 (define-public xfce4-panel
   (package
     (name "xfce4-panel")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -428,7 +396,7 @@ management D-Bus specification.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1x3flv86jh9vqah7mr5mmfx2991mc6icsqjygsc3j88lgsyz7y6m"))
+                "0gf57hgx6v44bc2hj570inkafbi291scc6wbhmr6sc3xngp9m5sy"))
               (patches (search-patches "xfce4-panel-plugins.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -631,6 +599,15 @@ applications, and includes a search bar to search for applications.")
                (base32
                 "18b7cnaf3zxm598p2i47vim3kbbi8w923ia1hwabdph1c89cz7n1"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; https://gitlab.xfce.org/panel-plugins/xfce4-xkb-plugin/-/issues/37
+         (add-after 'unpack 'fix-build-with-panel-v416
+           (lambda* _
+             (substitute* "panel-plugin/xkb-plugin.h"
+               (("xfce-panel-plugin.h") "libxfce4panel.h"))
+             #t)))))
     (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
@@ -659,7 +636,7 @@ per window.")
 (define-public xfce4-appfinder
   (package
     (name "xfce4-appfinder")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://archive.xfce.org/xfce/"
@@ -667,7 +644,7 @@ per window.")
                                   "/src/" name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "162dibl6ipp72x0s35yhk7kkzxd4qimagg5zdkkv5kjgjpa7bhby"))))
+                "0m09vwgs5i1dy484r2y4w14kp38n469zhg0n4gnj10pcxsm2mf9p"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -686,7 +663,7 @@ your system in categories, so you can quickly find and launch them.")
 (define-public xfce4-session
   (package
     (name "xfce4-session")
-    (version "4.14.2")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -694,7 +671,7 @@ your system in categories, so you can quickly find and launch them.")
                                   "xfce4-session-" version ".tar.bz2"))
               (sha256
                (base32
-                "1bwpylcn7x9i301yz45wvkzah9bncv9b44nf4hh9ln4i1jka9qzv"))
+                "1dqpgnq1hy9z170aapjglyp6jpyq1iqn5331nph727a82br77wi2"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -731,7 +708,7 @@ allows you to shut down the computer from Xfce.")
 (define-public xfce4-settings
   (package
     (name "xfce4-settings")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -739,7 +716,7 @@ allows you to shut down the computer from Xfce.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "0g0ipkg2fyg8r1z95ynx0xjr78bp49c2dwh4mli05nmb4gb40c70"))
+                "1hnx88a8xmi38mdf5gxdvx7n8yax1vzah8hy8g37bijlqx7l18b7"))
               (patches (search-patches "xfce4-settings-defaults.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -758,7 +735,7 @@ allows you to shut down the computer from Xfce.")
        ("libxklavier" ,libxklavier)
        ("libxrandr" ,libxrandr)
        ("libxfce4ui" ,libxfce4ui)
-       ("upower" ,upower)
+       ("upower" ,upower)  ;; TODO: needs upower-glib
        ("xf86-input-libinput" ,xf86-input-libinput)))
     (home-page "https://www.xfce.org/")
     (synopsis "Xfce settings manager")
@@ -770,7 +747,7 @@ like appearance, display, keyboard and mouse settings.")
 (define-public thunar
   (package
     (name "thunar")
-    (version "1.8.16")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -778,7 +755,7 @@ like appearance, display, keyboard and mouse settings.")
                                   "thunar-" version ".tar.bz2"))
               (sha256
                (base32
-                "0k1w2zwa8z6sc8vi3frva74npks79x79n7q9p7ibwk7irfqkh4r2"))))
+                "16zxznc3zcdpcjqjp84j9636kvvrimfn8wj9avxfp4ba254c8xv2"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -802,7 +779,7 @@ fast.")
 (define-public thunar-volman
   (package
     (name "thunar-volman")
-    (version "0.9.5")
+    (version "4.16.0")
     (source
      (origin
        (method url-fetch)
@@ -810,7 +787,7 @@ fast.")
                            (version-major+minor version) "/"
                            "thunar-volman-" version ".tar.bz2"))
        (sha256
-        (base32 "0dqqkbhn43hhmhqyx1fnmawpvysdjzw6ln4ryf629wil6dlwd9vy"))))
+        (base32 "0zaliahfz9ci2md7g6w9mb7z5azi5n56gihbnwyzvds2n8cygh6j"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -833,7 +810,7 @@ and import the new pictures from your camera.")
 (define-public xfwm4
   (package
     (name "xfwm4")
-    (version "4.14.3")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -841,7 +818,7 @@ and import the new pictures from your camera.")
                                   "xfwm4-" version ".tar.bz2"))
               (sha256
                (base32
-                "1gw3fbiwraylarl1bqbvfh7nxlss5w8w0im5ahfg3a9mkrdfr6w2"))))
+                "1czyy4vck4yh6bbxyk6f15mvzv3ndrhabc2k2zyynv5npghyl8hy"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -863,7 +840,7 @@ on the screen.")
 (define-public xfdesktop
   (package
     (name "xfdesktop")
-    (version "4.14.3")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -871,7 +848,7 @@ on the screen.")
                                   "xfdesktop-" version ".tar.bz2"))
               (sha256
                (base32
-                "14sp5a4n21prwmh2l5mjq5fjaq7r2pbjxddfx4wzaix8867x1mq6"))
+                "1bjv2mpkv7zmpzssbvvzh0x4pn8cqm8dvhgsv5i1xwngzspsajwk"))
               (modules '((guix build utils)))
               (snippet
                #~(begin
@@ -1007,7 +984,7 @@ system resources, while still being visually appealing and user friendly.")
 (define-public xfce4-power-manager
   (package
     (name "xfce4-power-manager")
-    (version "1.7.1")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -1015,7 +992,7 @@ system resources, while still being visually appealing and user friendly.")
                                   "xfce4-power-manager-" version ".tar.bz2"))
               (sha256
                (base32
-                "1ki088iyr266cfyq9bmmhhd27wrsrmbhsblyf4yqby03hlvqif3k"))))
+                "1wrvqiifaxsgcn1kh4vm2hwxi9lgm6mw4zrfld2zl0mm05y5i77b"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
-- 
2.29.2





^ permalink raw reply	[flat|nested] 8+ messages in thread

* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
  2020-12-24 13:21 [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0 Michael Rohleder
@ 2020-12-24 21:51 ` Leo Famulari
  2020-12-25 13:24   ` Michael Rohleder
  2020-12-25 11:02 ` Jonathan Brielmaier
  1 sibling, 1 reply; 8+ messages in thread
From: Leo Famulari @ 2020-12-24 21:51 UTC (permalink / raw)
  To: Michael Rohleder; +Cc: 45405

On Thu, Dec 24, 2020 at 02:21:46PM +0100, Michael Rohleder wrote:
> * gnu/packages/xfce.scm (xfdesktop): Update to 4.16.0.
[...]
> Tested with some vm-images and xfce-plugins.  As far as I can tell, it looks good ;)

Thanks for the work and for telling us how tested it!

> I couldn't get the test for xfconf run, so I disabled it.  If someone(TM) wants
> to take a look... (I'm a bit exhausted)

Okay. When your energy is renewed, can you send a message saying what
goes wrong and what you tried?

> Random Thoughts/Notes:
> Sooner or later we need the xfce-dev-tools packaged, because I tried building
> xfce4-xkb-plugin from upstream master and noticed it needs it.
> (Maybe the xfconf test is also supposed to run with it).

Could it be that xfce-dev-tools is needed when building from VCS, but
not for "real" releases?

> Also, I noticed that debian sid has added a new pkg xfce4-helper yesterday.  Maybe
> something like this could be a good idea for us too...

What would that xfce4-helper package do? I couldn't find the new package
on Debian's web site.




^ permalink raw reply	[flat|nested] 8+ messages in thread

* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
  2020-12-24 13:21 [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0 Michael Rohleder
  2020-12-24 21:51 ` Leo Famulari
@ 2020-12-25 11:02 ` Jonathan Brielmaier
  2020-12-25 11:43   ` Michael Rohleder
  1 sibling, 1 reply; 8+ messages in thread
From: Jonathan Brielmaier @ 2020-12-25 11:02 UTC (permalink / raw)
  To: Michael Rohleder, 45405

On 24.12.20 14:21, Michael Rohleder wrote:
> * gnu/packages/xfce.scm (libxfce4util): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfconf): Update to 4.16.0.
> [arguments]: Remove failing custom-check phase. Disabled tests.
>
> * gnu/packages/xfce.scm (libxfce4ui): Update to 4.16.0.
> [inputs]: Remove unneeded gtk+-2.
>
> * gnu/packages/xfce.scm (exo): Update to 4.16.0.
> [arguments]: Remove wrap-exo-compose-mail phase.
> [inputs]: Remove unneeded gtk+-2 and perl-uri.
>
> * gnu/packages/xfce.scm (garcon): Update to 0.8.0.
> [inputs]: Remove unneeded gtk+-2.
>
> * gnu/packages/xfce.scm (tumbler): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfce4-panel): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfce4-xkb-plugin)[arguments]: Add phase to
> make it build against 4.16.
>
> * gnu/packages/xfce.scm (xfce4-appfinder): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfce4-session): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfce4-settings): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (thunar): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (thunar-volman): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfwm4): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfdesktop): Update to 4.16.0.
>
> * gnu/packages/xfce.scm (xfce4-power-manager): Update to 4.16.0.
> ---
> [...]
>   gnu/packages/xfce.scm | 111 +++++++++++++++++-------------------------
>   1 file changed, 44 insertions(+), 67 deletions(-)

Nice one! Although I find it better to have each update as a seperate
commit. If we stick with this big commit we can at least make the commit
message a bit leaner:

* gnu/packages/xfce.scm (libxfce4util): Update to 4.16.0.
(xfconf): Update to 4.16.0.

[arguments]: Remove failing custom-check phase. Disabled tests.
(libxfce4ui): Update to 4.16.0.

[inputs]: Remove unneeded gtk+-2.
...




^ permalink raw reply	[flat|nested] 8+ messages in thread

* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
  2020-12-25 11:02 ` Jonathan Brielmaier
@ 2020-12-25 11:43   ` Michael Rohleder
  2021-01-13 15:15     ` Ludovic Courtès
  0 siblings, 1 reply; 8+ messages in thread
From: Michael Rohleder @ 2020-12-25 11:43 UTC (permalink / raw)
  To: Jonathan Brielmaier; +Cc: 45405

[-- Attachment #1: Type: text/plain, Size: 1051 bytes --]

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
> Nice one! Although I find it better to have each update as a seperate
> commit. If we stick with this big commit we can at least make the commit
> message a bit leaner:
>
> * gnu/packages/xfce.scm (libxfce4util): Update to 4.16.0.
> (xfconf): Update to 4.16.0.
>
> [arguments]: Remove failing custom-check phase. Disabled tests.
> (libxfce4ui): Update to 4.16.0.
>
> [inputs]: Remove unneeded gtk+-2.
> ...
>

A seperate commit for each update would not build inbetween, because of
some (inter)dependencies (libxfce4util, etc...), no?

For the commit messages I took the last xfce4 update (to 4.14) as an
example (commit 8549e0ca6fd68a57253471436de49b88b2d47e64).
If that is/was wrong, I apologize and rewrite them, although I'm not
entirely sure how.

-- 
"One basic notion underlying Usenet is that it is a cooperative."

Having been on USENET for going on ten years, I disagree with this.
The basic notion underlying USENET is the flame.
		-- Chuq Von Rospach

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 511 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
  2020-12-24 21:51 ` Leo Famulari
@ 2020-12-25 13:24   ` Michael Rohleder
  0 siblings, 0 replies; 8+ messages in thread
From: Michael Rohleder @ 2020-12-25 13:24 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 45405


[-- Attachment #1.1: Type: text/plain, Size: 1575 bytes --]

Thank you for reviewing!

Leo Famulari <leo@famulari.name> writes:
>> I couldn't get the test for xfconf run, so I disabled it.  If someone(TM) wants
>> to take a look... (I'm a bit exhausted)
>
> Okay. When your energy is renewed, can you send a message saying what
> goes wrong and what you tried?

With some energy regained, I found that only the last test is hanging,
so I added a hack to disable only that one.

>> Random Thoughts/Notes:
>> Sooner or later we need the xfce-dev-tools packaged, because I tried building
>> xfce4-xkb-plugin from upstream master and noticed it needs it.
>> (Maybe the xfconf test is also supposed to run with it).
>
> Could it be that xfce-dev-tools is needed when building from VCS, but
> not for "real" releases?

Yes, could very well be the case.

>> Also, I noticed that debian sid has added a new pkg xfce4-helper yesterday.  Maybe
>> something like this could be a good idea for us too...
>
> What would that xfce4-helper package do? I couldn't find the new package
> on Debian's web site.
>

They extracted the .desktop files and a python script
("xfce4-compose-mail", see below) from the xfce4-settings package:
https://packages.debian.org/sid/xfce4-helpers and after looking more
closely, I don't think it's useful.


Please find an updated version of the patch.

Changes to the previous version:
- Disable one test in xfconf, not all.
- Removed hack to make xfce4-xkb-plugin compile, because upstream made a
release, see https://issues.guix.gnu.org/45420
- Add python input to xfce4-settings to fix "xfce4-compose-mail" script.


[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #1.2: Update Xfce4 base to 4.16.0 --]
[-- Type: text/x-patch, Size: 16369 bytes --]

>From 60b3ce265ecef258369ac92fc9b8f209e1e88cbe Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Fri, 25 Dec 2020 13:44:33 +0100
Subject: [PATCH] gnu: Update Xfce base to 4.16.0.

* gnu/packages/xfce.scm (libxfce4util): Update to 4.16.0.

* gnu/packages/xfce.scm (xfconf): Update to 4.16.0.
[arguments]: Add phase to disable hanging test.

* gnu/packages/xfce.scm (libxfce4ui): Update to 4.16.0.
[inputs]: Remove unneeded gtk+-2.

* gnu/packages/xfce.scm (exo): Update to 4.16.0.
[arguments]: Remove wrap-exo-compose-mail phase.
[inputs]: Remove unneeded gtk+-2 and perl-uri.

* gnu/packages/xfce.scm (garcon): Update to 0.8.0.
[inputs]: Remove unneeded gtk+-2.

* gnu/packages/xfce.scm (tumbler): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-panel): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-appfinder): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-session): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-settings): Update to 4.16.0.
[inputs]: Add python.

* gnu/packages/xfce.scm (thunar): Update to 4.16.0.

* gnu/packages/xfce.scm (thunar-volman): Update to 4.16.0.

* gnu/packages/xfce.scm (xfwm4): Update to 4.16.0.

* gnu/packages/xfce.scm (xfdesktop): Update to 4.16.0.

* gnu/packages/xfce.scm (xfce4-power-manager): Update to 4.16.0.
---
 gnu/packages/xfce.scm | 96 ++++++++++++++++++-------------------------
 1 file changed, 41 insertions(+), 55 deletions(-)

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 3b0ff54308..8f7c5ffb4a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -54,6 +54,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages popt)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages search)
@@ -100,7 +101,7 @@
 (define-public libxfce4util
   (package
     (name "libxfce4util")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -108,7 +109,7 @@
                                   "/" name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "093338faqqsrlc8dkmzr7qv411ysxczg1wlg7s3gvhrfk6vpkb9j"))))
+                "10svnpc8ggasym1pfgh24bfr0ndqs6lc7v1wmpsizj0zbms8snb0"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -126,7 +127,7 @@ Xfce Desktop Environment.")
 (define-public xfconf
   (package
     (name "xfconf")
-    (version "4.14.4")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -134,12 +135,17 @@ Xfce Desktop Environment.")
                                   "xfconf-" version ".tar.bz2"))
               (sha256
                (base32
-                "0wszp93z64112jq5wm4133s64in2ndvnzbgsbn8dh7p5xhp64dyc"))))
+                "09al5bkq89b8pb3xyxnw0cnz6crxj8678ymwq2k9nzf60y812ak5"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
        ;; Run check after install phase to test dbus activation.
        (modify-phases %standard-phases
+         ;; tests-end seems to hang forever
+         (add-before 'configure 'patchout-tests-end
+           (lambda _
+             (substitute* "tests/Makefile.in"
+               (("tests-end") ""))))
          (add-after 'install 'custom-check
            (lambda _
              (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
@@ -147,7 +153,7 @@ Xfce Desktop Environment.")
              (setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
                      (string-append %output "/share"))
              ;; For the missing '/etc/machine-id'.
-             (setenv "DBUS_FATAL_WARNINGS" "0");
+             (setenv "DBUS_FATAL_WARNINGS" "0")
              (invoke "dbus-launch" "make" "check")))
          (delete 'check))))
     (native-inputs
@@ -172,7 +178,7 @@ storage system.")
 (define-public libxfce4ui
   (package
     (name "libxfce4ui")
-    (version "4.14.1")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -180,7 +186,7 @@ storage system.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1npjhznmnckhnylsv3l7p1zvhckhmp9d7vifs8w12kdfmrg0fjf4"))))
+                "1anfj3n28abv9kbcpybs7q3k5g3c3d0r4xf4hyfqms2b9zlwj1lb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -191,14 +197,11 @@ storage system.")
        ("gobject-introspection" ,gobject-introspection)))
     (propagated-inputs
      `(("gtk+-3" ,gtk+)    ; required by libxfce4ui-2.pc
-       ;; libxfce4kbd-private-2.pc refers to all these.
+       ;; libxfce4kbd-private-3.pc refers to all these.
        ("libxfce4util" ,libxfce4util)
        ("xfconf" ,xfconf)))
     (inputs `(("libsm" ,libsm)
               ("libice" ,libice)
-              ;; FIXME: required by libxfce4ui-1.pc, so should be propagated,
-              ;; but will lead to a conflict with gtk+.
-              ("gtk+-2" ,gtk+-2)
               ("startup-notification" ,startup-notification)))
     (home-page "https://www.xfce.org/")
     (synopsis "Widgets library for Xfce")
@@ -303,7 +306,7 @@ upstream occasionally.")
 (define-public exo
   (package
     (name "exo")
-    (version "0.12.11")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -311,21 +314,8 @@ upstream occasionally.")
                                   "exo-" version ".tar.bz2"))
               (sha256
                (base32
-                "1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
+                "1k5sfm9cmg8k5zzzv0wb2cciqwwklnpfzcpak7wa32lsxl7b0x8r"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; exo won't find URI::Escape otherwise
-         (add-after 'install 'wrap-exo-compose-mail
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (perl5lib (getenv "PERL5LIB")))
-               (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
-                 `("PERL5LIB" ":" prefix
-                   (,(string-append perl5lib ":" out
-                                    "/lib/perl5/site_perl")))))
-             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
@@ -334,10 +324,7 @@ upstream occasionally.")
      `(("gtk+-3" ,gtk+)
        ("libxfce4util" ,libxfce4util)))
     (inputs
-     `(;; FIXME Referred to in exo-1.pc but conflict with gtk+-3.
-       ("gtk+-2" ,gtk+-2)
-       ("libxfce4ui" ,libxfce4ui)
-       ("perl-uri" ,perl-uri)))
+     `(("libxfce4ui" ,libxfce4ui)))
     (home-page "https://www.xfce.org/")
     (synopsis "Extension library for Xfce")
     (description
@@ -350,7 +337,7 @@ development.")
 (define-public garcon
   (package
     (name "garcon")
-    (version "0.7.0")
+    (version "0.8.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -358,14 +345,12 @@ development.")
                                   "garcon-" version ".tar.bz2"))
               (sha256
                (base32
-                "08r4dfvdvl178cjajm7ww16lwb7jsfqh3yz614mn84c0a0dvdhw2"))))
+                "1fx19953fnrk93lak66y3zqbn4n1qvpc77ynzzgdnj5wwngdh4a8"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
        ("glib:bin" ,glib "bin")))
-    (inputs
-     `(("gtk+-2" ,gtk+-2)))             ; required by garcon-gtk2-1.pc
     (propagated-inputs
      `(("gtk+-3" ,gtk+)                 ; required by garcon-gtk3-1.pc
        ("libxfce4ui" ,libxfce4ui)))     ; required by garcon-gtk3-1.pc
@@ -381,7 +366,7 @@ merging features essential for loading menus modified with menu editors.")
 (define-public tumbler
   (package
     (name "tumbler")
-    (version "0.2.9")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -389,7 +374,7 @@ merging features essential for loading menus modified with menu editors.")
                                   "tumbler-" version ".tar.bz2"))
               (sha256
                (base32
-                "1dh7h0jcbf8brvv9vwq4amnk6zgldl2ipdq3clzsx9p50dpr0235"))))
+                "0rmga1l7da0pjrs6jlyq1nfn513r543v7cchshrif1341knpy2wv"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -420,7 +405,7 @@ management D-Bus specification.")
 (define-public xfce4-panel
   (package
     (name "xfce4-panel")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -428,7 +413,7 @@ management D-Bus specification.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1x3flv86jh9vqah7mr5mmfx2991mc6icsqjygsc3j88lgsyz7y6m"))
+                "0gf57hgx6v44bc2hj570inkafbi291scc6wbhmr6sc3xngp9m5sy"))
               (patches (search-patches "xfce4-panel-plugins.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -659,7 +644,7 @@ per window.")
 (define-public xfce4-appfinder
   (package
     (name "xfce4-appfinder")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://archive.xfce.org/xfce/"
@@ -667,7 +652,7 @@ per window.")
                                   "/src/" name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "162dibl6ipp72x0s35yhk7kkzxd4qimagg5zdkkv5kjgjpa7bhby"))))
+                "0m09vwgs5i1dy484r2y4w14kp38n469zhg0n4gnj10pcxsm2mf9p"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -686,7 +671,7 @@ your system in categories, so you can quickly find and launch them.")
 (define-public xfce4-session
   (package
     (name "xfce4-session")
-    (version "4.14.2")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -694,7 +679,7 @@ your system in categories, so you can quickly find and launch them.")
                                   "xfce4-session-" version ".tar.bz2"))
               (sha256
                (base32
-                "1bwpylcn7x9i301yz45wvkzah9bncv9b44nf4hh9ln4i1jka9qzv"))
+                "1dqpgnq1hy9z170aapjglyp6jpyq1iqn5331nph727a82br77wi2"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -731,7 +716,7 @@ allows you to shut down the computer from Xfce.")
 (define-public xfce4-settings
   (package
     (name "xfce4-settings")
-    (version "4.14.0")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -739,7 +724,7 @@ allows you to shut down the computer from Xfce.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "0g0ipkg2fyg8r1z95ynx0xjr78bp49c2dwh4mli05nmb4gb40c70"))
+                "1hnx88a8xmi38mdf5gxdvx7n8yax1vzah8hy8g37bijlqx7l18b7"))
               (patches (search-patches "xfce4-settings-defaults.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -758,7 +743,8 @@ allows you to shut down the computer from Xfce.")
        ("libxklavier" ,libxklavier)
        ("libxrandr" ,libxrandr)
        ("libxfce4ui" ,libxfce4ui)
-       ("upower" ,upower)
+       ("upower" ,upower) ;; TODO needs upower-glib
+       ("python" ,python) ;; for xfce4-compose-mail
        ("xf86-input-libinput" ,xf86-input-libinput)))
     (home-page "https://www.xfce.org/")
     (synopsis "Xfce settings manager")
@@ -770,7 +756,7 @@ like appearance, display, keyboard and mouse settings.")
 (define-public thunar
   (package
     (name "thunar")
-    (version "1.8.16")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -778,7 +764,7 @@ like appearance, display, keyboard and mouse settings.")
                                   "thunar-" version ".tar.bz2"))
               (sha256
                (base32
-                "0k1w2zwa8z6sc8vi3frva74npks79x79n7q9p7ibwk7irfqkh4r2"))))
+                "16zxznc3zcdpcjqjp84j9636kvvrimfn8wj9avxfp4ba254c8xv2"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -802,7 +788,7 @@ fast.")
 (define-public thunar-volman
   (package
     (name "thunar-volman")
-    (version "0.9.5")
+    (version "4.16.0")
     (source
      (origin
        (method url-fetch)
@@ -810,7 +796,7 @@ fast.")
                            (version-major+minor version) "/"
                            "thunar-volman-" version ".tar.bz2"))
        (sha256
-        (base32 "0dqqkbhn43hhmhqyx1fnmawpvysdjzw6ln4ryf629wil6dlwd9vy"))))
+        (base32 "0zaliahfz9ci2md7g6w9mb7z5azi5n56gihbnwyzvds2n8cygh6j"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -833,7 +819,7 @@ and import the new pictures from your camera.")
 (define-public xfwm4
   (package
     (name "xfwm4")
-    (version "4.14.3")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -841,7 +827,7 @@ and import the new pictures from your camera.")
                                   "xfwm4-" version ".tar.bz2"))
               (sha256
                (base32
-                "1gw3fbiwraylarl1bqbvfh7nxlss5w8w0im5ahfg3a9mkrdfr6w2"))))
+                "1czyy4vck4yh6bbxyk6f15mvzv3ndrhabc2k2zyynv5npghyl8hy"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -863,7 +849,7 @@ on the screen.")
 (define-public xfdesktop
   (package
     (name "xfdesktop")
-    (version "4.14.3")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -871,7 +857,7 @@ on the screen.")
                                   "xfdesktop-" version ".tar.bz2"))
               (sha256
                (base32
-                "14sp5a4n21prwmh2l5mjq5fjaq7r2pbjxddfx4wzaix8867x1mq6"))
+                "1bjv2mpkv7zmpzssbvvzh0x4pn8cqm8dvhgsv5i1xwngzspsajwk"))
               (modules '((guix build utils)))
               (snippet
                #~(begin
@@ -1007,7 +993,7 @@ system resources, while still being visually appealing and user friendly.")
 (define-public xfce4-power-manager
   (package
     (name "xfce4-power-manager")
-    (version "1.7.1")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -1015,7 +1001,7 @@ system resources, while still being visually appealing and user friendly.")
                                   "xfce4-power-manager-" version ".tar.bz2"))
               (sha256
                (base32
-                "1ki088iyr266cfyq9bmmhhd27wrsrmbhsblyf4yqby03hlvqif3k"))))
+                "1wrvqiifaxsgcn1kh4vm2hwxi9lgm6mw4zrfld2zl0mm05y5i77b"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
-- 
2.29.2


[-- Attachment #1.3: Type: text/plain, Size: 33 bytes --]



-- 
CHERNOBYL used Windows

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 511 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
  2020-12-25 11:43   ` Michael Rohleder
@ 2021-01-13 15:15     ` Ludovic Courtès
  2021-01-13 16:02       ` Michael Rohleder
  0 siblings, 1 reply; 8+ messages in thread
From: Ludovic Courtès @ 2021-01-13 15:15 UTC (permalink / raw)
  To: Michael Rohleder; +Cc: 45405

Hi Michael,

Michael Rohleder <mike@rohleder.de> skribis:

> Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
>> Nice one! Although I find it better to have each update as a seperate
>> commit. If we stick with this big commit we can at least make the commit
>> message a bit leaner:
>>
>> * gnu/packages/xfce.scm (libxfce4util): Update to 4.16.0.
>> (xfconf): Update to 4.16.0.
>>
>> [arguments]: Remove failing custom-check phase. Disabled tests.
>> (libxfce4ui): Update to 4.16.0.
>>
>> [inputs]: Remove unneeded gtk+-2.
>> ...
>>
>
> A seperate commit for each update would not build inbetween, because of
> some (inter)dependencies (libxfce4util, etc...), no?

Probably; a single commit makes sense when updating large intertwined
stacks like this.

I think this fell through the cracks during the holidays.  Should we go
ahead and apply it; are there additional changes needed?

Thanks,
Ludo’.




^ permalink raw reply	[flat|nested] 8+ messages in thread

* [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0.
  2021-01-13 15:15     ` Ludovic Courtès
@ 2021-01-13 16:02       ` Michael Rohleder
  2021-01-14 16:20         ` bug#45405: " Ludovic Courtès
  0 siblings, 1 reply; 8+ messages in thread
From: Michael Rohleder @ 2021-01-13 16:02 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 45405

[-- Attachment #1: Type: text/plain, Size: 416 bytes --]

Hey Ludo!

Thank you very much!

Ludovic Courtès <ludo@gnu.org> writes:
> I think this fell through the cracks during the holidays.  Should we go
> ahead and apply it; are there additional changes needed?

No, I think the second version of the patch is in good shape and could
be applied, imho.

-- 
I have seen the needle and the damage done
and every junkie is like a setting sun.
   -- Neil Young

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 511 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* bug#45405: [PATCH] gnu: Update Xfce base to 4.16.0.
  2021-01-13 16:02       ` Michael Rohleder
@ 2021-01-14 16:20         ` Ludovic Courtès
  0 siblings, 0 replies; 8+ messages in thread
From: Ludovic Courtès @ 2021-01-14 16:20 UTC (permalink / raw)
  To: Michael Rohleder; +Cc: 45405-done

Hi!

Michael Rohleder <mike@rohleder.de> skribis:

> No, I think the second version of the patch is in good shape and could
> be applied, imho.

I applied it, tested it in a VM to confirm nothing was obviously broken,
tweaked the commit log, and pushed.

That made me realize there’s no updater for Xfce; we should write one!

Thank you!

Ludo’.




^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2021-01-14 16:31 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-24 13:21 [bug#45405] [PATCH] gnu: Update Xfce base to 4.16.0 Michael Rohleder
2020-12-24 21:51 ` Leo Famulari
2020-12-25 13:24   ` Michael Rohleder
2020-12-25 11:02 ` Jonathan Brielmaier
2020-12-25 11:43   ` Michael Rohleder
2021-01-13 15:15     ` Ludovic Courtès
2021-01-13 16:02       ` Michael Rohleder
2021-01-14 16:20         ` bug#45405: " Ludovic Courtès

unofficial mirror of guix-patches@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-patches/1 guix-patches/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-patches guix-patches/ https://yhetil.org/guix-patches \
		guix-patches@gnu.org
	public-inbox-index guix-patches

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.patches


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git