unofficial mirror of emacs-orgmode@gnu.org
 help / color / mirror / Atom feed
* Turning off all indentation in 9.4.4
@ 2021-02-04  6:23 Raoul Comninos
  2021-02-04 17:45 ` Kévin Le Gouguec
  0 siblings, 1 reply; 9+ messages in thread
From: Raoul Comninos @ 2021-02-04  6:23 UTC (permalink / raw)
  To: Orgmode Mailing List

I noticed a change in org since I updated to the latest version when it
comes to automatic indentation. I prefer to turn this off globally,
including for lists. I have tinkered with various settings but have had
no luck so far.
-- 


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-04  6:23 Turning off all indentation in 9.4.4 Raoul Comninos
@ 2021-02-04 17:45 ` Kévin Le Gouguec
  2021-02-14 20:31   ` TRS-80
  0 siblings, 1 reply; 9+ messages in thread
From: Kévin Le Gouguec @ 2021-02-04 17:45 UTC (permalink / raw)
  To: emacs-orgmode

Raoul Comninos <revrari@mweb.co.za> writes:

> I noticed a change in org since I updated to the latest version when it
> comes to automatic indentation. I prefer to turn this off globally,
> including for lists. I have tinkered with various settings but have had
> no luck so far.

ORG-NEWS provides these hints:

> To get the previous behaviour back, disable ~electric-indent-mode~
> explicitly:
> 
> #+begin_src emacs-lisp
> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
> #+end_src
> 
> Alternatively, if you wish to keep =RET= as the "smart-return" key,
> but dislike Org's default indentation of sections, you may prefer to
> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.

Normally I would recommend customizing org-adapt-indentation over
disabing electric-indent-local-mode, but if you'd rather move back to
column 0 when hitting RET in a list, the hook is probably the way to go.



^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-04 17:45 ` Kévin Le Gouguec
@ 2021-02-14 20:31   ` TRS-80
  2021-02-14 21:07     ` Tim Cross
  2021-02-17  4:30     ` Kyle Meyer
  0 siblings, 2 replies; 9+ messages in thread
From: TRS-80 @ 2021-02-14 20:31 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-04 12:45, Kévin Le Gouguec wrote:
> Raoul Comninos <revrari@mweb.co.za> writes:
> 
>> I noticed a change in org since I updated to the latest version when 
>> it
>> comes to automatic indentation. I prefer to turn this off globally,
>> including for lists. I have tinkered with various settings but have 
>> had
>> no luck so far.
> 
> ORG-NEWS provides these hints:
> 
>> To get the previous behaviour back, disable ~electric-indent-mode~
>> explicitly:
>> 
>> #+begin_src emacs-lisp
>> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>> #+end_src
>> 
>> Alternatively, if you wish to keep =RET= as the "smart-return" key,
>> but dislike Org's default indentation of sections, you may prefer to
>> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.
> 
> Normally I would recommend customizing org-adapt-indentation over
> disabing electric-indent-local-mode, but if you'd rather move back to
> column 0 when hitting RET in a list, the hook is probably the way to 
> go.

I have been struggling with this as well.  After reading this email, I
gave it another try.

Unfortunately, unless I am doing something wrong, none of these options
seem to really restore the previous behavior.  I have set
~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
to column 0.  However, unfortunately, TAB now no longer jumps to the
indentation level of the previous block (for example, so I can insert a
code block or other block structure into a plain list at the correct
level).

I am finding all of this /extremely/ annoying, and if I am being honest,
quite obnoxious behavior, which is the last thing I usually expect from
Emacs.

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-14 20:31   ` TRS-80
@ 2021-02-14 21:07     ` Tim Cross
  2021-02-17  4:30     ` Kyle Meyer
  1 sibling, 0 replies; 9+ messages in thread
From: Tim Cross @ 2021-02-14 21:07 UTC (permalink / raw)
  To: emacs-orgmode


TRS-80 <lists.trs-80@isnotmyreal.name> writes:

>
> I have been struggling with this as well.  After reading this email, I
> gave it another try.
>
> Unfortunately, unless I am doing something wrong, none of these options
> seem to really restore the previous behavior.  I have set
> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
> to column 0.  However, unfortunately, TAB now no longer jumps to the
> indentation level of the previous block (for example, so I can insert a
> code block or other block structure into a plain list at the correct
> level).
>

I can report I'm seeing the same behaviour. While now I only get indent
after a heading, I cannot hit tab to indent to the same level as the
last line to insert things like a code blcok or even a new paragraph at
the same indent level.

--
Tim Cross


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-14 20:31   ` TRS-80
  2021-02-14 21:07     ` Tim Cross
@ 2021-02-17  4:30     ` Kyle Meyer
  2021-02-17  7:56       ` Tim Cross
  2021-02-24 20:58       ` TRS-80
  1 sibling, 2 replies; 9+ messages in thread
From: Kyle Meyer @ 2021-02-17  4:30 UTC (permalink / raw)
  To: TRS-80; +Cc: emacs-orgmode

TRS-80 writes:

> On 2021-02-04 12:45, Kévin Le Gouguec wrote:
[...]
>> ORG-NEWS provides these hints:
>> 
>>> To get the previous behaviour back, disable ~electric-indent-mode~
>>> explicitly:
>>> 
>>> #+begin_src emacs-lisp
>>> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>>> #+end_src
>>> 
>>> Alternatively, if you wish to keep =RET= as the "smart-return" key,
>>> but dislike Org's default indentation of sections, you may prefer to
>>> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.
[...]
> Unfortunately, unless I am doing something wrong, none of these options
> seem to really restore the previous behavior.  I have set
> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
> to column 0.  However, unfortunately, TAB now no longer jumps to the
> indentation level of the previous block (for example, so I can insert a
> code block or other block structure into a plain list at the correct
> level).

I think you're talking about the following behavior.

  * a
  <point>foo

With org-adapt-indentation at nil (or the new headline-data value), foo
doesn't get indented.  This behavior is not new to 9.4.  If you try with
9.3.8 and org-adapt-indentation is set to nil, it also will not indent.
Step through org--get-expected-indentation to see how the different
values of org-adapt-indentation are handled.

So, if I'm reading your preferences correctly, it sounds like you want
just the first suggestion in the above snippet, leaving
org-adapt-indentation at its default value:

  (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-17  4:30     ` Kyle Meyer
@ 2021-02-17  7:56       ` Tim Cross
  2021-02-24 20:58       ` TRS-80
  1 sibling, 0 replies; 9+ messages in thread
From: Tim Cross @ 2021-02-17  7:56 UTC (permalink / raw)
  To: emacs-orgmode


Kyle Meyer <kyle@kyleam.com> writes:

> TRS-80 writes:
>
>> On 2021-02-04 12:45, Kévin Le Gouguec wrote:
> [...]
>>> ORG-NEWS provides these hints:
>>>
>>>> To get the previous behaviour back, disable ~electric-indent-mode~
>>>> explicitly:
>>>>
>>>> #+begin_src emacs-lisp
>>>> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>>>> #+end_src
>>>>
>>>> Alternatively, if you wish to keep =RET= as the "smart-return" key,
>>>> but dislike Org's default indentation of sections, you may prefer to
>>>> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.
> [...]
>> Unfortunately, unless I am doing something wrong, none of these options
>> seem to really restore the previous behavior.  I have set
>> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
>> to column 0.  However, unfortunately, TAB now no longer jumps to the
>> indentation level of the previous block (for example, so I can insert a
>> code block or other block structure into a plain list at the correct
>> level).
>
> I think you're talking about the following behavior.
>
>   * a
>   <point>foo
>
> With org-adapt-indentation at nil (or the new headline-data value), foo
> doesn't get indented.  This behavior is not new to 9.4.  If you try with
> 9.3.8 and org-adapt-indentation is set to nil, it also will not indent.
> Step through org--get-expected-indentation to see how the different
> values of org-adapt-indentation are handled.
>
> So, if I'm reading your preferences correctly, it sounds like you want
> just the first suggestion in the above snippet, leaving
> org-adapt-indentation at its default value:
>
>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))

I think it might be slightly more complicated.

For me, here is what I would like

1. Draws and planning data indented according to the headline level
(i.e. headline-data)

2. No indentation on 'normal' lines UNLESS I indent the first line of
the paragraph/block. Then, once I do indent that first line, after
hitting return, I can hit tab and it will indent to the same level as
the proceeding line.

I thought this was the behaviour I use to have before org was updated to
comply with electric-indent mode. I could be wrong.

Currently, if I have org-adaptive-indent set to 'heading-data, if I
manually indent a line, I cannot indent subsequent lines to the same
level. Tab does nothing and I have to hit spaces.

I need to go back through the possible combinations to make sure I
didn't miss something. However, it seems I can have drawers/planning
lines indented to the headline level with org-adaptive-indent set to
heading-data, but then cannot indent individual paragraphs/blocks inside
the heading with tab or I set org-adaptive-indent to nil and manually
indent the draw/planning lines and then can manage content indentation
as I use to.

None of this is critical as it is really just aesthetics (i.e. does not
affect exports), but it did seem to be more DWIM before than it is now.

--
Tim Cross


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-17  4:30     ` Kyle Meyer
  2021-02-17  7:56       ` Tim Cross
@ 2021-02-24 20:58       ` TRS-80
  2021-02-25 14:18         ` TRS-80
  1 sibling, 1 reply; 9+ messages in thread
From: TRS-80 @ 2021-02-24 20:58 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-16 23:30, Kyle Meyer wrote:
> TRS-80 writes:
> 
>> Unfortunately, unless I am doing something wrong, none of these 
>> options
>> seem to really restore the previous behavior.  I have set
>> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
>> to column 0.  However, unfortunately, TAB now no longer jumps to the
>> indentation level of the previous block (for example, so I can insert 
>> a
>> code block or other block structure into a plain list at the correct
>> level).
> 
> I think you're talking about the following behavior.
> 
>   * a
>   <point>foo
> 
> With org-adapt-indentation at nil (or the new headline-data value), foo
> doesn't get indented.  This behavior is not new to 9.4.  If you try 
> with
> 9.3.8 and org-adapt-indentation is set to nil, it also will not indent.
> Step through org--get-expected-indentation to see how the different
> values of org-adapt-indentation are handled.
> 
> So, if I'm reading your preferences correctly, it sounds like you want
> just the first suggestion in the above snippet, leaving
> org-adapt-indentation at its default value:
> 
>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))

OK, I just did eval-expression (M-:) with (electric-indent-local-mode
-1) in an Orgmode buffer.  After very brief testing, it does indeed seem
to return the desired behavior.  So thanks a lot for that tip!

In the same timeframe, I have also noticed my Logbook entries not being
indented (when changing TODO states) which I think was also brought
about by this change (or rather, my changes to org-adapt-indentation).
I am not sure if I should make a separate thread about that, or not?

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-24 20:58       ` TRS-80
@ 2021-02-25 14:18         ` TRS-80
  2021-02-26  6:20           ` Kyle Meyer
  0 siblings, 1 reply; 9+ messages in thread
From: TRS-80 @ 2021-02-25 14:18 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-24 15:58, TRS-80 wrote:
> On 2021-02-16 23:30, Kyle Meyer wrote:
>> TRS-80 writes:
>> 
>>> Unfortunately, unless I am doing something wrong, none of these 
>>> options
>>> seem to really restore the previous behavior.  I have set
>>> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET 
>>> goes
>>> to column 0.  However, unfortunately, TAB now no longer jumps to the
>>> indentation level of the previous block (for example, so I can insert 
>>> a
>>> code block or other block structure into a plain list at the correct
>>> level).
>> 
>> I think you're talking about the following behavior.
>> 
>>   * a
>>   <point>foo
>> 
>> With org-adapt-indentation at nil (or the new headline-data value), 
>> foo
>> doesn't get indented.  This behavior is not new to 9.4.  If you try 
>> with
>> 9.3.8 and org-adapt-indentation is set to nil, it also will not 
>> indent.
>> Step through org--get-expected-indentation to see how the different
>> values of org-adapt-indentation are handled.
>> 
>> So, if I'm reading your preferences correctly, it sounds like you want
>> just the first suggestion in the above snippet, leaving
>> org-adapt-indentation at its default value:
>> 
>>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode 
>> -1)))
> 
> OK, I just did eval-expression (M-:) with (electric-indent-local-mode
> -1) in an Orgmode buffer.  After very brief testing, it does indeed 
> seem
> to return the desired behavior.  So thanks a lot for that tip!
> 
> In the same timeframe, I have also noticed my Logbook entries not being
> indented (when changing TODO states) which I think was also brought
> about by this change (or rather, my changes to org-adapt-indentation).
> I am not sure if I should make a separate thread about that, or not?

OK, so after that yesterday, I went ahead and added
(electric-indent-local-mode -1) to my org-mode hook.  Then today upon
re-starting Emacs, I am back to not working.

By not working I mean:  Pressing enter goes to column 0 as it should,
however then pressing <TAB> does nothing.  Where previously it would
jump to same level as indented above.

My settings are:

- electric-indent-local-mode nil (local in each Orgmode buffer, set via
hook)

- org-adapt-indentation 'headline-data

I am also using adaptive-wrap-prefix-mode to do a soft wrap on left
side, not sure if this is involved or not.

Any help is greatly appreciated, as this is maddeningly aggravating.

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-25 14:18         ` TRS-80
@ 2021-02-26  6:20           ` Kyle Meyer
  0 siblings, 0 replies; 9+ messages in thread
From: Kyle Meyer @ 2021-02-26  6:20 UTC (permalink / raw)
  To: TRS-80; +Cc: emacs-orgmode

TRS-80 writes:

> On 2021-02-24 15:58, TRS-80 wrote:
>> On 2021-02-16 23:30, Kyle Meyer wrote:
[...]
>>> So, if I'm reading your preferences correctly, it sounds like you want
>>> just the first suggestion in the above snippet, leaving
>>> org-adapt-indentation at its default value:
>>> 
>>>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>> 
>> OK, I just did eval-expression (M-:) with (electric-indent-local-mode
>> -1) in an Orgmode buffer.  After very brief testing, it does indeed
>> seem to return the desired behavior.  So thanks a lot for that tip!
[...]
> OK, so after that yesterday, I went ahead and added
> (electric-indent-local-mode -1) to my org-mode hook.  Then today upon
> re-starting Emacs, I am back to not working.
>
> By not working I mean:  Pressing enter goes to column 0 as it should,
> however then pressing <TAB> does nothing.  Where previously it would
> jump to same level as indented above.
>
> My settings are:
>
> - electric-indent-local-mode nil (local in each Orgmode buffer, set via
> hook)
>
> - org-adapt-indentation 'headline-data

I'm just repeating my suggestion from above, but perhaps you want to
leave org-adapt-indentation at its default value of t?


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2021-02-26  6:20 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-04  6:23 Turning off all indentation in 9.4.4 Raoul Comninos
2021-02-04 17:45 ` Kévin Le Gouguec
2021-02-14 20:31   ` TRS-80
2021-02-14 21:07     ` Tim Cross
2021-02-17  4:30     ` Kyle Meyer
2021-02-17  7:56       ` Tim Cross
2021-02-24 20:58       ` TRS-80
2021-02-25 14:18         ` TRS-80
2021-02-26  6:20           ` Kyle Meyer

unofficial mirror of emacs-orgmode@gnu.org

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/orgmode/0 orgmode/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 orgmode orgmode/ https://yhetil.org/orgmode \
		emacs-orgmode@gnu.org
	public-inbox-index orgmode

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.emacs.orgmode
	nntp://news.gmane.io/gmane.emacs.orgmode


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git