emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Turning off all indentation in 9.4.4
@ 2021-02-04  6:23 Raoul Comninos
  2021-02-04 17:45 ` Kévin Le Gouguec
  0 siblings, 1 reply; 14+ messages in thread
From: Raoul Comninos @ 2021-02-04  6:23 UTC (permalink / raw)
  To: Orgmode Mailing List

I noticed a change in org since I updated to the latest version when it
comes to automatic indentation. I prefer to turn this off globally,
including for lists. I have tinkered with various settings but have had
no luck so far.
-- 


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-04  6:23 Turning off all indentation in 9.4.4 Raoul Comninos
@ 2021-02-04 17:45 ` Kévin Le Gouguec
  2021-02-14 20:31   ` TRS-80
  0 siblings, 1 reply; 14+ messages in thread
From: Kévin Le Gouguec @ 2021-02-04 17:45 UTC (permalink / raw)
  To: emacs-orgmode

Raoul Comninos <revrari@mweb.co.za> writes:

> I noticed a change in org since I updated to the latest version when it
> comes to automatic indentation. I prefer to turn this off globally,
> including for lists. I have tinkered with various settings but have had
> no luck so far.

ORG-NEWS provides these hints:

> To get the previous behaviour back, disable ~electric-indent-mode~
> explicitly:
> 
> #+begin_src emacs-lisp
> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
> #+end_src
> 
> Alternatively, if you wish to keep =RET= as the "smart-return" key,
> but dislike Org's default indentation of sections, you may prefer to
> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.

Normally I would recommend customizing org-adapt-indentation over
disabing electric-indent-local-mode, but if you'd rather move back to
column 0 when hitting RET in a list, the hook is probably the way to go.



^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-04 17:45 ` Kévin Le Gouguec
@ 2021-02-14 20:31   ` TRS-80
  2021-02-14 21:07     ` Tim Cross
  2021-02-17  4:30     ` Kyle Meyer
  0 siblings, 2 replies; 14+ messages in thread
From: TRS-80 @ 2021-02-14 20:31 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-04 12:45, Kévin Le Gouguec wrote:
> Raoul Comninos <revrari@mweb.co.za> writes:
> 
>> I noticed a change in org since I updated to the latest version when 
>> it
>> comes to automatic indentation. I prefer to turn this off globally,
>> including for lists. I have tinkered with various settings but have 
>> had
>> no luck so far.
> 
> ORG-NEWS provides these hints:
> 
>> To get the previous behaviour back, disable ~electric-indent-mode~
>> explicitly:
>> 
>> #+begin_src emacs-lisp
>> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>> #+end_src
>> 
>> Alternatively, if you wish to keep =RET= as the "smart-return" key,
>> but dislike Org's default indentation of sections, you may prefer to
>> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.
> 
> Normally I would recommend customizing org-adapt-indentation over
> disabing electric-indent-local-mode, but if you'd rather move back to
> column 0 when hitting RET in a list, the hook is probably the way to 
> go.

I have been struggling with this as well.  After reading this email, I
gave it another try.

Unfortunately, unless I am doing something wrong, none of these options
seem to really restore the previous behavior.  I have set
~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
to column 0.  However, unfortunately, TAB now no longer jumps to the
indentation level of the previous block (for example, so I can insert a
code block or other block structure into a plain list at the correct
level).

I am finding all of this /extremely/ annoying, and if I am being honest,
quite obnoxious behavior, which is the last thing I usually expect from
Emacs.

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-14 20:31   ` TRS-80
@ 2021-02-14 21:07     ` Tim Cross
  2021-02-17  4:30     ` Kyle Meyer
  1 sibling, 0 replies; 14+ messages in thread
From: Tim Cross @ 2021-02-14 21:07 UTC (permalink / raw)
  To: emacs-orgmode


TRS-80 <lists.trs-80@isnotmyreal.name> writes:

>
> I have been struggling with this as well.  After reading this email, I
> gave it another try.
>
> Unfortunately, unless I am doing something wrong, none of these options
> seem to really restore the previous behavior.  I have set
> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
> to column 0.  However, unfortunately, TAB now no longer jumps to the
> indentation level of the previous block (for example, so I can insert a
> code block or other block structure into a plain list at the correct
> level).
>

I can report I'm seeing the same behaviour. While now I only get indent
after a heading, I cannot hit tab to indent to the same level as the
last line to insert things like a code blcok or even a new paragraph at
the same indent level.

--
Tim Cross


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-14 20:31   ` TRS-80
  2021-02-14 21:07     ` Tim Cross
@ 2021-02-17  4:30     ` Kyle Meyer
  2021-02-17  7:56       ` Tim Cross
  2021-02-24 20:58       ` TRS-80
  1 sibling, 2 replies; 14+ messages in thread
From: Kyle Meyer @ 2021-02-17  4:30 UTC (permalink / raw)
  To: TRS-80; +Cc: emacs-orgmode

TRS-80 writes:

> On 2021-02-04 12:45, Kévin Le Gouguec wrote:
[...]
>> ORG-NEWS provides these hints:
>> 
>>> To get the previous behaviour back, disable ~electric-indent-mode~
>>> explicitly:
>>> 
>>> #+begin_src emacs-lisp
>>> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>>> #+end_src
>>> 
>>> Alternatively, if you wish to keep =RET= as the "smart-return" key,
>>> but dislike Org's default indentation of sections, you may prefer to
>>> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.
[...]
> Unfortunately, unless I am doing something wrong, none of these options
> seem to really restore the previous behavior.  I have set
> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
> to column 0.  However, unfortunately, TAB now no longer jumps to the
> indentation level of the previous block (for example, so I can insert a
> code block or other block structure into a plain list at the correct
> level).

I think you're talking about the following behavior.

  * a
  <point>foo

With org-adapt-indentation at nil (or the new headline-data value), foo
doesn't get indented.  This behavior is not new to 9.4.  If you try with
9.3.8 and org-adapt-indentation is set to nil, it also will not indent.
Step through org--get-expected-indentation to see how the different
values of org-adapt-indentation are handled.

So, if I'm reading your preferences correctly, it sounds like you want
just the first suggestion in the above snippet, leaving
org-adapt-indentation at its default value:

  (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-17  4:30     ` Kyle Meyer
@ 2021-02-17  7:56       ` Tim Cross
  2021-02-24 20:58       ` TRS-80
  1 sibling, 0 replies; 14+ messages in thread
From: Tim Cross @ 2021-02-17  7:56 UTC (permalink / raw)
  To: emacs-orgmode


Kyle Meyer <kyle@kyleam.com> writes:

> TRS-80 writes:
>
>> On 2021-02-04 12:45, Kévin Le Gouguec wrote:
> [...]
>>> ORG-NEWS provides these hints:
>>>
>>>> To get the previous behaviour back, disable ~electric-indent-mode~
>>>> explicitly:
>>>>
>>>> #+begin_src emacs-lisp
>>>> (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>>>> #+end_src
>>>>
>>>> Alternatively, if you wish to keep =RET= as the "smart-return" key,
>>>> but dislike Org's default indentation of sections, you may prefer to
>>>> customize ~org-adapt-indentation~ to either =nil= or ='headline-data=.
> [...]
>> Unfortunately, unless I am doing something wrong, none of these options
>> seem to really restore the previous behavior.  I have set
>> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
>> to column 0.  However, unfortunately, TAB now no longer jumps to the
>> indentation level of the previous block (for example, so I can insert a
>> code block or other block structure into a plain list at the correct
>> level).
>
> I think you're talking about the following behavior.
>
>   * a
>   <point>foo
>
> With org-adapt-indentation at nil (or the new headline-data value), foo
> doesn't get indented.  This behavior is not new to 9.4.  If you try with
> 9.3.8 and org-adapt-indentation is set to nil, it also will not indent.
> Step through org--get-expected-indentation to see how the different
> values of org-adapt-indentation are handled.
>
> So, if I'm reading your preferences correctly, it sounds like you want
> just the first suggestion in the above snippet, leaving
> org-adapt-indentation at its default value:
>
>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))

I think it might be slightly more complicated.

For me, here is what I would like

1. Draws and planning data indented according to the headline level
(i.e. headline-data)

2. No indentation on 'normal' lines UNLESS I indent the first line of
the paragraph/block. Then, once I do indent that first line, after
hitting return, I can hit tab and it will indent to the same level as
the proceeding line.

I thought this was the behaviour I use to have before org was updated to
comply with electric-indent mode. I could be wrong.

Currently, if I have org-adaptive-indent set to 'heading-data, if I
manually indent a line, I cannot indent subsequent lines to the same
level. Tab does nothing and I have to hit spaces.

I need to go back through the possible combinations to make sure I
didn't miss something. However, it seems I can have drawers/planning
lines indented to the headline level with org-adaptive-indent set to
heading-data, but then cannot indent individual paragraphs/blocks inside
the heading with tab or I set org-adaptive-indent to nil and manually
indent the draw/planning lines and then can manage content indentation
as I use to.

None of this is critical as it is really just aesthetics (i.e. does not
affect exports), but it did seem to be more DWIM before than it is now.

--
Tim Cross


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-17  4:30     ` Kyle Meyer
  2021-02-17  7:56       ` Tim Cross
@ 2021-02-24 20:58       ` TRS-80
  2021-02-25 14:18         ` TRS-80
  2021-04-28  4:03         ` Bastien
  1 sibling, 2 replies; 14+ messages in thread
From: TRS-80 @ 2021-02-24 20:58 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-16 23:30, Kyle Meyer wrote:
> TRS-80 writes:
> 
>> Unfortunately, unless I am doing something wrong, none of these 
>> options
>> seem to really restore the previous behavior.  I have set
>> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET goes
>> to column 0.  However, unfortunately, TAB now no longer jumps to the
>> indentation level of the previous block (for example, so I can insert 
>> a
>> code block or other block structure into a plain list at the correct
>> level).
> 
> I think you're talking about the following behavior.
> 
>   * a
>   <point>foo
> 
> With org-adapt-indentation at nil (or the new headline-data value), foo
> doesn't get indented.  This behavior is not new to 9.4.  If you try 
> with
> 9.3.8 and org-adapt-indentation is set to nil, it also will not indent.
> Step through org--get-expected-indentation to see how the different
> values of org-adapt-indentation are handled.
> 
> So, if I'm reading your preferences correctly, it sounds like you want
> just the first suggestion in the above snippet, leaving
> org-adapt-indentation at its default value:
> 
>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))

OK, I just did eval-expression (M-:) with (electric-indent-local-mode
-1) in an Orgmode buffer.  After very brief testing, it does indeed seem
to return the desired behavior.  So thanks a lot for that tip!

In the same timeframe, I have also noticed my Logbook entries not being
indented (when changing TODO states) which I think was also brought
about by this change (or rather, my changes to org-adapt-indentation).
I am not sure if I should make a separate thread about that, or not?

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-24 20:58       ` TRS-80
@ 2021-02-25 14:18         ` TRS-80
  2021-02-26  6:20           ` Kyle Meyer
  2021-04-28  4:03         ` Bastien
  1 sibling, 1 reply; 14+ messages in thread
From: TRS-80 @ 2021-02-25 14:18 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-24 15:58, TRS-80 wrote:
> On 2021-02-16 23:30, Kyle Meyer wrote:
>> TRS-80 writes:
>> 
>>> Unfortunately, unless I am doing something wrong, none of these 
>>> options
>>> seem to really restore the previous behavior.  I have set
>>> ~org-adapt-indentation~ to ~'headline-data~, and now pressing RET 
>>> goes
>>> to column 0.  However, unfortunately, TAB now no longer jumps to the
>>> indentation level of the previous block (for example, so I can insert 
>>> a
>>> code block or other block structure into a plain list at the correct
>>> level).
>> 
>> I think you're talking about the following behavior.
>> 
>>   * a
>>   <point>foo
>> 
>> With org-adapt-indentation at nil (or the new headline-data value), 
>> foo
>> doesn't get indented.  This behavior is not new to 9.4.  If you try 
>> with
>> 9.3.8 and org-adapt-indentation is set to nil, it also will not 
>> indent.
>> Step through org--get-expected-indentation to see how the different
>> values of org-adapt-indentation are handled.
>> 
>> So, if I'm reading your preferences correctly, it sounds like you want
>> just the first suggestion in the above snippet, leaving
>> org-adapt-indentation at its default value:
>> 
>>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode 
>> -1)))
> 
> OK, I just did eval-expression (M-:) with (electric-indent-local-mode
> -1) in an Orgmode buffer.  After very brief testing, it does indeed 
> seem
> to return the desired behavior.  So thanks a lot for that tip!
> 
> In the same timeframe, I have also noticed my Logbook entries not being
> indented (when changing TODO states) which I think was also brought
> about by this change (or rather, my changes to org-adapt-indentation).
> I am not sure if I should make a separate thread about that, or not?

OK, so after that yesterday, I went ahead and added
(electric-indent-local-mode -1) to my org-mode hook.  Then today upon
re-starting Emacs, I am back to not working.

By not working I mean:  Pressing enter goes to column 0 as it should,
however then pressing <TAB> does nothing.  Where previously it would
jump to same level as indented above.

My settings are:

- electric-indent-local-mode nil (local in each Orgmode buffer, set via
hook)

- org-adapt-indentation 'headline-data

I am also using adaptive-wrap-prefix-mode to do a soft wrap on left
side, not sure if this is involved or not.

Any help is greatly appreciated, as this is maddeningly aggravating.

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-25 14:18         ` TRS-80
@ 2021-02-26  6:20           ` Kyle Meyer
  2021-02-26 19:12             ` TRS-80
  0 siblings, 1 reply; 14+ messages in thread
From: Kyle Meyer @ 2021-02-26  6:20 UTC (permalink / raw)
  To: TRS-80; +Cc: emacs-orgmode

TRS-80 writes:

> On 2021-02-24 15:58, TRS-80 wrote:
>> On 2021-02-16 23:30, Kyle Meyer wrote:
[...]
>>> So, if I'm reading your preferences correctly, it sounds like you want
>>> just the first suggestion in the above snippet, leaving
>>> org-adapt-indentation at its default value:
>>> 
>>>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode -1)))
>> 
>> OK, I just did eval-expression (M-:) with (electric-indent-local-mode
>> -1) in an Orgmode buffer.  After very brief testing, it does indeed
>> seem to return the desired behavior.  So thanks a lot for that tip!
[...]
> OK, so after that yesterday, I went ahead and added
> (electric-indent-local-mode -1) to my org-mode hook.  Then today upon
> re-starting Emacs, I am back to not working.
>
> By not working I mean:  Pressing enter goes to column 0 as it should,
> however then pressing <TAB> does nothing.  Where previously it would
> jump to same level as indented above.
>
> My settings are:
>
> - electric-indent-local-mode nil (local in each Orgmode buffer, set via
> hook)
>
> - org-adapt-indentation 'headline-data

I'm just repeating my suggestion from above, but perhaps you want to
leave org-adapt-indentation at its default value of t?


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-26  6:20           ` Kyle Meyer
@ 2021-02-26 19:12             ` TRS-80
  2021-04-28  4:09               ` Bastien
  0 siblings, 1 reply; 14+ messages in thread
From: TRS-80 @ 2021-02-26 19:12 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-02-26 01:20, Kyle Meyer wrote:
> TRS-80 writes:
> 
>> On 2021-02-24 15:58, TRS-80 wrote:
>>> On 2021-02-16 23:30, Kyle Meyer wrote:
> [...]
>>>> So, if I'm reading your preferences correctly, it sounds like you 
>>>> want
>>>> just the first suggestion in the above snippet, leaving
>>>> org-adapt-indentation at its default value:
>>>> 
>>>>   (add-hook 'org-mode-hook (lambda () (electric-indent-local-mode 
>>>> -1)))
>>> 
>>> OK, I just did eval-expression (M-:) with (electric-indent-local-mode
>>> -1) in an Orgmode buffer.  After very brief testing, it does indeed
>>> seem to return the desired behavior.  So thanks a lot for that tip!
> [...]
>> OK, so after that yesterday, I went ahead and added
>> (electric-indent-local-mode -1) to my org-mode hook.  Then today upon
>> re-starting Emacs, I am back to not working.
>> 
>> By not working I mean:  Pressing enter goes to column 0 as it should,
>> however then pressing <TAB> does nothing.  Where previously it would
>> jump to same level as indented above.
>> 
>> My settings are:
>> 
>> - electric-indent-local-mode nil (local in each Orgmode buffer, set 
>> via
>> hook)
>> 
>> - org-adapt-indentation 'headline-data
> 
> I'm just repeating my suggestion from above, but perhaps you want to
> leave org-adapt-indentation at its default value of t?

Apologies, I had skipped right over that bit!

Doing as you say appears (after very brief test just now) to have given
me back all the expected behavior:

- RET goes to column zero

- TAB goes to indentation level

- Logbook entries are indented as they should be

However in the course of doing this, it reminded me of what I was trying
to do in the first place, which I thought I could accomplish with some
of the new functionality (headline-data in particular).

In my mind at least, the headline data belongs "with" the headline.  So
all drawers like LOGBOOK and PROPERTIES (and their respective entries,
of course) should all be indented to same level as headline.

Now, I used to think the same way about the body text, but I changed my
mind a year or two (maybe more) ago, as I realized that was just wasting
too mych space.

So, my reading of this new(?) headline-data setting, was that it seemed
to be exactly what I had been looking for!  But perhaps I misunderstood?

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-24 20:58       ` TRS-80
  2021-02-25 14:18         ` TRS-80
@ 2021-04-28  4:03         ` Bastien
  2021-04-29 22:49           ` TRS-80
  1 sibling, 1 reply; 14+ messages in thread
From: Bastien @ 2021-04-28  4:03 UTC (permalink / raw)
  To: TRS-80; +Cc: emacs-orgmode

Hi TRS-80,

TRS-80 <lists.trs-80@isnotmyreal.name> writes:

> In the same timeframe, I have also noticed my Logbook entries not being
> indented (when changing TODO states) which I think was also brought
> about by this change (or rather, my changes to org-adapt-indentation).
> I am not sure if I should make a separate thread about that, or not?

this particular issue has been fixed yesterday in master, if you want
to give it a try.

Thanks!


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-02-26 19:12             ` TRS-80
@ 2021-04-28  4:09               ` Bastien
  2021-04-29 22:30                 ` TRS-80
  0 siblings, 1 reply; 14+ messages in thread
From: Bastien @ 2021-04-28  4:09 UTC (permalink / raw)
  To: TRS-80; +Cc: emacs-orgmode

TRS-80 <lists.trs-80@isnotmyreal.name> writes:

> So, my reading of this new(?) headline-data setting, was that it seemed
> to be exactly what I had been looking for!  But perhaps I misunderstood?

So core idea behind (setq org-adapt-indentation 'headline-data) is to
let people end up with:

* TODO item
  :PROPERTIES:
  :CUSTOM_ID: item
  :END:
  :LOGBOOK:
  ...
  :END:

A paragraph here.

Let me know if if does not what you want, including what you expect
from hitting RET after the headline, with the various combinations of
org-adapt-indentation and electric-indent-mode.


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-04-28  4:09               ` Bastien
@ 2021-04-29 22:30                 ` TRS-80
  0 siblings, 0 replies; 14+ messages in thread
From: TRS-80 @ 2021-04-29 22:30 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-04-28 00:09, Bastien wrote:
> TRS-80 <lists.trs-80@isnotmyreal.name> writes:
> 
>> So, my reading of this new(?) headline-data setting, was that it 
>> seemed
>> to be exactly what I had been looking for!  But perhaps I 
>> misunderstood?
> 
> So core idea behind (setq org-adapt-indentation 'headline-data) is to
> let people end up with:
> 
> * TODO item
>   :PROPERTIES:
>   :CUSTOM_ID: item
>   :END:
>   :LOGBOOK:
>   ...
>   :END:
> 
> A paragraph here.
> 
> Let me know if if does not what you want, including what you expect
> from hitting RET after the headline, with the various combinations of
> org-adapt-indentation and electric-indent-mode.

Thank you for the follow-up, Bastien.

I haven't touched this in a while, but I do believe it does as I had
always wanted (mainly leaving the body alone at column 0 as I
in/out-dent the heading (and its associated data)) which sounds like
the intention.

The one issue I recall experiencing (breaking indentation of logbook
entries) you seem to have addressed in another reply in this thread,
where I will reply with more specifics.

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 14+ messages in thread

* Re: Turning off all indentation in 9.4.4
  2021-04-28  4:03         ` Bastien
@ 2021-04-29 22:49           ` TRS-80
  0 siblings, 0 replies; 14+ messages in thread
From: TRS-80 @ 2021-04-29 22:49 UTC (permalink / raw)
  To: emacs-orgmode

On 2021-04-28 00:03, Bastien wrote:
> TRS-80 <lists.trs-80@isnotmyreal.name> writes:
> 
>> In the same timeframe, I have also noticed my Logbook entries not 
>> being
>> indented (when changing TODO states) which I think was also brought
>> about by this change (or rather, my changes to org-adapt-indentation).
>> I am not sure if I should make a separate thread about that, or not?
> 
> this particular issue has been fixed yesterday in master, if you want
> to give it a try.

Again, thanks for follow up.

I think I had given up on this because of the strange behavior I
couldn't figure out at the time.  In fact, looking again today, my
setting for org-adapt-indentation was commented out in my init file.
Hopefully this is what was fixed recently.  Here is what I remember:

** Heading
    :LOGBOOK:
    - State "CREATED" from           [2021-01-22 Fri 12:56] \\
      - Some comments here.
    :END:

Then doing in/out dent with org-adapt-indentation set to
'headline-data would break just the comment part of the logbook entry,
like so (everything else seemed to move OK):

*** Heading
     :LOGBOOK:
     - State "CREATED" from           [2021-01-22 Fri 12:56] \\
     - Some comments here.
     :END:

I am a Debian user, so I will get to test the latest commit in about 2
more years maybe?  :D

Jokes aside, I appreciate your follow up and so wanted to report back.
I don't know when I will get to actually test the new fix, but if this
is what was fixed I greatly appreciate it.

Cheers,
TRS-80


^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2021-04-29 22:50 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-02-04  6:23 Turning off all indentation in 9.4.4 Raoul Comninos
2021-02-04 17:45 ` Kévin Le Gouguec
2021-02-14 20:31   ` TRS-80
2021-02-14 21:07     ` Tim Cross
2021-02-17  4:30     ` Kyle Meyer
2021-02-17  7:56       ` Tim Cross
2021-02-24 20:58       ` TRS-80
2021-02-25 14:18         ` TRS-80
2021-02-26  6:20           ` Kyle Meyer
2021-02-26 19:12             ` TRS-80
2021-04-28  4:09               ` Bastien
2021-04-29 22:30                 ` TRS-80
2021-04-28  4:03         ` Bastien
2021-04-29 22:49           ` TRS-80

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).