all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / Atom feed
* bug#25138: failing hackage import
@ 2016-12-08 13:56 Dave Love
  2016-12-09 20:57 ` Ludovic Courtès
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Dave Love @ 2016-12-08 13:56 UTC (permalink / raw)
  To: 25138

With guix 20161208.12 I see the following, which would probably take me
a while to debug as I don't know my way around.  (With the 0.11.0
version I got a different error without a backtrace.  I upgraded after
seeing a bug fix for hackage in the tracker.)

  $ guix import hackage -t darcs
  Backtrace:
  In ice-9/boot-9.scm:
   160: 16 [catch #t #<catch-closure 11e6e40> ...]
  In unknown file:
     ?: 15 [apply-smob/1 #<catch-closure 11e6e40>]
  In ice-9/boot-9.scm:
    66: 14 [call-with-prompt prompt0 ...]
  In ice-9/eval.scm:
   432: 13 [eval # #]
  In ice-9/boot-9.scm:
  2404: 12 [save-module-excursion #<procedure 1206900 at ice-9/boot-9.scm:4051:3 ()>]
  4056: 11 [#<procedure 1206900 at ice-9/boot-9.scm:4051:3 ()>]
  1727: 10 [%start-stack load-stack ...]
  1732: 9 [#<procedure 1219b70 ()>]
  In unknown file:
     ?: 8 [primitive-load "/gnu/store/hckw4cw3m6r55afrldhn9gf66wrznh7i-guix-0.11.0-8.8d12/bin/.guix-real"]
  In guix/ui.scm:
  1222: 7 [run-guix-command import "hackage" "-t" "darcs"]
  In guix/scripts/import.scm:
   110: 6 [guix-import "hackage" "-t" "darcs"]
  In guix/scripts/import/hackage.scm:
   110: 5 [guix-import-hackage "-t" "darcs"]
  In guix/import/hackage.scm:
   247: 4 [hackage->guix-package "darcs" #:include-test-dependencies? ...]
   113: 3 [hackage-fetch "darcs"]
  In guix/import/cabal.scm:
   580: 2 [read-cabal #<input: r6rs-custom-binary-input-port 38ef8f0> #f]
  In system/base/lalr.upstream.scm:
  1956: 1 [___run]
  1851: 0 [___push 1 6 ...]
  
  system/base/lalr.upstream.scm:1851:2: In procedure ___push:
  system/base/lalr.upstream.scm:1851:2: Wrong number of arguments to #<procedure ___push (delta new-category lvalue tok)>

^ permalink raw reply	[flat|nested] 6+ messages in thread

* bug#25138: failing hackage import
  2016-12-08 13:56 bug#25138: failing hackage import Dave Love
@ 2016-12-09 20:57 ` Ludovic Courtès
  2016-12-09 22:09   ` Federico Beffa
  2016-12-12 13:40   ` Dave Love
  2019-05-22 15:39 ` bug#25138: updated import error Robert Vollmert
  2021-09-15 12:34 ` bug#25138: guix import hackage darcs: fails due to flag executable Lars-Dominik Braun
  2 siblings, 2 replies; 6+ messages in thread
From: Ludovic Courtès @ 2016-12-09 20:57 UTC (permalink / raw)
  To: Dave Love; +Cc: 25138, Federico Beffa

Hi,

Dave Love <fx@gnu.org> skribis:

> With guix 20161208.12 I see the following, which would probably take me
> a while to debug as I don't know my way around.  (With the 0.11.0
> version I got a different error without a backtrace.  I upgraded after
> seeing a bug fix for hackage in the tracker.)
>
>   $ guix import hackage -t darcs
>   Backtrace:
>   In ice-9/boot-9.scm:
>    160: 16 [catch #t #<catch-closure 11e6e40> ...]
>   In unknown file:
>      ?: 15 [apply-smob/1 #<catch-closure 11e6e40>]
>   In ice-9/boot-9.scm:
>     66: 14 [call-with-prompt prompt0 ...]
>   In ice-9/eval.scm:
>    432: 13 [eval # #]
>   In ice-9/boot-9.scm:
>   2404: 12 [save-module-excursion #<procedure 1206900 at ice-9/boot-9.scm:4051:3 ()>]
>   4056: 11 [#<procedure 1206900 at ice-9/boot-9.scm:4051:3 ()>]
>   1727: 10 [%start-stack load-stack ...]
>   1732: 9 [#<procedure 1219b70 ()>]
>   In unknown file:
>      ?: 8 [primitive-load "/gnu/store/hckw4cw3m6r55afrldhn9gf66wrznh7i-guix-0.11.0-8.8d12/bin/.guix-real"]
>   In guix/ui.scm:
>   1222: 7 [run-guix-command import "hackage" "-t" "darcs"]
>   In guix/scripts/import.scm:
>    110: 6 [guix-import "hackage" "-t" "darcs"]
>   In guix/scripts/import/hackage.scm:
>    110: 5 [guix-import-hackage "-t" "darcs"]
>   In guix/import/hackage.scm:
>    247: 4 [hackage->guix-package "darcs" #:include-test-dependencies? ...]
>    113: 3 [hackage-fetch "darcs"]
>   In guix/import/cabal.scm:
>    580: 2 [read-cabal #<input: r6rs-custom-binary-input-port 38ef8f0> #f]
>   In system/base/lalr.upstream.scm:
>   1956: 1 [___run]
>   1851: 0 [___push 1 6 ...]
>   
>   system/base/lalr.upstream.scm:1851:2: In procedure ___push:
>   system/base/lalr.upstream.scm:1851:2: Wrong number of arguments to #<procedure ___push (delta new-category lvalue tok)>

I’m seeing a different error:

--8<---------------cut here---------------start------------->8---
$ git describe
v0.11.0-3322-gf80b4d2
$ ./pre-inst-env guix import hackage -t darcs
Syntax error: unexpected token : (buildable (False)) (at line 494, column 4)
Syntax error: unexpected end of input
guix import: error: failed to download cabal file for package 'darcs'
--8<---------------cut here---------------end--------------->8---

The .cabal file is at
<https://hackage.haskell.org/package/darcs/darcs.cabal> and the faulty
line comes from:

--8<---------------cut here---------------start------------->8---
Executable          darcs
  if !flag(executable)
    buildable: False
  else
    buildable: True
--8<---------------cut here---------------end--------------->8---

In addition, this .cabal file has “Build-Type: Custom”, which is
currently not supported as noted in <https://bugs.gnu.org/23961>.

Federico, WDYT?

Thanks,
Ludo’.

^ permalink raw reply	[flat|nested] 6+ messages in thread

* bug#25138: failing hackage import
  2016-12-09 20:57 ` Ludovic Courtès
@ 2016-12-09 22:09   ` Federico Beffa
  2016-12-12 13:40   ` Dave Love
  1 sibling, 0 replies; 6+ messages in thread
From: Federico Beffa @ 2016-12-09 22:09 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: Dave Love, 25138

On Fri, Dec 9, 2016 at 9:57 PM, Ludovic Courtès <ludo@gnu.org> wrote:
> I’m seeing a different error:
>
> --8<---------------cut here---------------start------------->8---
> $ git describe
> v0.11.0-3322-gf80b4d2
> $ ./pre-inst-env guix import hackage -t darcs
> Syntax error: unexpected token : (buildable (False)) (at line 494, column 4)
> Syntax error: unexpected end of input
> guix import: error: failed to download cabal file for package 'darcs'
> --8<---------------cut here---------------end--------------->8---
>
> The .cabal file is at
> <https://hackage.haskell.org/package/darcs/darcs.cabal> and the faulty
> line comes from:
>
> --8<---------------cut here---------------start------------->8---
> Executable          darcs
>   if !flag(executable)
>     buildable: False
>   else
>     buildable: True
> --8<---------------cut here---------------end--------------->8---
>
> In addition, this .cabal file has “Build-Type: Custom”, which is
> currently not supported as noted in <https://bugs.gnu.org/23961>.
>
> Federico, WDYT?

The problem is that the name of the flag is 'executable' and the
string 'executable' is also a reserved keyword to define the start of
a cabal file section.  The cabal parser incorrectly dismissed this
keyword as a possible flag name (in the code it is referred to as a
test identifier).  See line 369 of the file 'guix/import/cabal.scm'.
The predicate 'is-id' should be smarter and recognize if the string
'executable' refers to the start of an 'executable section' or not
(and similarly for some other reserved keywords dismissed by the same
procedure).

The predicate 'is-id' dismisses some specific reserved keywords such
as 'executable' because this check is performed before the ones (based
on full lines) such as 'is-exec' which checks for the start of an
executable section.

HTH,
Fede

^ permalink raw reply	[flat|nested] 6+ messages in thread

* bug#25138: failing hackage import
  2016-12-09 20:57 ` Ludovic Courtès
  2016-12-09 22:09   ` Federico Beffa
@ 2016-12-12 13:40   ` Dave Love
  1 sibling, 0 replies; 6+ messages in thread
From: Dave Love @ 2016-12-12 13:40 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 25138, Federico Beffa

Ludovic Courtès <ludo@gnu.org> writes:

> I’m seeing a different error:
>
> --8<---------------cut here---------------start------------->8---
> $ git describe
> v0.11.0-3322-gf80b4d2
> $ ./pre-inst-env guix import hackage -t darcs
> Syntax error: unexpected token : (buildable (False)) (at line 494, column 4)
> Syntax error: unexpected end of input
> guix import: error: failed to download cabal file for package 'darcs'
> --8<---------------cut here---------------end--------------->8---

That's what I saw with 0.11, but the new version with the backtrace
seemed a worthwhile improvement!  (I tried an update after looking for a
way to configure generating backtraces and not finding one for guix or
an environment variable for guile that might have done it.)

^ permalink raw reply	[flat|nested] 6+ messages in thread

* bug#25138: updated import error
  2016-12-08 13:56 bug#25138: failing hackage import Dave Love
  2016-12-09 20:57 ` Ludovic Courtès
@ 2019-05-22 15:39 ` Robert Vollmert
  2021-09-15 12:34 ` bug#25138: guix import hackage darcs: fails due to flag executable Lars-Dominik Braun
  2 siblings, 0 replies; 6+ messages in thread
From: Robert Vollmert @ 2019-05-22 15:39 UTC (permalink / raw)
  To: 25138

These days it’s:

Syntax error: unexpected token : (buildable (False)) (at line 471, column 4)
Syntax error: unexpected end of input

Relevant cabal extract:

   469  Executable          darcs
   470    if !flag(executable)
   471      buildable: False
   472    else
   473      buildable: True
   474  

^ permalink raw reply	[flat|nested] 6+ messages in thread

* bug#25138: guix import hackage darcs: fails due to flag executable
  2016-12-08 13:56 bug#25138: failing hackage import Dave Love
  2016-12-09 20:57 ` Ludovic Courtès
  2019-05-22 15:39 ` bug#25138: updated import error Robert Vollmert
@ 2021-09-15 12:34 ` Lars-Dominik Braun
  2 siblings, 0 replies; 6+ messages in thread
From: Lars-Dominik Braun @ 2021-09-15 12:34 UTC (permalink / raw)
  To: Dave Love; +Cc: 25138-done

Hi,

this was fixed by the patch from #50588.

Cheers,
Lars





^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-09-15 12:37 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-12-08 13:56 bug#25138: failing hackage import Dave Love
2016-12-09 20:57 ` Ludovic Courtès
2016-12-09 22:09   ` Federico Beffa
2016-12-12 13:40   ` Dave Love
2019-05-22 15:39 ` bug#25138: updated import error Robert Vollmert
2021-09-15 12:34 ` bug#25138: guix import hackage darcs: fails due to flag executable Lars-Dominik Braun

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.