all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
* [bug#53278] [PATCH] gnu: emacs-consult: Remove propagated-inputs.
@ 2022-01-15  7:46 Aleksandr Vityazev
  2022-01-15 20:30 ` bug#53278: " Nicolas Goaziou
  0 siblings, 1 reply; 2+ messages in thread
From: Aleksandr Vityazev @ 2022-01-15  7:46 UTC (permalink / raw)
  To: 53278

* gnu/packages/emacs-xyz (emacs-consult): [propagated-inputs]:
  Remove emacs-flycheck, there is currently no consult-flycheck.el
file in the consult.el repository. consult-flycheck.el is stored in
its own repository.
  Remove emacs-selectrum, an optional dependency. Not required for
successful compilation.
---
 gnu/packages/emacs-xyz.scm | 2 --
 1 file changed, 2 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f7022d1f34..c5cb07e16e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8249,8 +8249,6 @@ (define-public emacs-consult
         (base32 "051fjp03lj3b5kkzpdhk78g2lj37v973q0f012zld1n6937srj6h"))
        (file-name (git-file-name name version))))
     (build-system emacs-build-system)
-    (propagated-inputs
-     (list emacs-flycheck emacs-selectrum))
     (home-page "https://github.com/minad/consult")
     (synopsis "Consulting completing-read")
     (description "This package provides various handy commands based on the
-- 
2.34.0



-- 

Aleksandr Vityazev




^ permalink raw reply	[flat|nested] 2+ messages in thread

* bug#53278: [PATCH] gnu: emacs-consult: Remove propagated-inputs.
  2022-01-15  7:46 [bug#53278] [PATCH] gnu: emacs-consult: Remove propagated-inputs Aleksandr Vityazev
@ 2022-01-15 20:30 ` Nicolas Goaziou
  0 siblings, 0 replies; 2+ messages in thread
From: Nicolas Goaziou @ 2022-01-15 20:30 UTC (permalink / raw)
  To: Aleksandr Vityazev; +Cc: 53278-done

Hello,

Aleksandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/emacs-xyz (emacs-consult): [propagated-inputs]:
>   Remove emacs-flycheck, there is currently no consult-flycheck.el
> file in the consult.el repository. consult-flycheck.el is stored in
> its own repository.
>   Remove emacs-selectrum, an optional dependency. Not required for
> successful compilation.

Applied. Thank you.

Regards,
-- 
Nicolas Goaziou




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-01-15 20:31 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-15  7:46 [bug#53278] [PATCH] gnu: emacs-consult: Remove propagated-inputs Aleksandr Vityazev
2022-01-15 20:30 ` bug#53278: " Nicolas Goaziou

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.