unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* freecad 19.1 / flatpak
@ 2021-03-31  9:15 Christophe Pisteur
  2021-03-31  9:46 ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-03-31  9:15 UTC (permalink / raw)
  To: help guix

Hello,

After having failed to install freecad from an Appimage on guix system
(1), a new version of freecad (freecad 19.1) has just been realised and
proposed on flathub (2).

Unfortunately, the addon manager does not work with this version of
freecad on flathub on guix system. But it is in the addons that we find
one of the main functions until a mature version can be included in the
main project: the assembly modules (A2+, Assembly2, Assembly4). 

Here are the error messages:

1) When launching freecad from terminal:
$ flatpak run org.freecadweb.FreeCAD
FreeCAD 0.19, Libs: 0.19R14555 (Git shallow)
© Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2021
FreeCAD is free and open-source software licensed under the terms of
LGPL2+ license.
FreeCAD wouldn't be possible without FreeCAD community.
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Traceback (most recent call last):
  File "/app/freecad/Mod/Tux/NavigationIndicatorGui.py", line 55, in
changeEvent
    onTooltip()
NameError: name 'onTooltip' is not defined
connect failed: Aucun fichier ou dossier de ce type

2) When you click on the "install" button from the addon manager:
Traceback (most recent call last):
  File "/app/freecad/Mod/AddonManager/addonmanager_workers.py", line
769, in run
    repo = git.Repo.clone_from(self.repos[idx][1], clonedir)
  File "/app/lib/python3.8/site-packages/git/repo/base.py", line 1032,
in clone_from
    return cls._clone(git, url, to_path, GitCmdObjectDB, progress,
multi_options, **kwargs)
  File "/app/lib/python3.8/site-packages/git/repo/base.py", line 973,
in _clone
    finalize_process(proc, stderr=stderr)
  File "/app/lib/python3.8/site-packages/git/util.py", line 329, in
finalize_process
    proc.wait(**kwargs)
  File "/app/lib/python3.8/site-packages/git/cmd.py", line 408, in wait
    raise GitCommandError(self.args, status, errstr)
git.exc.GitCommandError: Cmd('git') failed due to: exit code(128)
  cmdline: git clone -v https://github.com/Zolko-123/FreeCAD_Assembly4
/home/christophe/.FreeCAD//Mod/Assembly4
  stderr: 'Cloning into '/home/christophe/.FreeCAD//Mod/Assembly4'...
fatal: unable to find remote helper for 'https'

I tried with several addons: same results. 

Any Idea? 

Christophe

(1) https://lists.gnu.org/archive/html/help-guix/2021-02/msg00035.html
(2) https://flathub.org/apps/details/org.freecadweb.FreeCAD


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-03-31  9:15 freecad 19.1 / flatpak Christophe Pisteur
@ 2021-03-31  9:46 ` Ekaitz Zarraga
  2021-03-31 12:56   ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-03-31  9:46 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help guix

Hi there,


On Wednesday, March 31, 2021 11:15 AM, Christophe Pisteur <christophe.pisteur@fsfe.org> wrote:

> Hello,
>
> After having failed to install freecad from an Appimage on guix system
> (1), a new version of freecad (freecad 19.1) has just been realised and
> proposed on flathub (2).
>
> Unfortunately, the addon manager does not work with this version of
> freecad on flathub on guix system. But it is in the addons that we find
> one of the main functions until a mature version can be included in the
> main project: the assembly modules (A2+, Assembly2, Assembly4).
>
> Here are the error messages:
>
> 1.  When launching freecad from terminal:
>     $ flatpak run org.freecadweb.FreeCAD
>     FreeCAD 0.19, Libs: 0.19R14555 (Git shallow)
>     © Juergen Riegel, Werner Mayer, Yorik van Havre and others 2001-2021
>     FreeCAD is free and open-source software licensed under the terms of
>     LGPL2+ license.
>     FreeCAD wouldn't be possible without FreeCAD community.
>
>
> ##### #### ###
>
> # # # #
>
> ========
>
> ## #### #### # # # #
>
> =====================
>
> #### # # # # # # # ##### #
>
> # #### #### # # # #
>
> ====================
>
> # # # # # # # # ## ##
>
> ======================
>
> # #### #### ### # # #### ## ##
>
> ===============================
>
> Traceback (most recent call last):
> File "/app/freecad/Mod/Tux/NavigationIndicatorGui.py", line 55, in
> changeEvent
> onTooltip()
> NameError: name 'onTooltip' is not defined
> connect failed: Aucun fichier ou dossier de ce type
>
> 2) When you click on the "install" button from the addon manager:
> Traceback (most recent call last):
> File "/app/freecad/Mod/AddonManager/addonmanager_workers.py", line
> 769, in run
> repo = git.Repo.clone_from(self.repos[idx][1], clonedir)
> File "/app/lib/python3.8/site-packages/git/repo/base.py", line 1032,
> in clone_from
> return cls._clone(git, url, to_path, GitCmdObjectDB, progress,
> multi_options, **kwargs)
> File "/app/lib/python3.8/site-packages/git/repo/base.py", line 973,
> in _clone
> finalize_process(proc, stderr=stderr)
> File "/app/lib/python3.8/site-packages/git/util.py", line 329, in
> finalize_process
> proc.wait(**kwargs)
> File "/app/lib/python3.8/site-packages/git/cmd.py", line 408, in wait
> raise GitCommandError(self.args, status, errstr)
> git.exc.GitCommandError: Cmd('git') failed due to: exit code(128)
> cmdline: git clone -v https://github.com/Zolko-123/FreeCAD_Assembly4
> /home/christophe/.FreeCAD//Mod/Assembly4
> stderr: 'Cloning into '/home/christophe/.FreeCAD//Mod/Assembly4'...
> fatal: unable to find remote helper for 'https'
>
> I tried with several addons: same results.
>
> Any Idea?
>
> Christophe
>
> (1) https://lists.gnu.org/archive/html/help-guix/2021-02/msg00035.html
> (2) https://flathub.org/apps/details/org.freecadweb.FreeCAD



According to a random blogpost in the wild you can see this:
https://blog.hostonnet.com/git-unable-to-find-remote-helper-for-https

Looks like your git is not installed with SSL support. Probably
the package comes with its own git and it's not capable enough.

Try to install it separately or something. I'm not sure if
flatpak is going to use it or not, because I have no idea about
how flatpak works, but the problem you have is because of the
git version your freecad is using.

Hope that helps,

Ekaitz


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-03-31  9:46 ` Ekaitz Zarraga
@ 2021-03-31 12:56   ` Christophe Pisteur
  2021-03-31 14:29     ` Gary Johnson
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-03-31 12:56 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help guix

Le mercredi 31 mars 2021 à 09:46 +0000, Ekaitz Zarraga a écrit :
> Hi there,
> 
> On Wednesday, March 31, 2021 11:15 AM, Christophe Pisteur <
> christophe.pisteur@fsfe.org> wrote:
> > Hello,
> > After having failed to install freecad from an Appimage on guix
> > system(1), a new version of freecad (freecad 19.1) has just been
> > realised andproposed on flathub (2).
> > Unfortunately, the addon manager does not work with this version
> > offreecad on flathub on guix system. But it is in the addons that
> > we findone of the main functions until a mature version can be
> > included in themain project: the assembly modules (A2+, Assembly2,
> > Assembly4).
> > ...
> 
> According to a random blogpost in the wild you can see this:
> https://blog.hostonnet.com/git-unable-to-find-remote-helper-for-https
> 
> Looks like your git is not installed with SSL support. Probablythe
> package comes with its own git and it's not capable enough.
> Try to install it separately or something. I'm not sure ifflatpak is
> going to use it or not, because I have no idea abouthow flatpak
> works, but the problem you have is because of thegit version your
> freecad is using.
> Hope that helps,
> Ekaitz

Thank you for the quick answer.
I have git installed on my system via 
guix package -i git
which is probably with ssl support?
So I think that the version of flatpak does not use this version of my
system. 
From there, I am blocked.

Christophe

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-03-31 12:56   ` Christophe Pisteur
@ 2021-03-31 14:29     ` Gary Johnson
  2021-03-31 18:38       ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Gary Johnson @ 2021-03-31 14:29 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: Ekaitz Zarraga, help-guix

Christophe Pisteur <christophe.pisteur@fsfe.org> writes:

> Thank you for the quick answer.
> I have git installed on my system via 
> guix package -i git
> which is probably with ssl support?
> So I think that the version of flatpak does not use this version of my
> system. 
> From there, I am blocked.
>
> Christophe

The git package for Guix includes SSL support. Since flatpak is kind of
its own world, perhaps you should try installing git through flatpak as
well in hopes that FreeCAD will be able to use that version.

Good luck,
  Gary

-- 
GPG Key ID: 7BC158ED
Use `gpg --search-keys lambdatronic' to find me
Protect yourself from surveillance: https://emailselfdefense.fsf.org
=======================================================================
()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments

Why is HTML email a security nightmare? See https://useplaintext.email/

Please avoid sending me MS-Office attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-03-31 14:29     ` Gary Johnson
@ 2021-03-31 18:38       ` Christophe Pisteur
  2021-04-02 14:43         ` Gary Johnson
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-03-31 18:38 UTC (permalink / raw)
  To: Gary Johnson; +Cc: help-guix



Le mercredi 31 mars 2021 à 10:29 -0400, Gary Johnson a écrit :
> Christophe Pisteur <christophe.pisteur@fsfe.org> writes:
> > Thank you for the quick answer.I have git installed on my system
> > via guix package -i gitwhich is probably with ssl support?So I
> > think that the version of flatpak does not use this version of
> > mysystem. From there, I am blocked.
> > Christophe
> 
> The git package for Guix includes SSL support. Since flatpak is kind
> ofits own world, perhaps you should try installing git through
> flatpak aswell in hopes that FreeCAD will be able to use that
> version.
> Good luck,  Gary

Unfortunately there is no git on flathub. There is only gitg, which I
installed, but the problem remains with the freecad addons. 

Christophe

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-03-31 18:38       ` Christophe Pisteur
@ 2021-04-02 14:43         ` Gary Johnson
  2021-04-03 19:10           ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Gary Johnson @ 2021-04-02 14:43 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: Ekaitz Zarraga, help-guix

Christophe Pisteur <christophe.pisteur@fsfe.org> writes:

> Unfortunately there is no git on flathub. There is only gitg, which I
> installed, but the problem remains with the freecad addons. 

That's unfortunate. So...maybe I missed (or forgot) this part of the
discussion, but I see that guix has a package definition for freecad. Is
there a reason you don't want to build and install it through guix
instead of flatpak?

-- 
GPG Key ID: 7BC158ED
Use `gpg --search-keys lambdatronic' to find me
Protect yourself from surveillance: https://emailselfdefense.fsf.org
=======================================================================
()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments

Why is HTML email a security nightmare? See https://useplaintext.email/

Please avoid sending me MS-Office attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-02 14:43         ` Gary Johnson
@ 2021-04-03 19:10           ` Christophe Pisteur
  2021-04-03 19:21             ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-03 19:10 UTC (permalink / raw)
  To: Gary Johnson; +Cc: help-guix

Le vendredi 02 avril 2021 à 10:43 -0400, Gary Johnson a écrit :
> Christophe Pisteur <christophe.pisteur@fsfe.org> writes:
> > Unfortunately there is no git on flathub. There is only gitg, which
> > Iinstalled, but the problem remains with the freecad addons. 
> 
> That's unfortunate. So...maybe I missed (or forgot) this part of
> thediscussion, but I see that guix has a package definition for
> freecad. Isthere a reason you don't want to build and install it
> through guixinstead of flatpak?
> 

Yes, there is a reason: ignorance, incompetence, idleness ;-) 
More seriously: I have no computer skills, I just know how to do: guix
package -i freecad... it seems to me to be very far from what would
allow me to start from the current definition package to make a freecad
19.1 package. Isn't it?
That said, why not give it a try if someone has the patience to answer
the countless questions I'm sure to have... with no guarantee of
success. See if the collective effort is worth it.

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-03 19:10           ` Christophe Pisteur
@ 2021-04-03 19:21             ` Ekaitz Zarraga
  2021-04-03 19:59               ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-03 19:21 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help-guix

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, April 3, 2021 9:10 PM, Christophe Pisteur <christophe.pisteur@fsfe.org> wrote:

> Yes, there is a reason: ignorance, incompetence, idleness ;-)

Don't be so hard on yourself.

> More seriously: I have no computer skills, I just know how to do: guix package -i freecad...
>
> it seems to me to be very far from what would allow me to start from the current definition package
>
> to make a freecad 19.1 package. Isn't it?

At the moment we have the 18.5 version of freecad available.
Surprising or not, I was the guy who updated it to that version (and fixed the package because it wasn't even working) and I have bad news for you.
Freecad is very hard to compile. It has tons of dependencies and all of them require special effort (some are broken, have broken compilation tools...).
Maybe they changed that in the new version but... I don't think so.
I spent a hella lot of time trying to fix it.
I will take a look to the Nix package and try to convert it to Guix but it will take time.

If anyone is interested on taking a look...
https://github.com/NixOS/nixpkgs/blob/3ab6e84b79abc45855e666fff33078189b4960c3/pkgs/applications/graphics/freecad/default.nix

> That said, why not give it a try if someone has the patience to answer the
>
> countless questions I'm sure to have... with no guarantee of success.
>
> See if the collective effort is worth it.

I can (try to) answer every single question you have so please, don't be shy.

Best,
Ekaitz

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-03 19:21             ` Ekaitz Zarraga
@ 2021-04-03 19:59               ` Christophe Pisteur
  2021-04-03 20:26                 ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-03 19:59 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help-guix

Le samedi 03 avril 2021 à 19:21 +0000, Ekaitz Zarraga a écrit :
> ....
> 
> At the moment we have the 18.5 version of freecad available.
> Surprising or not, I was the guy who updated it to that version (and
> fixed the package because it wasn't even working) and I have bad news
> for you.
> Freecad is very hard to compile. It has tons of dependencies and all
> of them require special effort (some are broken, have broken
> compilation tools...).
> Maybe they changed that in the new version but... I don't think so.
> I spent a hella lot of time trying to fix it.
> I will take a look to the Nix package and try to convert it to Guix
> but it will take time.
> 
> If anyone is interested on taking a look...
> https://github.com/NixOS/nixpkgs/blob/3ab6e84b79abc45855e666fff33078189b4960c3/pkgs/applications/graphics/freecad/default.nix
> 
> > That said, why not give it a try if someone has the patience to
> > answer the 
> > countless questions I'm sure to have... with no guarantee of
> > success. 
> > See if the collective effort is worth it.
> I can (try to) answer every single question you have so please, don't
> be shy.
> 
> Best,
> Ekaitz

Ok, I will try. 
If I understand correctly, we will communicate privately, won't we?
I'll start by reading the document on the definition of package at
guix.

Christophe




^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-03 19:59               ` Christophe Pisteur
@ 2021-04-03 20:26                 ` Ekaitz Zarraga
  2021-04-08 13:05                   ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-03 20:26 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help-guix

hi,

> Ok, I will try.
> If I understand correctly, we will communicate privately, won't we?
> I'll start by reading the document on the definition of package at guix.
>
> Christophe

You can send me the questions privately if you want, yes.

If you are not used to package stuff on Guix, you'll lose time reading the package. It's a pretty complex one.
You should report to freecad that the flatpak version doesn't provide plugin support. They may fix it fast and you'll have a working freecad until we fix the package definition on the guix side.

Best,
Ekaitz

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-03 20:26                 ` Ekaitz Zarraga
@ 2021-04-08 13:05                   ` Ekaitz Zarraga
  2021-04-11 13:30                     ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-08 13:05 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: Christophe Pisteur, help-guix

Hi all,

I had some free time and I decided to spend it on updating the
freecad package to the 0.19.1 version.

I managed it to compile with the changes I add below, but I
prefer someone to test it thoroughly because it's a program
I don't use that much so I don't know if the workbenches are
working as expected, or if the addons work.

Pleas Christophe, could you install try it and see if it works?

This is the diff on the current guix repository, I hope that's
enough to let you use it. If its not, I can make a separate
package for you.

Cheers,
Ekaitz


diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8d7ba9c1da..8e7974f1f1 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2351,21 +2351,19 @@ OpenSCAD code.  It supports syntax highlighting, indenting and refilling of
 comments.")))

 (define-public freecad
-  (let ((commit-ref "7616153b3c31ace006169cdc2fdafab484498858")
-        (revision "1"))
-    (package
+  (package
       (name "freecad")
-      (version (git-version "0.18.5" revision commit-ref))
+      (version "0.19.1")
       (source
         (origin
           (method git-fetch)
           (uri (git-reference
                  (url "https://github.com/FreeCAD/FreeCAD")
-                 (commit commit-ref)))
+                 (commit version)))
           (file-name (git-file-name name version))
           (sha256
             (base32
-              "16965yxnp2pq7nm8z3p0pjkzjdyq62vfrj8j3nk26bwc898czyn2"))))
+              "0c53q2iawy4yfp11czyc7lbr9ivp3r7v24x4c20myh11wyplffc0"))))
       (build-system qt-build-system)
       (native-inputs
        `(("doxygen" ,doxygen)
@@ -2393,6 +2391,8 @@ comments.")))
          ("python-shiboken-2" ,python-shiboken-2)
          ("python-pivy" ,python-pivy)
          ("python-wrapper" ,python-wrapper)
+         ("python-gitpython" ,python-gitpython)
+         ("python-pyyaml" ,python-pyyaml)
          ("qtbase" ,qtbase)
          ("qtsvg" ,qtsvg)
          ("qtx11extras" ,qtx11extras)
@@ -2454,7 +2454,7 @@ customization.")
         license:lgpl2.1+
         license:lgpl2.0+
         license:gpl3+
-        license:bsd-3)))))
+        license:bsd-3))))

 (define-public libmedfile
   (package



^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-08 13:05                   ` Ekaitz Zarraga
@ 2021-04-11 13:30                     ` Christophe Pisteur
  2021-04-11 16:45                       ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-11 13:30 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help-guix

Le jeudi 08 avril 2021 à 13:05 +0000, Ekaitz Zarraga a écrit :
> Hi all,
> I had some free time and I decided to spend it on updating thefreecad
> package to the 0.19.1 version.

MANY THANKS
> 
> I managed it to compile with the changes I add below, but I
> prefer someone to test it thoroughly because it's a program
> I don't use that much so I don't know if the workbenches are
> working as expected, or if the addons work.
> 
> Pleas Christophe, could you install try it and see if it works?
> 
> This is the diff on the current guix repository, I hope that's
> enough to let you use it. If its not, I can make a separate
> package for you.

Sorry, that's not enough for me. Do what is simpler for you: a package
or the procedure from the diff. 

Christophe
> 
> Cheers,
> Ekaitz
> 
> 
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 8d7ba9c1da..8e7974f1f1 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -2351,21 +2351,19 @@ OpenSCAD code.  It supports syntax highlighting, indenting and refilling of
>  comments.")))
> 
>  (define-public freecad
> -  (let ((commit-ref "7616153b3c31ace006169cdc2fdafab484498858")
> -        (revision "1"))
> -    (package
> +  (package
>        (name "freecad")
> -      (version (git-version "0.18.5" revision commit-ref))
> +      (version "0.19.1")
>        (source
>          (origin
>            (method git-fetch)
>            (uri (git-reference
>                   (url "
https://github.com/FreeCAD/FreeCAD> ")
> -                 (commit commit-ref)))
> +                 (commit version)))
>            (file-name (git-file-name name version))
>            (sha256
>              (base32
> -              "16965yxnp2pq7nm8z3p0pjkzjdyq62vfrj8j3nk26bwc898czyn2"))))
> +              "0c53q2iawy4yfp11czyc7lbr9ivp3r7v24x4c20myh11wyplffc0"))))
>        (build-system qt-build-system)
>        (native-inputs
>         `(("doxygen" ,doxygen)
> @@ -2393,6 +2391,8 @@ comments.")))
>           ("python-shiboken-2" ,python-shiboken-2)
>           ("python-pivy" ,python-pivy)
>           ("python-wrapper" ,python-wrapper)
> +         ("python-gitpython" ,python-gitpython)
> +         ("python-pyyaml" ,python-pyyaml)
>           ("qtbase" ,qtbase)
>           ("qtsvg" ,qtsvg)
>           ("qtx11extras" ,qtx11extras)
> @@ -2454,7 +2454,7 @@ customization.")
>          license:lgpl2.1+
>          license:lgpl2.0+
>          license:gpl3+
> -        license:bsd-3)))))
> +        license:bsd-3))))
> 
>  (define-public libmedfile
>    (package
> 

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 13:30                     ` Christophe Pisteur
@ 2021-04-11 16:45                       ` Ekaitz Zarraga
  2021-04-11 19:02                         ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-11 16:45 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 1013 bytes --]

Hi,

You can try with the file attached.

You just need to run the following, considering `freecad.scm` is the attached file, and that you are in the folder that contains the file.
```
guix build -f freecad.scm
```

Like half an hour later, you'll get an output similar to this:

```
$ guix build -f freecad.scm
>>TONS OF COMPILATION RELATED NONSENSE<<
/gnu/store/74c1nrijb1x29pj9f94265zaq8frqf4f-freecad-0.19.1
```

That's the folder where the result of the build is. You can run that freecad using the path you got like this:

```
$ /gnu/store/74c1nrijb1x29pj9f94265zaq8frqf4f-freecad-0.19.1/bin/FreeCAD
```

Tell me if it works and how does it look.
If it works fine I'll send a patch to Guix with this package and you'll soon have it in Guix. Also, if you need it now, you can use the file I gave you and install it from there with the same -f trick, or even create an environment for it, that way it will be easier to run.

For any question you have, just ask.

Good luck!
Ekaitz

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: freecad.scm --]
[-- Type: text/x-scheme; name=freecad.scm, Size: 5289 bytes --]

(define-module (freecad)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system qt)
  #:use-module (gnu packages)
  #:use-module (gnu packages engineering)
  #:use-module (gnu packages algebra)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages gl)
  #:use-module (gnu packages xorg)
  #:use-module (gnu packages tbb)
  #:use-module (gnu packages image-processing)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages documentation)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages swig)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages graphics)
  #:use-module (gnu packages maths)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages mpi)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages version-control))


(define-public freecad
  (package
      (name "freecad")
      (version "0.19.1")
      (source
        (origin
          (method git-fetch)
          (uri (git-reference
                 (url "https://github.com/FreeCAD/FreeCAD")
                 (commit version)))
          (file-name (git-file-name name version))
          (sha256
            (base32
              "0c53q2iawy4yfp11czyc7lbr9ivp3r7v24x4c20myh11wyplffc0"))))
      (build-system qt-build-system)
      (native-inputs
       `(("doxygen" ,doxygen)
         ("graphviz" ,graphviz)
         ("qttools" ,qttools)
         ("pkg-config" ,pkg-config)
         ("python-pyside-2-tools" ,python-pyside-2-tools)
         ("swig" ,swig)))
      (inputs
       `(("boost" ,boost)
         ("coin3D" ,coin3D)
         ("eigen" ,eigen)
         ("freetype" ,freetype)
         ("glew" ,glew)
         ("hdf5" ,hdf5-1.10)
         ("libarea" ,libarea)
         ("libmedfile" ,libmedfile)
         ("libspnav" ,libspnav)
         ("libxi" ,libxi)
         ("libxmu" ,libxmu)
         ("openmpi" ,openmpi)
         ("opencascade-occt" ,opencascade-occt)
         ("python-matplotlib" ,python-matplotlib)
         ("python-pyside-2" ,python-pyside-2)
         ("python-shiboken-2" ,python-shiboken-2)
         ("python-pivy" ,python-pivy)
         ("python-wrapper" ,python-wrapper)
         ("python-gitpython" ,python-gitpython)
         ("python-pyyaml" ,python-pyyaml)
         ("qtbase" ,qtbase)
         ("qtsvg" ,qtsvg)
         ("qtx11extras" ,qtx11extras)
         ("qtxmlpatterns" ,qtxmlpatterns)
         ("qtwebkit" ,qtwebkit)
         ("tbb" ,tbb)
         ("vtk" ,vtk)
         ("xerces-c" ,xerces-c)
         ("zlib" ,zlib)))
      (arguments
       `(#:tests? #f
         #:configure-flags
         (list
          "-DBUILD_QT5=ON"
          (string-append "-DCMAKE_INSTALL_LIBDIR=" (assoc-ref %outputs "out") "/lib")
          (string-append "-DPYSIDE2UICBINARY="
                         (assoc-ref %build-inputs "python-pyside-2-tools")
                         "/bin/uic")
          (string-append "-DPYSIDE2RCCBINARY="
                         (assoc-ref %build-inputs "python-pyside-2-tools")
                         "/bin/rcc")
          "-DPYSIDE_LIBRARY=PySide2::pyside2"
          (string-append
           "-DPYSIDE_INCLUDE_DIR="
           (assoc-ref %build-inputs "python-pyside-2") "/include;"
           (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2;"
           (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtCore;"
           (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtWidgets;"
           (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtGui;")
          "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken"
          (string-append "-DSHIBOKEN_INCLUDE_DIR="
                         (assoc-ref %build-inputs "python-shiboken-2")
                         "/include/shiboken2"))
         #:phases
         (modify-phases %standard-phases
           (add-before 'configure 'restore-pythonpath
             (lambda _
               (substitute* "src/Main/MainGui.cpp"
                 (("_?putenv\\(\"PYTHONPATH=\"\\);") ""))
               #t))
           (add-after 'install 'wrap-pythonpath
             (lambda* (#:key outputs #:allow-other-keys)
               (let ((out (assoc-ref outputs "out")))
                 (wrap-program (string-append out "/bin/FreeCAD")
                   (list "PYTHONPATH"
                         'prefix (list (getenv "PYTHONPATH")))))
               #t)))))
      (home-page "https://www.freecadweb.org/")
      (synopsis "Your Own 3D Parametric Modeler")
      (description
       "FreeCAD is a general purpose feature-based, parametric 3D modeler for
CAD, MCAD, CAx, CAE and PLM, aimed directly at mechanical engineering and
product design but also fits a wider range of uses in engineering, such as
architecture or other engineering specialties.  It is 100% Open Source (LGPL2+
license) and extremely modular, allowing for very advanced extension and
customization.")
      (license
       (list
        license:lgpl2.1+
        license:lgpl2.0+
        license:gpl3+
        license:bsd-3))))

freecad

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 16:45                       ` Ekaitz Zarraga
@ 2021-04-11 19:02                         ` Christophe Pisteur
       [not found]                           ` <0bK6s9aqPT66hiBxFF21Y8VTjlN3l4=5FcHxOT5UU8Ul4vRfRFZSKXDgoz5iqi4wMPzySTfxvoQhsEyDLLQPSPqmvOTWRgUMI1uE9Zt9tqemU=3D@elenq.tech>
  2021-04-11 19:30                           ` Ekaitz Zarraga
  0 siblings, 2 replies; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-11 19:02 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 1248 bytes --]

Le dimanche 11 avril 2021 à 16:45 +0000, Ekaitz Zarraga a écrit :
> Hi,
> 
> You can try with the file attached.
> 
> You just need to run the following, considering `freecad.scm` is the attached file, and that you are in the folder that contains the file.
> ```
> guix build -f freecad.scm
> ```
> 
> Like half an hour later, you'll get an output similar to this:
> 
> ```
> $ guix build -f freecad.scm
> > > TONS OF COMPILATION RELATED NONSENSE<<
> /gnu/store/74c1nrijb1x29pj9f94265zaq8frqf4f-freecad-0.19.1
> ```
> 
> That's the folder where the result of the build is. You can run that freecad using the path you got like this:
> 
> ```
> $ /gnu/store/74c1nrijb1x29pj9f94265zaq8frqf4f-freecad-0.19.1/bin/FreeCAD
> ```
> 
> Tell me if it works and how does it look.
> If it works fine I'll send a patch to Guix with this package and you'll soon have it in Guix. Also, if you need it now, you can use the file I gave you and install it from there with the same -f trick, or even create an environment for it, that way it will be easier to run.
> 
> For any question you have, just ask.
> 
> Good luck!
> Ekaitz

Many thanks!
Unfortunately, the build does not work and has stopped after a few
minutes. 
See attached the build log. 

Christophe


[-- Attachment #2: mpm48fcxn826zggxsy2p7nx874csx6-freecad-0.19.1.drv.bz2 --]
[-- Type: application/x-bzip, Size: 87249 bytes --]

[-- Attachment #3: freecad_error.txt --]
[-- Type: text/plain, Size: 18285 bytes --]

phase `unpack' succeeded after 2.9 seconds
starting phase `patch-usr-bin-file'
phase `patch-usr-bin-file' succeeded after 0.1 seconds
starting phase `patch-source-shebangs'
patch-shebang: ./package/conda/run_docker_build.sh: changing `/usr/bin/env bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./src/3rdParty/libkdtree/python-bindings/gen-swig-hpp.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/AddonManager/AddonManager.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Material/StandardMaterial/Tools/FCMat2csv.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./src/Mod/Material/StandardMaterial/Tools/make_FCMats.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./src/Mod/Material/StandardMaterial/Tools/make_ods.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./src/Mod/Mesh/App/MeshTestsApp.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/OpenSCAD/prototype.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Path/Tools/toolbit-attributes.py: changing `/usr/bin/python3' to `/gnu/store/rz42ba0my9vrgbkjpkzr2drmnjk5ah50-python-3.8.2/bin/python3'
patch-shebang: ./src/Mod/Path/utils/path-lint.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./src/Mod/Robot/KukaExporter.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Robot/MovieTool.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Sketcher/Gui/Resources/UpdateResources.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./src/Mod/Spreadsheet/App/create_regexps.sh: changing `/bin/sh' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/sh'
patch-shebang: ./src/Mod/Spreadsheet/importXLSX.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DHatchTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DLeaderRText.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DProjGroupTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DVAnnoSymImageTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DVBalloonTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DVDimensionTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DVPartTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/TDTest/DVSectionTest.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/TechDraw/moveViews.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Test/testPathArray.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Test/testPathArraySel.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Test/testmakeWireString.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Mod/Test/unittestgui.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/PythonToCPP.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/fcinfo: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/freecad-thumbnailer: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/generateBase/generateDS.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/generateBase/generateModel_Module.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/githubstats.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/offlinedoc/buildpdf.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/offlinedoc/buildqhelp.py: changing `/usr/bin/env python3' to `/gnu/store/rz42ba0my9vrgbkjpkzr2drmnjk5ah50-python-3.8.2/bin/python3'
patch-shebang: ./src/Tools/offlinedoc/buildwikiindex.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/offlinedoc/downloadwiki.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/offlinedoc/fixlinks.py: changing `/usr/bin/env python3' to `/gnu/store/rz42ba0my9vrgbkjpkzr2drmnjk5ah50-python-3.8.2/bin/python3'
patch-shebang: ./src/Tools/offlinedoc/update.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/updatecrowdin.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/updatefromcrowdin.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/updateppa.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/updatets.py: changing `/usr/bin/python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/Tools/wiki2qhelp.py: changing `/usr/bin/env python' to `/gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python'
patch-shebang: ./src/fc.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./vagrant/FreeCAD.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./vagrant/Xenial/bin/launcher: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./vagrant/Xenial/generate_yaml.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./vagrant/Xenial/reset: changing `/bin/sh' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/sh'
patch-shebang: ./vagrant/bin/launcher: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./vagrant/generate_yaml.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
phase `patch-source-shebangs' succeeded after 1.8 seconds
starting phase `restore-pythonpath'
phase `restore-pythonpath' succeeded after 0.0 seconds
starting phase `configure'
source directory: "/tmp/guix-build-freecad-0.19.1.drv-0/source" (relative from build: "../source")
build directory: "/tmp/guix-build-freecad-0.19.1.drv-0/build"
running 'cmake' with arguments ("../source" "-DCMAKE_BUILD_TYPE=RelWithDebInfo" "-DCMAKE_INSTALL_PREFIX=/gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1" "-DCMAKE_INSTALL_LIBDIR=lib" "-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE" "-DCMAKE_INSTALL_RPATH=/gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1/lib" "-DCMAKE_VERBOSE_MAKEFILE=ON" "-DBUILD_QT5=ON" "-DCMAKE_INSTALL_LIBDIR=/gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1/lib" "-DPYSIDE2UICBINARY=/gnu/store/75vhybxkblcz9crw8j91m4gh11ay6h4c-python-pyside-2-tools-5.14.2.3/bin/uic" "-DPYSIDE2RCCBINARY=/gnu/store/75vhybxkblcz9crw8j91m4gh11ay6h4c-python-pyside-2-tools-5.14.2.3/bin/rcc" "-DPYSIDE_LIBRARY=PySide2::pyside2" "-DPYSIDE_INCLUDE_DIR=/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2/QtCore;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2/QtWidgets;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2/QtGui;" "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken" "-DSHIBOKEN_INCLUDE_DIR=/gnu/store/24891kfrl4vd619bzkvmykqmkqd3bpqd-python-shiboken-2-5.14.2.3/include/shiboken2")
-- The C compiler identification is GNU 7.5.0
-- The CXX compiler identification is GNU 7.5.0
-- Check for working C compiler: /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/gcc
-- Check for working C compiler: /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++
-- Check for working CXX compiler: /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Compiler: GNU, version: 7.5.0
-- Looking for GL/gl.h
-- Looking for GL/gl.h - found
-- Looking for C++ include istream
-- Looking for C++ include istream - found
-- Looking for C++ include ostream
-- Looking for C++ include ostream - found
-- Looking for C++ include fstream
-- Looking for C++ include fstream - found
-- Looking for C++ include sstream
-- Looking for C++ include sstream - found
-- Looking for C++ include ios
-- Looking for C++ include ios - found
-- Looking for C++ include iostream
-- Looking for C++ include iostream - found
-- Looking for C++ include iomanip
-- Looking for C++ include iomanip - found
-- Looking for C++ include iostream
-- Looking for C++ include iostream - found
-- Check for STD namespace
-- Check for STD namespace - found
-- prefix: /gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1
-- bindir: bin
-- datadir: share
-- docdir: share/doc/FreeCAD
-- includedir: include
-- libdir: /gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1/lib
-- cmake: 3.16.5
-- Found Doxygen: /gnu/store/l9910ppzvz628ddd84mg7q6axx9khrjc-doxygen-1.8.17/bin/doxygen (found version "1.8.17") found components: doxygen dot 
-- Found PythonInterp: /gnu/store/bvd09gb8ka642jzgxd2lpqlpdp160gn0-python-wrapper-3.8.2/bin/python (found version "3.8.2") 
-- Found PythonLibs: /gnu/store/rz42ba0my9vrgbkjpkzr2drmnjk5ah50-python-3.8.2/lib/libpython3.8.so (found suitable exact version "3.8.2") 
-- Found Boost: /gnu/store/kxabg9r2wnb4inc5lvh7r4wxnpj5f8kr-boost-1.72.0/lib/cmake/Boost-1.72.0/BoostConfig.cmake (found suitable version "1.72.0", minimum required is "1.55") found components: filesystem program_options regex system thread 
-- Found Xerces-C: /gnu/store/pqkw03d7vk3a2dql1j28ks3bx1p16l90-xerces-c-3.2.3/lib/libxerces-c.so
-- Found ZLIB: /gnu/store/rykm237xkmq7rl1p0nwass01p090p88x-zlib-1.2.11/lib/libz.so (found version "1.2.11") 
-- PyCXX found:
--   Headers:  /tmp/guix-build-freecad-0.19.1.drv-0/source/src
--   Sources:  /tmp/guix-build-freecad-0.19.1.drv-0/source/src/CXX
--   Version:  6.2.8
-- Found OCC: /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/include/opencascade (found version "7.3.0") 
-- -- Found OCE/OpenCASCADE version: 7.3.0
-- -- OCE/OpenCASCADE include directory: /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/include/opencascade
-- -- OCE/OpenCASCADE shared libraries directory: /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib
-- Found OpenGL: /gnu/store/7disnxqw8i3n4zhw5s0xj9kkdckkmr1p-mesa-20.2.4/lib/libGL.so   
-- Found OpenGLU: /gnu/store/3ph833p40yg1i995lrf2sjv0zld3w9j7-glu-9.0.1/lib/libGLU.so
CMake Deprecation Warning at /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/lib/cmake/vtk-9.0/vtk-config.cmake:64 (message):
  The new name for the 'vtkCommonCore' component is 'CommonCore'
Call Stack (most recent call first):
  cMake/FreeCAD_Helpers/SetupSalomeSMESH.cmake:29 (find_package)
  CMakeLists.txt:59 (SetupSalomeSMESH)


-- Found Threads: TRUE  
-- VTK components: not found or used
-- Found X11: /gnu/store/wxl57nkbqgamfp73b7v62kk3f1hiv0cz-xorgproto-2019.2/include   
-- Looking for XOpenDisplay in /gnu/store/fx3979c88s9yxdbchyf36qryawgzpwb5-libx11-1.6.10/lib/libX11.so;/gnu/store/qrs0p8j3wq6q5a4dm0ndjdavk9gyal5q-libxext-1.3.4/lib/libXext.so
-- Looking for XOpenDisplay in /gnu/store/fx3979c88s9yxdbchyf36qryawgzpwb5-libx11-1.6.10/lib/libX11.so;/gnu/store/qrs0p8j3wq6q5a4dm0ndjdavk9gyal5q-libxext-1.3.4/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Found GLEW: /gnu/store/41sslcnbbjcm7zlsgdlz6qfz4x3af0rl-glew-2.1.0/lib/libGLEW.so  
-- Found OpenGL: /gnu/store/7disnxqw8i3n4zhw5s0xj9kkdckkmr1p-mesa-20.2.4/lib/libGL.so  found components: OpenGL missing components: GLX
-- HDF5: Using hdf5 compiler wrapper to determine C configuration
-- Found HDF5: /gnu/store/m7jn58prb6dwz33hic8qpdyacr5dmvzd-hdf5-1.10.7/lib/libhdf5.so;/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/lib/libpthread.so;/gnu/store/rykm237xkmq7rl1p0nwass01p090p88x-zlib-1.2.11/lib/libz.so;/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/lib/libdl.so;/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31/lib/libm.so (found version "1.10.7") found components: C HL 
-- Found OGG: /gnu/store/16v7w5z5h5dxvi23q096qarhdngvkwmh-libogg-1.3.4/lib/libogg.so  
CMake Error at /gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
  Could NOT find THEORA (missing: THEORA_LIBRARY THEORA_enc_LIBRARY
  THEORA_dec_LIBRARY THEORA_INCLUDE_DIR)
Call Stack (most recent call first):
  /gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
  /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/lib/cmake/vtk-9.0/FindTHEORA.cmake:40 (find_package_handle_standard_args)
  /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/lib/cmake/vtk-9.0/VTK-vtk-module-find-packages.cmake:350 (find_package)
  /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/lib/cmake/vtk-9.0/vtk-config.cmake:131 (include)
  cMake/FreeCAD_Helpers/SetupSalomeSMESH.cmake:45 (find_package)
  CMakeLists.txt:59 (SetupSalomeSMESH)


-- Configuring incomplete, errors occurred!
See also "/tmp/guix-build-freecad-0.19.1.drv-0/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/guix-build-freecad-0.19.1.drv-0/build/CMakeFiles/CMakeError.log".
command "cmake" "../source" "-DCMAKE_BUILD_TYPE=RelWithDebInfo" "-DCMAKE_INSTALL_PREFIX=/gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1" "-DCMAKE_INSTALL_LIBDIR=lib" "-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE" "-DCMAKE_INSTALL_RPATH=/gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1/lib" "-DCMAKE_VERBOSE_MAKEFILE=ON" "-DBUILD_QT5=ON" "-DCMAKE_INSTALL_LIBDIR=/gnu/store/mdx3gpgi7lfhdjjy189bzvc2wwv3xq55-freecad-0.19.1/lib" "-DPYSIDE2UICBINARY=/gnu/store/75vhybxkblcz9crw8j91m4gh11ay6h4c-python-pyside-2-tools-5.14.2.3/bin/uic" "-DPYSIDE2RCCBINARY=/gnu/store/75vhybxkblcz9crw8j91m4gh11ay6h4c-python-pyside-2-tools-5.14.2.3/bin/rcc" "-DPYSIDE_LIBRARY=PySide2::pyside2" "-DPYSIDE_INCLUDE_DIR=/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2/QtCore;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2/QtWidgets;/gnu/store/97yh4rn9psxmqv7380qv3141nwynkd9r-python-pyside-2-5.14.2.3/include/PySide2/QtGui;" "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken" "-DSHIBOKEN_INCLUDE_DIR=/gnu/store/24891kfrl4vd619bzkvmykqmkqd3bpqd-python-shiboken-2-5.14.2.3/include/shiboken2" failed with status 1
builder for `/gnu/store/ijmpm48fcxn826zggxsy2p7nx874csx6-freecad-0.19.1.drv' failed with exit code 1
la compilation de /gnu/store/ijmpm48fcxn826zggxsy2p7nx874csx6-freecad-0.19.1.drv a échoué
Vous trouverez le journal de compilation dans « /var/log/guix/drvs/ij/mpm48fcxn826zggxsy2p7nx874csx6-freecad-0.19.1.drv.bz2 ».
guix build: error: build of `/gnu/store/ijmpm48fcxn826zggxsy2p7nx874csx6-freecad-0.19.1.drv' failed


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 19:02                         ` Christophe Pisteur
       [not found]                           ` <0bK6s9aqPT66hiBxFF21Y8VTjlN3l4=5FcHxOT5UU8Ul4vRfRFZSKXDgoz5iqi4wMPzySTfxvoQhsEyDLLQPSPqmvOTWRgUMI1uE9Zt9tqemU=3D@elenq.tech>
@ 2021-04-11 19:30                           ` Ekaitz Zarraga
  2021-04-11 20:52                             ` Luis Felipe
  1 sibling, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-11 19:30 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help-guix

> Many thanks!
> Unfortunately, the build does not work and has stopped after a few minutes.
> See attached the build log.
>
> Christophe

I'll try to compile it again... I wasn't expecting the package to fail. LOL
I'll keep you posted, thanks for the log!

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 19:30                           ` Ekaitz Zarraga
@ 2021-04-11 20:52                             ` Luis Felipe
  2021-04-11 20:59                               ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Luis Felipe @ 2021-04-11 20:52 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: Christophe Pisteur, help-guix

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, April 11, 2021 7:30 PM, Ekaitz Zarraga <ekaitz@elenq.tech> wrote:

> > Many thanks!
> > Unfortunately, the build does not work and has stopped after a few minutes.
> > See attached the build log.
> > Christophe
>
> I'll try to compile it again... I wasn't expecting the package to fail. LOL
> I'll keep you posted, thanks for the log!

Eh, I just built it successfully, and it starts (0.19).

I'll follow a couple of tutorials and see how it performs.


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 20:52                             ` Luis Felipe
@ 2021-04-11 20:59                               ` Ekaitz Zarraga
  2021-04-11 21:25                                 ` Ekaitz Zarraga
  2021-04-11 22:17                                 ` Christophe Pisteur
  0 siblings, 2 replies; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-11 20:59 UTC (permalink / raw)
  To: Luis Felipe; +Cc: Christophe Pisteur, help-guix

[-- Attachment #1: Type: text/plain, Size: 900 bytes --]


> > > Many thanks!
> > > Unfortunately, the build does not work and has stopped after a few minutes.
> > > See attached the build log.
> > > Christophe
> >
> > I'll try to compile it again... I wasn't expecting the package to fail. LOL
> > I'll keep you posted, thanks for the log!
>
> Eh, I just built it successfully, and it starts (0.19).
>
> I'll follow a couple of tutorials and see how it performs.

I supposed I had an old system so I `guix pulled` and it
doesn't compile anymore. Looks like we've changed the order of
the libraries and now it fails.

I re-made the package, but now it doesn't compile with some
weird compilation error related with C++ stuff. I can't really
believe what I see.

Please, try to guix pull and build it again.

I attach what I have right now, I had to add some deps on top of
what I sent before and it doesn't work :S

This is crazy :D

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: freecad.scm --]
[-- Type: text/x-scheme; name=freecad.scm, Size: 5624 bytes --]

(define-module (freecad)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system qt)
  #:use-module (gnu packages)
  #:use-module (gnu packages algebra)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages documentation)
  #:use-module (gnu packages engineering)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages geo)
  #:use-module (gnu packages gl)
  #:use-module (gnu packages graphics)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages image)
  #:use-module (gnu packages image-processing)
  #:use-module (gnu packages maths)
  #:use-module (gnu packages mpi)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages serialization)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages swig)
  #:use-module (gnu packages tbb)
  #:use-module (gnu packages version-control)
  #:use-module (gnu packages xiph)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))



(package
    (name "freecad-mine")
    (version "0.19.1")
    (source
      (origin
        (method git-fetch)
        (uri (git-reference
               (url "https://github.com/FreeCAD/FreeCAD")
               (commit version)))
        (file-name (git-file-name name version))
        (sha256
          (base32
            "0c53q2iawy4yfp11czyc7lbr9ivp3r7v24x4c20myh11wyplffc0"))))
    (build-system qt-build-system)
    (native-inputs
     `(("doxygen" ,doxygen)
       ("graphviz" ,graphviz)
       ("qttools" ,qttools)
       ("pkg-config" ,pkg-config)
       ("python-pyside-2-tools" ,python-pyside-2-tools)
       ("swig" ,swig)))
    (inputs
     `(("boost" ,boost)
       ("coin3D" ,coin3D)
       ("double-conversion" ,double-conversion)
       ("eigen" ,eigen)
       ("freetype" ,freetype)
       ("gl2ps" ,gl2ps)
       ("glew" ,glew)
       ("hdf5" ,hdf5-1.10)
       ("jsoncpp" ,jsoncpp)
       ("libarea" ,libarea)
       ("libjpeg-turbo" ,libjpeg-turbo)
       ("libmedfile" ,libmedfile)
       ("libspnav" ,libspnav)
       ("libtheora" ,libtheora)
       ("libtiff" ,libtiff)
       ("libxi" ,libxi)
       ("libxmlplusplus" ,libxmlplusplus) 
       ("libxmu" ,libxmu)
       ("lz4" ,lz4)
       ("netcdf" ,netcdf)
       ("opencascade-occt" ,opencascade-occt)
       ("openmpi" ,openmpi)
       ("proj" ,proj)
       ("python-gitpython" ,python-gitpython)
       ("python-matplotlib" ,python-matplotlib)
       ("python-pivy" ,python-pivy)
       ("python-pyside-2" ,python-pyside-2)
       ("python-pyyaml" ,python-pyyaml)
       ("python-shiboken-2" ,python-shiboken-2)
       ("python-wrapper" ,python-wrapper)
       ("qtbase" ,qtbase)
       ("qtsvg" ,qtsvg)
       ("qtwebkit" ,qtwebkit)
       ("qtx11extras" ,qtx11extras)
       ("qtxmlpatterns" ,qtxmlpatterns)
       ("sqlite" ,sqlite)
       ("tbb" ,tbb)
       ("vtk" ,vtk)
       ("xerces-c" ,xerces-c)
       ("zlib" ,zlib)))
    (arguments
     `(#:tests? #f
       #:configure-flags
       (list
        "-DBUILD_QT5=ON"
        "-DBUILD_FLAT_MESH:BOOL=ON"
        (string-append "-DCMAKE_INSTALL_LIBDIR=" (assoc-ref %outputs "out") "/lib")
        (string-append "-DPYSIDE2UICBINARY="
                       (assoc-ref %build-inputs "python-pyside-2-tools")
                       "/bin/uic")
        (string-append "-DPYSIDE2RCCBINARY="
                       (assoc-ref %build-inputs "python-pyside-2-tools")
                       "/bin/rcc")
        "-DPYSIDE_LIBRARY=PySide2::pyside2"
        (string-append
         "-DPYSIDE_INCLUDE_DIR="
         (assoc-ref %build-inputs "python-pyside-2") "/include;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtCore;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtWidgets;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtGui;")
        "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken"
        (string-append "-DSHIBOKEN_INCLUDE_DIR="
                       (assoc-ref %build-inputs "python-shiboken-2")
                       "/include/shiboken2"))
       #:phases
       (modify-phases %standard-phases
         (add-before 'configure 'restore-pythonpath
           (lambda _
             (substitute* "src/Main/MainGui.cpp"
               (("_?putenv\\(\"PYTHONPATH=\"\\);") ""))
             #t))
         (add-after 'install 'wrap-pythonpath
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (wrap-program (string-append out "/bin/FreeCAD")
                 (list "PYTHONPATH"
                       'prefix (list (getenv "PYTHONPATH")))))
             #t)))))
    (home-page "https://www.freecadweb.org/")
    (synopsis "Your Own 3D Parametric Modeler")
    (description
     "FreeCAD is a general purpose feature-based, parametric 3D modeler for
CAD, MCAD, CAx, CAE and PLM, aimed directly at mechanical engineering and
product design but also fits a wider range of uses in engineering, such as
architecture or other engineering specialties.  It is 100% Open Source (LGPL2+
license) and extremely modular, allowing for very advanced extension and
customization.")
    (license
     (list
      license:lgpl2.1+
      license:lgpl2.0+
      license:gpl3+
      license:bsd-3)))


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 20:59                               ` Ekaitz Zarraga
@ 2021-04-11 21:25                                 ` Ekaitz Zarraga
  2021-04-11 22:19                                   ` Ekaitz Zarraga
  2021-04-11 22:17                                 ` Christophe Pisteur
  1 sibling, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-11 21:25 UTC (permalink / raw)
  To: Luis Felipe; +Cc: Christophe Pisteur, help-guix


>
> > > > Many thanks!
> > > > Unfortunately, the build does not work and has stopped after a few minutes.
> > > > See attached the build log.
> > > > Christophe
> > >
> > > I'll try to compile it again... I wasn't expecting the package to fail. LOL
> > > I'll keep you posted, thanks for the log!
> >
> > Eh, I just built it successfully, and it starts (0.19).
> > I'll follow a couple of tutorials and see how it performs.
>
> I supposed I had an old system so I`guix pulled` and it
> doesn't compile anymore. Looks like we've changed the order of
> the libraries and now it fails.
>
> I re-made the package, but now it doesn't compile with some
> weird compilation error related with C++ stuff. I can't really
> believe what I see.
>
> Please, try to guix pull and build it again.
>
> I attach what I have right now, I had to add some deps on top of
> what I sent before and it doesn't work :S
>
> This is crazy :D

I think it was related with vtk being updated to 9.0.0.

I'll package it back to 8.2.0 and see what happens.

https://forum.freecadweb.org/viewtopic.php?style=4&f=4&t=46934&start=10

I'll keep you all informed.
Thanks for the help!


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 20:59                               ` Ekaitz Zarraga
  2021-04-11 21:25                                 ` Ekaitz Zarraga
@ 2021-04-11 22:17                                 ` Christophe Pisteur
  2021-04-11 22:27                                   ` Ekaitz Zarraga
  1 sibling, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-11 22:17 UTC (permalink / raw)
  To: Ekaitz Zarraga, Luis Felipe; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 1253 bytes --]

Le dimanche 11 avril 2021 à 20:59 +0000, Ekaitz Zarraga a écrit :
> > > > Many thanks!
> > > > Unfortunately, the build does not work and has stopped after a few minutes.
> > > > See attached the build log.
> > > > Christophe
> > > 
> > > I'll try to compile it again... I wasn't expecting the package to fail. LOL
> > > I'll keep you posted, thanks for the log!
> > 
> > Eh, I just built it successfully, and it starts (0.19).
> > 
> > I'll follow a couple of tutorials and see how it performs.
> 
> I supposed I had an old system so I `guix pulled` and it
> doesn't compile anymore. Looks like we've changed the order of
> the libraries and now it fails.
> 
> I re-made the package, but now it doesn't compile with some
> weird compilation error related with C++ stuff. I can't really
> believe what I see.
> 
> Please, try to guix pull and build it again.
> 
> I attach what I have right now, I had to add some deps on top of
> what I sent before and it doesn't work :S
> 
> This is crazy :D

Hi Ekaitz,
Many thanks!

I did guix pull  and tried to build again but It failed.
Attached: build log and the output of terminal (The last lines, since
"cmake --build /tmp/guix-build-freecad-mine-0.19.1.drv-0/build").

Sorry for the news...

Christophe



[-- Attachment #2: freecad_error2.txt --]
[-- Type: text/plain, Size: 18887 bytes --]

=================================================
Now run 'cmake --build /tmp/guix-build-freecad-mine-0.19.1.drv-0/build' to build FreeCAD
=================================================

-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/guix-build-freecad-mine-0.19.1.drv-0/build
phase `configure' succeeded after 32.8 seconds
starting phase `patch-generated-file-shebangs'
phase `patch-generated-file-shebangs' succeeded after 2.0 seconds
starting phase `build'
/gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/bin/cmake -S/tmp/guix-build-freecad-mine-0.19.1.drv-0/source -B/tmp/guix-build-freecad-mine-0.19.1.drv-0/build --check-build-system CMakeFiles/Makefile.cmake 0
/gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/bin/cmake -E cmake_progress_start /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/CMakeFiles /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make[1]: Entering directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
make -f src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/build.make src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/depend
make -f src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/build.make src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/depend
make[2]: Entering directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
cd /tmp/guix-build-freecad-mine-0.19.1.drv-0/build && /gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/bin/cmake -E cmake_depends "Unix Makefiles" /tmp/guix-build-freecad-mine-0.19.1.drv-0/source /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh /tmp/guix-build-freecad-mine-0.19.1.drv-0/build /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/DependInfo.cmake --color=
make[2]: Entering directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
cd /tmp/guix-build-freecad-mine-0.19.1.drv-0/build && /gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/bin/cmake -E cmake_depends "Unix Makefiles" /tmp/guix-build-freecad-mine-0.19.1.drv-0/source /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh /tmp/guix-build-freecad-mine-0.19.1.drv-0/build /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/DependInfo.cmake --color=
Scanning dependencies of target MEFISTO2
make[2]: Leaving directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
make -f src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/build.make src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/build
make[2]: Entering directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
[  0%] Building CXX object src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o
cd /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh && /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++  -DCSFDB -DHAVE_CONFIG_H -DHAVE_LIMITS_H -DHAVE_TBB -DLIN -DMEFISTO2_EXPORTS -DOCC_CONVERT_SIGNALS -D_OCC64 -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/Driver -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverUNV -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverDAT -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverSTL -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/StdMeshers -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh -I/gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/include/opencascade  -Wall -Wextra -Wno-write-strings  -Wno-sign-compare -Wno-reorder -Wno-switch -Wno-unused-variable -Wno-unused-but-set-variable -Wno-comment -Wno-unused-parameter -Wno-empty-body -Wno-pedantic -Wno-unused-result -Wno-maybe-uninitialized -Wno-missing-field-initializers -O2 -g -DNDEBUG -fPIC   -DMEFISTO2D_EXPORTS -pthread -std=gnu++11 -o CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o -c /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/MEFISTO2/aptrte.cpp
Scanning dependencies of target SMDS
make[2]: Leaving directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
make -f src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/build.make src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/build
make[2]: Entering directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
[  0%] Building CXX object src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/src/SMDS/SMDS_BallElement.cpp.o
cd /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh && /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++  -DCSFDB -DDIY_NO_THREADS -DH5_BUILT_AS_DYNAMIC_LIB -DHAVE_CONFIG_H -DHAVE_LIMITS_H -DHAVE_TBB -DLIN -DOCC_CONVERT_SIGNALS -DSMDS_EXPORTS -DVTK_HAS_OGGTHEORA_SUPPORT -D_OCC64 -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/Driver -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverUNV -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverDAT -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverSTL -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/StdMeshers -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh -I/gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/include/opencascade -isystem /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0 -isystem /gnu/store/j3f5hx6yvhlj3sapiipigkwg05b49nwn-freetype-2.10.4/include/freetype2 -isystem /gnu/store/c8w9z48vvx2a3q3k44ch9yn00wk1qwhb-libxml2-2.9.10/include/libxml2 -isystem /gnu/store/albmvapdic4508p7r9hhw6p18ri5i946-double-conversion-3.1.5/include/double-conversion -isystem /gnu/store/n50ikpnyzdda0zklwnmqasklcrif2csg-eigen-3.3.8/include/eigen3  -Wall -Wextra -Wno-write-strings  -Wno-sign-compare -Wno-reorder -Wno-switch -Wno-unused-variable -Wno-unused-but-set-variable -Wno-comment -Wno-unused-parameter -Wno-empty-body -Wno-pedantic -Wno-unused-result -Wno-maybe-uninitialized -Wno-missing-field-initializers -O2 -g -DNDEBUG -fPIC   -pthread -std=gnu++11 -o CMakeFiles/SMDS.dir/src/SMDS/SMDS_BallElement.cpp.o -c /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp
[  0%] Building C object src/3rdParty/salomesmesh/CMakeFiles/MEFISTO2.dir/src/MEFISTO2/trte.c.o
cd /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh && /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/gcc -DCSFDB -DHAVE_CONFIG_H -DHAVE_LIMITS_H -DHAVE_TBB -DLIN -DMEFISTO2_EXPORTS -DOCC_CONVERT_SIGNALS -D_OCC64 -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/Driver -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverUNV -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverDAT -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/DriverSTL -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/StdMeshers -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc -I/tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh -I/gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/include/opencascade  -Wno-unused-variable -Wno-unused-but-set-variable -Wno-unused-result -O2 -g -DNDEBUG -fPIC   -DMEFISTO2D_EXPORTS -pthread -o CMakeFiles/MEFISTO2.dir/src/MEFISTO2/trte.c.o   -c /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/MEFISTO2/trte.c
In file included from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_VtkVolume.hxx:26:0,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_Mesh.hxx:45,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp:28:
/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_UnstructuredGrid.hxx: In member function ‘vtkCellLinks* SMDS_UnstructuredGrid::GetLinks()’:
/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_UnstructuredGrid.hxx:98:12: error: invalid user-defined conversion from ‘vtkSmartPointer<vtkAbstractCellLinks>’ to ‘vtkCellLinks*’ [-fpermissive]
     return Links;
            ^~~~~
In file included from /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkGenericDataArray.h:73:0,
                 from /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkAOSDataArrayTemplate.h:36,
                 from /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkCellArray.h:141,
                 from /gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkUnstructuredGrid.h:31,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_VtkEdge.hxx:30,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_Mesh.hxx:43,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp:28:
/gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkSmartPointer.h:188:3: note: candidate is: vtkSmartPointer<ArrayType>::operator T*() const [with T = vtkAbstractCellLinks] <near match>
   operator T*() const noexcept { return static_cast<T*>(this->Object); }
   ^~~~~~~~
/gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkSmartPointer.h:188:3: note:   no known conversion from ‘vtkAbstractCellLinks*’ to ‘vtkCellLinks*’
/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp: In member function ‘bool SMDS_BallElement::ChangeNode(const SMDS_MeshNode*)’:
/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp:72:41: error: cannot bind non-const lvalue reference of type ‘const vtkIdType*& {aka const long long int*&}’ to an rvalue of type ‘const vtkIdType* {aka const long long int*}’
   grid->GetCellPoints(myVtkID, npts, pts);
                                         ^
In file included from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_VtkEdge.hxx:30:0,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_Mesh.hxx:43,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp:28:
/gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkUnstructuredGrid.h:196:8: note:   initializing argument 3 of ‘void vtkUnstructuredGrid::GetCellPoints(vtkIdType, vtkIdType&, const vtkIdType*&)’
   void GetCellPoints(vtkIdType cellId, vtkIdType& npts, vtkIdType const*& pts)
        ^~~~~~~~~~~~~
/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp: In member function ‘virtual const SMDS_MeshNode* SMDS_BallElement::GetNode(int) const’:
/tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp:87:43: error: cannot bind non-const lvalue reference of type ‘const vtkIdType*& {aka const long long int*&}’ to an rvalue of type ‘const vtkIdType* {aka const long long int*}’
   grid->GetCellPoints( myVtkID, npts, pts );
                                           ^
In file included from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_VtkEdge.hxx:30:0,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_Mesh.hxx:43,
                 from /tmp/guix-build-freecad-mine-0.19.1.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_BallElement.cpp:28:
/gnu/store/60xdb8d9vv38bajvmc1smf0027nixlb9-vtk-9.0.1/include/vtk-9.0/vtkUnstructuredGrid.h:196:8: note:   initializing argument 3 of ‘void vtkUnstructuredGrid::GetCellPoints(vtkIdType, vtkIdType&, const vtkIdType*&)’
   void GetCellPoints(vtkIdType cellId, vtkIdType& npts, vtkIdType const*& pts)
        ^~~~~~~~~~~~~
make[2]: *** [src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/build.make:66: src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/src/SMDS/SMDS_BallElement.cpp.o] Error 1
make[2]: Leaving directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:2297: src/3rdParty/salomesmesh/CMakeFiles/SMDS.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[  0%] Linking CXX shared library ../../../lib/libMEFISTO2.so
cd /tmp/guix-build-freecad-mine-0.19.1.drv-0/build/src/3rdParty/salomesmesh && /gnu/store/3dsl2jalrcyldkrsqab1hc6sv8pyag9z-cmake-minimal-3.16.5/bin/cmake -E cmake_link_script CMakeFiles/MEFISTO2.dir/link.txt --verbose=1
/gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++ -fPIC  -Wall -Wextra -Wno-write-strings  -Wno-sign-compare -Wno-reorder -Wno-switch -Wno-unused-variable -Wno-unused-but-set-variable -Wno-comment -Wno-unused-parameter -Wno-empty-body -Wno-pedantic -Wno-unused-result -Wno-maybe-uninitialized -Wno-missing-field-initializers -O2 -g -DNDEBUG  -shared -Wl,-soname,libMEFISTO2.so -o ../../../lib/libMEFISTO2.so CMakeFiles/MEFISTO2.dir/src/MEFISTO2/aptrte.cpp.o CMakeFiles/MEFISTO2.dir/src/MEFISTO2/trte.c.o  -Wl,-rpath,::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::: -lmpi /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKSTL.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKOffset.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKFeat.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKBin.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKBinL.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKXDESTEP.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKXDEIGES.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKMeshVS.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKFillet.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKSTEP.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKSTEPAttr.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKSTEP209.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKSTEPBase.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKIGES.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKBool.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKXSBase.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKXCAF.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKVCAF.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKCAF.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKBO.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKPrim.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKLCAF.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKCDF.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKV3d.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKMesh.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKHLR.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKService.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKShHealing.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKTopAlgo.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKGeomAlgo.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKBRep.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKGeomBase.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKG3d.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKG2d.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKMath.so.7.3.0 /gnu/store/hzh121j9b9s7nvnfl5iqrlj07axp2yc8-opencascade-occt-7.3.0p3/lib/libTKernel.so.7.3.0 -lpthread -lrt -lstdc++ -ldl -ltbb -ltbbmalloc -lGL -lX11 -lXext -lXmu -lXi /gnu/store/j3f5hx6yvhlj3sapiipigkwg05b49nwn-freetype-2.10.4/lib/libfreetype.so 
make[2]: Leaving directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
[  0%] Built target MEFISTO2
make[1]: Leaving directory '/tmp/guix-build-freecad-mine-0.19.1.drv-0/build'
make: *** [Makefile:133: all] Error 2
command "make" "-j" "2" failed with status 2
builder for `/gnu/store/v3wkznqpd83l2rsaka36715qx1hcxl64-freecad-mine-0.19.1.drv' failed with exit code 1
la compilation de /gnu/store/v3wkznqpd83l2rsaka36715qx1hcxl64-freecad-mine-0.19.1.drv a échoué
Vous trouverez le journal de compilation dans « /var/log/guix/drvs/v3/wkznqpd83l2rsaka36715qx1hcxl64-freecad-mine-0.19.1.drv.bz2 ».
guix build: error: build of `/gnu/store/v3wkznqpd83l2rsaka36715qx1hcxl64-freecad-mine-0.19.1.drv' failed


[-- Attachment #3: wkznqpd83l2rsaka36715qx1hcxl64-freecad-mine-0.19.1.drv.bz2 --]
[-- Type: application/x-bzip, Size: 95911 bytes --]

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 21:25                                 ` Ekaitz Zarraga
@ 2021-04-11 22:19                                   ` Ekaitz Zarraga
  2021-04-12  2:03                                     ` Luis Felipe
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-11 22:19 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help-guix, Christophe Pisteur

[-- Attachment #1: Type: text/plain, Size: 675 bytes --]


> I think it was related with vtk being updated to 9.0.0.
>
> I'll package it back to 8.2.0 and see what happens.
>
> https://forum.freecadweb.org/viewtopic.php?style=4&f=4&t=46934&start=10
>
> I'll keep you all informed.
> Thanks for the help!

I think I have it working for the latest Guix version.

Please, try with this file.

WARNING: it's going to take ages to compile.

I had to re-package vtk for this case.

There was a problem with the latest version of Guix, because
it includes vtk9.0.0 and freecad is not compatible with that...

Hope this works as expected.

Please tell me if it works fine and if it does I'll submit a
patch

Cheers!

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: freecad.scm --]
[-- Type: text/x-scheme; name=freecad.scm, Size: 6307 bytes --]

(define-module (freecad)

  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (srfi srfi-1)

  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system qt)
  #:use-module (gnu packages)
  #:use-module (gnu packages algebra)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages documentation)
  #:use-module (gnu packages engineering)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages geo)
  #:use-module (gnu packages gl)
  #:use-module (gnu packages graphics)
  #:use-module (gnu packages graphviz)
  #:use-module (gnu packages image)
  #:use-module (gnu packages image-processing)
  #:use-module (gnu packages maths)
  #:use-module (gnu packages mpi)
  #:use-module (gnu packages multiprecision)
  #:use-module (gnu packages pcre)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages python-xyz)
  #:use-module (gnu packages qt)
  #:use-module (gnu packages serialization)
  #:use-module (gnu packages sqlite)
  #:use-module (gnu packages swig)
  #:use-module (gnu packages tbb)
  #:use-module (gnu packages version-control)
  #:use-module (gnu packages xiph)
  #:use-module (gnu packages xml)
  #:use-module (gnu packages xorg))


;; itksnap needs an older variant of VTK.
(define-public vtk-8
  (package (inherit vtk)
    (version "8.2.0")
    (source (origin
              (method url-fetch)
              (uri (string-append "https://vtk.org/files/release/"
                                  (version-major+minor version)
                                  "/VTK-" version ".tar.gz"))
              (sha256
               (base32
                "1fspgp8k0myr6p2a6wkc21ldcswb4bvmb484m12mxgk1a9vxrhrl"))))
    (inputs
     `(("jsoncpp" ,jsoncpp-for-tensorflow)
       ,@(alist-delete "jsoncpp" (package-inputs vtk))))))


(package
    (name "freecad-mine")
    (version "0.19.1")
    (source
      (origin
        (method git-fetch)
        (uri (git-reference
               (url "https://github.com/FreeCAD/FreeCAD")
               (commit version)))
        (file-name (git-file-name name version))
        (sha256
          (base32
            "0c53q2iawy4yfp11czyc7lbr9ivp3r7v24x4c20myh11wyplffc0"))))
    (build-system qt-build-system)
    (native-inputs
     `(("doxygen" ,doxygen)
       ("graphviz" ,graphviz)
       ("qttools" ,qttools)
       ("pkg-config" ,pkg-config)
       ("python-pyside-2-tools" ,python-pyside-2-tools)
       ("swig" ,swig)))
    (inputs
     `(("boost" ,boost)
       ("coin3D" ,coin3D)
       ("double-conversion" ,double-conversion)
       ("eigen" ,eigen)
       ("freetype" ,freetype)
       ("gl2ps" ,gl2ps)
       ("glew" ,glew)
       ("hdf5" ,hdf5-1.10)
       ("jsoncpp" ,jsoncpp)
       ("libarea" ,libarea)
       ("libjpeg-turbo" ,libjpeg-turbo)
       ("libmedfile" ,libmedfile)
       ("libspnav" ,libspnav)
       ("libtheora" ,libtheora)
       ("libtiff" ,libtiff)
       ("libxi" ,libxi)
       ("libxmlplusplus" ,libxmlplusplus) 
       ("libxmu" ,libxmu)
       ("lz4" ,lz4)
       ("netcdf" ,netcdf)
       ("opencascade-occt" ,opencascade-occt)
       ("openmpi" ,openmpi)
       ("proj" ,proj)
       ("python-gitpython" ,python-gitpython)
       ("python-matplotlib" ,python-matplotlib)
       ("python-pivy" ,python-pivy)
       ("python-pyside-2" ,python-pyside-2)
       ("python-pyyaml" ,python-pyyaml)
       ("python-shiboken-2" ,python-shiboken-2)
       ("python-wrapper" ,python-wrapper)
       ("qtbase" ,qtbase)
       ("qtsvg" ,qtsvg)
       ("qtwebkit" ,qtwebkit)
       ("qtx11extras" ,qtx11extras)
       ("qtxmlpatterns" ,qtxmlpatterns)
       ("sqlite" ,sqlite)
       ("tbb" ,tbb)
       ("vtk" ,vtk-8)
       ("xerces-c" ,xerces-c)
       ("zlib" ,zlib)))
    (arguments
     `(#:tests? #f
       #:configure-flags
       (list
        "-DBUILD_QT5=ON"
        "-DBUILD_FLAT_MESH:BOOL=ON"
        (string-append "-DCMAKE_INSTALL_LIBDIR=" (assoc-ref %outputs "out") "/lib")
        (string-append "-DPYSIDE2UICBINARY="
                       (assoc-ref %build-inputs "python-pyside-2-tools")
                       "/bin/uic")
        (string-append "-DPYSIDE2RCCBINARY="
                       (assoc-ref %build-inputs "python-pyside-2-tools")
                       "/bin/rcc")
        "-DPYSIDE_LIBRARY=PySide2::pyside2"
        (string-append
         "-DPYSIDE_INCLUDE_DIR="
         (assoc-ref %build-inputs "python-pyside-2") "/include;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtCore;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtWidgets;"
         (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtGui;")
        "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken"
        (string-append "-DSHIBOKEN_INCLUDE_DIR="
                       (assoc-ref %build-inputs "python-shiboken-2")
                       "/include/shiboken2"))
       #:phases
       (modify-phases %standard-phases
         (add-before 'configure 'restore-pythonpath
           (lambda _
             (substitute* "src/Main/MainGui.cpp"
               (("_?putenv\\(\"PYTHONPATH=\"\\);") ""))
             #t))
         (add-after 'install 'wrap-pythonpath
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (wrap-program (string-append out "/bin/FreeCAD")
                 (list "PYTHONPATH"
                       'prefix (list (getenv "PYTHONPATH")))))
             #t)))))
    (home-page "https://www.freecadweb.org/")
    (synopsis "Your Own 3D Parametric Modeler")
    (description
     "FreeCAD is a general purpose feature-based, parametric 3D modeler for
CAD, MCAD, CAx, CAE and PLM, aimed directly at mechanical engineering and
product design but also fits a wider range of uses in engineering, such as
architecture or other engineering specialties.  It is 100% Open Source (LGPL2+
license) and extremely modular, allowing for very advanced extension and
customization.")
    (license
     (list
      license:lgpl2.1+
      license:lgpl2.0+
      license:gpl3+
      license:bsd-3)))


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 22:17                                 ` Christophe Pisteur
@ 2021-04-11 22:27                                   ` Ekaitz Zarraga
  2021-04-13  7:58                                     ` Christophe Pisteur
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-11 22:27 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help-guix

Hi Christophe,

Yes, I just sent a new version with the package to the thread.
The problem was Luis Felipe was able to compile it, probably because his system wasn't as up-to-date as yours. (That's why it worked in my computer too)

So I found the same error you found after doing a guix-pull. The new file I shared should work with the latest guix.

As I explain in the previous message, the error was related with the update of some packages. More specifically with some graphics libraries and `vtk`, that changed its API in the 9.0.0 version and it doesn't work.
Freecad is pretty tied to Debian-based machines so they use old-ish packages for development. It's not the first time we have issues with the packaging due to new versions not being compatible.

> Sorry for the news...

Software, mate. It is like that all the time.
After all this time on the industry, I think I'm getting used to it :)

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 22:19                                   ` Ekaitz Zarraga
@ 2021-04-12  2:03                                     ` Luis Felipe
  0 siblings, 0 replies; 27+ messages in thread
From: Luis Felipe @ 2021-04-12  2:03 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: Christophe Pisteur, help-guix

On Sunday, April 11, 2021 10:19 PM, Ekaitz Zarraga <ekaitz@elenq.tech> wrote:

> > I think it was related with vtk being updated to 9.0.0.
> > I'll package it back to 8.2.0 and see what happens.
> > https://forum.freecadweb.org/viewtopic.php?style=4&f=4&t=46934&start=10
> > I'll keep you all informed.
> > Thanks for the help!
>
> I think I have it working for the latest Guix version.
>
> Please, try with this file.
>
> WARNING: it's going to take ages to compile.

It would take (* ages 3) to compile here, so I guess I pass :)

Good luck, and thank you for working on this.


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-11 22:27                                   ` Ekaitz Zarraga
@ 2021-04-13  7:58                                     ` Christophe Pisteur
  2021-04-13  8:48                                       ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-13  7:58 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help-guix

Le dimanche 11 avril 2021 à 22:27 +0000, Ekaitz Zarraga a écrit :
> Hi Christophe,
> 
> Yes, I just sent a new version with the package to the thread.
> The problem was Luis Felipe was able to compile it, probably because
> his system wasn't as up-to-date as yours. (That's why it worked in my
> computer too)
> 
> So I found the same error you found after doing a guix-pull. The new
> file I shared should work with the latest guix.
> 
> As I explain in the previous message, the error was related with the
> update of some packages. More specifically with some graphics
> libraries and `vtk`, that changed its API in the 9.0.0 version and it
> doesn't work.
> Freecad is pretty tied to Debian-based machines so they use old-ish
> packages for development. It's not the first time we have issues with
> the packaging due to new versions not being compatible.
> 
> > Sorry for the news...
> 
> Software, mate. It is like that all the time.
> After all this time on the industry, I think I'm getting used to it
> :)

Hi Ekaitz, 

Great news: I was able to build the package and use freecad without
problems. 
I tried several features, addons, with old complex models and new tests
for the occasion. 
I could do more tests in the next days if needed. 
Many thanks for your work! 

Christophe




^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-13  7:58                                     ` Christophe Pisteur
@ 2021-04-13  8:48                                       ` Ekaitz Zarraga
  2021-04-17 16:16                                         ` Ekaitz Zarraga
  0 siblings, 1 reply; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-13  8:48 UTC (permalink / raw)
  To: Christophe Pisteur; +Cc: help-guix

Hi!

> Hi Ekaitz,
>
> Great news: I was able to build the package and use freecad without problems.
> I tried several features, addons, with old complex models and new tests for the occasion.
> I could do more tests in the next days if needed.
>
> Many thanks for your work!
>
> Christophe

That's great!
When you are done testing it, please, ping me and I'll prepare the patch for guix.
Thanks for your help!

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-13  8:48                                       ` Ekaitz Zarraga
@ 2021-04-17 16:16                                         ` Ekaitz Zarraga
  2021-04-17 19:22                                           ` Christophe Pisteur
  2021-04-17 21:02                                           ` Jérémy Korwin-Zmijowski
  0 siblings, 2 replies; 27+ messages in thread
From: Ekaitz Zarraga @ 2021-04-17 16:16 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: Christophe Pisteur, help-guix

Hi all,
This was already merged the other day so you'll have access to the 0.19.1 version of freecad if you `guix pull`.

Best,
Ekaitz


^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-17 16:16                                         ` Ekaitz Zarraga
@ 2021-04-17 19:22                                           ` Christophe Pisteur
  2021-04-17 21:02                                           ` Jérémy Korwin-Zmijowski
  1 sibling, 0 replies; 27+ messages in thread
From: Christophe Pisteur @ 2021-04-17 19:22 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: help-guix

Le samedi 17 avril 2021 à 16:16 +0000, Ekaitz Zarraga a écrit :
> Hi all,
> This was already merged the other day so you'll have access to the 0.19.1 version of freecad if you `guix pull`.
> 
> Best,
> Ekaitz

Hi Ekaitz, 

Hello,
Thank you very much for including the latest version of freecad in
guix! 
As far as I'm concerned, everything works very well: installation and
use. And I find the new version of freecad very efficient. 
Thanks again!
Christophe

^ permalink raw reply	[flat|nested] 27+ messages in thread

* Re: freecad 19.1 / flatpak
  2021-04-17 16:16                                         ` Ekaitz Zarraga
  2021-04-17 19:22                                           ` Christophe Pisteur
@ 2021-04-17 21:02                                           ` Jérémy Korwin-Zmijowski
  1 sibling, 0 replies; 27+ messages in thread
From: Jérémy Korwin-Zmijowski @ 2021-04-17 21:02 UTC (permalink / raw)
  To: Ekaitz Zarraga; +Cc: Christophe Pisteur, help-guix

Le samedi 17 avril 2021 à 16:16 +0000, Ekaitz Zarraga a écrit :
> Hi all,
> This was already merged the other day so you'll have access to the
> 0.19.1 version of freecad if you `guix pull`.
> 
> Best,
> Ekaitz

Well done !

Jérémy



^ permalink raw reply	[flat|nested] 27+ messages in thread

end of thread, other threads:[~2021-04-17 21:02 UTC | newest]

Thread overview: 27+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-03-31  9:15 freecad 19.1 / flatpak Christophe Pisteur
2021-03-31  9:46 ` Ekaitz Zarraga
2021-03-31 12:56   ` Christophe Pisteur
2021-03-31 14:29     ` Gary Johnson
2021-03-31 18:38       ` Christophe Pisteur
2021-04-02 14:43         ` Gary Johnson
2021-04-03 19:10           ` Christophe Pisteur
2021-04-03 19:21             ` Ekaitz Zarraga
2021-04-03 19:59               ` Christophe Pisteur
2021-04-03 20:26                 ` Ekaitz Zarraga
2021-04-08 13:05                   ` Ekaitz Zarraga
2021-04-11 13:30                     ` Christophe Pisteur
2021-04-11 16:45                       ` Ekaitz Zarraga
2021-04-11 19:02                         ` Christophe Pisteur
     [not found]                           ` <0bK6s9aqPT66hiBxFF21Y8VTjlN3l4=5FcHxOT5UU8Ul4vRfRFZSKXDgoz5iqi4wMPzySTfxvoQhsEyDLLQPSPqmvOTWRgUMI1uE9Zt9tqemU=3D@elenq.tech>
     [not found]                             ` <Z6I2By8DRvfgcrC3sRhhRSY5ELj5FN7r12uByZhLGXKT0fgTNjARH5ug8DuUwknGmCmomgT466hZBhtmw5lN5fv8TKgFXogdLiTqLzjS4Tg=3D@protonmail.com>
     [not found]                               ` <PkhtPGqLIEla9M1ZKtJMfMWg7736yI3-2SlbZfmjg9NFniUxEYqAyZ38=5FDsA-uIbWYF9O-bPOtpaUpredyXbPYGKhZi3UzqGadOL6yloeXc=3D@elenq.tech>
     [not found]                                 ` <hj4mUFgYr-908J1TWCQUwu43jf-qUOsrXfg8UeE=5FItCV0PokJ2j9=5F7BCB3q7nbgg2c-4S-ag-hzVW9h89MA=5FwvM8xaKCL9Eob5SPes1AGh4=3D@elenq.tech>
2021-04-11 19:30                           ` Ekaitz Zarraga
2021-04-11 20:52                             ` Luis Felipe
2021-04-11 20:59                               ` Ekaitz Zarraga
2021-04-11 21:25                                 ` Ekaitz Zarraga
2021-04-11 22:19                                   ` Ekaitz Zarraga
2021-04-12  2:03                                     ` Luis Felipe
2021-04-11 22:17                                 ` Christophe Pisteur
2021-04-11 22:27                                   ` Ekaitz Zarraga
2021-04-13  7:58                                     ` Christophe Pisteur
2021-04-13  8:48                                       ` Ekaitz Zarraga
2021-04-17 16:16                                         ` Ekaitz Zarraga
2021-04-17 19:22                                           ` Christophe Pisteur
2021-04-17 21:02                                           ` Jérémy Korwin-Zmijowski

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git