unofficial mirror of guile-user@gnu.org 
 help / color / mirror / Atom feed
* Changes to Guile not effecting built binary
@ 2024-03-21 15:34 Ryan Raymond
  2024-03-21 16:45 ` Dr. Arne Babenhauserheide
  0 siblings, 1 reply; 2+ messages in thread
From: Ryan Raymond @ 2024-03-21 15:34 UTC (permalink / raw)
  To: guile-devel, Guile User

[-- Attachment #1: Type: text/plain, Size: 644 bytes --]

Hello, all.
Earlier I mentioned a patch I wanted to apply to the guile source code. I
have implemented my change but the guile binary I build with the default
build instructions still has the unmodified function.

For example, I modified "parse-http-method" and completely removed all
error throwing capabilities but I am still getting an error thrown from
within that function.
(bad-request "Invalid method: ~a" (substring str start end))

I am assuming that the modules are not being rebuilt. My workflow is as
follows:
1. Modify the source code
2. ./configure
3. make
4. make install

Can anyone point out a mistake I might be making?

Ryan

[-- Attachment #2: Type: text/html, Size: 844 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Changes to Guile not effecting built binary
  2024-03-21 15:34 Changes to Guile not effecting built binary Ryan Raymond
@ 2024-03-21 16:45 ` Dr. Arne Babenhauserheide
  0 siblings, 0 replies; 2+ messages in thread
From: Dr. Arne Babenhauserheide @ 2024-03-21 16:45 UTC (permalink / raw)
  To: Ryan Raymond; +Cc: Guile User, guile-devel

[-- Attachment #1: Type: text/plain, Size: 929 bytes --]


Ryan Raymond <rjraymond@oakland.edu> writes:

> For example, I modified "parse-http-method" and completely removed all error throwing capabilities but I am still getting an error thrown from
> within that function.
> (bad-request "Invalid method: ~a" (substring str start end))
>
> I am assuming that the modules are not being rebuilt. My workflow is as follows:
> 1. Modify the source code
> 2. ./configure
> 3. make
> 4. make install
>
> Can anyone point out a mistake I might be making?

A shot into the blue would be that some dependencies aren’t marked
correctly in the Makefile so some file is not being rebuilt and includes
the old version of the function via a macro.

Does it also happen when you add a `make clean` step?

Does it happen when you directly run meta/guile instead of installing?

Best wishes,
Arne
-- 
Unpolitisch sein
heißt politisch sein,
ohne es zu merken.
draketo.de

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 1125 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2024-03-21 16:45 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-03-21 15:34 Changes to Guile not effecting built binary Ryan Raymond
2024-03-21 16:45 ` Dr. Arne Babenhauserheide

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).