all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
From: Bassam Saeed <guix@bassamsaeed.ca>
To: 63303@debbugs.gnu.org
Cc: Bassam Saeed <guix@bassamsaeed.ca>
Subject: [bug#63303] [PATCH] gnu: Add font-recursive.
Date: Fri,  5 May 2023 09:44:51 -0400	[thread overview]
Message-ID: <43b80967d6d5193343481185796287d6371fd39c.1683294285.git.guix@bassamsaeed.ca> (raw)

* gnu/packages/fonts.scm (font-recursive): New variable.
---
 gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3aad42493d..1cb1cb1e3f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3049,3 +3049,27 @@ (define-public font-chiron-hei-hk
 Kong variant of Adobe’s Source Han Sans.  The font aims at providing a modern,
 region-agnostic glyph set adopting the “modern” glyph style that is similar to
 prevalent typefaces in Traditional Chinese regions.")))
+
+(define-public font-recursive
+  (package
+    (name "font-recursive")
+    (version "1.085")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/arrowtype/recursive/"
+                                  "releases/download/v"
+                                  version
+                                  "/ArrowType-Recursive-"
+                                  version
+                                  ".zip"))
+              (sha256
+               (base32
+                "00ns6zwizp0wyxyrf7fxqmxm4gl7ygarxq1mj952h78q1rxdzjyb"))))
+    (build-system font-build-system)
+    (home-page "https://www.recursive.design/")
+    (synopsis "Recursive Mono & Sans is a variable font family for code & UI")
+    (description "Recursive Sans & Mono is a variable type family built for
+better code & UI.  It is inspired by casual script signpainting, but designed
+primarily to meet the needs of programming environments and application
+interfaces.")
+    (license license:silofl1.1)))

base-commit: 3efdc84bbd1819aeef6e2290aaf54bc88ba72dda
prerequisite-patch-id: 6da8a8cbe7c43c9a2a42d1dbe8a77f819bfe5357
-- 
2.39.2





             reply	other threads:[~2023-05-05 13:46 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-05-05 13:44 Bassam Saeed [this message]
2023-05-15 10:26 ` bug#63303: [PATCH] gnu: Add font-recursive 宋文武 via Guix-patches via

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=43b80967d6d5193343481185796287d6371fd39c.1683294285.git.guix@bassamsaeed.ca \
    --to=guix@bassamsaeed.ca \
    --cc=63303@debbugs.gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this external index

	https://git.savannah.gnu.org/cgit/guix.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.