unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* Issues installing GUIX system in a ThinkCentre M71e (UEFI)
@ 2020-09-19 23:02 Abraham Jose
  0 siblings, 0 replies; only message in thread
From: Abraham Jose @ 2020-09-19 23:02 UTC (permalink / raw)
  To: help-guix

[-- Attachment #1: Type: text/plain, Size: 2637 bytes --]

So i have been interested in this distribution for quite some time and
decided to try it out since my last system got corrupted, but i have ran
into some problems while booting

#Specs
The machine is a ThinkCentreM71e (
https://support.lenovo.com/au/en/solutions/pd015061) with an I5 and 8GB of
ram

#Installation proccess
1- Burned the image (its like 2 months old, didn't have much time to update
it when my previous system died but i dont think that matters too much)
with ´dd if=GuixSystem.iso of=/dev/sdc´, booted into the live USB in UEFI
mode  (confirmed it by checking if efivars existed, wich it did)
2- Made a graphical install and once the config file was generated and
fitted my likings rebooted and did a manual install (i fixed the
filesystems UUIDs, obviously)
3-  After loading my keyboard layout (la-latin1) i formated my drive with 4
partitions(first and second pics(yes, sda is gpt and sda1 is dos for some
unholy reason)):
  3.1- sda1(boot): I made an 1gb partition in cfdisk with EFI system as its
type, labelled it gpt in fdisk, marked it with esp in parted, formated it
FAT32 with ´mkfs.fat -F32 /dev/sda1´ and finally i mounted it in
/mnt/boot/efi.
  3.2- sda2(swap): 8gb, made with ´mkswap /dev/sda2´ and ´swapon /dev/sda2´
  3.3- sda3(root): 100.5gb, made with ´mkfs.ext4 /dev/sda3´, mounted on /mnt
  3.4- sda4(home): 129gb, made with ´mkfs.ext4 /dev/sda4´, mounted on
/mnt/home
4- Then i did ´herd start cow-store /mnt´ and ´guix system init
/mnt/etc/config.scm /mnt´
5- Installation went smooothly with no errors, asked me to restart.

#Problems
1- When i restarted i was met with an blackscreen, not even a grub recovery
or something, the installation prompt said that everything went alright,
the config file had -- on it, im not sure if i failed in something
2- Everything seems a tad ummm incomplete?, my user isnt in the home
directory, /etc ONLY has the configuration file, etc. The only ones that
appear complete are /gnu/ (a TON of files) and /boot/ (has
efi/EFI/Guix/grubx64.efi and  the grub folder wich appears to be complete)

#Config file
See the third pic

#Notes
1- I wish there was a more minimalist image and a full image/offline with
all the programs, for people like me that have awful internet and like a
clean system its something very helpful
2- I had this same issue with artix but they had an "detect uefi and boot"
option so it never bothered me as much, im wondering if there is something
like that in the live image, i would do it even if i have to edit the init
script
3- Im sorry about the size of the images.

[-- Attachment #2: 2_partitions.jpg --]
[-- Type: image/jpeg, Size: 2387633 bytes --]

[-- Attachment #3: 1_partitions.jpg --]
[-- Type: image/jpeg, Size: 3064626 bytes --]

[-- Attachment #4: 3_config.jpg --]
[-- Type: image/jpeg, Size: 3050629 bytes --]

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2020-09-20  0:27 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-19 23:02 Issues installing GUIX system in a ThinkCentre M71e (UEFI) Abraham Jose

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git