unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* issue with gnome keyboard settings for dead keys
@ 2021-05-27 16:59 Tomás Chapunov
  2021-05-27 19:27 ` Luis Felipe
  0 siblings, 1 reply; 2+ messages in thread
From: Tomás Chapunov @ 2021-05-27 16:59 UTC (permalink / raw)
  To: help-guix

I have a strange issue with the dead keys in my spanish keyboard. I have a
Logitech G-105 gaming keyboard.
I type ok, but my I`m used to type the "tildes" pressing the tilde key, and
after that the letter.
And my gnome setting recognized my keyboard mapping exactly, but in the "no
dead keys" option. I can change the option to "dead tilde" and works, but
the key mapping is not accurate, seems to be from another keyboard.
Where can I look for the solution? Thanks!

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: issue with gnome keyboard settings for dead keys
  2021-05-27 16:59 issue with gnome keyboard settings for dead keys Tomás Chapunov
@ 2021-05-27 19:27 ` Luis Felipe
  0 siblings, 0 replies; 2+ messages in thread
From: Luis Felipe @ 2021-05-27 19:27 UTC (permalink / raw)
  To: Tomás Chapunov; +Cc: help-guix

Hi Tomás,

On Thursday, May 27, 2021 4:59 PM, Tomás Chapunov <tomaschapunov@gmail.com> wrote:

> I have a strange issue with the dead keys in my spanish keyboard. I have a
> Logitech G-105 gaming keyboard.
> I type ok, but my I`m used to type the "tildes" pressing the tilde key, and
> after that the letter.

That's the way it works for me. I press the accent key, then the vocal key.

My keyboard layout indicated in the OS configuration file looks like this:

  (keyboard-layout (keyboard-layout "latam" #:options '("ctrl:nocaps")))

And GNOME Settings displays this:

https://luis-felipe.gitlab.io/media/2021/05/gnome-setting-spanish-latam-keyboard-2021-05-27.png

Which is what I'd expect.


> And my gnome setting recognized my keyboard mapping exactly, but in the "no
> dead keys" option. I can change the option to "dead tilde" and works, but
> the key mapping is not accurate, seems to be from another keyboard.
> Where can I look for the solution? Thanks!

I'm not sure, but What's in the keyboard-layout field in your OS configuration file?


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-05-27 19:28 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-27 16:59 issue with gnome keyboard settings for dead keys Tomás Chapunov
2021-05-27 19:27 ` Luis Felipe

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git