unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* Xdm trisquel login fails after installing gajim on a fresh guix install (works after rolling back)
@ 2021-06-02  8:16 David Lecompte
  2021-06-02 13:30 ` Adonay Felipe Nogueira via
  0 siblings, 1 reply; 3+ messages in thread
From: David Lecompte @ 2021-06-02  8:16 UTC (permalink / raw)
  To: help-guix

Hi all,

I installed Guix on Trisquel 9 on an X200 following advice from the
section 2 of the manual. I ran the script mentioned in the first note
with sudo and made the guess that it replaces the steps from sections
2.1 up to 2.5 included, even though that is not mentioned.

Then, following advice from section 2.6 and 2.7, I installed the Guix
packages glibc-locales, fontconfig, font-adobe-source-han-sans and nss-
certs, and I installed the Trisquel package nscd. Then I ran guix pull,
guix package -u, sudo -i guix pull and systemctl restart guix-
daemon.service.

I understand one needs to run guix pull and guix package -u
periodically, but I don't know whether the last two are also needed as
frequently, I couldn't find any recommendation on that in the manual.

Anyway, the actions and time it took looked similar to when I installed
Guix on another computer running Trisquel 9 before, and everything was
working ok.

One small remark though: at various times, there are messages
recommending to set PATH, GUIX_PATH or GUIX_LOCPATH but these variables
are actually set automatically as part of the installation process, so
these messages are a bit misleading.

Then, when I asked to install the Guix gajim package, to my surprise,
the output said it needs to download more than 100 MB and a crazy number
of packages were processed, among which texlive or xorg, it took at lest
as long as all the previous steps and both cores of my CPU were at 100%
for more than 30 minutes. I'd love to provide some log of the output but
I didn't redirect it to a file and I don't know if that is kept
somewhere.

When it was finished, I logged out and logged in using the default
Trisquel xdm, my password is accepted but after maybe 30s, I get back to
the login screen and any further attempt to log in has the same result.

I logged in a console terminal, and since I did not know what to do, I
rolled back and then I could log in via xdm normally again.

I don't know whether I did something wrong when installing Guix or if
there is an issue with the gajim package, or with installing it in Guix
now, or the combination of both. My Trisquel 9 install is very recent
and Trisquel is highly stable, so I doubt there is anything wrong with
it.

I am happy that rolling back removes the problem but I'd like to find
out how to use guix without breaking trisquel.

Thanks in advance for the help.

David.





^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-06-02 17:36 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-02  8:16 Xdm trisquel login fails after installing gajim on a fresh guix install (works after rolling back) David Lecompte
2021-06-02 13:30 ` Adonay Felipe Nogueira via
2021-06-02 17:35   ` David Lecompte

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git