unofficial mirror of guix-patches@gnu.org 
 help / color / mirror / code / Atom feed
* [bug#63303] [PATCH] gnu: Add font-recursive.
@ 2023-05-05 13:44 Bassam Saeed
  2023-05-15 10:26 ` bug#63303: " 宋文武 via Guix-patches via
  0 siblings, 1 reply; 2+ messages in thread
From: Bassam Saeed @ 2023-05-05 13:44 UTC (permalink / raw)
  To: 63303; +Cc: Bassam Saeed

* gnu/packages/fonts.scm (font-recursive): New variable.
---
 gnu/packages/fonts.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3aad42493d..1cb1cb1e3f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3049,3 +3049,27 @@ (define-public font-chiron-hei-hk
 Kong variant of Adobe’s Source Han Sans.  The font aims at providing a modern,
 region-agnostic glyph set adopting the “modern” glyph style that is similar to
 prevalent typefaces in Traditional Chinese regions.")))
+
+(define-public font-recursive
+  (package
+    (name "font-recursive")
+    (version "1.085")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/arrowtype/recursive/"
+                                  "releases/download/v"
+                                  version
+                                  "/ArrowType-Recursive-"
+                                  version
+                                  ".zip"))
+              (sha256
+               (base32
+                "00ns6zwizp0wyxyrf7fxqmxm4gl7ygarxq1mj952h78q1rxdzjyb"))))
+    (build-system font-build-system)
+    (home-page "https://www.recursive.design/")
+    (synopsis "Recursive Mono & Sans is a variable font family for code & UI")
+    (description "Recursive Sans & Mono is a variable type family built for
+better code & UI.  It is inspired by casual script signpainting, but designed
+primarily to meet the needs of programming environments and application
+interfaces.")
+    (license license:silofl1.1)))

base-commit: 3efdc84bbd1819aeef6e2290aaf54bc88ba72dda
prerequisite-patch-id: 6da8a8cbe7c43c9a2a42d1dbe8a77f819bfe5357
-- 
2.39.2





^ permalink raw reply related	[flat|nested] 2+ messages in thread

* bug#63303: [PATCH] gnu: Add font-recursive.
  2023-05-05 13:44 [bug#63303] [PATCH] gnu: Add font-recursive Bassam Saeed
@ 2023-05-15 10:26 ` 宋文武 via Guix-patches via
  0 siblings, 0 replies; 2+ messages in thread
From: 宋文武 via Guix-patches via @ 2023-05-15 10:26 UTC (permalink / raw)
  To: Bassam Saeed; +Cc: 63303-done

Bassam Saeed <guix@bassamsaeed.ca> writes:

> * gnu/packages/fonts.scm (font-recursive): New variable.

Applied with change synopsis to "Variable font family for code & UI".

Thank you!




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2023-05-15 10:27 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-05-05 13:44 [bug#63303] [PATCH] gnu: Add font-recursive Bassam Saeed
2023-05-15 10:26 ` bug#63303: " 宋文武 via Guix-patches via

Code repositories for project(s) associated with this public inbox

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).