unofficial mirror of guix-devel@gnu.org 
 help / color / mirror / code / Atom feed
* python-libcst upgrade and python-flake8
@ 2022-06-10  4:14 jgart
  2022-06-10  6:27 ` Lars-Dominik Braun
  0 siblings, 1 reply; 2+ messages in thread
From: jgart @ 2022-06-10  4:14 UTC (permalink / raw)
  To: Guix Devel

Hi Guixers,

What do suggest as a recommended fix for this error?

```
============================= 482 passed in 3.80s ==============================
phase `check' succeeded after 5.0 seconds
starting phase `sanity-check'
validating 'flake8' /gnu/store/zaw5z708sldm6v3qxjczcia7gl65dw5x-python-flake8-3.9.2/lib/python3.9/site-packages
...checking requirements: ERROR: flake8==3.9.2 ContextualVersionConflict(pyflakes 2.4.0 (/gnu/store/mxkp1zl64cd3i247shp7njkxad8v13x9-python-pyflakes-2.4.0/lib/python3.9/site-packages), Requirement.parse('pyflakes<2.4.0,>=2.3.0'), {'flake8'})
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/zaw5z708sldm6v3qxjczcia7gl65dw5x-python-flake8-3.9.2/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f> 
phase `sanity-check' failed after 0.2 seconds
command "python" "/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/zaw5z708sldm6v3qxjczcia7gl65dw5x-python-flake8-3.9.2/lib/python3.9/site-packages" failed with status 1
builder for `/gnu/store/khh67agxwf3rvbrrph2m4x0ki7b0my2c-python-flake8-3.9.2.drv' failed with exit code 1
build of /gnu/store/khh67agxwf3rvbrrph2m4x0ki7b0my2c-python-flake8-3.9.2.drv failed
Could not find build log for '/gnu/store/khh67agxwf3rvbrrph2m4x0ki7b0my2c-python-flake8-3.9.2.drv'.
building /gnu/store/grfg324ljk5hpkwqq45pw99klxjib4bm-python-libcst-minimal-0.4.3.drv...
cannot build derivation `/gnu/store/5amv1366vcs79l3z0jfpd1c6s5w0315b-python-pylama-7.7.1.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/k6nw3cj8ckd3ss9v7a73km47wz27mkfw-python-isort-5.10.1.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/dd8qjvk6cd3xxfl6vspax6vbp3yyiix2-python-libcst-0.4.3.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/dd8qjvk6cd3xxfl6vspax6vbp3yyiix2-python-libcst-0.4.3.drv' failed
```

I was trying to upgrade python-libcst:

http://dpaste.com/AQDS5XW42 

Should I package a new version of flake8 that doesn't have a version conflict or patch out libcst?

all best,

jgart


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: python-libcst upgrade and python-flake8
  2022-06-10  4:14 python-libcst upgrade and python-flake8 jgart
@ 2022-06-10  6:27 ` Lars-Dominik Braun
  0 siblings, 0 replies; 2+ messages in thread
From: Lars-Dominik Braun @ 2022-06-10  6:27 UTC (permalink / raw)
  To: jgart; +Cc: Guix Devel

Hi jgart,

> validating 'flake8' /gnu/store/zaw5z708sldm6v3qxjczcia7gl65dw5x-python-flake8-3.9.2/lib/python3.9/site-packages
> ...checking requirements: ERROR: flake8==3.9.2 ContextualVersionConflict(pyflakes 2.4.0 (/gnu/store/mxkp1zl64cd3i247shp7njkxad8v13x9-python-pyflakes-2.4.0/lib/python3.9/site-packages), Requirement.parse('pyflakes<2.4.0,>=2.3.0'), {'flake8'})
I believe this was fixed in Guix proper already by upgrading to 4.0.1
and loosening the version checks. In any case it’s not a problem with
the library you are trying to package.

Cheers,
Lars



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-06-10  6:29 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-06-10  4:14 python-libcst upgrade and python-flake8 jgart
2022-06-10  6:27 ` Lars-Dominik Braun

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).