unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#52869: xpra 4.3 appears to be broken
@ 2021-12-29  9:38 t
  2022-01-03  8:20 ` Lars-Dominik Braun
  0 siblings, 1 reply; 3+ messages in thread
From: t @ 2021-12-29  9:38 UTC (permalink / raw)
  To: 52869


Hello guix.

Relatively fresh guix, pulled 2 days ago.

--------
$ guix describe
Generation 10	Dec 27 2021 15:36:01	(current)
  guix 9e9489f
    repository URL: https://git.savannah.gnu.org/git/guix.git
    branch: master
    commit: 9e9489fb11ac73e51abe293235738d70365affa9
--------

Installing xpra 4.3 package as described in xorg.scm. Looks like 
it pulls a substitute with upstream log at 
https://ci.guix.gnu.org/log/sy4ar80nk2hq32axl4by7bgmns6bcwl0-xpra-4.3 
where I don't really see anything pop as suspicious

Attempting to start a session however fails:
--------
$ guix environment --ad-hoc xpra --pure -- xpra start :100
2021-12-29 09:44:20,712 Warning: cannot load cython bencode 
module: No module named 'xpra.net.bencode.cython_bencode'
Warning: using '/run/user/1000' as XDG_RUNTIME_DIR
xpra initialization error:
 start is not supported by this local installation
--------

I reported this to xpra maintainer first thinking the problem was 
there https://github.com/Xpra-org/xpra/issues/3403 but they confirmed that our build was likely incomplete. As per 
above you can already tell that cython_bencode is in fact missing 
and indeed I don't see it in the built artefact in the store, 
though it is present in the source repo. "start not supported" 
above indicates we have bigger issues, as per maintainer we 
probably don't have access to the server component. Briefly 
grepping for that warning origin, looks like we're likely failing 
the supports_server test in xpra/scripts/parsing.py:

if supports_server:
    try:
        from xpra.x11.bindings.wait_for_x_server import 
        wait_for_x_server    #@UnresolvedImport @UnusedImport
    except ImportError:
        supports_server = False


I am way out of my depth to debug this on my own, but happy to try 
and assist.

I believe the previous build of 4.2.smth worked for me, so must be 
something new. Is there an easy way to downgrade this package 
without rolling entire guix? Do I use inferior guix for that 
somehow?

Happy to follow this up with guix xpra package maintainer if only 
I could figure who that courageous soul was.

Thanks




^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#52869: xpra 4.3 appears to be broken
  2021-12-29  9:38 bug#52869: xpra 4.3 appears to be broken t
@ 2022-01-03  8:20 ` Lars-Dominik Braun
  2022-01-07  8:02   ` Lars-Dominik Braun
  0 siblings, 1 reply; 3+ messages in thread
From: Lars-Dominik Braun @ 2022-01-03  8:20 UTC (permalink / raw)
  To: t; +Cc: 52869, atai

Hi,


> $ guix environment --ad-hoc xpra --pure -- xpra start :100
> 2021-12-29 09:44:20,712 Warning: cannot load cython bencode 
> module: No module named 'xpra.net.bencode.cython_bencode'
> Warning: using '/run/user/1000' as XDG_RUNTIME_DIR
> xpra initialization error:
>  start is not supported by this local installation
it’s also broken for me and I couldn’t come up with an easy fix,
so I reverted the upgrade to 4.3 for now. If you `guix pull` it should
be back to 4.2.2.

You definitely can use inferiors to work around something like this. You
could also run a known-good version via `guix shell --commit=xxx`.

Cheers,
Lars





^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#52869: xpra 4.3 appears to be broken
  2022-01-03  8:20 ` Lars-Dominik Braun
@ 2022-01-07  8:02   ` Lars-Dominik Braun
  0 siblings, 0 replies; 3+ messages in thread
From: Lars-Dominik Braun @ 2022-01-07  8:02 UTC (permalink / raw)
  To: t; +Cc: 52869-done

Hi again,

> it’s also broken for me and I couldn’t come up with an easy fix,
> so I reverted the upgrade to 4.3 for now. If you `guix pull` it should
> be back to 4.2.2.
it looks like this was not sufficient. I pushed
927c58925667eabdcd07a9dc68e283ef0f6b6b0e to fix it and upgraded xpra
again in b3b6373cd6a759896b2c5ea4f84b7f0fa9df9e8d.

Cheers,
Lars





^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-01-07  8:04 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-29  9:38 bug#52869: xpra 4.3 appears to be broken t
2022-01-03  8:20 ` Lars-Dominik Braun
2022-01-07  8:02   ` Lars-Dominik Braun

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).