unofficial mirror of 
 help / color / mirror / code / Atom feed
* bug#69616: Regression in eshell-tramp since Emacs 29.1
@ 2024-03-07 18:08 Baptiste Strazzulla
  0 siblings, 0 replies; only message in thread
From: Baptiste Strazzulla @ 2024-03-07 18:08 UTC (permalink / raw)
  To: 69616

[-- Attachment #1: Type: text/plain, Size: 1144 bytes --]


Since the Emacs upgrade to 29.1 last october, I've been struggling with `sudo` in Emacs shell with the `eshell-tramp` module loaded (`(add-to-list 'eshell-modules-list 'eshell-tramp)`).

It fails if given any command in ~/.guix-profile/bin:

~ $ sudo git
git: command not found

and also fails (and downright kills the buffer) if given any command in /run/current-system/profile/bin

~ $ sudo guix
sudo: /run/current-system/profile/bin/sudo must be owned by uid 0 and have the setuid bit set

I tried with Emacs 28.1 on an old generation of packages I had and both commands worked fine on it.

I could also just not load this module anymore but as it turns out, `guix` is having problem finding modules defined in external channels then:

~ $ sudo guix system reconfigure ~/.config/guix/config.scm
guix system: error: failed to load '/home/baptiste/.config/guix/config.scm':
/home/baptiste/.config/guix/config.scm:127:2: Module named (nongnu packages linux) has no public interface

Does anyone have any ideas?

Kind regards and thank you for your dedication,
Baptiste Strazzulla

[-- Attachment #2: Type: text/html, Size: 5186 bytes --]

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2024-03-16 21:50 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-03-07 18:08 bug#69616: Regression in eshell-tramp since Emacs 29.1 Baptiste Strazzulla

Code repositories for project(s) associated with this public inbox

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).