unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64
@ 2021-05-13  2:01 Leo Famulari
  2021-08-20 11:16 ` Timotej Lazar
  2022-08-04 23:03 ` Pavel Shlyak
  0 siblings, 2 replies; 4+ messages in thread
From: Leo Famulari @ 2021-05-13  2:01 UTC (permalink / raw)
  To: 48393

I tried building the installer on my aarch64 computer, but it fails to
build v86d, as shown below.

This package v86d is used in the installer's uvesafb-shepherd-service
service, which is supposed to not be used on aarch64 (the 'start' action
of the service limits use to Intel-compatible systems).

------
$ guix system image -t iso9660 gnu/system/install.scm -v3
[...]
starting phase `build'
make -e -w -C libs/lrmi-0.10 liblrmi.a
/gnu/store/ap7hgyv4rjqmhg4a6cb6cypsh3g1f5q4-gcc-7.5.0/bin/gcc -Wall -g -O2 -I/lib/modules/5.11.19-gnu/source/include -Ilibs/lrmi-0.10 -c -o v86_lrmi.o v86_lrmi.c
make[1]: Entering directory '/tmp/guix-build-v86d-0.1.10.drv-0/v86d-0.1.10-checkout/libs/lrmi-0.10'
/gnu/store/ap7hgyv4rjqmhg4a6cb6cypsh3g1f5q4-gcc-7.5.0/bin/gcc -c  -g -Wall -o lrmi.o lrmi.c
/gnu/store/ap7hgyv4rjqmhg4a6cb6cypsh3g1f5q4-gcc-7.5.0/bin/gcc -Wall -g -O2 -I/lib/modules/5.11.19-gnu/source/include -Ilibs/lrmi-0.10 -c -o v86_common.o v86_common.c
/gnu/store/ap7hgyv4rjqmhg4a6cb6cypsh3g1f5q4-gcc-7.5.0/bin/gcc -Wall -g -O2 -I/lib/modules/5.11.19-gnu/source/include -Ilibs/lrmi-0.10 -c -o v86.o v86.c
lrmi.c:1093:2: warning: #warning "LRMI is not supported on your system!" [-Wcpp]
 #warning "LRMI is not supported on your system!"
  ^~~~~~~
In file included from v86_lrmi.c:2:0:
libs/lrmi-0.10/lrmi.h:105:2: warning: #warning "LRMI is not supported on your system!" [-Wcpp]
 #warning "LRMI is not supported on your system!"
  ^~~~~~~
ar -rs liblrmi.a lrmi.o
In file included from v86_lrmi.c:3:0:
v86.h:8:10: fatal error: config.h: No such file or directory
 #include "config.h"
          ^~~~~~~~~~
In file included from v86_common.c:2:0:
v86.h:8:10: fatal error: config.h: No such file or directory
 #include "config.h"
          ^~~~~~~~~~
compilation terminated.
compilation terminated.
make: *** [Makefile:40: v86_lrmi.o] Error 1
ar: make: *** Waiting for unfinished jobs....
creating liblrmi.a
make: *** [Makefile:40: v86_common.o] Error 1
make[1]: Leaving directory '/tmp/guix-build-v86d-0.1.10.drv-0/v86d-0.1.10-checkout/libs/lrmi-0.10'
In file included from v86.c:17:0:
v86.h:8:10: fatal error: config.h: No such file or directory
 #include "config.h"
          ^~~~~~~~~~
compilation terminated.
make: *** [Makefile:40: v86.o] Error 1
command "make" "-j" "4" failed with status 2
builder for `/gnu/store/ll2g97yxbqrqr4vsn0i5zjhdf3dbigpq-v86d-0.1.10.drv' failed with exit code 1
build of /gnu/store/ll2g97yxbqrqr4vsn0i5zjhdf3dbigpq-v86d-0.1.10.drv failed
View build log at '/var/log/guix/drvs/ll/2g97yxbqrqr4vsn0i5zjhdf3dbigpq-v86d-0.1.10.drv.bz2'.
cannot build derivation `/gnu/store/afv6x2id02mldbyirv59d7q3vwabkd27-shepherd-maybe-uvesafb.scm.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/fx3cfyff5lcgjd1dr3j2088cgsii0x7n-shepherd-maybe-uvesafb.go.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/3bbh5zpifch3jrb1g050pn5hvsza5dfq-shepherd.conf.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/gnrykng6fgcqg75z26gfyjcnbd3j7gx2-boot.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/yxikf0sqa67ydlbfk99dkw7brh5bg4a8-system.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/dzs47c2p79cj8yycmnxirab3xamcfsy6-image.iso.drv': 1 dependencies couldn't be built
guix system: error: build of `/gnu/store/dzs47c2p79cj8yycmnxirab3xamcfsy6-image.iso.drv' failed
------




^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64
  2021-05-13  2:01 bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64 Leo Famulari
@ 2021-08-20 11:16 ` Timotej Lazar
  2022-08-04 23:03 ` Pavel Shlyak
  1 sibling, 0 replies; 4+ messages in thread
From: Timotej Lazar @ 2021-08-20 11:16 UTC (permalink / raw)
  To: Leo Famulari, 48393

Leo Famulari <leo@famulari.name> [2021-05-12 22:01:29-0400]:
> I tried building the installer on my aarch64 computer, but it fails to
> build v86d, as shown below.

I just hit this one too. It’s been discussed previously[0]; as you note,
the problem is that v86d is built even though it’s not used on aarch64.
The patch in [1] works when compiling natively, not sure about cross
compiling.

I tried unsuccessfully to get the solution with let-system[2] to work,
maybe someone better versed in gexps can help?

[0] https://bugs.gnu.org/41120
[1] https://bugs.gnu.org/41120#20
[2] https://bugs.gnu.org/41120#23




^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64
  2021-05-13  2:01 bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64 Leo Famulari
  2021-08-20 11:16 ` Timotej Lazar
@ 2022-08-04 23:03 ` Pavel Shlyak
  2022-08-05 13:06   ` pelzflorian (Florian Pelz)
  1 sibling, 1 reply; 4+ messages in thread
From: Pavel Shlyak @ 2022-08-04 23:03 UTC (permalink / raw)
  To: 48393

This one is done with https://issues.guix.gnu.org/55806. I suggest closing it as resolved.



^ permalink raw reply	[flat|nested] 4+ messages in thread

* bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64
  2022-08-04 23:03 ` Pavel Shlyak
@ 2022-08-05 13:06   ` pelzflorian (Florian Pelz)
  0 siblings, 0 replies; 4+ messages in thread
From: pelzflorian (Florian Pelz) @ 2022-08-05 13:06 UTC (permalink / raw)
  To: 48393-done; +Cc: Pavel Shlyak

Pavel Shlyak <p.shlyak@pantherx.org> writes:
> This one is done with https://issues.guix.gnu.org/55806. I suggest closing it as resolved.

Indeed.  With 55806, the uvesafb is added if (supported-package? v86d
system), avoiding the need to check the system.  I’m Closing by sending
a mail to 48393-done@debbugs.gnu.org.

Thank you!




^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2022-08-05 13:11 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-13  2:01 bug#48393: Can't build installer on aarch64 / v86d fails to build on aarch64 Leo Famulari
2021-08-20 11:16 ` Timotej Lazar
2022-08-04 23:03 ` Pavel Shlyak
2022-08-05 13:06   ` pelzflorian (Florian Pelz)

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).