unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8
@ 2022-04-28  0:22 Benjamin Slade
  2022-04-30 21:11 ` Maxime Devos
  0 siblings, 1 reply; 5+ messages in thread
From: Benjamin Slade @ 2022-04-28  0:22 UTC (permalink / raw)
  To: 55158

[-- Attachment #1: Type: text/plain, Size: 740 bytes --]

The output of mu [ <https://guix.gnu.org/en/packages/mu-1.6.10/> ] (and thus, by extension, mu4e in Emacs) does not correctly handle characters outside of a certain range (which confuses Emacs to no end). This behaviour occurs both in mu4e and when using mu on the commandline.

For instance, subject lines including the 🎉 emoji ("celebration") do not show the emoji, but rather a backslashed \360. Similar issues occur with, for instance, devanagari characters (Hindi etc.).

When using mu/mu4e on non-Guix systems, this issue does not occur. (I.e. both in mu4e and in mu on the commandline these characters are correctly displayed.)

Since mu depends on xapian, it's possible the issue could also be with Guix's xapian package.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8
  2022-04-28  0:22 bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8 Benjamin Slade
@ 2022-04-30 21:11 ` Maxime Devos
  2022-04-30 21:50   ` Benjamin Slade
  0 siblings, 1 reply; 5+ messages in thread
From: Maxime Devos @ 2022-04-30 21:11 UTC (permalink / raw)
  To: Benjamin Slade, 55158

[-- Attachment #1: Type: text/plain, Size: 913 bytes --]

Benjamin Slade schreef op wo 27-04-2022 om 18:22 [-0600]:
> The output of mu [ <https://guix.gnu.org/en/packages/mu-1.6.10/> ] (and thus, by extension, mu4e in Emacs) does not correctly handle characters outside of a certain range (which confuses Emacs to no end). This behaviour occurs both in mu4e and when using mu on the commandline.
> 
> For instance, subject lines including the 🎉 emoji ("celebration") do not show the emoji, but rather a backslashed \360. Similar issues occur with, for instance, devanagari characters (Hindi etc.).
> 
> When using mu/mu4e on non-Guix systems, this issue does not occur. (I.e. both in mu4e and in mu on the commandline these characters are correctly displayed.)
> 
> Since mu depends on xapian, it's possible the issue could also be with Guix's xapian package.

Does installing glibc-locales + logging in and out again have an
effect?

Greetings,
Maxime.

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 260 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8
  2022-04-30 21:11 ` Maxime Devos
@ 2022-04-30 21:50   ` Benjamin Slade
  2022-05-07 20:23     ` Benjamin Slade
  0 siblings, 1 reply; 5+ messages in thread
From: Benjamin Slade @ 2022-04-30 21:50 UTC (permalink / raw)
  To: Maxime Devos; +Cc: 55158

[-- Attachment #1: Type: text/plain, Size: 1196 bytes --]

On Sat, 30 Apr 2022 15:11:01 -0600 (39 minutes, 22 seconds ago), Maxime Devos <maximedevos@telenet.be> wrote:

> 
> Benjamin Slade schreef op wo 27-04-2022 om 18:22 [-0600]:
> > The output of mu [ <https://guix.gnu.org/en/packages/mu-1.6.10/> ] (and thus,
> > by extension, mu4e in Emacs) does not correctly handle characters outside of a
> > certain range (which confuses Emacs to no end). This behaviour occurs both in
> > mu4e and when using mu on the commandline.
> > 
> > For instance, subject lines including the 🎉 emoji ("celebration") do not show
> > the emoji, but rather a backslashed \360. Similar issues occur with, for
> > instance, devanagari characters (Hindi etc.).
> > 
> > When using mu/mu4e on non-Guix systems, this issue does not occur. (I.e. both
> > in mu4e and in mu on the commandline these characters are correctly
> > displayed.)
> > 
> > Since mu depends on xapian, it's possible the issue could also be with Guix's
> > xapian package.

> Does installing glibc-locales + logging in and out again have an
> effect?

> Greetings,
> Maxime.

> 


I've had glibc-locales installed for some time and have rebooted the machines many times. 

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8
  2022-04-30 21:50   ` Benjamin Slade
@ 2022-05-07 20:23     ` Benjamin Slade
  2022-06-08 21:32       ` Maxim Cournoyer
  0 siblings, 1 reply; 5+ messages in thread
From: Benjamin Slade @ 2022-05-07 20:23 UTC (permalink / raw)
  To: 55158; +Cc: Maxime Devos

[-- Attachment #1: Type: text/plain, Size: 889 bytes --]

Update: So the encoding issue seems to be at a "lower level" than mu in fact. I noticed that new messages come through with the correct encoding now, so I assume it was an (odd) issue of locale settings when I initialised the mail initially/copied over old messages.

(Unfortunately there does not seem to be a great way to mass re-encode messages. I can use `iconv' to convert, but it fails on messages with attachments, I think.)

best,
 —Ben
--

'(Dr Benjamin Slade (he/him)
     ((Linguistics . University of Utah) . <https://linguistics.utah.edu> )
     `(pgp_fp: ,(21BA 2AE1 28F6 DF36 110A 0E9C A320 BBE8 2B52 EE19))
       ((:official-mail . <b.slade@utah.edu>)
        (:secure-mail . <slade@lambda-y.net>))    
     (:website . <https://lambda-y.net> )
       "sent by mu4e 1.6.10 in Emacs 28.1.50 with org-msg on GNU Guix")

^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8
  2022-05-07 20:23     ` Benjamin Slade
@ 2022-06-08 21:32       ` Maxim Cournoyer
  0 siblings, 0 replies; 5+ messages in thread
From: Maxim Cournoyer @ 2022-06-08 21:32 UTC (permalink / raw)
  To: Benjamin Slade; +Cc: 55158-done, Maxime Devos

Hi,

Benjamin Slade <slade@lambda-y.net> writes:

> Update: So the encoding issue seems to be at a "lower level" than mu
> in fact. I noticed that new messages come through with the correct
> encoding now, so I assume it was an (odd) issue of locale settings
> when I initialised the mail initially/copied over old messages.
>
> (Unfortunately there does not seem to be a great way to mass re-encode messages. I can use `iconv' to convert, but it fails on messages with attachments, I think.)

OK.  I'm glad you could figure it out at least to some degrees :-).

I'll close the report but if it becomes a problem again feel free to
reopen it, with a reproducer ideally.

Thanks,

Maxim




^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2022-06-08 21:33 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-04-28  0:22 bug#55158: bug: mu/mu4e on Guix does not use correct encoding/utf-8 Benjamin Slade
2022-04-30 21:11 ` Maxime Devos
2022-04-30 21:50   ` Benjamin Slade
2022-05-07 20:23     ` Benjamin Slade
2022-06-08 21:32       ` Maxim Cournoyer

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).