unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#51790: On core-updates-frozen, tracker-miners can’t find its tracker dependency
@ 2021-11-12 12:31 Vivien Kraus via Bug reports for GNU Guix
       [not found] ` <handler.51790.B.163672027322232.ack@debbugs.gnu.org>
  2021-11-13  9:36 ` bug#51790: On core-updates-frozen, tracker-miners can’t find its tracker dependency Ricardo Wurmus
  0 siblings, 2 replies; 3+ messages in thread
From: Vivien Kraus via Bug reports for GNU Guix @ 2021-11-12 12:31 UTC (permalink / raw)
  To: 51790

[-- Attachment #1: Type: text/plain, Size: 244 bytes --]


Dear guix,

I can’t build tracker-miners on core-updates-frozen, because it fails
its configuration phase not finding tracker-sparql 3.0 (a pkg-config
definition installed by tracker, which is a dependency).

Best regards,

Vivien

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 658 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#51790: [PATCH] Re: bug#51790: Fix it (On core-updates-frozen, tracker-miners can’t find its tracker dependency)
       [not found] ` <handler.51790.B.163672027322232.ack@debbugs.gnu.org>
@ 2021-11-13  8:22   ` Vivien Kraus via Bug reports for GNU Guix
  0 siblings, 0 replies; 3+ messages in thread
From: Vivien Kraus via Bug reports for GNU Guix @ 2021-11-13  8:22 UTC (permalink / raw)
  To: 51790


[-- Attachment #1.1: Type: text/plain, Size: 108 bytes --]


It turns out that tracker-miners wants the same libsoup version as
tracker, so we need libsoup-minimal-2.


[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #1.2: Use libsoup2 in tracker-miners --]
[-- Type: text/x-patch, Size: 1546 bytes --]

From e76c51853913686234ec008cc9cf6e3117a15fa2 Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Sat, 13 Nov 2021 08:19:09 +0000
Subject: [PATCH] gnu: tracker-miners: Require the same libsoup as tracker.

* gnu/packages/gnome.scm (tracker-miners) [inputs]: Use the same libsoup
version as tracker.
* gnu/packages/gnome.scm (tracker) [inputs]: Warn that tracker-miners should
use the same version of libsoup.
---
 gnu/packages/gnome.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9557fcf4c8..bc885156e4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8923,7 +8923,8 @@ (define-public tracker
        ("libxml2" ,libxml2)
        ("icu4c" ,icu4c)                 ; libunistring gets miner-miner-fs test to fail.
        ("json-glib" ,json-glib)
-       ("libsoup" ,libsoup-minimal-2)))
+       ("libsoup" ,libsoup-minimal-2)   ; tracker-miners requires the same version.
+       ))
     (synopsis "Metadata database, indexer and search tool")
     (home-page "https://wiki.gnome.org/Projects/Tracker")
     (description
@@ -9042,7 +9043,7 @@ (define-public tracker-miners
        ("libosinfo" ,libosinfo)
        ("libpng" ,libpng)
        ("libseccomp" ,libseccomp)
-       ("libsoup" ,libsoup)
+       ("libsoup" ,libsoup-minimal-2) ; because tracker requires this version.
        ("libtiff" ,libtiff)
        ("libvorbis" ,libvorbis)
        ("libxml2" ,libxml2)
-- 
2.33.1


[-- Attachment #1.3: Type: text/plain, Size: 8 bytes --]


Vivien

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 658 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#51790: On core-updates-frozen, tracker-miners can’t find its tracker dependency
  2021-11-12 12:31 bug#51790: On core-updates-frozen, tracker-miners can’t find its tracker dependency Vivien Kraus via Bug reports for GNU Guix
       [not found] ` <handler.51790.B.163672027322232.ack@debbugs.gnu.org>
@ 2021-11-13  9:36 ` Ricardo Wurmus
  1 sibling, 0 replies; 3+ messages in thread
From: Ricardo Wurmus @ 2021-11-13  9:36 UTC (permalink / raw)
  To: 51790-done; +Cc: Vivien Kraus

Applied (with minor cosmetic changes), thanks!

-- 
Ricardo




^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-11-13  9:38 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-12 12:31 bug#51790: On core-updates-frozen, tracker-miners can’t find its tracker dependency Vivien Kraus via Bug reports for GNU Guix
     [not found] ` <handler.51790.B.163672027322232.ack@debbugs.gnu.org>
2021-11-13  8:22   ` bug#51790: [PATCH] Re: bug#51790: Fix it (On core-updates-frozen, tracker-miners can’t find its tracker dependency) Vivien Kraus via Bug reports for GNU Guix
2021-11-13  9:36 ` bug#51790: On core-updates-frozen, tracker-miners can’t find its tracker dependency Ricardo Wurmus

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).