unofficial mirror of guile-devel@gnu.org 
 help / color / mirror / Atom feed
* Unable to build Guile on macOS
@ 2021-04-01  6:25 Aleix Conchillo Flaqué
  2021-04-08  4:43 ` Aleix Conchillo Flaqué
  0 siblings, 1 reply; 5+ messages in thread
From: Aleix Conchillo Flaqué @ 2021-04-01  6:25 UTC (permalink / raw)
  To: guile-devel

Hi there,

After this Gnlib update, I am no longer able to build Guile on macOS:

commit a91b95cca2d397c84f8b9bbd602d40209a7092ce

There are other softwares with the same issue:
https://www.mail-archive.com/bug-wget@gnu.org/msg09941.html

I haven't had time to see if the issue is fixed already or not.

This is the error I'm getting:

  CC       time_rz.lo
  CC       timegm.lo
  CC       malloc/dynarray_at_failure.lo
In file included from regex.c:74:
In file included from ./regexec.c:1362:
./malloc/dynarray-skeleton.c:195:13: error: expected identifier or '('
__nonnull ((1))
            ^
./malloc/dynarray-skeleton.c:195:13: error: expected ')'
./malloc/dynarray-skeleton.c:195:12: note: to match this '('
__nonnull ((1))
           ^
./malloc/dynarray-skeleton.c:205:40: error: expected identifier or '('
__attribute_maybe_unused__ __nonnull ((1))
                                       ^
./malloc/dynarray-skeleton.c:205:40: error: expected ')'
./malloc/dynarray-skeleton.c:205:39: note: to match this '('
__attribute_maybe_unused__ __nonnull ((1))
                                      ^



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Unable to build Guile on macOS
  2021-04-01  6:25 Unable to build Guile on macOS Aleix Conchillo Flaqué
@ 2021-04-08  4:43 ` Aleix Conchillo Flaqué
  2021-04-08 20:10   ` lloda
  0 siblings, 1 reply; 5+ messages in thread
From: Aleix Conchillo Flaqué @ 2021-04-08  4:43 UTC (permalink / raw)
  To: guile-devel

The following recent Gnulib commit fixes the issue:

https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=fc6d7d850bdebfed81e9212910f44edf99dd7743

If someone could update Gnulib to a more recent version I'd really
appreciate it.

Thanks!

Aleix

On Wed, Mar 31, 2021 at 11:25 PM Aleix Conchillo Flaqué
<aconchillo@gmail.com> wrote:
>
> Hi there,
>
> After this Gnlib update, I am no longer able to build Guile on macOS:
>
> commit a91b95cca2d397c84f8b9bbd602d40209a7092ce
>
> There are other softwares with the same issue:
> https://www.mail-archive.com/bug-wget@gnu.org/msg09941.html
>
> I haven't had time to see if the issue is fixed already or not.
>
> This is the error I'm getting:
>
>   CC       time_rz.lo
>   CC       timegm.lo
>   CC       malloc/dynarray_at_failure.lo
> In file included from regex.c:74:
> In file included from ./regexec.c:1362:
> ./malloc/dynarray-skeleton.c:195:13: error: expected identifier or '('
> __nonnull ((1))
>             ^
> ./malloc/dynarray-skeleton.c:195:13: error: expected ')'
> ./malloc/dynarray-skeleton.c:195:12: note: to match this '('
> __nonnull ((1))
>            ^
> ./malloc/dynarray-skeleton.c:205:40: error: expected identifier or '('
> __attribute_maybe_unused__ __nonnull ((1))
>                                        ^
> ./malloc/dynarray-skeleton.c:205:40: error: expected ')'
> ./malloc/dynarray-skeleton.c:205:39: note: to match this '('
> __attribute_maybe_unused__ __nonnull ((1))
>                                       ^



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Unable to build Guile on macOS
  2021-04-08  4:43 ` Aleix Conchillo Flaqué
@ 2021-04-08 20:10   ` lloda
  2021-04-08 22:10     ` Aleix Conchillo Flaqué
  0 siblings, 1 reply; 5+ messages in thread
From: lloda @ 2021-04-08 20:10 UTC (permalink / raw)
  To: Aleix Conchillo Flaqué; +Cc: guile-devel



> On 8 Apr 2021, at 06:43, Aleix Conchillo Flaqué <aconchillo@gmail.com> wrote:
> 
> The following recent Gnulib commit fixes the issue:
> 
> https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=fc6d7d850bdebfed81e9212910f44edf99dd7743
> 
> If someone could update Gnulib to a more recent version I'd really
> appreciate it.
> 
> Thanks!
> 
> Aleix

I pushed an update to branch wip-gnulib-update. Could you give that a try? I tested on macos 10.15.7 and I had two test failures, in async.test and filesys.test, but I'm not sure those didn't happen before.  (Everything was fine on Debian).

Regards

	Daniel


> 
> On Wed, Mar 31, 2021 at 11:25 PM Aleix Conchillo Flaqué
> <aconchillo@gmail.com> wrote:
>> 
>> Hi there,
>> 
>> After this Gnlib update, I am no longer able to build Guile on macOS:
>> 
>> commit a91b95cca2d397c84f8b9bbd602d40209a7092ce
>> 
>> There are other softwares with the same issue:
>> https://www.mail-archive.com/bug-wget@gnu.org/msg09941.html
>> 
>> I haven't had time to see if the issue is fixed already or not.
>> 
>> This is the error I'm getting:
>> 
>>  CC       time_rz.lo
>>  CC       timegm.lo
>>  CC       malloc/dynarray_at_failure.lo
>> In file included from regex.c:74:
>> In file included from ./regexec.c:1362:
>> ./malloc/dynarray-skeleton.c:195:13: error: expected identifier or '('
>> __nonnull ((1))
>>            ^
>> ./malloc/dynarray-skeleton.c:195:13: error: expected ')'
>> ./malloc/dynarray-skeleton.c:195:12: note: to match this '('
>> __nonnull ((1))
>>           ^
>> ./malloc/dynarray-skeleton.c:205:40: error: expected identifier or '('
>> __attribute_maybe_unused__ __nonnull ((1))
>>                                       ^
>> ./malloc/dynarray-skeleton.c:205:40: error: expected ')'
>> ./malloc/dynarray-skeleton.c:205:39: note: to match this '('
>> __attribute_maybe_unused__ __nonnull ((1))
>>                                      ^
> 




^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Unable to build Guile on macOS
  2021-04-08 20:10   ` lloda
@ 2021-04-08 22:10     ` Aleix Conchillo Flaqué
  2021-04-09  7:27       ` lloda
  0 siblings, 1 reply; 5+ messages in thread
From: Aleix Conchillo Flaqué @ 2021-04-08 22:10 UTC (permalink / raw)
  To: lloda; +Cc: guile-devel

On Thu, Apr 8, 2021 at 1:10 PM lloda <lloda@sarc.name> wrote:
>
>
>
> > On 8 Apr 2021, at 06:43, Aleix Conchillo Flaqué <aconchillo@gmail.com> wrote:
> >
> > The following recent Gnulib commit fixes the issue:
> >
> > https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=fc6d7d850bdebfed81e9212910f44edf99dd7743
> >
> > If someone could update Gnulib to a more recent version I'd really
> > appreciate it.
> >
> > Thanks!
> >
> > Aleix
>
> I pushed an update to branch wip-gnulib-update. Could you give that a try? I tested on macos 10.15.7 and I had two test failures, in async.test and filesys.test, but I'm not sure those didn't happen before.  (Everything was fine on Debian).
>

It builds fine now on macOS 11.2.3. I'm getting 2 errors as well (I
don't see async.test though):

FAIL: 00-socket.test: setsockopt AF_INET: IPPROTO_TCP TCP_NODELAY
FAIL: filesys.test: mkdtemp: invalid template


Totals for this test run:
passes:                 44240
failures:               2
unexpected passes:      0
expected failures:      24
unresolved test cases:  70
untested test cases:    1
unsupported test cases: 1
errors:                 0

FAIL: check-guile
==================================
1 of 1 test failed
Please report to bug-guile@gnu.org
==================================



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Unable to build Guile on macOS
  2021-04-08 22:10     ` Aleix Conchillo Flaqué
@ 2021-04-09  7:27       ` lloda
  0 siblings, 0 replies; 5+ messages in thread
From: lloda @ 2021-04-09  7:27 UTC (permalink / raw)
  To: Aleix Conchillo Flaqué; +Cc: guile-devel

[-- Attachment #1: Type: text/plain, Size: 2146 bytes --]



> On 9 Apr 2021, at 00:10, Aleix Conchillo Flaqué <aconchillo@gmail.com> wrote:
> 
> On Thu, Apr 8, 2021 at 1:10 PM lloda <lloda@sarc.name> wrote:
>> 
>> 
>> 
>>> On 8 Apr 2021, at 06:43, Aleix Conchillo Flaqué <aconchillo@gmail.com> wrote:
>>> 
>>> The following recent Gnulib commit fixes the issue:
>>> 
>>> https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=fc6d7d850bdebfed81e9212910f44edf99dd7743
>>> 
>>> If someone could update Gnulib to a more recent version I'd really
>>> appreciate it.
>>> 
>>> Thanks!
>>> 
>>> Aleix
>> 
>> I pushed an update to branch wip-gnulib-update. Could you give that a try? I tested on macos 10.15.7 and I had two test failures, in async.test and filesys.test, but I'm not sure those didn't happen before.  (Everything was fine on Debian).
>> 
> 
> It builds fine now on macOS 11.2.3. I'm getting 2 errors as well (I
> don't see async.test though):
> 
> FAIL: 00-socket.test: setsockopt AF_INET: IPPROTO_TCP TCP_NODELAY
> FAIL: filesys.test: mkdtemp: invalid template
> 
> 
> Totals for this test run:
> passes:                 44240
> failures:               2
> unexpected passes:      0
> expected failures:      24
> unresolved test cases:  70
> untested test cases:    1
> unsupported test cases: 1
> errors:                 0
> 
> FAIL: check-guile
> ==================================
> 1 of 1 test failed
> Please report to bug-guile@gnu.org
> ==================================


Thanks for checking, for the record, this is what I got myself:

FAIL: 00-socket.test: setsockopt AF_INET: IPPROTO_TCP TCP_NODELAY

ERROR: asyncs.test: preemption via sigprof - arguments: ((wrong-type-arg #f "Wrong type (expecting ~A): ~S" ("resumable continuation" #<vm-continuation 1094b94e0>) (#<vm-continuation 1094b94e0>)))

FAIL: filesys.test: mkdtemp: invalid template

Totals for this test run:
passes:                 44240
failures:               2
unexpected passes:      0
expected failures:      24
unresolved test cases:  69
untested test cases:    1
unsupported test cases: 1
errors:                 1

Regards

	Daniel




[-- Attachment #2: Type: text/html, Size: 7739 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-04-09  7:27 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-01  6:25 Unable to build Guile on macOS Aleix Conchillo Flaqué
2021-04-08  4:43 ` Aleix Conchillo Flaqué
2021-04-08 20:10   ` lloda
2021-04-08 22:10     ` Aleix Conchillo Flaqué
2021-04-09  7:27       ` lloda

unofficial mirror of guile-devel@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guile-devel/0 guile-devel/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guile-devel guile-devel/ https://yhetil.org/guile-devel \
		guile-devel@gnu.org
	public-inbox-index guile-devel

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.lisp.guile.devel
	nntp://news.gmane.io/gmane.lisp.guile.devel


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git