emacs-orgmode@gnu.org archives
 help / color / mirror / code / Atom feed
* Bug: Fill-paragraph with pretty link at linebreak [9.4.4 (release_9.4.4 @/usr/share/emacs/27.2/lisp/org/)]
@ 2021-09-13 10:36 Nathan Shostek
  0 siblings, 0 replies; only message in thread
From: Nathan Shostek @ 2021-09-13 10:36 UTC (permalink / raw)
  To: emacs-orgmode


Remember to cover the basics, that is, what you expected to happen and
what in fact did happen.  You don't know how to make a good report?  See

     https://orgmode.org/manual/Feedback.html#Feedback

Your bug report will be posted to the Org mailing list.
------------------------------------------------------------------------

Hello,

Ive found a bug with (org-)fill-paragraph when pretty links are enabled
(ie calling org-toggle-link-display works around this, but its
undesirable for me to have full link text). When links are "prettified"
(i am uncertain what the actual terminology is, but when the link itself
is hidden and only the description text is shown) calling fill paragraph
will cause there to be new lines (as reported by the (line, col)
indicator in the mode line) but there will be no rendered
newline/linebreak if the linebreak begins within the link portion of a
link. This happens with multiple configurations as well as with `emacs
-Q`.

I looked through the first several pages of search results to try and
find a related bug (and hopefully a fix) but didnt find anything. 

Expected:
What I expect to happen is that calling fill-paragraph will insert
newlines at or before the fill column, and that they will be rendered.

Observed:
What seems to happen is that calling fill-paragraph inserts newlines but
they aren't rendered. After calling fill-paragraph a pretty link begins
at line 28 column 67, and moving forward one character moves me to line
29 column 1, however this is not rendered on a new line. Moving
backwards a character brings me to the same graphical point as line 28
column 67 but i am instead at line 29 column 0. fill-column is 70.

Thanks,
Nathan

PS: Here is the raw text that causes this issue, from a report for an
obligatory informatics course. I have removed all line breaks from the
text to allow those who wish to call fill-paragraph on it after placing
the text into an org buffer. I can also send images if its desired.

* Introduction
  This report shall describe the initial obligatory assignment for ~INF 1100~.  The [[comparing values][comparison of values]], [[display of a triangle][displaying of a triangle]], [[determination of prime factors][determination of prime factors]], [[range of numbers][outputting of a range of numbers]], [[The determining of the most significant bit][determination of the most significant bit]], and the [[The in-place reversal of a string][reversal of a string]] shall be implemented.  We assume that this will be compiled and run on 


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-09-13 13:39 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-13 10:36 Bug: Fill-paragraph with pretty link at linebreak [9.4.4 (release_9.4.4 @/usr/share/emacs/27.2/lisp/org/)] Nathan Shostek

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/emacs/org-mode.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).