unofficial mirror of notmuch@notmuchmail.org
 help / color / Atom feed
* [PATCH] configure: require python 3.5 for CFFI-based notmuch bindings
@ 2020-06-05 21:57 Tomi Ollila
  2020-06-06 11:47 ` David Bremner
  0 siblings, 1 reply; 2+ messages in thread
From: Tomi Ollila @ 2020-06-05 21:57 UTC (permalink / raw)
  To: notmuch; +Cc: tomi.ollila

Also tell users what the consequences of a "No" answer is when
python version is less than 3.5, cffi or setuptools is missing,
or no pytest >= 3.0 is available.
---
 configure | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/configure b/configure
index e4c738e5..f4b3c61a 100755
--- a/configure
+++ b/configure
@@ -713,14 +713,14 @@ fi
 
 have_python3_dev=0
 if [ $have_python -eq 1 ]; then
-    printf "Checking for python3 dev..."
+    printf "Checking for python3 dev (>= 3.5)..."
     if "$python" -c 'import os, sys, sysconfig;
-assert sys.version_info >= (3,0)
+assert sys.version_info >= (3,5)
 assert os.path.isfile(sysconfig.get_config_h_filename())' >/dev/null 2>&1; then
         printf "Yes.\n"
         have_python3_dev=1
     else
-        printf "No.\n"
+        printf "No (will not install CFFI-based python bindings).\n"
     fi
 fi
 
@@ -732,7 +732,7 @@ if [ $have_python3_dev -eq 1 ]; then
         printf "Yes.\n"
         have_python3_cffi=1
     else
-        printf "No.\n"
+        printf "No (will not install CFFI-based python bindings).\n"
     fi
 
     printf "Checking for python3 pytest (>= 3.0)... "
@@ -742,7 +742,7 @@ if [ $have_python3_dev -eq 1 ]; then
         printf "Yes.\n"
         have_python3_pytest=1
     else
-        printf "No.\n"
+        printf "No (will not test CFFI-based python bindings).\n"
     fi
     rm -f $conf
 fi
-- 
2.26.2

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] configure: require python 3.5 for CFFI-based notmuch bindings
  2020-06-05 21:57 [PATCH] configure: require python 3.5 for CFFI-based notmuch bindings Tomi Ollila
@ 2020-06-06 11:47 ` David Bremner
  0 siblings, 0 replies; 2+ messages in thread
From: David Bremner @ 2020-06-06 11:47 UTC (permalink / raw)
  To: Tomi Ollila, notmuch; +Cc: tomi.ollila

Tomi Ollila <tomi.ollila@iki.fi> writes:

> Also tell users what the consequences of a "No" answer is when
> python version is less than 3.5, cffi or setuptools is missing,
> or no pytest >= 3.0 is available.

pushed to master and release.

d

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-05 21:57 [PATCH] configure: require python 3.5 for CFFI-based notmuch bindings Tomi Ollila
2020-06-06 11:47 ` David Bremner

unofficial mirror of notmuch@notmuchmail.org

Archives are clonable:
	git clone --mirror https://yhetil.org/notmuch/0 notmuch/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 notmuch notmuch/ https://yhetil.org/notmuch \
		notmuch@notmuchmail.org
	public-inbox-index notmuch

Example config snippet for mirrors

Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.mail.notmuch.general
	nntp://news.gmane.io/gmane.mail.notmuch.general


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git