unofficial mirror of notmuch@notmuchmail.org
 help / color / mirror / code / Atom feed
* Bug: Emacs notmuch display
@ 2021-09-22 20:11 Jeff Elliott
  2021-09-22 22:23 ` David Bremner
  0 siblings, 1 reply; 7+ messages in thread
From: Jeff Elliott @ 2021-09-22 20:11 UTC (permalink / raw)
  To: notmuch


Hello,

I've been using notmuch for a few years now.  And it's great for my
small business because of the tagging and searching.

Anyway, I just upgraded my OS packages (Solus), and it has notmuch
upgraded to 0.31.4  Which I'm guessing my be my problem?  I notice you
have version 0.33.1 recently released.

And Emacs version 27.2


And so:

When I try to display certain "tags", inbox or anything, I get:

[Wed Sep 22 15:49:36 2021]
A caller requested output format version 5, but the installed notmuch
CLI only supports up to format version 4.  You may need to upgrade your
notmuch CLI.

When I try to upgrade my notmuch from the Solus package manager, I get
that it is already updated.

Can you point me in the right direction to fix this?

Thanks you,
Jeff.




^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Bug: Emacs notmuch display
  2021-09-22 20:11 Bug: Emacs notmuch display Jeff Elliott
@ 2021-09-22 22:23 ` David Bremner
  2021-09-22 23:30   ` jeff
  0 siblings, 1 reply; 7+ messages in thread
From: David Bremner @ 2021-09-22 22:23 UTC (permalink / raw)
  To: Jeff Elliott, notmuch

Jeff Elliott <jeff@fedge.ca> writes:

> [Wed Sep 22 15:49:36 2021]
> A caller requested output format version 5, but the installed notmuch
> CLI only supports up to format version 4.  You may need to upgrade your
> notmuch CLI.
>
> When I try to upgrade my notmuch from the Solus package manager, I get
> that it is already updated.

Yep, this is exactly the problem mentioned in the README on melpa (which
I'm guessing is where you installed notmuch from). You need to use a
version of the notmuch CLI that is as new as as your version of
notmuch-emacs, or an older version of notmuch-emacs. Normally I would
recommend using the notmuch-emacs package from your distro, but I
couldn't figure out if it exists in solus.

If you have the appropriate version of the source, then "make elpa" will
create package you can install in emacs

    M-x package-install-file <return>
    notmuch-0.31.4.tar <return>

should work. If you're stuck, I can make such an elpa package for you.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Bug: Emacs notmuch display
  2021-09-22 22:23 ` David Bremner
@ 2021-09-22 23:30   ` jeff
  2021-09-23  0:42     ` David Bremner
  0 siblings, 1 reply; 7+ messages in thread
From: jeff @ 2021-09-22 23:30 UTC (permalink / raw)
  To: David Bremner; +Cc: notmuch


[-- Attachment #1.1: Plaintext Message --]
[-- Type: text/plain, Size: 1459 bytes --]

  Quoting David Bremner <david@tethera.net>:

> Jeff Elliott <jeff@fedge.ca> writes:
>
>> [Wed Sep 22 15:49:36 2021]
>> A caller requested output format version 5, but the installed notmuch
>> CLI only supports up to format version 4.  You may need to upgrade your
>> notmuch CLI.
>>
>> When I try to upgrade my notmuch from the Solus package manager, I get
>> that it is already updated.
>
> Yep, this is exactly the problem mentioned in the README on melpa (which
> I'm guessing is where you installed notmuch from). You need to use a
> version of the notmuch CLI that is as new as as your version of
> notmuch-emacs, or an older version of notmuch-emacs. Normally I would
> recommend using the notmuch-emacs package from your distro, but I
> couldn't figure out if it exists in solus.
>
> If you have the appropriate version of the source, then "make elpa" will
> create package you can install in emacs
>
>    M-x package-install-file <return>
>    notmuch-0.31.4.tar <return>
> should work. If you're stuck, I can make such an elpa package for you.

Thanks. I guess I'm still stuck.  I downloaded version 31.4 from:
https://notmuchmail.org/releases/

But when I select "notmuch-0.31.4.tar" for the package-install-file, I  
get an error:
 Wrong type argument: stringp, nil

Would it not make sense to upgrade notmuch to 0.33.1 ?  Which I guess I would
have to do from source, which I haven't done before...
 

[-- Attachment #1.2: HTML Message --]
[-- Type: text/html, Size: 2171 bytes --]

[-- Attachment #2: Type: text/plain, Size: 0 bytes --]



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Bug: Emacs notmuch display
  2021-09-22 23:30   ` jeff
@ 2021-09-23  0:42     ` David Bremner
  2021-09-23  0:45       ` David Bremner
  0 siblings, 1 reply; 7+ messages in thread
From: David Bremner @ 2021-09-23  0:42 UTC (permalink / raw)
  To: jeff; +Cc: notmuch

jeff@fedge.ca writes:

>
> Thanks. I guess I'm still stuck.  I downloaded version 31.4 from:
> https://notmuchmail.org/releases/
>
> But when I select "notmuch-0.31.4.tar" for the package-install-file, I  
> get an error:
>  Wrong type argument: stringp, nil

It's a bit confusing, but there is the source tarball notmuch-0.31.tar.xz, that you
downloaded, and the output from "make elpa", which is called
notmuch-0.31.4.tar. I'll send you copy of the latter off list.

> Would it not make sense to upgrade notmuch to 0.33.1 ?  Which I guess I would
> have to do from source, which I haven't done before...

Sure, definitely an option, it just requires installing a few more
dependencies, and maybe figuring out how to make sure the binaries are
in your path.\r

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Bug: Emacs notmuch display
  2021-09-23  0:42     ` David Bremner
@ 2021-09-23  0:45       ` David Bremner
  2021-09-23 22:30         ` jeff
  0 siblings, 1 reply; 7+ messages in thread
From: David Bremner @ 2021-09-23  0:45 UTC (permalink / raw)
  To: jeff; +Cc: notmuch

David Bremner <david@tethera.net> writes:

> jeff@fedge.ca writes:
>
>>
>> Thanks. I guess I'm still stuck.  I downloaded version 31.4 from:
>> https://notmuchmail.org/releases/
>>
>> But when I select "notmuch-0.31.4.tar" for the package-install-file, I  
>> get an error:
>>  Wrong type argument: stringp, nil
>
> It's a bit confusing, but there is the source tarball notmuch-0.31.tar.xz, that you
> downloaded, and the output from "make elpa", which is called
> notmuch-0.31.4.tar. I'll send you copy of the latter off list.

Even more confusing when I mess up the name. The output from "make elpa"
is actually notmuch-emacs-0.31.4.tar

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Bug: Emacs notmuch display
  2021-09-23  0:45       ` David Bremner
@ 2021-09-23 22:30         ` jeff
  2021-09-24 12:42           ` David Bremner
  0 siblings, 1 reply; 7+ messages in thread
From: jeff @ 2021-09-23 22:30 UTC (permalink / raw)
  To: David Bremner; +Cc: notmuch


[-- Attachment #1.1: Plaintext Message --]
[-- Type: text/plain, Size: 1029 bytes --]

  Quoting David Bremner <david@tethera.net>:

> David Bremner <david@tethera.net> writes:
>
>> jeff@fedge.ca writes:
>>
>>> Thanks. I guess I'm still stuck.  I downloaded version 31.4 from:
>>> https://notmuchmail.org/releases/
>>>
>>> But when I select "notmuch-0.31.4.tar" for the package-install-file, I
>>> get an error:
>>>  Wrong type argument: stringp, nil
>>
>> It's a bit confusing, but there is the source tarball  
>> notmuch-0.31.tar.xz, that you
>> downloaded, and the output from "make elpa", which is called
>> notmuch-0.31.4.tar. I'll send you copy of the latter off list.
>
> Even more confusing when I mess up the name. The output from "make  
> elpa"is actually notmuch-emacs-0.31.4.tar

Hey David, that worked!  Thanks so much!

So going forward... should I reach out to the Solus development and  
ask them to update their "notmuch" version?
And until the Solus repository version matches the emacs one, I should  
refuse to update the emacs notmuch?

Thanks again.
 

 

[-- Attachment #1.2: HTML Message --]
[-- Type: text/html, Size: 1880 bytes --]

[-- Attachment #2: Type: text/plain, Size: 0 bytes --]



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: Bug: Emacs notmuch display
  2021-09-23 22:30         ` jeff
@ 2021-09-24 12:42           ` David Bremner
  0 siblings, 0 replies; 7+ messages in thread
From: David Bremner @ 2021-09-24 12:42 UTC (permalink / raw)
  To: jeff; +Cc: notmuch

jeff@fedge.ca writes:

> Hey David, that worked!  Thanks so much!
>
> So going forward... should I reach out to the Solus development and  
> ask them to update their "notmuch" version?
> And until the Solus repository version matches the emacs one, I should  
> refuse to update the emacs notmuch?
>
> Thanks again.

Yes, it seems reasonable to ask them to update notmuch, 0.31.4 is about
6 months old, so not ancient, but not yesterday either. The ideal
situation would be that they provide a matching package for
notmuch-emacs as other linux distros like Debian and Fedora do. Failing
that, yes you will want to be careful about upgrading notmuch-emacs.

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-09-24 12:42 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-22 20:11 Bug: Emacs notmuch display Jeff Elliott
2021-09-22 22:23 ` David Bremner
2021-09-22 23:30   ` jeff
2021-09-23  0:42     ` David Bremner
2021-09-23  0:45       ` David Bremner
2021-09-23 22:30         ` jeff
2021-09-24 12:42           ` David Bremner

Code repositories for project(s) associated with this inbox:

	notmuch.git.git (no URL configured)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).