unofficial mirror of notmuch@notmuchmail.org
 help / color / mirror / code / Atom feed
From: Carl Worth <cworth@cworth.org>
To: Ruben Pollan <meskio@sindominio.net>, notmuch@notmuchmail.org
Subject: Re: [PATCH] Added regress option to tags iterator
Date: Tue, 09 Mar 2010 09:36:10 -0800	[thread overview]
Message-ID: <873a09jt2t.fsf@yoom.home.cworth.org> (raw)
In-Reply-To: <87pr67ofz2.fsf@yoom.home.cworth.org>

[-- Attachment #1: Type: text/plain, Size: 1584 bytes --]

On Mon, 21 Dec 2009 19:16:49 -0800, Carl Worth <cworth@cworth.org> wrote:
> One option is to just drop the "move_ " prefix. Then everything will be
> a two-word function. So the new proposal is:
> 
> to_first
> has_current
> to_next
> 
> to_last
> has_current
> to_previous
> 
> get_current
> 
> Better?

Looking back at this proposal now, (after a long delay), I found I
didn't like it at all. With function names like:

	notmuch_threads_to_first
	notmuch_threads_to_next

the missing verb in the name is really distracting. I ended up reading
these names as if they were conversion functions. So I've gone back to
preferring the names with the explicit verbs (even though quite long):

	notmuch_threads_move_to_first
	notmuch_threads_move_to_next

Meanwhile, I also decided that _current wasn't adding anything to the
names it showed up in, (we can never "get" anything other than the
current item, so why qualify as "get_current"?). So I'm changing from
"has_current" to "valid", and leaving "get" as it is.

So the final proposal for iteration in either direction is:

	move_to_first
        valid
        move_to_next

	move_to_last
        valid
        move_to_previous

        get

I've just pushed commits changing the existing functions (which allow
only forward iteration) to use this naming scheme. I haven't added any
of the reverse-iteration functions yet, so Ruben, if you'd like to do
those within this scheme, that would be find. (Or we could wait until we
have an actual use in mind for them.)

Thanks,

-Carl

[-- Attachment #2: Type: application/pgp-signature, Size: 189 bytes --]

  parent reply	other threads:[~2010-03-09 20:02 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-11-26 20:23 notmuch_threads_back and notmuch_messages_back Ruben Pollan
2009-11-28  3:57 ` Carl Worth
2009-12-06 17:34   ` Ruben Pollan
2009-12-07 17:23     ` Carl Worth
2009-12-08  9:41 ` regress option to messages iterator meskio
2009-12-08  9:41   ` [PATCH 1/2] Convert notmuch_message_list_t in a doubly linked meskio
2009-12-08  9:41     ` [PATCH 2/2] Added regress option to messages iterator meskio
2009-12-08  9:57   ` ruben pollan
2009-12-09 12:45 ` [PATCH] Added regress option to threads iterator Ruben Pollan
2009-12-09 13:10 ` [PATCH] Added regress option to tags iterator Ruben Pollan
2009-12-09 13:24   ` Ruben Pollan
2009-12-09 20:08     ` Carl Worth
2009-12-09 21:21       ` Mark Anderson
2009-12-09 21:37         ` Carl Worth
2009-12-09 22:05         ` Ruben Pollan
2009-12-09 22:01       ` Ruben Pollan
2009-12-22  1:23       ` Carl Worth
2009-12-22  3:16         ` Carl Worth
2010-01-05 15:33           ` Ruben Pollan
2010-01-05 19:39             ` Carl Worth
2010-01-06  9:08               ` Ruben Pollan
2010-03-09 17:36           ` Carl Worth [this message]
2010-03-11 14:28             ` Ruben Pollan
2010-03-20 10:23             ` reverse iterators Ruben Pollan
2010-03-21 20:07               ` Sebastian Spaeth
2010-03-22 10:18                 ` Ruben Pollan
2010-03-21 21:32               ` [PATCH] sending again patches 3 & 4 Ruben Pollan
2010-03-21 21:32               ` [PATCH 1/2] Move the logic of threads iterator out of 'valid' Ruben Pollan
2010-03-21 21:32               ` [PATCH 2/2] Added backwards iterator to threads Ruben Pollan
2010-03-20 10:23             ` [PATCH 1/5] Convert notmuch_message_list_t in a doubly linked Ruben Pollan
2010-03-20 10:23             ` [PATCH 2/5] Added backwards iterator to messages Ruben Pollan
2010-03-20 10:23             ` [PATCH 3/5] Move the logic of threads iterator out of 'valid' Ruben Pollan
2010-03-20 10:23             ` [PATCH 4/5] Added backwards iterator to threads Ruben Pollan
2010-03-20 10:23             ` [PATCH 5/5] Added backwards iterator to tags Ruben Pollan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

  List information: https://notmuchmail.org/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=873a09jt2t.fsf@yoom.home.cworth.org \
    --to=cworth@cworth.org \
    --cc=meskio@sindominio.net \
    --cc=notmuch@notmuchmail.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://yhetil.org/notmuch.git/

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).