unofficial mirror of notmuch@notmuchmail.org
 help / color / mirror / Atom feed
* [PATCH] configure: Check if emacs >= 25 (instead of >= 24) is available
@ 2020-08-11  7:38 Tomi Ollila
  2020-08-12 23:45 ` David Bremner
  0 siblings, 1 reply; 2+ messages in thread
From: Tomi Ollila @ 2020-08-11  7:38 UTC (permalink / raw)
  To: notmuch; +Cc: tomi.ollila

"The minimum supported major version of GNU Emacs is now 25.1."

25.1 is the first "released" version of Emacs 25.
---
 configure | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure b/configure
index a357eb91..40e8b255 100755
--- a/configure
+++ b/configure
@@ -829,8 +829,8 @@ if [ -z "${EMACSETCDIR-}" ]; then
 fi
 
 if [ $WITH_EMACS = "1" ]; then
-    printf "Checking if emacs (>= 24) is available... "
-    if emacs --quick --batch --eval '(if (< emacs-major-version 24) (kill-emacs 1))' > /dev/null 2>&1; then
+    printf "Checking if emacs (>= 25) is available... "
+    if emacs --quick --batch --eval '(if (< emacs-major-version 25) (kill-emacs 1))' > /dev/null 2>&1; then
         printf "Yes.\n"
     else
         printf "No (disabling emacs related parts of build)\n"
-- 
2.26.2

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] configure: Check if emacs >= 25 (instead of >= 24) is available
  2020-08-11  7:38 [PATCH] configure: Check if emacs >= 25 (instead of >= 24) is available Tomi Ollila
@ 2020-08-12 23:45 ` David Bremner
  0 siblings, 0 replies; 2+ messages in thread
From: David Bremner @ 2020-08-12 23:45 UTC (permalink / raw)
  To: Tomi Ollila, notmuch; +Cc: tomi.ollila

Tomi Ollila <tomi.ollila@iki.fi> writes:

> "The minimum supported major version of GNU Emacs is now 25.1."
>
> 25.1 is the first "released" version of Emacs 25.

applied to master.

d

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-08-12 23:45 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-11  7:38 [PATCH] configure: Check if emacs >= 25 (instead of >= 24) is available Tomi Ollila
2020-08-12 23:45 ` David Bremner

unofficial mirror of notmuch@notmuchmail.org

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/notmuch/0 notmuch/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 notmuch notmuch/ https://yhetil.org/notmuch \
		notmuch@notmuchmail.org
	public-inbox-index notmuch

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.mail.notmuch.general
	nntp://news.gmane.io/gmane.mail.notmuch.general


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git