unofficial mirror of meta@public-inbox.org
 help / color / mirror / Atom feed
* [PATCH] INSTALL: depend on URI rather than URI::Escape
@ 2021-09-10 13:10 Eric Wong
  0 siblings, 0 replies; only message in thread
From: Eric Wong @ 2021-09-10 13:10 UTC (permalink / raw)
  To: meta

As far as I can tell, URI::Escape has always been a part of the
`URI' package (aka "distribution" on CPAN) and not distributed
separately (unlike URI::Escape::XS).  So avoid confusing users
with `URI::Escape' and just document `URI' instead.

Along the same lines, we depend on the `Plack' package rather
than Plack::Util or Plack::Builder, after all.
---
 INSTALL      | 4 ++--
 Makefile.PL  | 2 +-
 ci/deps.perl | 5 ++---
 3 files changed, 5 insertions(+), 6 deletions(-)

diff --git a/INSTALL b/INSTALL
index e93731f1..eb939a59 100644
--- a/INSTALL
+++ b/INSTALL
@@ -36,9 +36,9 @@ To accept incoming mail into a public inbox, you'll likely want:
 * MTA - postfix is recommended (for public-inbox-mda)
 * SpamAssassin (spamc/spamd)   (for public-inbox-watch/public-inbox-mda)
 
-Beyond that, there is one non-standard Perl module required:
+Beyond that, there is one non-standard Perl package required:
 
-* URI::Escape                      deb: liburi-perl
+* URI                              deb: liburi-perl
                                    pkg: p5-URI
                                    rpm: perl-URI
                                    (for HTML/Atom generation)
diff --git a/Makefile.PL b/Makefile.PL
index bfabb171..1e935012 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -168,7 +168,7 @@ WriteMakefile(
 		# Plack is needed for public-inbox-httpd and PublicInbox::WWW
 		# 'Plack' => 0,
 
-		'URI::Escape' => 0,
+		'URI' => 0,
 
 		# We have more test dependencies, but do not force
 		# users to install them.  See INSTALL
diff --git a/ci/deps.perl b/ci/deps.perl
index 643e86c0..a797911a 100755
--- a/ci/deps.perl
+++ b/ci/deps.perl
@@ -14,7 +14,6 @@ my @test_essential = qw(Test::Simple); # we actually use Test::More
 # package profiles
 my $profiles = {
 	# the smallest possible profile for testing
-	# TODO: trim URI::Escape from this, maybe
 	essential => [ qw(
 		git
 		perl
@@ -23,7 +22,7 @@ my $profiles = {
 		Encode
 		ExtUtils::MakeMaker
 		IO::Compress::Gzip
-		URI::Escape
+		URI
 		), @test_essential ],
 
 	# everything optional for normal use
@@ -109,7 +108,7 @@ my $non_auto = {
 		pkg => 'p5-Plack',
 		rpm => 'perl-Plack-Test',
 	},
-	'URI::Escape' => {
+	'URI' => {
 		deb => 'liburi-perl',
 		pkg => 'p5-URI',
 		rpm => 'perl-URI',

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-09-10 13:10 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-10 13:10 [PATCH] INSTALL: depend on URI rather than URI::Escape Eric Wong

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).