all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / Atom feed
* [bug#52113] [PATCH] gnu: Add pnmixer
       [not found] <529632162.5471310.1637869688182.ref@mail.yahoo.com>
@ 2021-11-25 19:48 ` Jaft
  0 siblings, 0 replies; only message in thread
From: Jaft @ 2021-11-25 19:48 UTC (permalink / raw)
  To: 52113

* gnu/packages/gtk.scm (pnmixer):Add PNMixer
---
gnu/packages/gtk.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4e427deaef..782dfebdb2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -27,6 +27,7 @@
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -50,6 +51,7 @@ (define-module (gnu packages gtk)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix build utils) #:select (alist-replace))
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
@@ -2474,3 +2476,40 @@ (define-public volctl
     ;; XXX: 'setup.py' says "GPLv2" but nothing says "version 2 only".  Is
     ;; GPLv2+ intended?
     (license license:gpl2)))
+
+(define-public pnmixer
+  (let ([version "0.7.2"])
+    (package
+      (name "pnmixer")
+      (version version)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/nicklan/pnmixer/")
+                      (commit (string-append "v" version))))
+                (file-name (git-file-name name version))
+                (sha256 (base32
+                         "0416pa933ddf4b7ph9zxhk5jppkk7ppcq1aqph6xsrfnka4yb148"))
+                (modules '((guix build utils)))))
+    (build-system cmake-build-system)
+    (arguments `(#:phases (modify-phases %standard-phases (delete 'check))))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("gettext" ,gettext-minimal)))
+    (inputs `(("alsa-lib" ,alsa-lib)
+              ("glib" ,glib)
+              ("libx11" ,libx11)
+              ("gtk+" ,gtk+)
+              ("libnotify" ,libnotify)))
+    (home-page "https://github.com/nicklan/pnmixer/")
+    (synopsis "Simple mixer application designed to run in your system tray")
+    (description "PNMixer is a simple mixer application designed to run in your
+system tray.  It integrates nicely into desktop environments that don't have a
+panel that supports applets and therefore can't run a mixer applet.  In
+particular, it's been used quite a lot with fbpanel and tint2 but should run
+fine in any system tray.
+
+PNMixer is designed to work on systems that use ALSA for sound management.  Any
+other sound driver like OSS or FFADO are, currently, not supported.  There is no
+official PulseAudio support, at the moment, but it seems that PNMixer behaves
+quite well anyway when PA is running.")
+    (license license:gpl3))))




^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-11-25 19:51 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <529632162.5471310.1637869688182.ref@mail.yahoo.com>
2021-11-25 19:48 ` [bug#52113] [PATCH] gnu: Add pnmixer Jaft

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.