all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
* bug#53234: terminal URL capability not correctly detected (gnome-terminal 3.22.2).
@ 2022-01-13 18:49 Maxim Cournoyer
  2022-01-14 21:35 ` Ludovic Courtès
  0 siblings, 1 reply; 3+ messages in thread
From: Maxim Cournoyer @ 2022-01-13 18:49 UTC (permalink / raw)
  To: 53234

Hello,

I discovered that on a Debian 9 (stretch) box equipped with
gnome-terminal 3.22.2, Guix would use terminal ANSI codes to represent
hyperlinks in its output, which were not supported by GNOME terminal
3.22.2 which uses VTE 0.46.1 (it picked up support in 3.26 IIRC).

Thanks,

Maxim




^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#53234: terminal URL capability not correctly detected (gnome-terminal 3.22.2).
  2022-01-13 18:49 bug#53234: terminal URL capability not correctly detected (gnome-terminal 3.22.2) Maxim Cournoyer
@ 2022-01-14 21:35 ` Ludovic Courtès
  2022-01-15  4:54   ` Maxim Cournoyer
  0 siblings, 1 reply; 3+ messages in thread
From: Ludovic Courtès @ 2022-01-14 21:35 UTC (permalink / raw)
  To: Maxim Cournoyer; +Cc: 53234

Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> I discovered that on a Debian 9 (stretch) box equipped with
> gnome-terminal 3.22.2, Guix would use terminal ANSI codes to represent
> hyperlinks in its output, which were not supported by GNOME terminal
> 3.22.2 which uses VTE 0.46.1 (it picked up support in 3.26 IIRC).

I’m afraid there’s not much we can do: terminal emulators are supposed
to ignore ANSI sequences they don’t understand.

My recollection is that there was a bug in libvte back then:

  https://issues.guix.gnu.org/38940#6-lineno18

That bug mentions a much older VTE though, so I wonder if it’s a newer
regression?

Ludo’.




^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#53234: terminal URL capability not correctly detected (gnome-terminal 3.22.2).
  2022-01-14 21:35 ` Ludovic Courtès
@ 2022-01-15  4:54   ` Maxim Cournoyer
  0 siblings, 0 replies; 3+ messages in thread
From: Maxim Cournoyer @ 2022-01-15  4:54 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 53234-done

Hello!

Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> I discovered that on a Debian 9 (stretch) box equipped with
>> gnome-terminal 3.22.2, Guix would use terminal ANSI codes to represent
>> hyperlinks in its output, which were not supported by GNOME terminal
>> 3.22.2 which uses VTE 0.46.1 (it picked up support in 3.26 IIRC).
>
> I’m afraid there’s not much we can do: terminal emulators are supposed
> to ignore ANSI sequences they don’t understand.

Ah, thanks for pointing that to me.  I had guessed we had to do some
work to detect the terminal capability and conditionally output escapes
or not, but I'm glad that's not how it works :-).

> My recollection is that there was a bug in libvte back then:
>
>   https://issues.guix.gnu.org/38940#6-lineno18
>
> That bug mentions a much older VTE though, so I wonder if it’s a newer
> regression?

According to [0]:

> At this moment, terminals known to be buggy (OSC 8 resulting in
> display corruption) are VTE versions up to 0.46.2 and 0.48.1, Windows
> Terminal up to 0.9, Emacs's built-in terminal, and screen with 700+
> character long URLs.

Which gnome-terminal shipped with Debian 9 uses.  Luckily, this release
will be EOL in a few months (June 2022) [1], so the problem will
disappear soon.

I'm closing this report, thank you for the explanations!

Maxim

[0]  https://gist.github.com/egmontkob/eb114294efbcd5adb1944c9f3cb5feda
[1]  https://www.debian.org/releases/stretch/




^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-01-15  4:55 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-13 18:49 bug#53234: terminal URL capability not correctly detected (gnome-terminal 3.22.2) Maxim Cournoyer
2022-01-14 21:35 ` Ludovic Courtès
2022-01-15  4:54   ` Maxim Cournoyer

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.