all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / Atom feed
* Is Guix vulnerable to this polkit CVE?
@ 2021-06-10 22:35 jbranso
  2021-06-10 22:56 ` Tobias Geerinckx-Rice
  0 siblings, 1 reply; 3+ messages in thread
From: jbranso @ 2021-06-10 22:35 UTC (permalink / raw)
  To: guix-devel, guix-security

[-- Attachment #1: Type: text/plain, Size: 1125 bytes --]

I just found this article on polkit having a CVE:

https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/ (https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/)
It looks pretty nasty...

" The vulnerability enables an unprivileged local user to get a root shell on the system. It’s easy to exploit with a few standard command line tools, as you can see in this short video (https://youtu.be/QZhz64yEd0g). In this blog post, I’ll explain how the exploit works and show you where the bug was in the source code. "
In the hacker news comments it is fixed in:
https://news.ycombinator.com/item?id=27462247 (https://news.ycombinator.com/item?id=27462247)

Polkit version 0.119 fixes it, here's the diff: https://gitlab.freedesktop.org/polkit/polkit/-/commit/a04d13... (https://gitlab.freedesktop.org/polkit/polkit/-/commit/a04d13affe0fa53ff618e07aa8f57f4c0e3b9b81)
You all awesome devs have probably already fixed it, but I am just emailing to make sure.

Thanks!

Joshua

"Aim for stars...because even if you'll fall at least you'll fall on Uranus."

[-- Attachment #2: Type: text/html, Size: 1570 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Is Guix vulnerable to this polkit CVE?
  2021-06-10 22:35 Is Guix vulnerable to this polkit CVE? jbranso
@ 2021-06-10 22:56 ` Tobias Geerinckx-Rice
  0 siblings, 0 replies; 3+ messages in thread
From: Tobias Geerinckx-Rice @ 2021-06-10 22:56 UTC (permalink / raw)
  To: jbranso; +Cc: guix-devel, guix-security

[-- Attachment #1: Type: text/plain, Size: 320 bytes --]

jbranso@dismail.de 写道:
> You all awesome devs have probably already fixed it, but I am 
> just emailing to make sure.

It was fixed in Guix[0], but thank you for your vigilance! o7

Rest well,

T G-R

[0]: 
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=9178566954cc7f34d2d991d31df4565adad93508

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Is Guix vulnerable to this polkit CVE?
@ 2021-06-10 23:00 Leo Prikler
  0 siblings, 0 replies; 3+ messages in thread
From: Leo Prikler @ 2021-06-10 23:00 UTC (permalink / raw)
  To: jbranso; +Cc: guix-devel

Guix commit 9178566954cc7f34d2d991d31df4565adad93508 ought to fix this
with a patch and graft.  If you haven't updated already, consider doing
so.  If you want to play with polkit, you can always roll back :P



^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-06-10 23:02 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-06-10 22:35 Is Guix vulnerable to this polkit CVE? jbranso
2021-06-10 22:56 ` Tobias Geerinckx-Rice
2021-06-10 23:00 Leo Prikler

all messages for Guix-related lists mirrored at yhetil.org

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix

Example config snippet for mirrors.


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git