all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / Atom feed
* emacs xwidget build with exwm
@ 2021-04-07 22:18 Phil
  2021-04-10 23:33 ` Phil
  0 siblings, 1 reply; 2+ messages in thread
From: Phil @ 2021-04-07 22:18 UTC (permalink / raw)
  To: help-guix

Hi all,

I'm using latest GuixSD.

I modified my /etc/config.scm in the hope of configuring exwm as my window
manager, but with xwidget support see below - "emacs" has been changed to "emacs-xwidgets".

However with this in place I still get errors saying emacs was not
 compiled with xwidget support when I slect exwm at the login screen.

emacs-xwidget works when installed in a different WM (eg Gnome or MATE) inside my
default profile.  However I note the rendering of the HTML is often
badly positioned with the right hand part of the window completely cut-off - I
don't see this on the same computer running Ubuntu+emacs, so it is
somehow broadly related to my guix config, I guess?


 (packages
  (append
   (list (specification->package "emacs-xwidgets")
         (specification->package "emacs-exwm")
         (specification->package
          "emacs-desktop-environment")
         (specification->package "nss-certs"))
   %base-packages))


Any ideas how to configure xwidgets as exwm, and/or any ideas who to resolve bad
placement/rendering of xwidgets within buffer?


Thanks,
Phil.


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: emacs xwidget build with exwm
  2021-04-07 22:18 emacs xwidget build with exwm Phil
@ 2021-04-10 23:33 ` Phil
  0 siblings, 0 replies; 2+ messages in thread
From: Phil @ 2021-04-10 23:33 UTC (permalink / raw)
  To: help-guix


> Any ideas how to configure xwidgets as exwm, and/or any ideas who to resolve bad
> placement/rendering of xwidgets within buffer?

In case it helps others to answer my own question - you need to define a
specific exwm package which builds against emacs-xwidgets:


(define-module (emacs-exwm-xwidgets)
  #:use-module (guix packages)
  #:use-module (guix utils)
  #:use-module (gnu packages emacs)
  #:use-module (gnu packages emacs-xyz))

(define-public emacs-exwm-xwidgets
  (package
   (inherit emacs-exwm)
   (name "emacs-exwm-xwidgets")
   (arguments
     (substitute-keyword-arguments (package-arguments emacs-exwm)
       ((#:emacs emacs) `,emacs-xwidgets)))))



You can then reconfigure modifying the /etc/config.scm:


 (packages
  (append
   (list (specification->package "emacs-xwidgets")
         (specification->package "emacs-exwm-xwidgets")
         (specification->package
          "emacs-desktop-environment")
         (specification->package "nss-certs"))
   %base-packages))



The suprising bonus was that this also resolved the rendering issues too
- I can only assume they were specific to running xwidgets on MATE.


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-04-10 23:34 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-07 22:18 emacs xwidget build with exwm Phil
2021-04-10 23:33 ` Phil

all messages for Guix-related lists mirrored at yhetil.org

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix

Example config snippet for mirrors.


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git