all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
* language server doesn't let me emote
@ 2022-08-06 14:02 jgart
  2022-08-06 14:52 ` Tobias Geerinckx-Rice
  2022-08-06 17:53 ` Akib Azmain Turja
  0 siblings, 2 replies; 8+ messages in thread
From: jgart @ 2022-08-06 14:02 UTC (permalink / raw)
  To: Guix Help


substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
0.0 MB will be downloaded
 emacs-ht-2.3  5KiB                   331KiB/s 00:00 [##################] 100.0%
guix install: error: profile contains conflicting entries for emacs-ht
guix install: error:   first entry: emacs-ht@2.3 /gnu/store/pci18w9qa6740hsaqq4cxfg793sbvn6v-emacs-ht-2.3
guix install: error:    ... propagated from emacs-emojify@1.2
guix install: error:   second entry: emacs-ht@2.3 /gnu/store/7y2q2aiaahkhrc7m8ykn3i7s95ypqmlh-emacs-ht-2.3
guix install: error:    ... propagated from emacs-lsp-mode@8.0.1-0.4aafe25
hint: Try upgrading both `emacs-emojify' and `emacs-lsp-mode', or remove one of
them from the profile.

Did I just get DAGed?

Or am I conflating an obscene amount of things I don't fully understand here?


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 14:02 language server doesn't let me emote jgart
@ 2022-08-06 14:52 ` Tobias Geerinckx-Rice
  2022-08-06 16:09   ` jgart
  2022-08-06 17:53 ` Akib Azmain Turja
  1 sibling, 1 reply; 8+ messages in thread
From: Tobias Geerinckx-Rice @ 2022-08-06 14:52 UTC (permalink / raw)
  To: jgart; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 1254 bytes --]

Hi jgart,

jgart 写道:
> substitute: updating substitutes from 
> 'https://ci.guix.gnu.org'... 100.0%

Which command triggered this?

> 0.0 MB will be downloaded
>  emacs-ht-2.3  5KiB                   331KiB/s 00:00 
>  [##################] 100.0%
> guix install: error: profile contains conflicting entries for 
> emacs-ht
> guix install: error:   first entry: emacs-ht@2.3 
> /gnu/store/pci18w9qa6740hsaqq4cxfg793sbvn6v-emacs-ht-2.3
> guix install: error:    ... propagated from emacs-emojify@1.2
> guix install: error:   second entry: emacs-ht@2.3 
> /gnu/store/7y2q2aiaahkhrc7m8ykn3i7s95ypqmlh-emacs-ht-2.3
> guix install: error:    ... propagated from 
> emacs-lsp-mode@8.0.1-0.4aafe25
> hint: Try upgrading both `emacs-emojify' and `emacs-lsp-mode', 
> or remove one of
> them from the profile.

Did you try upgrading both packages at the same time?  (guix 
package -u emacs-emojify emacs-lsp-mode, for example?)

This hint isn't bad or unclear per se, but we should probably make 
it ridiculously explicit.

> Or am I conflating an obscene amount of things I don't fully 
> understand here?

We're blobs of fat in a skull trying to computer.  I'd say we're 
all coping remarkably.

Kind regards,

T G-R

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 14:52 ` Tobias Geerinckx-Rice
@ 2022-08-06 16:09   ` jgart
  2022-08-06 16:19     ` Tobias Geerinckx-Rice
  0 siblings, 1 reply; 8+ messages in thread
From: jgart @ 2022-08-06 16:09 UTC (permalink / raw)
  To: Tobias Geerinckx-Rice; +Cc: help-guix

On Sat, 06 Aug 2022 16:52:38 +0200 Tobias Geerinckx-Rice <me@tobias.gr> wrote:
> Did you try upgrading both packages at the same time?  (guix 
> package -u emacs-emojify emacs-lsp-mode, for example?)

I only ran this™:

guix install emacs-emojify

Here's the profile I ran the above against:

```
guix package --export-manifest
;; This "manifest" file can be passed to 'guix package -m' to reproduce
;; the content of your profile.  This is "symbolic": it only specifies
;; package names.  To reproduce the exact same profile, you also need to
;; capture the channels being used, as returned by "guix describe".
;; See the "Replicating Guix" section in the manual.

(specifications->manifest
  (list "nyxt"
        "emacs-eglot"
        "emacs-consult-org-roam"
        "emacs-org-roam"
        "emacs-setup"
        "emacs-use-package"
        "emacs-load-relative"
        "emacs-company-lsp"
        "emacs-company"
        "emacs-placeholder"
        "emacs-counsel"
        "emacs-consult-lsp"
        "emacs-lsp-mode"
        "emacs-realgud"
        "emacs-pcmpl-args"
        "racket"
        "emacs-jedi"
        "emacs-marginalia"
        "emacs-pyvenv"
        "st"
        "xonsh"
        "emacs-geiser-guile"
        "emacs-geiser"
        "guile"
        "emacs-rg"
        "emacs-xclip"
        "emacs-wgrep"
        "emacs-evil-leader"
        "emacs-lispy"
        "tig"
        "nss-certs"
        "emacs-code-cells"
        "emacs-diff-hl"
        "emacs-purescript-mode"
        "esbuild"
        "xwrits"
        "emacs-org-modern"
        "castor"
        "emacs-elpher"
        "fontconfig"
        "vis"
        "man-db"
        "visidata"
        "emacs-shell-command+"
        "sxiv"
        "feh"
        "emacs-imenu-list"
        "emacs-tempel"
        "litterbox"
        "emacs"
        "emacs-consult"
        "emacs-corfu"
        "emacs-evil-collection"
        "emacs-evil"
        "tokei"
        "ripgrep"
        "fzf"
        "dragon-drop"
        "skim"
        "git-open"
        "tz"
        "emacs-terminal-here"
        "emacs-orderless"
        "catgirl"
        "emacs-vertico"
        "lynx"
        "bower"
        "glibc-locales"))
```

And the generation I'm on:

```
 λ guix describe
Generation 88	Aug 03 2022 19:26:59	(current)
  guix 47a38d0
    repository URL: https://git.savannah.gnu.org/git/guix.git
    branch: master
    commit: 47a38d09696b309f6174b585465e621352444ddb
  guixrus ba8eac4
    repository URL: https://git.sr.ht/~whereiseveryone/guixrus
    branch: master
    commit: ba8eac42546a101b165d3dfd1d3d89a2bd1f788c
```

maybe we need a `guix doctor` command?


^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 16:09   ` jgart
@ 2022-08-06 16:19     ` Tobias Geerinckx-Rice
  2022-08-06 16:34       ` Tobias Geerinckx-Rice
  0 siblings, 1 reply; 8+ messages in thread
From: Tobias Geerinckx-Rice @ 2022-08-06 16:19 UTC (permalink / raw)
  To: jgart; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 100 bytes --]

jgart 写道:
> I only ran this™:

OK.  Did you not see the hint?

Kind regards,

T G-R

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 16:19     ` Tobias Geerinckx-Rice
@ 2022-08-06 16:34       ` Tobias Geerinckx-Rice
  2022-08-06 17:24         ` jgart
  0 siblings, 1 reply; 8+ messages in thread
From: Tobias Geerinckx-Rice @ 2022-08-06 16:34 UTC (permalink / raw)
  Cc: jgart, help-guix

[-- Attachment #1: Type: text/plain, Size: 226 bytes --]

Tobias Geerinckx-Rice 写道:
> OK.  Did you not see the hint?

If you did, what did you think it meant and how did you try to 
address what it said?  Would adding ‘at the same time’ help?

Kind regards,

T G-R

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 16:34       ` Tobias Geerinckx-Rice
@ 2022-08-06 17:24         ` jgart
  2022-08-06 18:02           ` Dr. Arne Babenhauserheide
  0 siblings, 1 reply; 8+ messages in thread
From: jgart @ 2022-08-06 17:24 UTC (permalink / raw)
  To: Tobias Geerinckx-Rice; +Cc: help-guix

On Sat, 06 Aug 2022 18:34:30 +0200 Tobias Geerinckx-Rice <me@tobias.gr> wrote:
> Tobias Geerinckx-Rice 写道:
> > OK.  Did you not see the hint?

I thought that the hint was a false positive but thanks for pointing it
out because now it lead me to my original issue:

```
 λ guix upgrade emacs-emojify emacs-lsp-mode
The following package will be upgraded:
   emacs-lsp-mode (dependencies or package changed)

substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
0.4 MB will be downloaded
 emacs-f-0.20.0  9KiB                                                 290KiB/s 00:00 [##################] 100.0%
 emacs-lsp-mode-8.0.1-0.4aafe25  388KiB                               383KiB/s 00:01 [##################] 100.0%
 emacs-s-1.12.0  20KiB                                                1.3MiB/s 00:00 [##################] 100.0%
guix upgrade: error: profile contains conflicting entries for emacs-lsp-mode
guix upgrade: error:   first entry: emacs-lsp-mode@8.0.1-0.4aafe25 /gnu/store/kzcj5cr56873lsb5z2b8g9i8a4hy0zl6-emacs-lsp-mode-8.0.1-0.4aafe25
guix upgrade: error:   second entry: emacs-lsp-mode@8.0.1-0.4aafe25 /gnu/store/y2h6z5dqnsrn8fnklw1xdg42dvsykqnm-emacs-lsp-mode-8.0.1-0.4aafe25
guix upgrade: error:    ... propagated from emacs-consult-lsp@1.0
hint: Try upgrading both `emacs-lsp-mode' and `emacs-consult-lsp', or remove one of them from the profile.
```

-------------------------------------------------------------------------------------------

intending to follow hint:

 λ guix upgrade emacs-lsp-mode emacs-consult-lsp
The following packages will be upgraded:
   emacs-consult-lsp (dependencies or package changed)
   emacs-lsp-mode    (dependencies or package changed)

guix upgrade: error: profile contains conflicting entries for emacs-consult
guix upgrade: error:   first entry: emacs-consult@0.18 /gnu/store/fybqb9jl3lp4grdbmhcvb1fgzxi99cdc-emacs-consult-0.18
guix upgrade: error:    ... propagated from emacs-consult-lsp@1.0
guix upgrade: error:   second entry: emacs-consult@0.18 /gnu/store/4xm7ll4xbnpdabb5q02h3i5cm0xwq9vc-emacs-consult-0.18
hint: Try upgrading both `emacs-consult-lsp' and `emacs-consult', or remove one
of them from the profile.

------------------------------------------------------------------------------------------

intending to follow hint:

```
 λ guix upgrade emacs-consult emacs-consult-lsp
The following packages will be upgraded:
   emacs-consult          (dependencies or package changed)
   emacs-consult-lsp      (dependencies or package changed)
   emacs-consult-org-roam (dependencies or package changed)

substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
1.5 MB will be downloaded
 emacs-emacsql-3.0.0  508KiB          480KiB/s 00:01 [##################] 100.0%
 emacs-emacsql-sqlite3-1.0.2  6KiB    366KiB/s 00:00 [##################] 100.0%
 emacs-magit-3.3.0  530KiB            521KiB/s 00:01 [##################] 100.0%
 emacs-org-roam-2.2.2  381KiB         540KiB/s 00:01 [##################] 100.0%
guix upgrade: error: profile contains conflicting entries for emacs-org-roam
guix upgrade: error:   first entry: emacs-org-roam@2.2.2 /gnu/store/wcrl5ka5icf7w4g3bi8gw98sr233zm8a-emacs-org-roam-2.2.2
guix upgrade: error:    ... propagated from emacs-consult-org-roam@0.1-0.05cec28
guix upgrade: error:   second entry: emacs-org-roam@2.2.2 /gnu/store/lp35wfrmin58fbvi5wjgy2scasvirpsg-emacs-org-roam-2.2.2
hint: Try upgrading both `emacs-consult-org-roam' and `emacs-org-roam', or remove
one of them from the profile.
```

------------------------------------------------------------------------------------------

intending to follow hint:

 λ guix upgrade emacs-consult-org-roam emacs-org-roam
The following packages will be upgraded:
   emacs-consult-org-roam (dependencies or package changed)
   emacs-org-roam         (dependencies or package changed)

guix upgrade: error: profile contains conflicting entries for emacs-consult
guix upgrade: error:   first entry: emacs-consult@0.18 /gnu/store/fybqb9jl3lp4grdbmhcvb1fgzxi99cdc-emacs-consult-0.18
guix upgrade: error:    ... propagated from emacs-consult-org-roam@0.1-0.05cec28
guix upgrade: error:   second entry: emacs-consult@0.18 /gnu/store/4xm7ll4xbnpdabb5q02h3i5cm0xwq9vc-emacs-consult-0.18
hint: Try upgrading both `emacs-consult-org-roam' and `emacs-consult', or remove
one of them from the profile.

-------------------------------------------------------------------------------------------------

It feels like that infinite recursion scene from "Dude, Where's My Car"
at the drive-thru: https://invidious.flokinet.to/watch?v=oqwzuiSy9y0

Or, the infinite recursion in the tatoo scene: https://invidious.flokinet.to/watch?v=BMuGjeoS3qI

I digress, should I try removing one of them? But, what If I want both?

emacs-consult-lsp is in guixrus/packages/emacs.scm:1477:2 
emacs-consult-org-roam is in guixrus/packages/emacs.scm:1401:4

Should I keep only one because of propagated-inputs but then doesn't
that break the declarativeness of wanting a particular package without
worrying about dep bleed?

¯\_(ツ)_/¯




^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 14:02 language server doesn't let me emote jgart
  2022-08-06 14:52 ` Tobias Geerinckx-Rice
@ 2022-08-06 17:53 ` Akib Azmain Turja
  1 sibling, 0 replies; 8+ messages in thread
From: Akib Azmain Turja @ 2022-08-06 17:53 UTC (permalink / raw)
  To: jgart; +Cc: Guix Help

[-- Attachment #1: Type: text/plain, Size: 1645 bytes --]

jgart <jgart@dismail.de> writes:

> substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
> 0.0 MB will be downloaded
>  emacs-ht-2.3  5KiB                   331KiB/s 00:00 [##################] 100.0%
> guix install: error: profile contains conflicting entries for emacs-ht
> guix install: error:   first entry: emacs-ht@2.3 /gnu/store/pci18w9qa6740hsaqq4cxfg793sbvn6v-emacs-ht-2.3
> guix install: error:    ... propagated from emacs-emojify@1.2
> guix install: error:   second entry: emacs-ht@2.3 /gnu/store/7y2q2aiaahkhrc7m8ykn3i7s95ypqmlh-emacs-ht-2.3
> guix install: error:    ... propagated from emacs-lsp-mode@8.0.1-0.4aafe25
> hint: Try upgrading both `emacs-emojify' and `emacs-lsp-mode', or remove one of
> them from the profile.
>
> Did I just get DAGed?
>
> Or am I conflating an obscene amount of things I don't fully understand here?
>

It just means that "emacs-emojify" and "emacs-lsp-mode" depends on two
separate versions of "emacs-ht".  This is probably because one of the
package is obsolete (i.e. you installed before and there is a update
available after you did "guix pull", but you didn't update).

Just try to do what guix is saying.  And if that doesn't work, try "guix
package --upgrade --install WHAT-EVER-YOU-WANNA-INSTALL", it will
upgrade all package and install your package, and there shouldn't be any
conflict.  If the problem still persists, IMHO that's a bug.

-- 
Akib Azmain Turja

Find me on Mastodon at @akib@hostux.social.

This message is signed by me with my GnuPG key.  Its fingerprint is:

    7001 8CE5 819F 17A3 BBA6  66AF E74F 0EFA 922A E7F5

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 832 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: language server doesn't let me emote
  2022-08-06 17:24         ` jgart
@ 2022-08-06 18:02           ` Dr. Arne Babenhauserheide
  0 siblings, 0 replies; 8+ messages in thread
From: Dr. Arne Babenhauserheide @ 2022-08-06 18:02 UTC (permalink / raw)
  To: jgart; +Cc: Tobias Geerinckx-Rice, help-guix

[-- Attachment #1: Type: text/plain, Size: 1041 bytes --]


jgart <jgart@dismail.de> writes:

> Should I keep only one because of propagated-inputs but then doesn't
> that break the declarativeness of wanting a particular package without
> worrying about dep bleed?
>
> ¯\_(ツ)_/¯

I also used to run into such problems pretty often.

The only way I found to break such cycles reliably (without in the end
putting tens of packages into "update also" list) is to create a
manifest-file and always install new packages by adding them to the
manifest and then installing the manifest:

    guix package  --fallback -k -m ~/fluss-guix.manifest

To create the manifest, you can nowadays just export it:

    guix package --export-manifest > ~/fluss-guix.manifest

This works, but is hard to tell newcomers, so I’d much prefer having
install show me the list of all other packages that need to be updated
to install the package in question and being asked yes or no to that.

Best wishes,
Arne
-- 
Unpolitisch sein
heißt politisch sein,
ohne es zu merken.
draketo.de

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 1125 bytes --]

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2022-08-06 18:07 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-08-06 14:02 language server doesn't let me emote jgart
2022-08-06 14:52 ` Tobias Geerinckx-Rice
2022-08-06 16:09   ` jgart
2022-08-06 16:19     ` Tobias Geerinckx-Rice
2022-08-06 16:34       ` Tobias Geerinckx-Rice
2022-08-06 17:24         ` jgart
2022-08-06 18:02           ` Dr. Arne Babenhauserheide
2022-08-06 17:53 ` Akib Azmain Turja

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.