all messages for Guix-related lists mirrored at yhetil.org
 help / color / mirror / code / Atom feed
From: vicvbcun <guix@ikherbers.com>
To: 56729@debbugs.gnu.org
Cc: "Ludovic Courtès" <ludo@gnu.org>, "Andreas Enge" <andreas.enge@inria.fr>
Subject: [bug#56729] [RFC PATCH v2 01/29] gnu: Remove ecl-16.
Date: Mon,  8 Aug 2022 17:45:36 +0200	[thread overview]
Message-ID: <786a15803950a03fa7f47abe8e3457c4d7d611f4.1659973115.git.guix@ikherbers.com> (raw)
In-Reply-To: <cover.1658595756.git.guix@ikherbers.com>

* gnu/packages/sagemath.scm (ecl-16): Delete variable.
* gnu/packages/patches/ecl-16-format-directive-limit.patch,
gnu/packages/patches/ecl-16-ignore-stderr-write-error.patch,
gnu/packages/patches/ecl-16-libffi.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them here.
---
 gnu/local.mk                                  |  3 -
 .../ecl-16-format-directive-limit.patch       | 83 -------------------
 .../ecl-16-ignore-stderr-write-error.patch    | 17 ----
 gnu/packages/patches/ecl-16-libffi.patch      | 16 ----
 gnu/packages/sagemath.scm                     | 21 -----
 5 files changed, 140 deletions(-)
 delete mode 100644 gnu/packages/patches/ecl-16-format-directive-limit.patch
 delete mode 100644 gnu/packages/patches/ecl-16-ignore-stderr-write-error.patch
 delete mode 100644 gnu/packages/patches/ecl-16-libffi.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 07e3497d10..2049964ff7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1013,9 +1013,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/dstat-skip-devices-without-io.patch	\
   %D%/packages/patches/dvd+rw-tools-add-include.patch 		\
   %D%/packages/patches/dynaconf-unvendor-deps.patch		\
-  %D%/packages/patches/ecl-16-format-directive-limit.patch	\
-  %D%/packages/patches/ecl-16-ignore-stderr-write-error.patch	\
-  %D%/packages/patches/ecl-16-libffi.patch			\
   %D%/packages/patches/efibootmgr-remove-extra-decl.patch	\
   %D%/packages/patches/efivar-211.patch			\
   %D%/packages/patches/eigen-remove-openmp-error-counting.patch	\
diff --git a/gnu/packages/patches/ecl-16-format-directive-limit.patch b/gnu/packages/patches/ecl-16-format-directive-limit.patch
deleted file mode 100644
index 237db92722..0000000000
--- a/gnu/packages/patches/ecl-16-format-directive-limit.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-Patch backported by Sage.
-
-Fix from upstream that happens to work around
-https://trac.sagemath.org/ticket/23011
-diff --git a/src/lsp/format.lsp b/src/lsp/format.lsp
-index 77ca799..53b887c 100644
---- a/src/lsp/format.lsp
-+++ b/src/lsp/format.lsp
-@@ -307,11 +307,13 @@
-                   :start (format-directive-start struct)
-                   :end (format-directive-end struct))))
- 
-+(defconstant +format-directive-limit+ (1+ (char-code #\~)))
-+
- #+formatter
- (defparameter *format-directive-expanders*
--  (make-array char-code-limit :initial-element nil))
-+  (make-array +format-directive-limit+ :initial-element nil))
- (defparameter *format-directive-interpreters*
--  (make-array char-code-limit :initial-element nil))
-+  (make-array +format-directive-limit+ :initial-element nil))
- 
- (defparameter *default-format-error-control-string* nil)
- (defparameter *default-format-error-offset* nil)
-@@ -550,24 +552,24 @@
-            (write-string directive stream)
-            (interpret-directive-list stream (cdr directives) orig-args args))
-           (#-ecl format-directive #+ecl vector
-+           (multiple-value-bind
-+                 (new-directives new-args)
-+               (let* ((code (char-code (format-directive-character directive)))
-+                      (function
-+                        (and (< code +format-directive-limit+)
-+                             (svref *format-directive-interpreters* code)))
-+                      (*default-format-error-offset*
-+                        (1- (format-directive-end directive))))
-+                 (unless function
-+                   (error 'format-error
-+                          :complaint "Unknown format directive."))
-                  (multiple-value-bind
-                        (new-directives new-args)
--                     (let ((function
--                            (svref *format-directive-interpreters*
--                                   (char-code (format-directive-character
--                                               directive))))
--                           (*default-format-error-offset*
--                            (1- (format-directive-end directive))))
--                       (unless function
--                         (error 'format-error
--                                :complaint "Unknown format directive."))
--                       (multiple-value-bind
--                             (new-directives new-args)
--                           (funcall function stream directive
--                                    (cdr directives) orig-args args)
--                         (values new-directives new-args)))
--                   (interpret-directive-list stream new-directives
--                                             orig-args new-args)))))
-+                     (funcall function stream directive
-+                              (cdr directives) orig-args args)
-+                   (values new-directives new-args)))
-+             (interpret-directive-list stream new-directives
-+                                       orig-args new-args)))))
-       args))
- 
- \f
-@@ -639,11 +641,12 @@
-        (values `(write-string ,directive stream)
-                more-directives))
-       (format-directive
--       (let ((expander
--              (aref *format-directive-expanders*
--                    (char-code (format-directive-character directive))))
--             (*default-format-error-offset*
--              (1- (format-directive-end directive))))
-+       (let* ((code (char-code (format-directive-character directive)))
-+              (expander
-+                (and (< code +format-directive-limit+)
-+                     (svref *format-directive-expanders* code)))
-+              (*default-format-error-offset*
-+                (1- (format-directive-end directive))))
-          (if expander
-              (funcall expander directive more-directives)
-              (error 'format-error
diff --git a/gnu/packages/patches/ecl-16-ignore-stderr-write-error.patch b/gnu/packages/patches/ecl-16-ignore-stderr-write-error.patch
deleted file mode 100644
index 42d213c0e9..0000000000
--- a/gnu/packages/patches/ecl-16-ignore-stderr-write-error.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Patch adapted from Sage.
-diff -Naur ecl-16.1.2.orig/src/c/file.d ecl-16.1.2/src/c/file.d
---- ecl-16.1.2.orig/src/c/file.d	2016-05-11 13:10:51.867673867 +1200
-+++ ecl-16.1.2/src/c/file.d	2016-05-11 14:44:48.121907307 +1200
-@@ -3354,8 +3354,10 @@
-   ecl_disable_interrupts();
-   do {
-     out = fwrite(c, sizeof(char), n, IO_STREAM_FILE(strm));
--  } while (out < n && restartable_io_error(strm, "fwrite"));
--  ecl_enable_interrupts();
-+  /* Ignore write errors to stderr to avoid an infinite loop */
-+  } while (out < n && (IO_STREAM_FILE(strm) != stderr) && restartable_io_error(strm, "fwrite"));
-+
-+  ecl_enable_interrupts();
-   return out;
- }
- 
diff --git a/gnu/packages/patches/ecl-16-libffi.patch b/gnu/packages/patches/ecl-16-libffi.patch
deleted file mode 100644
index fc06a07606..0000000000
--- a/gnu/packages/patches/ecl-16-libffi.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Patch adapted from Sage. Allows building ECL on libffi 3.3.
-diff --git a/src/c/ffi.d b/src/c/ffi.d
-index 8861303e..8a959c23 100644
---- a/src/c/ffi.d
-+++ b/src/c/ffi.d
-@@ -133,8 +133,8 @@ static struct {
- #elif defined(X86_WIN64)
-   {@':win64', FFI_WIN64},
- #elif defined(X86_ANY) || defined(X86) || defined(X86_64)
--  {@':cdecl', FFI_SYSV},
--  {@':sysv', FFI_SYSV},
-+  {@':cdecl', FFI_UNIX64},
-+  {@':sysv', FFI_UNIX64},
-   {@':unix64', FFI_UNIX64},
- #endif
- };
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 7f76f8912b..75720f31a5 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -174,27 +174,6 @@ (define-public libhomfly
     (license license:public-domain)
     (home-page "https://github.com/miguelmarco/libhomfly")))
 
-;; Sage 9.1 doesn't build with ECL 20.  This won't be necessary once 9.2 is
-;; released.  See https://trac.sagemath.org/ticket/22191
-(define-public ecl-16
-  (package
-    (inherit ecl)
-    (version "16.1.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://common-lisp.net/project/ecl/static/files/release/ecl"
-             "-" version ".tgz"))
-       (sha256
-        (base32 "0m0j24w5d5a9dwwqyrg0d35c0nys16ijb4r0nyk87yp82v38b9bn"))
-       (patches (search-patches
-                  "ecl-16-libffi.patch"
-                  "ecl-16-ignore-stderr-write-error.patch"
-                  "ecl-16-format-directive-limit.patch"))))
-    ;; Current ECL uses LGPL 2.1+
-    (license license:lgpl2.0+)))
-
 (define-public pynac
   (package
     (name "pynac")
-- 
2.37.0





  parent reply	other threads:[~2022-08-08 15:52 UTC|newest]

Thread overview: 90+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-23 19:59 [bug#56729] [RFC PATCH 00/10] Add sagemath vicvbcun
2022-07-23 20:51 ` [bug#56729] [RFC PATCH 01/10] gnu: edge-addition-planarity-suite: Update to 3.0.2.0 vicvbcun
2022-07-23 20:51 ` [bug#56729] [RFC PATCH 02/10] gnu: gap: Update to 4.11.1 vicvbcun
2022-08-03  9:25   ` [bug#56729] [RFC PATCH v2] " vicvbcun
2022-07-23 20:51 ` [bug#56729] [RFC PATCH 03/10] gnu: Remove ecl-16 vicvbcun
2022-07-23 20:51 ` [bug#56729] [RFC PATCH 04/10] gnu: cliquer: Update to 1.22 vicvbcun
2022-07-23 20:51 ` [bug#56729] [RFC PATCH 05/10] gnu: lcalc: Update to 2.0.5 vicvbcun
2022-07-23 20:52 ` [bug#56729] [RFC PATCH 06/10] gnu: ntl: Update to 11.5.1 vicvbcun
2022-07-23 20:52 ` [bug#56729] [RFC PATCH 07/10] gnu: eclib: Update to 20220621 vicvbcun
2022-07-23 20:52 ` [bug#56729] [RFC PATCH 08/10] gnu: Add python-memory-allocator vicvbcun
2022-07-23 20:52 ` [bug#56729] [RFC PATCH 09/10] gnu: Add python-pplpy vicvbcun
2022-07-23 20:52 ` [bug#56729] [RFC PATCH 10/10] gnu: Add sagemath vicvbcun
2022-08-01  9:24 ` [bug#56729] [RFC PATCH 00/10] " Ludovic Courtès
2022-08-03  9:21   ` guix
2022-08-11 18:05     ` Andreas Enge
2022-08-08 14:40   ` Andreas Enge
2022-08-08 16:20     ` guix
2022-08-09 10:47       ` Andreas Enge
2022-08-09 10:55         ` ( via Guix-patches via
2022-08-09 12:19         ` Andreas Enge
2022-08-09 13:40         ` vicvbcun
2022-08-12  8:50           ` Andreas Enge
2022-08-12  8:58           ` Andreas Enge
2022-08-09 21:32         ` Maxime Devos
2022-08-10  8:26           ` Andreas Enge
2022-08-10  9:03       ` Andreas Enge
2022-08-06  1:28 ` vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 00/29] " vicvbcun
2022-08-08 15:45 ` vicvbcun [this message]
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 02/29] gnu: edge-addition-planarity-suite: Update to 3.0.2.0 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 03/29] gnu: gap: Update to 4.11.1 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 04/29] gnu: cliquer: Update to 1.22 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 05/29] gnu: lcalc: Update to 2.0.5 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 06/29] gnu: ntl: Update to 11.5.1 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 07/29] gnu: eclib: Update to 20220621 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 08/29] gnu: lrcalc: Update to 2.1 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 09/29] gnu: maxima: Update to 5.46.0 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 10/29] gnu: python-sympy: Update to 1.10.1 vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 11/29] gnu: cddlib: Update to 0.94m vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 12/29] gnu: Add python-memory-allocator vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 13/29] gnu: Add python-pplpy vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 14/29] gnu: Add primecount vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 15/29] gnu: Add python-primecountpy vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 16/29] gnu: Add python-lrcalc vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 17/29] gnu: Add palp vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 18/29] gnu: Add gfan vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 19/29] gnu: Add flintqs vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 20/29] gnu: Add tachyon vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 21/29] gnu: Add sagemath-data-conway-polynomials vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 22/29] gnu: Add sagemath-data-elliptic-curves vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 23/29] gnu: Add sagemath-data-combinatorial-designs vicvbcun
2022-08-08 15:45 ` [bug#56729] [RFC PATCH v2 24/29] gnu: Add sagemath-data-graphs vicvbcun
2022-08-08 15:46 ` [bug#56729] [RFC PATCH v2 25/29] gnu: Add sagemath-data-poytopes-db vicvbcun
2022-08-08 15:46 ` [bug#56729] [RFC PATCH v2 26/29] gnu: Add pari-galdata vicvbcun
2022-08-08 15:46 ` [bug#56729] [RFC PATCH v2 27/29] gnu: Add sagemath-just-build vicvbcun
2022-08-08 15:46 ` [bug#56729] [RFC PATCH v2 28/29] gnu: Add sagemath-with-dependencies vicvbcun
2022-08-08 15:46 ` [bug#56729] [RFC PATCH v2 29/29] gnu: Add sagemath-tests vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 00/32] Add sagemath vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 01/32] gnu: python-cysignals: Update to 1.11.2 vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 02/32] gnu: cliquer: Update to 1.22 vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 03/32] gnu: Add python-memory-allocator vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 04/32] gnu: python-gmpy2: Move to (gnu packages multiprecision) vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 05/32] gnu: Add python-pplpy vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 06/32] gnu: Add primecount vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 07/32] gnu: Add python-primecountpy vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 08/32] gnu: Add python-lrcalc vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 09/32] gnu: Add palp vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 10/32] gnu: Add gfan vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 11/32] gnu: Add sympow vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 12/32] download: Add SageMath mirrors vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 13/32] gnu: Add sagemath-data-combinatorial-designs vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 14/32] gnu: Add sagemath-data-conway-polynomials vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 15/32] gnu: Add sagemath-data-elliptic-curves vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 16/32] gnu: Add sagemath-data-graphs vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 17/32] gnu: Add sagemath-data-polytopes-db vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 18/32] gnu: pari-gp: Use G-expression vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 19/32] gnu: pari-gp: Install galdata vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 20/32] gnu: gap: Build reproducibly vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 21/32] gnu: gap: Compile atlasrep package vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 22/32] gnu: gap: Remove leftover source and build files vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 23/32] gnu: maxima: Build with ecl vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 24/32] gnu: maxima: Install maxima.fas vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 25/32] gnu: maxima: Apply matrix exponentiation patch vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 26/32] gnu: Add tachyon vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 27/32] gnu: singular: Update to 4.3.2 vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 28/32] gnu: singular: Don't compress info file vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 29/32] gnu: eclib: Update to 20230424 vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 30/32] gnu: python-pythran: Update to 0.13.1 vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 31/32] gnu: Add python-sagemath-standard vicvbcun
2023-05-29 20:38 ` [bug#56729] [RFC PATCH v3 32/32] gnu: Add sagemath vicvbcun

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=786a15803950a03fa7f47abe8e3457c4d7d611f4.1659973115.git.guix@ikherbers.com \
    --to=guix@ikherbers.com \
    --cc=56729@debbugs.gnu.org \
    --cc=andreas.enge@inria.fr \
    --cc=ludo@gnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this external index

	https://git.savannah.gnu.org/cgit/guix.git

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.