unofficial mirror of 
 help / color / mirror / Atom feed
* SweetHome3D
@ 2022-06-18 21:05 Milan Svoboda
  0 siblings, 0 replies; only message in thread
From: Milan Svoboda @ 2022-06-18 21:05 UTC (permalink / raw)
  To: help-guix


I am trying to run SweetHome3D. I used it on NixOS and it worked without 
any issue,

here I tried to mimic variables and flags used on NixOS, but it doesn't 
work. It requires old version of JDK/JRE, therefore icedtea@3 is used 


MESA_GL_VERSION_OVERRIDE=2.1 LD_LIBRARY_PATH="$(printf '%s/lib:' $(guix 
build --no-grafts libx{11,xf86vm,render} mesa 
icedtea@3))$LD_LIBRARY_PATH" java -Dsun.java2d.opengl=true -jar 


It looks to me like icedtea@3 is missing something that should be there...


Caught AppContextInfo(Bug 1004) InaccessibleObjectException: Unable to 
make public static sun.awt.AppContext sun.awt.AppContext.getAppContext() 
accessible: module java.desktop does not "exports sun.awt" to unnamed 
module @5a2e4553 on thread J3D-Renderer-1


Any idea what is wrong here? I am not very knowledgeable in Java land.



^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2022-06-18 21:40 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-06-18 21:05 SweetHome3D Milan Svoboda

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).