unofficial mirror of 
 help / color / mirror / Atom feed
* nvme0n1p1 (NVME/M2/SSD) boot device recovery
@ 2022-05-21  7:15 yasu
  0 siblings, 0 replies; only message in thread
From: yasu @ 2022-05-21  7:15 UTC (permalink / raw)
  To: Help Guix


I have just had a horrible experience of my Asus motherboard (TUF
GAMING X570-PLUS) suddenly not booting...The NVME device (CSSD-
M2B05GPG2VN) was no longer availalbe on the list of bootable devices
from BIOS menu of the motherboard.

I still don't know exactly what happened but my suspicion is that
something triggered the 'reset' of the motherboard (may have been that
the cr2032 battery went bad?  I replaced it)

Here is what I did to solve it:

- I downloaded SystemRescue , created a
USB thumbdrive boot device.

- After booting from it, I ran
  efibootmgr -c -d /dev/nvme0n1p1 -p 1 -L "Guix" -l

- Finally, I was able to select the NVME boot device.

It seemes that onboard ethernet (Probaly RealTek) completely died at
the same time... I tried various BIOS recovery procedure such as
triggeron ON/OFF of LAN from Bios Settings screen, updating to the
latest BIOS, etc, - none of it worked.   So I am using a USB3.0
Ethernet Adaptor right now.

I hope this memo will be of use to someone in the future!


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2022-05-21  7:16 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-21  7:15 nvme0n1p1 (NVME/M2/SSD) boot device recovery yasu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).