unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* can't connect
@ 2022-05-12 16:08 Matkovsky88 via
  2022-05-13 14:40 ` Tobias Geerinckx-Rice
  2022-05-13 14:54 ` Tobias Geerinckx-Rice
  0 siblings, 2 replies; 3+ messages in thread
From: Matkovsky88 via @ 2022-05-12 16:08 UTC (permalink / raw)
  To: help-guix

Hello. I can't connect to guix.gnu.org from my russian IP. Also, I can't install GNU Guix System, because I can't connect to Guix's servers. What I should do? Can I install GNU Guix System without internet connection? Thank you

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: can't connect
  2022-05-12 16:08 can't connect Matkovsky88 via
@ 2022-05-13 14:40 ` Tobias Geerinckx-Rice
  2022-05-13 14:54 ` Tobias Geerinckx-Rice
  1 sibling, 0 replies; 3+ messages in thread
From: Tobias Geerinckx-Rice @ 2022-05-13 14:40 UTC (permalink / raw)
  To: Matkovsky88, Matkovsky88 via, help-guix

Hi,

Due to increased attacks from Russian IP space 'lately', the MDC (the research institute hosting most Guix hardware) has blocked parts of it.  

The Guix project proper doesn't block anyone, but appreciates the MDC's efforts to keep our machines safe.

There's a third-party Chinese mirror that might work for you.  Try:

--substitute-urls='https://mirrors.sjtug.sjtu.edu.cn/guix'

As it's a pure mirror, to use it you SHOULD NOT add any signing keys beyond those already provided by Guix.

Kind regards,

T G-R

Sent on the go.  Excuse or enjoy my brevity.


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: can't connect
  2022-05-12 16:08 can't connect Matkovsky88 via
  2022-05-13 14:40 ` Tobias Geerinckx-Rice
@ 2022-05-13 14:54 ` Tobias Geerinckx-Rice
  1 sibling, 0 replies; 3+ messages in thread
From: Tobias Geerinckx-Rice @ 2022-05-13 14:54 UTC (permalink / raw)
  To: Matkovsky88, Matkovsky88 via, help-guix

*thinking noises*

Hm,

Your message did seem to imply you already got the installer ISO somehow, from a GNU mirror if I had to guess.  Is that correct?

I usually recommend using the 'latest' installer as 1.3.0 is over a year old now, but the former isn't mirrored AFAIK and the latter should work -- it's just old.  Unless you hit a bug during the installation you can upgrade the system once it's installed.

Kind regards,

T G-R

Sent on the go.  Excuse or enjoy my brevity.


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-05-13 14:55 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-12 16:08 can't connect Matkovsky88 via
2022-05-13 14:40 ` Tobias Geerinckx-Rice
2022-05-13 14:54 ` Tobias Geerinckx-Rice

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).