unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* failed to install the python-umap-learn package
@ 2020-09-21 11:23 Hong.Li
  2020-09-29 14:09 ` Ludovic Courtès
  0 siblings, 1 reply; 9+ messages in thread
From: Hong.Li @ 2020-09-21 11:23 UTC (permalink / raw)
  To: help-guix

Dear developers,


I had a failure when installing python-umap-learn in guix. It took very long time in the 'check' phase.

The error does not change before and after 'guix pull'. Could you please tell me how to solve this problem?

Thanks in advance! Please see the screen output below:


$ guix package -i python-umap-learn

The following package will be installed:
   python-umap-learn 0.3.10

The following derivations will be built:
   /gnu/store/4sbifbl79yy6xnbnkvj0hvc3i2mp6jcj-python-umap-learn-0.3.10.drv
   /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv
building /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv...
- 'check' phasebuilder for `/gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv' failed with exit code 1
build of /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv failed
View build log at '/gnu/var/log/guix/drvs/ra/7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv'.
guix package: error: build of `/gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv' failed

$ guix package -i python-numba

The following package will be installed:
   python-numba 0.46.0

The following derivation will be built:
   /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv
building /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv...
- 'check' phasebuilder for `/gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv' failed with exit code 1
build of /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv failed
View build log at '/gnu/var/log/guix/drvs/ra/7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv'.
guix package: error: build of `/gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv' failed

$ guix -V
guix (GNU Guix) 90492a9f13b4b8eaa6025d5a18e0b130cf257dbe

best regards,
Hong

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: failed to install the python-umap-learn package
  2020-09-21 11:23 failed to install the python-umap-learn package Hong.Li
@ 2020-09-29 14:09 ` Ludovic Courtès
  2020-09-29 14:56   ` zimoun
  0 siblings, 1 reply; 9+ messages in thread
From: Ludovic Courtès @ 2020-09-29 14:09 UTC (permalink / raw)
  To: Hong.Li; +Cc: help-guix

Hi,

"Hong.Li@mdc-berlin.de" <Hong.Li@mdc-berlin.de> skribis:

> I had a failure when installing python-umap-learn in guix. It took very long time in the 'check' phase.
>
> The error does not change before and after 'guix pull'. Could you please tell me how to solve this problem?
>
> Thanks in advance! Please see the screen output below:
>
>
> $ guix package -i python-umap-learn
>
> The following package will be installed:
>    python-umap-learn 0.3.10
>
> The following derivations will be built:
>    /gnu/store/4sbifbl79yy6xnbnkvj0hvc3i2mp6jcj-python-umap-learn-0.3.10.drv
>    /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv
> building /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv...
> - 'check' phasebuilder for `/gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv' failed with exit code 1
> build of /gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv failed
> View build log at '/gnu/var/log/guix/drvs/ra/7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv'.
> guix package: error: build of `/gnu/store/ra7xx13ni736p0kvcsbhsl0g9yhy4d68-python-numba-0.46.0.drv' failed

It would seem that one of the tests of python-numba is failing, perhaps
in a non-deterministic way.

As a stopgap, you should be able to run:

  guix install python-umap-learn --without-tests=python-numba

Note that ‘--without-tests’ was added just a couple of days ago, so you
may need to run ‘guix pull’ to get a recent-enough Guix:

  https://guix.gnu.org/manual/devel/en/html_node/Package-Transformation-Options.html

HTH,
Ludo’.


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: failed to install the python-umap-learn package
  2020-09-29 14:09 ` Ludovic Courtès
@ 2020-09-29 14:56   ` zimoun
  2020-09-30  8:56     ` Ludovic Courtès
  0 siblings, 1 reply; 9+ messages in thread
From: zimoun @ 2020-09-29 14:56 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: Hong.Li, help-guix

Dear Hong Li,


On Tue, 29 Sep 2020 at 16:09, Ludovic Courtès <ludovic.courtes@inria.fr> wrote:
> "Hong.Li@mdc-berlin.de" <Hong.Li@mdc-berlin.de> skribis:
>
> > I had a failure when installing python-umap-learn in guix. It took very long time in the 'check' phase.

Usually, if "guix weather python-umap-learn" says that there is no
substitute, then it is a bad sign. :-)


> > The error does not change before and after 'guix pull'. Could you please tell me how to solve this problem?

Thank you for pointing out the issue.  Using the Guix Data Service,

  https://data.guix.gnu.org/repository/1/branch/master/package/python-umap-learn/output-history

one can see the versions which build and the ones which fail (mainly
because dependencies, apparently).  One the last Succeeded row, you
can click on the revision 2020-04-18 19:24:20 which indicates the last
known commit where python-umap-learn builds.  Therefore, you can run:

   guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 \
          -- package -i pyhton-umap-learn


Hope that helps.


> It would seem that one of the tests of python-numba is failing, perhaps
> in a non-deterministic way.

From the Guix Data Service, the first offending commit is
cac674d99dc4a332e6210c57ec7f1b8164f66642 which updates python-cython.


All the best,
simon


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: failed to install the python-umap-learn package
  2020-09-29 14:56   ` zimoun
@ 2020-09-30  8:56     ` Ludovic Courtès
  2020-09-30 11:41       ` [ext] " Hong.Li
  0 siblings, 1 reply; 9+ messages in thread
From: Ludovic Courtès @ 2020-09-30  8:56 UTC (permalink / raw)
  To: zimoun; +Cc: Hong.Li, help-guix

Hi,

zimoun <zimon.toutoune@gmail.com> skribis:

> Thank you for pointing out the issue.  Using the Guix Data Service,
>
>   https://data.guix.gnu.org/repository/1/branch/master/package/python-umap-learn/output-history

[...]

> From the Guix Data Service, the first offending commit is
> cac674d99dc4a332e6210c57ec7f1b8164f66642 which updates python-cython.

Neat!  We should put that that to good use somehow to quickly notice and
fix regressions: with IRC/email notifications, ‘guix weather’ reporting
info from the Data Service, things like that.

Ludo’.


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [ext] Re: failed to install the python-umap-learn package
  2020-09-30  8:56     ` Ludovic Courtès
@ 2020-09-30 11:41       ` Hong.Li
  2020-09-30 12:11         ` zimoun
  0 siblings, 1 reply; 9+ messages in thread
From: Hong.Li @ 2020-09-30 11:41 UTC (permalink / raw)
  To: Ludovic Courtès, zimoun; +Cc: help-guix

Dear Ludo and Simon,


Thanks for the reply.

Unfortunately, I still have errors to install python-umap-learn package (dependencies error), see messages below:


$ guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 -- package -p guix/new/.guix-profile -i python3 python-umap-learn
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
The following derivations will be built:
   /gnu/store/6h3y0lp2mg8rlqbaam26n8dn6yfafrv7-compute-guix-derivation.drv
   /gnu/store/dfglc6l495466asp04ajwqlqdi2bgn6d-module-import-compiled.drv
   /gnu/store/zgi9gikccaa882a8amivvc0wlc7x610i-module-import.drv
building /gnu/store/zgi9gikccaa882a8amivvc0wlc7x610i-module-import.drv...
building /gnu/store/dfglc6l495466asp04ajwqlqdi2bgn6d-module-import-compiled.drv...
building /gnu/store/6h3y0lp2mg8rlqbaam26n8dn6yfafrv7-compute-guix-derivation.drv...
Computing Guix derivation for 'x86_64-linux'... /
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
The following derivations will be built:
   /gnu/store/fqaf4nrmvyjclisrf4b8chx0idlm1xrv-profile.drv
   /gnu/store/c718qi7pdrzshrppv03v91sf6057j5fm-guix-bimsb-nonfree.drv
   /gnu/store/fh3306a50cnh1l6y6dij2l6243d6cvc2-inferior-script.scm.drv
   /gnu/store/flj6npydjr8fxv3g30qfw4gxsg77q48a-guix-bimsb.drv
   /gnu/store/z4ckz3745wzng8bn53n22kc0ib3h61p8-inferior-script.scm.drv
   /gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv
   /gnu/store/ydj320kw2ylvkkzvs39nn1qsy5ykpmvw-module-import-compiled.drv
   /gnu/store/p7727k2lldx5s2h2kr71i74999np2pl2-module-import-compiled.drv
   /gnu/store/xzzd9bvs0rm71clvrbpk937hban06yh2-inferior-script.scm.drv
   /gnu/store/y7vc292wihdzias98dyzxfbnd24szc04-profile.drv
The following profile hooks will be built:
   /gnu/store/fv1gghy2a7m3s6bbpal32xbl8dfnw5dz-ca-certificate-bundle.drv
   /gnu/store/lz2s0p1k6ppjc0mjrq8ylcb82f2bwwif-guix-package-cache.drv
   /gnu/store/pq81nf3xdhkbrmfaig1m2mc0h0519ygl-info-dir.drv
   /gnu/store/s638gz72pfazskd3j0l5labcfkgnxz44-fonts-dir.drv
   /gnu/store/x43hvdc1rrsqhi6zy5p9wn8g1la2rw1x-manual-database.drv
building /gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv...
|builder for `/gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv' failed to produce output path `/gnu/store/gg8fs00h7vqx29icijxpd7w99z1p8lmf-guix-past'
build of /gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv failed
View build log at '/gnu/var/log/guix/drvs/jv/ffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv'.
cannot build derivation `/gnu/store/fqaf4nrmvyjclisrf4b8chx0idlm1xrv-profile.drv': 1 dependencies couldn't be built
guix time-machine: error: build of `/gnu/store/fqaf4nrmvyjclisrf4b8chx0idlm1xrv-profile.drv' failed
[hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- package -p guix/new/.guix-profile -i python3 python-umap-learn
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
^C
[hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- package -p guix/new/.guix-profile -i python3 python-umap-learn
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
Computing Guix derivation for 'x86_64-linux'...  WARNING: (guix build emacs-build-system): imported module (guix build utils) overrides core binding `delete'                                                |
The following derivation will be built:
   /gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv
The following profile hook will be built:
   /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv
building package cache...
/builder for `/gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv' failed to produce output path `/gnu/store/9vpcvp00acz4lvglfs1k69a4i05p5hbw-guix-package-cache'
build of /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv failed
View build log at '/gnu/var/log/guix/drvs/ya/j4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv'.
cannot build derivation `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv': 1 dependencies couldn't be built
guix time-machine: error: build of `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv' failed


best regards,

Hong

________________________________
From: Ludovic Courtès <ludovic.courtes@inria.fr>
Sent: 30 September 2020 10:56:24
To: zimoun
Cc: Li, Hong; help-guix@gnu.org
Subject: [ext] Re: failed to install the python-umap-learn package

Hi,

zimoun <zimon.toutoune@gmail.com> skribis:

> Thank you for pointing out the issue.  Using the Guix Data Service,
>
>   https://data.guix.gnu.org/repository/1/branch/master/package/python-umap-learn/output-history

[...]

> From the Guix Data Service, the first offending commit is
> cac674d99dc4a332e6210c57ec7f1b8164f66642 which updates python-cython.

Neat!  We should put that that to good use somehow to quickly notice and
fix regressions: with IRC/email notifications, ‘guix weather’ reporting
info from the Data Service, things like that.

Ludo’.

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [ext] Re: failed to install the python-umap-learn package
  2020-09-30 11:41       ` [ext] " Hong.Li
@ 2020-09-30 12:11         ` zimoun
  2020-09-30 13:08           ` Hong.Li
  0 siblings, 1 reply; 9+ messages in thread
From: zimoun @ 2020-09-30 12:11 UTC (permalink / raw)
  To: Hong.Li; +Cc: Ludovic Courtès, help-guix

On Wed, 30 Sep 2020 at 13:41, Hong.Li@mdc-berlin.de
<Hong.Li@mdc-berlin.de> wrote:

> $ guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 -- package -p guix/new/.guix-profile -i python3 python-umap-learn
> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
> Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
> Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...

[...]

> |builder for `/gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv' failed to produce output path `/gnu/store/gg8fs00h7vqx29icijxpd7w99z1p8lmf-guix-past'
> build of /gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv failed

The error comes from the channel 'guix-past'.  Well, I will investigate later...
Therefore, you have to turn off this channel.  The simplest is to run:

    echo "%default-channels" > /tmp/chan.scm
    guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 \
          -C /tmp/chan.scm \
         -- package -p guix/new/.guix-profile -i python3 python-umap-learn

Hope that helps.


> [hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- package -p guix/new/.guix-profile -i python3 python-umap-learn

Why this commit?  'python-umap-learn' should be broken

> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
> Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
> Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
> Computing Guix derivation for 'x86_64-linux'...  WARNING: (guix build emacs-build-system): imported module (guix build utils) overrides core binding `delete'                                                |
> The following derivation will be built:
>    /gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv
> The following profile hook will be built:
>    /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv
> building package cache...
> /builder for `/gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv' failed to produce output path `/gnu/store/9vpcvp00acz4lvglfs1k69a4i05p5hbw-guix-package-cache'
> build of /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv failed
> View build log at '/gnu/var/log/guix/drvs/ya/j4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv'.
> cannot build derivation `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv': 1 dependencies couldn't be built

I do not know why it returns an error here.  What happens if you run:

  guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- help

?

All the best,
simon


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [ext] Re: failed to install the python-umap-learn package
  2020-09-30 12:11         ` zimoun
@ 2020-09-30 13:08           ` Hong.Li
  2020-09-30 13:54             ` zimoun
  0 siblings, 1 reply; 9+ messages in thread
From: Hong.Li @ 2020-09-30 13:08 UTC (permalink / raw)
  To: zimoun; +Cc: Ludovic Courtès, help-guix

Dear Simon,


Now the error is coming from python-scikit-learn-0.20.4.

Please find my answers and comments inline.


best regards,

Hong


________________________________
From: zimoun <zimon.toutoune@gmail.com>
Sent: 30 September 2020 14:11
To: Li, Hong
Cc: Ludovic Courtès; help-guix@gnu.org
Subject: Re: [ext] Re: failed to install the python-umap-learn package

On Wed, 30 Sep 2020 at 13:41, Hong.Li@mdc-berlin.de
<Hong.Li@mdc-berlin.de> wrote:

> $ guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 -- package -p guix/new/.guix-profile -i python3 python-umap-learn
> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
> Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
> Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...

[...]

> |builder for `/gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv' failed to produce output path `/gnu/store/gg8fs00h7vqx29icijxpd7w99z1p8lmf-guix-past'
> build of /gnu/store/jvffmvaz1rm0q11c57wmsp08h0slj9ym-guix-past.drv failed

The error comes from the channel 'guix-past'.  Well, I will investigate later...
Therefore, you have to turn off this channel.  The simplest is to run:

    echo "%default-channels" > /tmp/chan.scm
    guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 \
          -C /tmp/chan.scm \
         -- package -p guix/new/.guix-profile -i python3 python-umap-learn

Hope that helps.

[hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 -C /tmp/chan.scm  -- package -p guix/new/.guix-profile -i  python-umap-learn
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
guile: warning: failed to install locale
guix package: warning: Consider running 'guix pull' followed by
'guix package -u' to get up-to-date packages and security updates.

updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
The following package will be installed:
   python-umap-learn    0.3.10  /gnu/store/yg68y32h1fhngn8mqpfyc8lzfg25df48-python-umap-learn-0.3.10

substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
building /gnu/store/fzcysynrdkz52f077c4hbrdmpwkb01nx-python-numba-0.46.0.drv...
updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
building /gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv...
100% 'check' [###############################################################################################################################################################################################]builder for `/gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv' failed with exit code 1
build of /gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv failed
View build log at '/gnu/var/log/guix/drvs/vx/f3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv'.
guix package: error: build of `/gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv' failed

> [hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- package -p guix/new/.guix-profile -i python3 python-umap-learn

Why this commit?  'python-umap-learn' should be broken

This commit is the most recent succeeded build from 2020-04-18 19:24:20, you also suggested this commit before.

> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
> Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
> Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
> Computing Guix derivation for 'x86_64-linux'...  WARNING: (guix build emacs-build-system): imported module (guix build utils) overrides core binding `delete'                                                |
> The following derivation will be built:
>    /gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv
> The following profile hook will be built:
>    /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv
> building package cache...
> /builder for `/gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv' failed to produce output path `/gnu/store/9vpcvp00acz4lvglfs1k69a4i05p5hbw-guix-package-cache'
> build of /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv failed
> View build log at '/gnu/var/log/guix/drvs/ya/j4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv'.
> cannot build derivation `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv': 1 dependencies couldn't be built

I do not know why it returns an error here.  What happens if you run:

  guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- help

?

[hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- help
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
WARNING: (guix build emacs-build-system): imported module (guix build utils) overrides core binding `delete'
Computing Guix derivation for 'x86_64-linux'... \
The following derivation will be built:
   /gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv
The following profile hook will be built:
   /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv
building package cache...
/builder for `/gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv' failed to produce output path `/gnu/store/9vpcvp00acz4lvglfs1k69a4i05p5hbw-guix-package-cache'
build of /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv failed
View build log at '/gnu/var/log/guix/drvs/ya/j4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv'.
cannot build derivation `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv': 1 dependencies couldn't be built
guix time-machine: error: build of `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv' failed


All the best,
simon

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [ext] Re: failed to install the python-umap-learn package
  2020-09-30 13:08           ` Hong.Li
@ 2020-09-30 13:54             ` zimoun
  2020-09-30 20:47               ` Hong.Li
  0 siblings, 1 reply; 9+ messages in thread
From: zimoun @ 2020-09-30 13:54 UTC (permalink / raw)
  To: Hong.Li; +Cc: Ludovic Courtès, help-guix

Dear,

Please run:

   echo "%default-channels" > /tmp/chan.scm
   guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 \
          -C /tmp/chan.scm \
          -- package -i pyhton-umap-learn

This will fix your initial issue, I guess.



> [hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 -C /tmp/chan.scm  -- package -p guix/new/.guix-profile -i  python-umap-learn

I have not checked in your previous email, but it is the wrong commit.

> build of /gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv failed
> View build log at '/gnu/var/log/guix/drvs/vx/f3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv'.
> guix package: error: build of `/gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv' failed

It could be expected since the package 'python-scikit-learn' is broken:

https://data.guix.gnu.org/repository/1/branch/master/package/python-scikit-learn/output-history

especially for the commit you are trying (which is not the one you
need for the working 'python-umap-learn' package).


> Why this commit?  'python-umap-learn' should be broken
>
> This commit is the most recent succeeded build from 2020-04-18 19:24:20, you also suggested this commit before.

Ah yeah but then what was the previous commit
cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523? :-)


> [hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- help
> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
> Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
> Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
[...]
> /builder for `/gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv' failed to produce output path `/gnu/store/9vpcvp00acz4lvglfs1k69a4i05p5hbw-guix-package-cache'
> build of /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv failed
> View build log at '/gnu/var/log/guix/drvs/ya/j4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv'.
> cannot build derivation `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv': 1 dependencies couldn't be built
> guix time-machine: error: build of `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv' failed

This comes from the extra 3 channels you added.  If you remove them
(see above), then it should work, I guess.


Hope that helps,
simon


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: [ext] Re: failed to install the python-umap-learn package
  2020-09-30 13:54             ` zimoun
@ 2020-09-30 20:47               ` Hong.Li
  0 siblings, 0 replies; 9+ messages in thread
From: Hong.Li @ 2020-09-30 20:47 UTC (permalink / raw)
  To: zimoun; +Cc: Ludovic Courtès, help-guix

Dear Simon,


Thank you so much, the build was successful using:

    guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 \

                      -C /tmp/chan.scm \

                      -- package -p .guix-profile -i python-umap-learn



best regards,

Hong


________________________________
From: zimoun <zimon.toutoune@gmail.com>
Sent: 30 September 2020 15:54
To: Li, Hong
Cc: Ludovic Courtès; help-guix@gnu.org
Subject: Re: [ext] Re: failed to install the python-umap-learn package

Dear,

Please run:

   echo "%default-channels" > /tmp/chan.scm
   guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 \
          -C /tmp/chan.scm \
          -- package -i pyhton-umap-learn

This will fix your initial issue, I guess.

Exactly, this works in the end.

> [hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523 -C /tmp/chan.scm  -- package -p guix/new/.guix-profile -i  python-umap-learn

I have not checked in your previous email, but it is the wrong commit.

I tried all succeeded commits, and this commit is the first succeeded one from 2020-01-07 03:09:35
https://data.guix.gnu.org/repository/1/branch/master/package/python-umap-learn/output-history


> build of /gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv failed
> View build log at '/gnu/var/log/guix/drvs/vx/f3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv'.
> guix package: error: build of `/gnu/store/vxf3qwhkahgzfhwp6c63vm8vky9fj5bl-python-scikit-learn-0.20.4.drv' failed

It could be expected since the package 'python-scikit-learn' is broken:

https://data.guix.gnu.org/repository/1/branch/master/package/python-scikit-learn/output-history

especially for the commit you are trying (which is not the one you
need for the working 'python-umap-learn' package).


> Why this commit?  'python-umap-learn' should be broken
>
> This commit is the most recent succeeded build from 2020-04-18 19:24:20, you also suggested this commit before.

Ah yeah but then what was the previous commit
cd5406effa34fa5cfda7eb7bbd2ccaf5201cf523? :-)


> [hli@max-login3.mdc-berlin.net:~] $ guix time-machine --commit=cac674d99dc4a332e6210c57ec7f1b8164f66642 -- help
> Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
> Updating channel 'guix-bimsb' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb.git'...
> Updating channel 'guix-past' from Git repository at 'https://gitlab.inria.fr/guix-hpc/guix-past'...
> Updating channel 'guix-bimsb-nonfree' from Git repository at 'https://github.com/BIMSBbioinfo/guix-bimsb-nonfree.git'...
[...]
> /builder for `/gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv' failed to produce output path `/gnu/store/9vpcvp00acz4lvglfs1k69a4i05p5hbw-guix-package-cache'
> build of /gnu/store/yaj4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv failed
> View build log at '/gnu/var/log/guix/drvs/ya/j4m68r6l9jhdb767psz79fm84hb6x6-guix-package-cache.drv'.
> cannot build derivation `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv': 1 dependencies couldn't be built
> guix time-machine: error: build of `/gnu/store/zz2557r32hsq2ksa53ix4ygaskkrs2qi-profile.drv' failed

This comes from the extra 3 channels you added.  If you remove them
(see above), then it should work, I guess.


Hope that helps,
simon

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2020-09-30 21:04 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-21 11:23 failed to install the python-umap-learn package Hong.Li
2020-09-29 14:09 ` Ludovic Courtès
2020-09-29 14:56   ` zimoun
2020-09-30  8:56     ` Ludovic Courtès
2020-09-30 11:41       ` [ext] " Hong.Li
2020-09-30 12:11         ` zimoun
2020-09-30 13:08           ` Hong.Li
2020-09-30 13:54             ` zimoun
2020-09-30 20:47               ` Hong.Li

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git