unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* Trouble booting Guix System
@ 2020-11-04  6:21 Tom Willemse
  2020-11-05 14:36 ` Joshua Branson
  0 siblings, 1 reply; 5+ messages in thread
From: Tom Willemse @ 2020-11-04  6:21 UTC (permalink / raw)
  To: help-guix

[-- Attachment #1: Type: text/plain, Size: 539 bytes --]

Hey everyone,

I just installed Guix System on my PC and now I'm having some trouble
getting it to boot. When I start up and after I go through grub I just
get a few seemingly innocuous messages and then it just stops.

I've tried both the stable and latest installation images with the same
effect for both. I installed with encryption using the whole disk.

I've attached a screenshot of everything I see when I try to boot.

Any help in figuring out what's going wrong would be greatly appreciated
:) Thanks in advance!


Cheers,

Tom


[-- Attachment #2: Screenshot --]
[-- Type: image/jpeg, Size: 3737414 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Trouble booting Guix System
  2020-11-04  6:21 Trouble booting Guix System Tom Willemse
@ 2020-11-05 14:36 ` Joshua Branson
  2020-11-09 17:48   ` Tom Willemse
  2020-11-10  6:45   ` Tom Willemse
  0 siblings, 2 replies; 5+ messages in thread
From: Joshua Branson @ 2020-11-05 14:36 UTC (permalink / raw)
  To: Tom Willemse; +Cc: help-guix


I actually couldn't get encryption to work for my on my librebooted
machine.  I re-installed with just 1 unencrypted ext4 machine, and now I
can use guix system.  Not really a fix I know, but you might give that a try.

-- 
Joshua Branson
Sent from Emacs and Gnus
https://gnucode.me
https://video.hardlimit.com/accounts/joshua_branson/video-channels
"You can have whatever you want, as long as you help enough other people get what they want." - Zig Ziglar


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Trouble booting Guix System
  2020-11-05 14:36 ` Joshua Branson
@ 2020-11-09 17:48   ` Tom Willemse
  2020-11-10  6:45   ` Tom Willemse
  1 sibling, 0 replies; 5+ messages in thread
From: Tom Willemse @ 2020-11-09 17:48 UTC (permalink / raw)
  To: Joshua Branson; +Cc: help-guix

Hey Joshua,

Joshua Branson <jbranso@dismail.de> writes:

> I actually couldn't get encryption to work for my on my librebooted
> machine.  I re-installed with just 1 unencrypted ext4 machine, and now I
> can use guix system.  Not really a fix I know, but you might give that a try.

Thanks! I guess I'll have to forego encrypting my root drive for now.


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Trouble booting Guix System
  2020-11-05 14:36 ` Joshua Branson
  2020-11-09 17:48   ` Tom Willemse
@ 2020-11-10  6:45   ` Tom Willemse
  2020-11-10 21:26     ` Joshua Branson
  1 sibling, 1 reply; 5+ messages in thread
From: Tom Willemse @ 2020-11-10  6:45 UTC (permalink / raw)
  To: Joshua Branson; +Cc: help-guix

Joshua Branson <jbranso@dismail.de> writes:

> I actually couldn't get encryption to work for my on my librebooted
> machine.  I re-installed with just 1 unencrypted ext4 machine, and now I
> can use guix system.  Not really a fix I know, but you might give that a try.

I've tried installing without encryption, but I still get the same
behavior. I did notice these lines in my messages log, I'm guessing this
certainly isn't good. I don't have any experience with the linux-libre
kernel, but I'm guessing it's a problem with my video card needing
non-free firmware?

amdgpu: mc: Failed to load firmware "/*(DEBLOBBED)*/"
[drm:gmc_v8_0_sw_init [amdgpu]] *ERROR* Failed to load mc firmware!
[drm:amdgpu_device_init [amdgpu]] *ERROR* sw_init of IP block <gmc_v8_0> failed -2
amdgpu 0000:03:00.0: amdgpu: amdgpu_device_ip_init failed
amdgpu 0000:03:00.0: amdgpu: Fatal error during GPU init
[drm] amdgpu: finishing device.
amdgpu: probe of 0000:03:00.0 failed with error -2


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: Trouble booting Guix System
  2020-11-10  6:45   ` Tom Willemse
@ 2020-11-10 21:26     ` Joshua Branson
  0 siblings, 0 replies; 5+ messages in thread
From: Joshua Branson @ 2020-11-10 21:26 UTC (permalink / raw)
  To: Tom Willemse; +Cc: help-guix


Yeah, any AMD graphics card is going to have a hard time.   Without the
firmware files, those graphics cards are nearly useless.  There's some
really old nvidia cards that work fairly well.  There's probably a
kernel parameter you could pass that would disable the AMD graphics
driver from loading.

The Intel CPU graphics driver is one of the better ones for running
libre graphics software.  :)

--
Joshua Branson
Sent from Emacs and Gnus
https://gnucode.me
https://video.hardlimit.com/accounts/joshua_branson/video-channels
"You can have whatever you want, as long as you help enough other people get what they want." - Zig Ziglar


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-11-10 21:26 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-04  6:21 Trouble booting Guix System Tom Willemse
2020-11-05 14:36 ` Joshua Branson
2020-11-09 17:48   ` Tom Willemse
2020-11-10  6:45   ` Tom Willemse
2020-11-10 21:26     ` Joshua Branson

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git