unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* Re: stumpwm on guix - "sb-cltl2" issues
@ 2022-05-03 14:35 Wil deBeest
  2022-05-06 14:44 ` Katherine Cox-Buday
  0 siblings, 1 reply; 6+ messages in thread
From: Wil deBeest @ 2022-05-03 14:35 UTC (permalink / raw)
  To: Benjamin Slade; +Cc: help-guix


Wil deBeest <bovid-19@4tii.de> writes:

> 
> Benjamin Slade <beoram@gmail.com> writes:
> 
>> I'm trying to run my long-standing stumpwm init.lisp on a recent Guix
>> install, using the packaged stumpwm, however when it launches, it
>> fails to process the init.lisp and gives me an "Don't know how to
>> REQUIRE sb-cltl2." error.
>> I've set the SBCL_HOME variable both in .xprofile and in the init.lisp
>> itself [via `(sb-posix:putenv
>> "SBCL_HOME=/run/current-system/profile/lib/sbcl/")' ], but this
>> doesn't seem to help.
>> Is there a good way around this? (On my other system I just compile
>> stumpwm from source and install; I don't know if that makes a
>> difference here.)
>> —Ben
> 
> I used to have the same problem, but I don't remember what fixed it.
> 
> SBCL_HOME isn't set at all, I only have `exec /home/bovid-19/.guix-profile/bin/stumpwm' in my
> `~/.xinitrc', and my stumpwm init file starts like this:
> 
> (in-package :stumpwm)
> (require 'sb-cltl2)
> 
> 
> I'm not sure what else I can look for.

I have probably found the solution: in addition to stumpwm, I also have
`cl-trivial-cltl2' and `cl-asdf' (and sbcl) in my system configuration.
If you can confirm that those two packages are what was missing, we
should add them to the stumpwm package as inputs.


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: stumpwm on guix - "sb-cltl2" issues
  2022-05-03 14:35 stumpwm on guix - "sb-cltl2" issues Wil deBeest
@ 2022-05-06 14:44 ` Katherine Cox-Buday
  2022-05-13 19:09   ` Benjamin Slade
  0 siblings, 1 reply; 6+ messages in thread
From: Katherine Cox-Buday @ 2022-05-06 14:44 UTC (permalink / raw)
  To: Wil deBeest; +Cc: Benjamin Slade, help-guix

Wil deBeest <bovid-19@4tii.de> writes:

> 
> Wil deBeest <bovid-19@4tii.de> writes:
>
>> 
>> Benjamin Slade <beoram@gmail.com> writes:
>> 
>>> I'm trying to run my long-standing stumpwm init.lisp on a recent Guix
>>> install, using the packaged stumpwm, however when it launches, it
>>> fails to process the init.lisp and gives me an "Don't know how to
>>> REQUIRE sb-cltl2." error.
>>> I've set the SBCL_HOME variable both in .xprofile and in the init.lisp
>>> itself [via `(sb-posix:putenv
>>> "SBCL_HOME=/run/current-system/profile/lib/sbcl/")' ], but this
>>> doesn't seem to help.
>>> Is there a good way around this? (On my other system I just compile
>>> stumpwm from source and install; I don't know if that makes a
>>> difference here.)
>>> —Ben
>> 
>> I used to have the same problem, but I don't remember what fixed it.
>> 
>> SBCL_HOME isn't set at all, I only have `exec /home/bovid-19/.guix-profile/bin/stumpwm' in my
>> `~/.xinitrc', and my stumpwm init file starts like this:
>> 
>> (in-package :stumpwm)
>> (require 'sb-cltl2)
>> 
>> 
>> I'm not sure what else I can look for.
>
> I have probably found the solution: in addition to stumpwm, I also have
> `cl-trivial-cltl2' and `cl-asdf' (and sbcl) in my system configuration.
> If you can confirm that those two packages are what was missing, we
> should add them to the stumpwm package as inputs.

I think I have this problem? But like Benjamin, it has also been a very long time since I addressed it. In my profiles, I include:

                 "stumpwm"
                 "sbcl-stumpwm-kbd-layouts"
                 ;; net module has this unacknowledged dependency
                 "sbcl-cl-ppcre"
                 "sbcl-stumpwm-net"
                 "sbcl-stumpwm-pass"
                 "sbcl-stumpwm-stumptray"
                 "sbcl-stumpwm-swm-gaps"
                 "sbcl-stumpwm-ttf-fonts"

and I don't seem to have any problem. I start it from lightdm, and I don't think that's doing anything special.

Probably in my case some of the modules are including the missing dependencies.

I hope that helps somehow.

-- 
Katherine


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: stumpwm on guix - "sb-cltl2" issues
  2022-05-06 14:44 ` Katherine Cox-Buday
@ 2022-05-13 19:09   ` Benjamin Slade
  0 siblings, 0 replies; 6+ messages in thread
From: Benjamin Slade @ 2022-05-13 19:09 UTC (permalink / raw)
  To: Katherine Cox-Buday; +Cc: Wil deBeest, help-guix

On Fri, 06 May 2022 08:44:46 -0600 (1 week, 4 hours, 25 minutes ago), Katherine Cox-Buday <cox.katherine.e@gmail.com> wrote:

> Wil deBeest <bovid-19@4tii.de> writes:

> > 
> > Wil deBeest <bovid-19@4tii.de> writes:
> >
> >> 
> >> Benjamin Slade <beoram@gmail.com> writes:
> >> 
> >>> I'm trying to run my long-standing stumpwm init.lisp on a recent Guix
> >>> install, using the packaged stumpwm, however when it launches, it
> >>> fails to process the init.lisp and gives me an "Don't know how to
> >>> REQUIRE sb-cltl2." error.
> >>> I've set the SBCL_HOME variable both in .xprofile and in the init.lisp
> >>> itself [via `(sb-posix:putenv
> >>> "SBCL_HOME=/run/current-system/profile/lib/sbcl/")' ], but this
> >>> doesn't seem to help.
> >>> Is there a good way around this? (On my other system I just compile
> >>> stumpwm from source and install; I don't know if that makes a
> >>> difference here.)
> >>> —Ben
> >> 
> >> I used to have the same problem, but I don't remember what fixed it.
> >> 
> >> SBCL_HOME isn't set at all, I only have `exec
> >> /home/bovid-19/.guix-profile/bin/stumpwm' in my
> >> `~/.xinitrc', and my stumpwm init file starts like this:
> >> 
> >> (in-package :stumpwm)
> >> (require 'sb-cltl2)
> >> 
> >> 
> >> I'm not sure what else I can look for.
> >
> > I have probably found the solution: in addition to stumpwm, I also have
> > `cl-trivial-cltl2' and `cl-asdf' (and sbcl) in my system configuration.
> > If you can confirm that those two packages are what was missing, we
> > should add them to the stumpwm package as inputs.

> I think I have this problem? But like Benjamin, it has also been a very long
> time since I addressed it. In my profiles, I include:

>                  "stumpwm"
>                  "sbcl-stumpwm-kbd-layouts"
>                  ;; net module has this unacknowledged dependency
>                  "sbcl-cl-ppcre"
>                  "sbcl-stumpwm-net"
>                  "sbcl-stumpwm-pass"
>                  "sbcl-stumpwm-stumptray"
>                  "sbcl-stumpwm-swm-gaps"
>                  "sbcl-stumpwm-ttf-fonts"

> and I don't seem to have any problem. I start it from lightdm, and I don't think
> that's doing anything special.

> Probably in my case some of the modules are including the missing dependencies.

> I hope that helps somehow.

> -- 
> Katherine

Thanks! I'll try adding these packages and see if that helps.

best,
 —Ben

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: stumpwm on guix - "sb-cltl2" issues
@ 2022-05-03 14:18 Wil deBeest
  0 siblings, 0 replies; 6+ messages in thread
From: Wil deBeest @ 2022-05-03 14:18 UTC (permalink / raw)
  To: Benjamin Slade; +Cc: help-guix


Benjamin Slade <beoram@gmail.com> writes:

> I'm trying to run my long-standing stumpwm init.lisp on a recent Guix
> install, using the packaged stumpwm, however when it launches, it
> fails to process the init.lisp and gives me an "Don't know how to
> REQUIRE sb-cltl2." error.
> 
> I've set the SBCL_HOME variable both in .xprofile and in the init.lisp
> itself [via `(sb-posix:putenv
> "SBCL_HOME=/run/current-system/profile/lib/sbcl/")' ], but this
> doesn't seem to help.
> 
> Is there a good way around this? (On my other system I just compile
> stumpwm from source and install; I don't know if that makes a
> difference here.)
> 
>  —Ben

I used to have the same problem, but I don't remember what fixed it.

SBCL_HOME isn't set at all, I only have `exec /home/bovid-19/.guix-profile/bin/stumpwm' in my
`~/.xinitrc', and my stumpwm init file starts like this:

(in-package :stumpwm)
(require 'sb-cltl2)


I'm not sure what else I can look for.


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: stumpwm on guix - "sb-cltl2" issues
  2022-04-16  0:29 Benjamin Slade
@ 2022-04-16 17:40 ` Guillaume Le Vaillant
  0 siblings, 0 replies; 6+ messages in thread
From: Guillaume Le Vaillant @ 2022-04-16 17:40 UTC (permalink / raw)
  To: Benjamin Slade; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 1158 bytes --]

Benjamin Slade <beoram@gmail.com> skribis:

> I'm trying to run my long-standing stumpwm init.lisp on a recent Guix install,
> using the packaged stumpwm, however when it launches, it fails to process the
> init.lisp and gives me an "Don't know how to REQUIRE sb-cltl2." error.
>
> I've set the SBCL_HOME variable both in .xprofile and in the init.lisp itself [via `(sb-posix:putenv "SBCL_HOME=/run/current-system/profile/lib/sbcl/")' ], but this doesn't seem to help.
>
> Is there a good way around this? (On my other system I just compile stumpwm from source and install; I don't know if that makes a difference here.)
>
>  —Ben

Instead of setting SBCL_HOME, could you try adding something like
'(push "/path/to/lib/sbcl/contrib/" asdf:*central-registry*)'
at the beginning of your "init.lisp" file?

As stumpwm doesn't use the sb-cltl2 contrib, it is not included in the
stumpwm compiled binary. But telling ASDF where it can find it and then
using '(asdf:load-system :sb-cltl2)' or '(require :sb-cltl2)' should
work.
If it doesn't, you could also try loading it directly with
'(load "/path/to/lib/sbcl/contrib/sb-cltl2.fasl")'.

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 6+ messages in thread

* stumpwm on guix - "sb-cltl2" issues
@ 2022-04-16  0:29 Benjamin Slade
  2022-04-16 17:40 ` Guillaume Le Vaillant
  0 siblings, 1 reply; 6+ messages in thread
From: Benjamin Slade @ 2022-04-16  0:29 UTC (permalink / raw)
  To: help-guix

I'm trying to run my long-standing stumpwm init.lisp on a recent Guix install, using the packaged stumpwm, however when it launches, it fails to process the init.lisp and gives me an "Don't know how to REQUIRE sb-cltl2." error.

I've set the SBCL_HOME variable both in .xprofile and in the init.lisp itself [via `(sb-posix:putenv "SBCL_HOME=/run/current-system/profile/lib/sbcl/")' ], but this doesn't seem to help.

Is there a good way around this? (On my other system I just compile stumpwm from source and install; I don't know if that makes a difference here.)

 —Ben

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2022-05-13 19:11 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-03 14:35 stumpwm on guix - "sb-cltl2" issues Wil deBeest
2022-05-06 14:44 ` Katherine Cox-Buday
2022-05-13 19:09   ` Benjamin Slade
  -- strict thread matches above, loose matches on Subject: below --
2022-05-03 14:18 Wil deBeest
2022-04-16  0:29 Benjamin Slade
2022-04-16 17:40 ` Guillaume Le Vaillant

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).