unofficial mirror of help-guix@gnu.org 
 help / color / Atom feed
* Failed to install ungoogled-chromium
@ 2020-06-13 14:17 arkhan
  2020-06-14  0:10 ` Dmitry Alexandrov
  2020-06-14  3:24 ` Ricardo Wurmus
  0 siblings, 2 replies; 3+ messages in thread
From: arkhan @ 2020-06-13 14:17 UTC (permalink / raw)
  To: help-guix

Cheers,

I am trying to install ungoogled-chromium, but when I start applying the patches it gives the following error:

https://bin.disroot.org/?a5a35c2c0b751c30#AdWvRzuXMWfWe5cYN21CAcnXaR9iPw1BhjxftDqw3xtx

Thanks for the help

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Failed to install ungoogled-chromium
  2020-06-13 14:17 Failed to install ungoogled-chromium arkhan
@ 2020-06-14  0:10 ` Dmitry Alexandrov
  2020-06-14  3:24 ` Ricardo Wurmus
  1 sibling, 0 replies; 3+ messages in thread
From: Dmitry Alexandrov @ 2020-06-14  0:10 UTC (permalink / raw)
  To: arkhan; +Cc: help-guix


[-- Attachment #1.1: Type: text/plain, Size: 271 bytes --]

arkhan@disroot.org wrote:
> https://bin.disroot.org/?a5a35c2c0b751c30#AdWvRzuXMWfWe5cYN21CAcnXaR9iPw1BhjxftDqw3xtx

All it says is:
| JavaScript is required for PrivateBin to work. Sorry for the inconvenience.

In any case, this is not IRC.  Pastebins have no use here.


[-- Attachment #1.2: Type: text/verbatim, Size: 3377 bytes --]

patch-shebang: ./v8/tools/unittests/v8_presubmit_test.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
patch-shebang: ./v8/tools/update-object-macros-undef.py: warning: no binary for interpreter `python3' found in $PATH
patch-shebang: ./v8/tools/v8_presubmit.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
patch-shebang: ./v8/tools/wasm-compilation-hints/inject-compilation-hints.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
patch-shebang: ./v8/tools/wasm-compilation-hints/wasm-objdump-compilation-hints.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
patch-shebang: ./v8/tools/wasm-compilation-hints/wasm.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
patch-shebang: ./v8/tools/wasm/update-wasm-fuzzers.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./v8/tools/wasm/update-wasm-spec-tests.sh: changing `/bin/bash' to `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/bash'
patch-shebang: ./weblayer/tools/run_weblayer_shell.py: changing `/usr/bin/env python' to `/gnu/store/ln0jd0k32xbr2jyha1sdaynllkazgmsi-python2-2.7.17/bin/python'
phase `patch-source-shebangs' succeeded after 30.9 seconds
starting phase `prepare-build-environment'
Backtrace:
          14 (primitive-load "/gnu/store/fckx2i51pixnh5dn6dl1rclafa2…")
In ice-9/eval.scm:
   191:35 13 (_ _)
In guix/build/gnu-build-system.scm:
    838:2 12 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
  1736:10 11 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
   857:16 10 (every1 #<procedure 7ffff286e0e0 at guix/build/gnu-bui…> …)
In guix/build/gnu-build-system.scm:
   847:30  9 (_ _)
In ice-9/eval.scm:
    619:8  8 (_ #(#(#<directory (guile-user) 7ffff3bb5f00>) (# # …)))
In ice-9/boot-9.scm:
  1736:10  7 (with-exception-handler _ _ #:unwind? _ # _)
In ice-9/ports.scm:
   445:17  6 (call-with-input-file _ _ #:binary _ #:encoding _ # _)
In guix/build/utils.scm:
   741:26  5 (_ _)
   767:26  4 (_ #<input: third_party/devtools-frontend/src/scripts/…> …)
In srfi/srfi-1.scm:
   460:18  3 (fold #<procedure 7ffff31ed040 at guix/build/utils.scm…> …)
In unknown file:
           2 (string-concatenate-reverse ("'\n" #f "    return '") # #)
In ice-9/boot-9.scm:
  1669:16  1 (raise-exception _ #:continuable? _)
  1669:16  0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
In procedure string-append: Wrong type (expecting string): #f
builder for `/gnu/store/hr5qklnqbgbp2in7l91r873f8xq44plf-ungoogled-chromium-81.0.4044.138-0.c2a89fb.drv' failed with exit code 1
la construcción de /gnu/store/hr5qklnqbgbp2in7l91r873f8xq44plf-ungoogled-chromium-81.0.4044.138-0.c2a89fb.drv falló
Muestra el registro de construcción en '/var/log/guix/drvs/hr/5qklnqbgbp2in7l91r873f8xq44plf-ungoogled-chromium-81.0.4044.138-0.c2a89fb.drv.bz2'.
guix install: error: build of `/gnu/store/hr5qklnqbgbp2in7l91r873f8xq44plf-ungoogled-chromium-81.0.4044.138-0.c2a89fb.drv' failed

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: Failed to install ungoogled-chromium
  2020-06-13 14:17 Failed to install ungoogled-chromium arkhan
  2020-06-14  0:10 ` Dmitry Alexandrov
@ 2020-06-14  3:24 ` Ricardo Wurmus
  1 sibling, 0 replies; 3+ messages in thread
From: Ricardo Wurmus @ 2020-06-14  3:24 UTC (permalink / raw)
  To: arkhan; +Cc: help-guix


arkhan@disroot.org writes:

> I am trying to install ungoogled-chromium, but when I start applying
> the patches it gives the following error:

As of commit ea7882b2e397633eccf2ec7205404bec30f74312 I don’t see any
problems in building ungoogled-chromium.  I’m getting a substitute from ci.guix.gnu.org. 

-- 
Ricardo


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-13 14:17 Failed to install ungoogled-chromium arkhan
2020-06-14  0:10 ` Dmitry Alexandrov
2020-06-14  3:24 ` Ricardo Wurmus

unofficial mirror of help-guix@gnu.org 

Archives are clonable:
	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors

Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git