unofficial mirror of help-guix@gnu.org 
 help / color / mirror / Atom feed
* Freenode sasl authentication error rcirc
@ 2021-04-15  0:06 Bone Baboon
  2021-04-15  0:08 ` Frosku
  2021-04-15  0:17 ` Tobias Geerinckx-Rice
  0 siblings, 2 replies; 9+ messages in thread
From: Bone Baboon @ 2021-04-15  0:06 UTC (permalink / raw)
  To: help-guix

I am trying to connect to Freenode.  This was working fine but now I am
receiving this error message:

```
*** Notice -- You need to authenticate via sasl to use this server
!!! Closing link: <gateway-information>
    (SASL access only)
!!! freenode: connection broken by remote peer (closed)
```

The IRC client I am using is rcirc an Emacs IRC client.  I have not
changed my rcirc configuration that was working.

I am able to sign into Freenode without any trouble using Freenode's web
irc client.

I have tried adding the `gnutls`, `gsasl` and `cyrus-sasl` packages to
my system configuration and reconfiguring.  These packages do not fix
this problem.

The Emacs version is `27.2`.


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-15  0:06 Freenode sasl authentication error rcirc Bone Baboon
@ 2021-04-15  0:08 ` Frosku
  2021-04-15  2:06   ` Bone Baboon
  2021-04-15  0:17 ` Tobias Geerinckx-Rice
  1 sibling, 1 reply; 9+ messages in thread
From: Frosku @ 2021-04-15  0:08 UTC (permalink / raw)
  To: Bone Baboon, help-guix

On Thu Apr 15, 2021 at 1:06 AM BST, Bone Baboon wrote:
> I am trying to connect to Freenode. This was working fine but now I am
> receiving this error message:
>
> ```
> *** Notice -- You need to authenticate via sasl to use this server
> !!! Closing link: <gateway-information>
> (SASL access only)
> !!! freenode: connection broken by remote peer (closed)
> ```
>
> The IRC client I am using is rcirc an Emacs IRC client. I have not
> changed my rcirc configuration that was working.
>
> I am able to sign into Freenode without any trouble using Freenode's web
> irc client.
>
> I have tried adding the `gnutls`, `gsasl` and `cyrus-sasl` packages to
> my system configuration and reconfiguring. These packages do not fix
> this problem.
>
> The Emacs version is `27.2`.

Are you using tor? Because only certain forms of SASL authentication are
supported on tor.

https://freenode.net/news/tor-online

>>= %frosku = { os => 'gnu+linux', editor => 'emacs', coffee => 1 } =<<


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-15  0:06 Freenode sasl authentication error rcirc Bone Baboon
  2021-04-15  0:08 ` Frosku
@ 2021-04-15  0:17 ` Tobias Geerinckx-Rice
  2021-04-15  2:02   ` Bone Baboon
  1 sibling, 1 reply; 9+ messages in thread
From: Tobias Geerinckx-Rice @ 2021-04-15  0:17 UTC (permalink / raw)
  To: Bone Baboon; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 425 bytes --]

Bone Baboon writes:
> I am trying to connect to Freenode.  This was working fine but 
> now I am
> receiving this error message:
>
> ```
> *** Notice -- You need to authenticate via sasl to use this 
> server

Which server?  Would it by any chance be zettel., meaning that 
you're using Tor?  IIRC SASL authentication has always been 
mandatory there.

If not, I suggest asking Freenode for help first.

Kind regards,

T G-R

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-15  0:17 ` Tobias Geerinckx-Rice
@ 2021-04-15  2:02   ` Bone Baboon
  2021-04-16  1:26     ` Tobias Geerinckx-Rice
  0 siblings, 1 reply; 9+ messages in thread
From: Bone Baboon @ 2021-04-15  2:02 UTC (permalink / raw)
  To: Tobias Geerinckx-Rice; +Cc: help-guix

Tobias Geerinckx-Rice writes:
> Which server?  Would it by any chance be zettel., meaning that 
> you're using Tor?  IIRC SASL authentication has always been 
> mandatory there.

I am not using Tor.

The servers have not been zettel.


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-15  0:08 ` Frosku
@ 2021-04-15  2:06   ` Bone Baboon
  0 siblings, 0 replies; 9+ messages in thread
From: Bone Baboon @ 2021-04-15  2:06 UTC (permalink / raw)
  To: Frosku; +Cc: help-guix

Frosku writes:
> Are you using tor? Because only certain forms of SASL authentication
> are supported on tor.
>
> https://freenode.net/news/tor-online

I am not using tor.



^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-15  2:02   ` Bone Baboon
@ 2021-04-16  1:26     ` Tobias Geerinckx-Rice
  2021-04-16  2:18       ` Frosku
  2021-04-21  0:17       ` Bone Baboon
  0 siblings, 2 replies; 9+ messages in thread
From: Tobias Geerinckx-Rice @ 2021-04-16  1:26 UTC (permalink / raw)
  To: Bone Baboon; +Cc: help-guix

[-- Attachment #1: Type: text/plain, Size: 2052 bytes --]

Bone Baboon writes:
> I am not using Tor.

This bugged me, so I asked in #freenode.

> I have not changed my rcirc configuration that was working.

But Freenode probably changed theirs:

<jess> nckx: some IP ranges are sasl required
<jess> high risk ranges
<nckx> jess: Aha.  That's probably it.
<nckx> It would explain the suddenly.
<jess> it's an unfortunate measure but sometimes necessary
<darsie> VPNs used for password guessing?
<jess> we did it to some domestic ranges fairly recently in 
response to significant abuse
<jess> darsie: some VPNs require SASL to make it more work to 
evade/abuse using them
<nckx> So my suggestions are: (1) move (2) change ISPs/use a 
bouncer (3) just set up SASL 
<nckx> Definitely not in that order.
<jess> nckx: does rcirc not support sasl?
<jess> sasl is very good
<nckx> That I don't know yet.
<nckx> SASL is sweet and tasty.
<jess> if it doesn't, aim me at someone to whom i can explain sasl
<nckx> I'll keep that in mind.

Unless you can obtain a new IP that isn't part of these ‘high-risk 
ranges’, or connect through a bouncer elsewhere, you *need* to set 
up SASL.  How that's done differs per client.

I briefly looked for rcirc how-tos but found none.  The manual[0] 
doesn't mention SASL at all.  I'm not going to spend time learning 
about rcirc, but every modern IRC client should support SASL.  If 
it doesn't, find a better one, or take one of the alternative 
actions above.

jess seems to be willing to explain SASL to the rcirc developers 
if needed.

> I have tried adding the `gnutls`, `gsasl` and `cyrus-sasl` 
> packages to
> my system configuration and reconfiguring.  These packages do 
> not fix
> this problem.

Simply installing some packages won't cut it.  You need to 
actually register your nickname and configure your client to log 
you in using SASL.

Some very general information: 
<https://freenode.net/kb/answer/sasl>

Kind regards,

T G-R

[0]: 
https://www.gnu.org/software/emacs/manual/html_mono/rcirc.html

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 247 bytes --]

^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-16  1:26     ` Tobias Geerinckx-Rice
@ 2021-04-16  2:18       ` Frosku
  2021-04-21  0:17       ` Bone Baboon
  1 sibling, 0 replies; 9+ messages in thread
From: Frosku @ 2021-04-16  2:18 UTC (permalink / raw)
  To: Tobias Geerinckx-Rice, Bone Baboon; +Cc: help-guix

On Fri Apr 16, 2021 at 2:26 AM BST, Tobias Geerinckx-Rice wrote:
> I briefly looked for rcirc how-tos but found none. The manual[0]
> doesn't mention SASL at all. I'm not going to spend time learning
> about rcirc, but every modern IRC client should support SASL. If
> it doesn't, find a better one, or take one of the alternative
> actions above.

If you don't want to switch client, another option would be to set
up a ZNC instance instance to handle SASL and then connect to your
ZNC instance from rcirc using standard user/pass.

https://wiki.znc.in/Sasl

>>= %frosku = { os => 'gnu+linux', editor => 'emacs', coffee => 1 } =<<


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-16  1:26     ` Tobias Geerinckx-Rice
  2021-04-16  2:18       ` Frosku
@ 2021-04-21  0:17       ` Bone Baboon
  2021-04-23 18:37         ` Bone Baboon
  1 sibling, 1 reply; 9+ messages in thread
From: Bone Baboon @ 2021-04-21  0:17 UTC (permalink / raw)
  To: Tobias Geerinckx-Rice; +Cc: help-guix

Thank you

Tobias Geerinckx-Rice writes:
> Unless you can obtain a new IP that isn't part of these ‘high-risk
> ranges’, or connect through a bouncer elsewhere, you *need* to set 
> up SASL.  How that's done differs per client.

> Simply installing some packages won't cut it.  You need to actually
> register your nickname and configure your client to log you in using
> SASL.

I have registered an account with Freenode.  I will try to setup an
Emacs IRC client with SASL or CertFP for that account.

Searching melpa.org and emacs-tw/awesome-emacs on GitHub for irc I find:

- ERC (included with Emacs)
-- on #erc I was told
--- ERC does not currently support SASL but it is being worked on
--- ERC will support CertFP when Emacs 28 is released

- rcirc (included with Emacs)
-- no matches when searching for SASL or CertFP in the rcirc info
   document 

> I briefly looked for rcirc how-tos but found none.  The manual[0]
> doesn't mention SASL at all. 

- Riece
-- Riece's documentation does not mention of SASL or CertFP

- Circe
-- Circe's readme shows support for SASL and CertFP

I asked on #freenode if CertFP would work as an alternative to SASL and was told that it would.

I am going to try to get Circe connecting to Freenode using SASL or CertFP.

What Emacs IRC client's are people able to successfully connect to Freenode with using SASL or CertFP?

Are there other Emacs IRC clients that I should look into?


^ permalink raw reply	[flat|nested] 9+ messages in thread

* Re: Freenode sasl authentication error rcirc
  2021-04-21  0:17       ` Bone Baboon
@ 2021-04-23 18:37         ` Bone Baboon
  0 siblings, 0 replies; 9+ messages in thread
From: Bone Baboon @ 2021-04-23 18:37 UTC (permalink / raw)
  To: Bone Baboon; +Cc: Tobias Geerinckx-Rice, help-guix

I am now able to connect to Freenode using Circe with SASL
authentication.

I received help from wasamasa in #emacs-circe and staff in #freenode to
debug an issue with Circe's SASL authentication.  A fix was pushed to
the Circe repository.

This logging variable was helpful during Circe debugging:
`(setq irc-debug-log t)` 

Here is the contents of my Circe configuration that is working for me:

```
(setq circe-network-options
      '(("Freenode"
         :tls t
         :nick "bone-baboon"
         :user "bone-baboon"
         :realname "bone-baboon"
         :sasl-username "bone-baboon"
         :sasl-password "<password>")))
```

The sasl-username and sasl-password are the username and password used
when registering an account with Freenode.

Bone Baboon writes:

> Thank you
>
> Tobias Geerinckx-Rice writes:
>> Unless you can obtain a new IP that isn't part of these ‘high-risk
>> ranges’, or connect through a bouncer elsewhere, you *need* to set 
>> up SASL.  How that's done differs per client.
>
>> Simply installing some packages won't cut it.  You need to actually
>> register your nickname and configure your client to log you in using
>> SASL.
>
> I have registered an account with Freenode.  I will try to setup an
> Emacs IRC client with SASL or CertFP for that account.
>
> Searching melpa.org and emacs-tw/awesome-emacs on GitHub for irc I find:
>
> - ERC (included with Emacs)
> -- on #erc I was told
> --- ERC does not currently support SASL but it is being worked on
> --- ERC will support CertFP when Emacs 28 is released
>
> - rcirc (included with Emacs)
> -- no matches when searching for SASL or CertFP in the rcirc info
>    document 
>
>> I briefly looked for rcirc how-tos but found none.  The manual[0]
>> doesn't mention SASL at all. 
>
> - Riece
> -- Riece's documentation does not mention of SASL or CertFP
>
> - Circe
> -- Circe's readme shows support for SASL and CertFP
>
> I asked on #freenode if CertFP would work as an alternative to SASL and was told that it would.
>
> I am going to try to get Circe connecting to Freenode using SASL or CertFP.
>
> What Emacs IRC client's are people able to successfully connect to Freenode with using SASL or CertFP?
>
> Are there other Emacs IRC clients that I should look into?



^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2021-04-23 18:41 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-15  0:06 Freenode sasl authentication error rcirc Bone Baboon
2021-04-15  0:08 ` Frosku
2021-04-15  2:06   ` Bone Baboon
2021-04-15  0:17 ` Tobias Geerinckx-Rice
2021-04-15  2:02   ` Bone Baboon
2021-04-16  1:26     ` Tobias Geerinckx-Rice
2021-04-16  2:18       ` Frosku
2021-04-21  0:17       ` Bone Baboon
2021-04-23 18:37         ` Bone Baboon

unofficial mirror of help-guix@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-user/0 guix-user/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-user guix-user/ https://yhetil.org/guix-user \
		help-guix@gnu.org
	public-inbox-index guix-user

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.user
	nntp://news.gmane.io/gmane.comp.gnu.guix.user


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git