unofficial mirror of guix-patches@gnu.org 
 help / color / mirror / code / Atom feed
* [bug#53228] [PATCH 0/2] gnu: poetry: Fix inputs.
@ 2022-01-13  9:45 Tanguy Le Carrour
  2022-01-13  9:50 ` [bug#53228] [PATCH 1/2] Revert "gnu: Remove python-msgpack-transitional." Tanguy Le Carrour
  2022-01-13 19:05 ` bug#53228: [PATCH 0/2] " Leo Famulari
  0 siblings, 2 replies; 5+ messages in thread
From: Tanguy Le Carrour @ 2022-01-13  9:45 UTC (permalink / raw)
  To: 53228; +Cc: Tanguy Le Carrour

Dear Guix,

Unfortunately, I messed up Poetry package in my last patch set!

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53054

Poetry depends on an outdated version of `python-msgpack`, so I re-added
the `python-msgpack-transitional`.

I tried adding a `python-msgpack-0.5.6` instead, but I ended up with a
Poetry package containing conflicting inputs, for `python-cachecontrol`
was depending on a more recent version of `python-msgpack`.

This issue has been reported upstream as mentioned in the second patch.

Again, sorry for the mess!


Tanguy Le Carrour (2):
  Revert "gnu: Remove python-msgpack-transitional."
  gnu: poetry: Fix inputs.

 gnu/packages/python-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++-
 1 file changed, 37 insertions(+), 1 deletion(-)

-- 
2.34.0





^ permalink raw reply	[flat|nested] 5+ messages in thread

* [bug#53228] [PATCH 1/2] Revert "gnu: Remove python-msgpack-transitional."
  2022-01-13  9:45 [bug#53228] [PATCH 0/2] gnu: poetry: Fix inputs Tanguy Le Carrour
@ 2022-01-13  9:50 ` Tanguy Le Carrour
  2022-01-13  9:50   ` [bug#53228] [PATCH 2/2] gnu: poetry: Fix inputs Tanguy Le Carrour
  2022-01-13 19:05 ` bug#53228: [PATCH 0/2] " Leo Famulari
  1 sibling, 1 reply; 5+ messages in thread
From: Tanguy Le Carrour @ 2022-01-13  9:50 UTC (permalink / raw)
  To: 53228; +Cc: Tanguy Le Carrour

This reverts commit d5ae6739fdb4786c49d33de3fec9872c73d2e311.
---
 gnu/packages/python-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e53ba67cdc..66ec26d142 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10923,6 +10923,40 @@ (define-public python-msgpack
     (home-page "https://pypi.org/project/msgpack/")
     (license license:asl2.0)))
 
+;; This msgpack library's name changed from "python-msgpack" to "msgpack" with
+;; release 0.5. Some packages like borg still call it by the old name for now.
+;; <https://bugs.gnu.org/30662>
+(define-public python-msgpack-transitional
+  (package
+    (inherit python-msgpack)
+    (name "python-msgpack-transitional")
+    (version "0.5.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "msgpack" version))
+              (sha256
+               (base32
+                "1hz2dba1nvvn52afg34liijsm7kn65cmn06dl0xbwld6bb4cis0f"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments python-msgpack)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'configure-transitional
+             (lambda _
+               ;; Keep using the old name.
+               (substitute* "setup.py"
+                 (("TRANSITIONAL = False")
+                   "TRANSITIONAL = 1"))
+               ;; This old version is not compatible with Python 3.9
+               (substitute* '("test/test_buffer.py" "test/test_extension.py")
+                 ((".tostring\\(") ".tobytes("))
+               (substitute* '("test/test_buffer.py" "test/test_extension.py")
+                 ((".fromstring\\(") ".frombytes("))
+               #t))))))))
+
+(define-public python2-msgpack
+  (package-with-python2 python-msgpack))
+
 (define-public python-netaddr
   (package
     (name "python-netaddr")
-- 
2.34.0





^ permalink raw reply	[flat|nested] 5+ messages in thread

* [bug#53228] [PATCH 2/2] gnu: poetry: Fix inputs.
  2022-01-13  9:50 ` [bug#53228] [PATCH 1/2] Revert "gnu: Remove python-msgpack-transitional." Tanguy Le Carrour
@ 2022-01-13  9:50   ` Tanguy Le Carrour
  0 siblings, 0 replies; 5+ messages in thread
From: Tanguy Le Carrour @ 2022-01-13  9:50 UTC (permalink / raw)
  To: 53228; +Cc: Tanguy Le Carrour

* gnu/packages/python-xyz.scm (poetry)[propagated-inputs]: Replace python-msgpack with python-msgpack-transitional.
---
 gnu/packages/python-xyz.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66ec26d142..0091165d37 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16119,7 +16119,9 @@ (define-public poetry
            python-entrypoints
            python-html5lib
            python-keyring
-           python-msgpack
+           ; Use of deprecated version of msgpack reported upstream:
+           ; https://github.com/python-poetry/poetry/issues/3607
+           python-msgpack-transitional
            python-packaging
            python-pexpect
            python-pip
-- 
2.34.0





^ permalink raw reply	[flat|nested] 5+ messages in thread

* bug#53228: [PATCH 0/2] gnu: poetry: Fix inputs.
  2022-01-13  9:45 [bug#53228] [PATCH 0/2] gnu: poetry: Fix inputs Tanguy Le Carrour
  2022-01-13  9:50 ` [bug#53228] [PATCH 1/2] Revert "gnu: Remove python-msgpack-transitional." Tanguy Le Carrour
@ 2022-01-13 19:05 ` Leo Famulari
  2022-01-14  7:53   ` [bug#53228] " Tanguy LE CARROUR
  1 sibling, 1 reply; 5+ messages in thread
From: Leo Famulari @ 2022-01-13 19:05 UTC (permalink / raw)
  To: Tanguy Le Carrour; +Cc: 53228-done

On Thu, Jan 13, 2022 at 10:45:29AM +0100, Tanguy Le Carrour wrote:
> Dear Guix,
> 
> Unfortunately, I messed up Poetry package in my last patch set!
> 
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53054
> 
> Poetry depends on an outdated version of `python-msgpack`, so I re-added
> the `python-msgpack-transitional`.
> 
> I tried adding a `python-msgpack-0.5.6` instead, but I ended up with a
> Poetry package containing conflicting inputs, for `python-cachecontrol`
> was depending on a more recent version of `python-msgpack`.
> 
> This issue has been reported upstream as mentioned in the second patch.

Thanks for taking care of this.

> Tanguy Le Carrour (2):
>   Revert "gnu: Remove python-msgpack-transitional."
>   gnu: poetry: Fix inputs.

I tweaked the commit messages and pushed as
391f22fa3e34ac0ef0c31a422ccfb49c92f744ac




^ permalink raw reply	[flat|nested] 5+ messages in thread

* [bug#53228] [PATCH 0/2] gnu: poetry: Fix inputs.
  2022-01-13 19:05 ` bug#53228: [PATCH 0/2] " Leo Famulari
@ 2022-01-14  7:53   ` Tanguy LE CARROUR
  0 siblings, 0 replies; 5+ messages in thread
From: Tanguy LE CARROUR @ 2022-01-14  7:53 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53228-done

Hi Leo,


Quoting Leo Famulari (2022-01-13 20:05:28)
> On Thu, Jan 13, 2022 at 10:45:29AM +0100, Tanguy Le Carrour wrote:
> > Dear Guix,
> > 
> > Unfortunately, I messed up Poetry package in my last patch set!
> > 
> > https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53054
> > 
> > Poetry depends on an outdated version of `python-msgpack`, so I re-added
> > the `python-msgpack-transitional`.
> > 
> > I tried adding a `python-msgpack-0.5.6` instead, but I ended up with a
> > Poetry package containing conflicting inputs, for `python-cachecontrol`
> > was depending on a more recent version of `python-msgpack`.
> > 
> > This issue has been reported upstream as mentioned in the second patch.
> 
> Thanks for taking care of this.

Thanks!


-- 
Tanguy




^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2022-01-14  8:02 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-13  9:45 [bug#53228] [PATCH 0/2] gnu: poetry: Fix inputs Tanguy Le Carrour
2022-01-13  9:50 ` [bug#53228] [PATCH 1/2] Revert "gnu: Remove python-msgpack-transitional." Tanguy Le Carrour
2022-01-13  9:50   ` [bug#53228] [PATCH 2/2] gnu: poetry: Fix inputs Tanguy Le Carrour
2022-01-13 19:05 ` bug#53228: [PATCH 0/2] " Leo Famulari
2022-01-14  7:53   ` [bug#53228] " Tanguy LE CARROUR

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).