unofficial mirror of guix-patches@gnu.org 
 help / color / mirror / Atom feed
* [bug#45727] [PATCH] gnu: folly: Update to 2021.01.04.00.
@ 2021-01-08 12:19 Greg Hogan
  2021-01-19 14:59 ` Ludovic Courtès
  0 siblings, 1 reply; 2+ messages in thread
From: Greg Hogan @ 2021-01-08 12:19 UTC (permalink / raw)
  To: 45727


[-- Attachment #1.1: Type: text/plain, Size: 2346 bytes --]

I went to build folly against core-updates and the link failed due to
missing dependencies on libicu*. This patch also updates the folly version.


From e710c98a2f5beef9d8640bf3618ae20bd12c12f7 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Thu, 7 Jan 2021 21:54:37 +0000
Subject: [PATCH] gnu: folly: Update to 2021.01.04.00.

* gnu/packages/cpp.scm (folly): Update to 2021.01.04.00.
[propagated-inputs]: Add icu4c.
---
 gnu/packages/cpp.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..5032a5c58b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -14,7 +14,7 @@
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
-;;; Copyright © 2020 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -50,6 +50,7 @@
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages icu4c)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages linux)
@@ -688,7 +689,7 @@ standard GNU style syntax for options.")
 (define-public folly
   (package
     (name "folly")
-    (version "2020.10.05.00")
+    (version "2021.01.04.00")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -697,7 +698,7 @@ standard GNU style syntax for options.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0q4w4cvjxffc462hvs8h4zryq4965j7015zvkwagcm6cj6wmz3cn"))))
+                "03r16q966p3qg4661ns6q5phmi67i536vi804ayja9fmd6hyfqdj"))))
     (build-system cmake-build-system)
     (arguments
      '(;; Tests must be explicitly enabled
@@ -708,6 +709,7 @@ standard GNU style syntax for options.")
      `(("boost" ,boost)
        ("gflags" ,gflags)
        ("glog" ,glog)
+       ("icu4c" ,icu4c)
        ("liburing" ,liburing)))
     (inputs
      `(("bzip2" ,bzip2)
-- 
2.29.2

[-- Attachment #1.2: Type: text/html, Size: 3555 bytes --]

[-- Attachment #2: 0001-gnu-folly-Update-to-2021.01.04.00.patch --]
[-- Type: application/octet-stream, Size: 2135 bytes --]

^ permalink raw reply	[flat|nested] 2+ messages in thread

* [bug#45727] [PATCH] gnu: folly: Update to 2021.01.04.00.
  2021-01-08 12:19 [bug#45727] [PATCH] gnu: folly: Update to 2021.01.04.00 Greg Hogan
@ 2021-01-19 14:59 ` Ludovic Courtès
  0 siblings, 0 replies; 2+ messages in thread
From: Ludovic Courtès @ 2021-01-19 14:59 UTC (permalink / raw)
  To: Greg Hogan; +Cc: 45727

Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

> I went to build folly against core-updates and the link failed due to
> missing dependencies on libicu*. This patch also updates the folly version.
>
>
>>From e710c98a2f5beef9d8640bf3618ae20bd12c12f7 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Thu, 7 Jan 2021 21:54:37 +0000
> Subject: [PATCH] gnu: folly: Update to 2021.01.04.00.
>
> * gnu/packages/cpp.scm (folly): Update to 2021.01.04.00.
> [propagated-inputs]: Add icu4c.

If there’s a reason to propagate ICU4C, could you state it in a comment?
Otherwise, can we just move it to ‘inputs’?

Apart from that it LGTM, and it’s applicable to ‘master’.

Could you send an updated patch?

Thanks,
Ludo’.




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-01-19 15:00 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-08 12:19 [bug#45727] [PATCH] gnu: folly: Update to 2021.01.04.00 Greg Hogan
2021-01-19 14:59 ` Ludovic Courtès

unofficial mirror of guix-patches@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-patches/1 guix-patches/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-patches guix-patches/ https://yhetil.org/guix-patches \
		guix-patches@gnu.org
	public-inbox-index guix-patches

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.patches


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git