unofficial mirror of guix-patches@gnu.org 
 help / color / Atom feed
* [bug#42132] [PATCH] gnu: gfortran: Remove unusable versions.
@ 2020-06-29 20:48 Jakub Kądziołka
  2020-06-30  9:23 ` Ludovic Courtès
  0 siblings, 1 reply; 3+ messages in thread
From: Jakub Kądziołka @ 2020-06-29 20:48 UTC (permalink / raw)
  To: 42132

The gfortran packages cannot be used without being wrapped with
gfortran-toolchain. However, as the comment in (gnu packages
commencement) explains, there cannot be more than one gfortran-toolchain
package because of ABI issues. Thus, versions of gfortran other than the
main one are useless.

* gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
  gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
  (gfortran): Define the gfortran package based on the gcc variable.
---
 gnu/packages/gcc.scm | 41 ++---------------------------------------
 1 file changed, 2 insertions(+), 39 deletions(-)

diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 0c5be69fbf..31d88f2e0b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -687,48 +687,11 @@ as the 'native-search-paths' field."
          (variable "LIBRARY_PATH")
          (files '("lib" "lib64")))))
 
-(define-public gfortran-4.8
-  (hidden-package
-   (custom-gcc gcc-4.8 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-4.9
-  (hidden-package
-   (custom-gcc gcc-4.9 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-5
-  (hidden-package
-   (custom-gcc gcc-5 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-6
-  (hidden-package
-   (custom-gcc gcc-6 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-7
-  (hidden-package
-   (custom-gcc gcc-7 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-8
-  (hidden-package
-   (custom-gcc gcc-8 "gfortran" '("fortran")
-               %generic-search-paths)))
-
-(define-public gfortran-9
+(define-public gfortran
   (hidden-package
-   (custom-gcc gcc-9 "gfortran" '("fortran")
+   (custom-gcc gcc "gfortran" '("fortran")
                %generic-search-paths)))
 
-(define-public gfortran
-  ;; Note: Update this when GCC changes!  We cannot use
-  ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
-  ;; that is not 'eq?' with GFORTRAN-5, and thus 'fold-packages' would
-  ;; report two gfortran@5 that are in fact identical.
-  gfortran-7)
-
 (define-public libgccjit
   (package
     (inherit gcc-9)
-- 
2.27.0





^ permalink raw reply	[flat|nested] 3+ messages in thread

* [bug#42132] [PATCH] gnu: gfortran: Remove unusable versions.
  2020-06-29 20:48 [bug#42132] [PATCH] gnu: gfortran: Remove unusable versions Jakub Kądziołka
@ 2020-06-30  9:23 ` Ludovic Courtès
  2020-06-30 11:01   ` bug#42132: " Jakub Kądziołka
  0 siblings, 1 reply; 3+ messages in thread
From: Ludovic Courtès @ 2020-06-30  9:23 UTC (permalink / raw)
  To: Jakub Kądziołka; +Cc: 42132

Hello,

Jakub Kądziołka <kuba@kadziolka.net> skribis:

> The gfortran packages cannot be used without being wrapped with
> gfortran-toolchain. However, as the comment in (gnu packages
> commencement) explains, there cannot be more than one gfortran-toolchain
> package because of ABI issues. Thus, versions of gfortran other than the
> main one are useless.
>
> * gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
>   gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
>   (gfortran): Define the gfortran package based on the gcc variable.

LGTM, thanks!  :-)

Ludo’.




^ permalink raw reply	[flat|nested] 3+ messages in thread

* bug#42132: [PATCH] gnu: gfortran: Remove unusable versions.
  2020-06-30  9:23 ` Ludovic Courtès
@ 2020-06-30 11:01   ` Jakub Kądziołka
  0 siblings, 0 replies; 3+ messages in thread
From: Jakub Kądziołka @ 2020-06-30 11:01 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 42132-done

[-- Attachment #1: Type: text/plain, Size: 812 bytes --]

On Tue, Jun 30, 2020 at 11:23:00AM +0200, Ludovic Courtès wrote:
> Hello,
> 
> Jakub Kądziołka <kuba@kadziolka.net> skribis:
> 
> > The gfortran packages cannot be used without being wrapped with
> > gfortran-toolchain. However, as the comment in (gnu packages
> > commencement) explains, there cannot be more than one gfortran-toolchain
> > package because of ABI issues. Thus, versions of gfortran other than the
> > main one are useless.
> >
> > * gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
> >   gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
> >   (gfortran): Define the gfortran package based on the gcc variable.
> 
> LGTM, thanks!  :-)
> 
> Ludo’.

Thanks, pushed as 0681f05486d901c92637c098bb7afddef35068b0.

Regards,
Jakub Kądziołka

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, back to index

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-29 20:48 [bug#42132] [PATCH] gnu: gfortran: Remove unusable versions Jakub Kądziołka
2020-06-30  9:23 ` Ludovic Courtès
2020-06-30 11:01   ` bug#42132: " Jakub Kądziołka

unofficial mirror of guix-patches@gnu.org 

Archives are clonable:
	git clone --mirror https://yhetil.org/guix-patches/1 guix-patches/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-patches guix-patches/ https://yhetil.org/guix-patches \
		guix-patches@gnu.org
	public-inbox-index guix-patches

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.patches


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git