Hi Stefan, In 04-gnu-bootloader-add-u-boot.patch, I think that having #:name is too magical (it still only replaces part of the package name, and then still only after substitution). But if made non-magical, then it has too little benefit. Likewise for #:description. If it's alright with you, can we just drop #:name xxx and #:description xxx altogether and instead do: (define-public u-boot-rpi-3-efi (package (inherit (make-preinstalled-u-boot-package "rpi_3_32b" "arm-linux-gnueabihf" #:name "rpi-3-efi" #:configs %u-boot-rpi-efi-configs #:description %u-boot-rpi-efi-description-32-bit)) (name "u-boot-rpi-3-efi") (description %u-boot-rpi-efi-description-32-bit))) And similar for all the other u-boot definitions, and for the usage of make-u-boot-package inside make-preinstalled-u-boot-package ? Or are there upsides to doing it like you did it? I'm aware that the same can be said for "board" ... which is used already. However, that parameter is also used for something else, so it needs to be there. NAME isn't used for anything else but for doing what a regular package inherit could do anyway. Is there a downside when using package inherit?