unofficial mirror of guix-devel@gnu.org 
 help / color / mirror / Atom feed
* [core-updates-frozen] python2-google-api-client and sanity-check
@ 2021-08-31  7:18 zimoun
  2021-08-31 12:39 ` Lars-Dominik Braun
  0 siblings, 1 reply; 5+ messages in thread
From: zimoun @ 2021-08-31  7:18 UTC (permalink / raw)
  To: Guix Devel

Hi,

Using the Mathieu’s script to pick one missing package from
core-updates-frozen, ’python2-google-api-client’ pops up.  Initially, I
thought to simply remove it because it is Python 2 and Python 2 is EOL.

Well, ’python2-google-api-client’ builds fine on master.  Therefore, let
try to build it locally and to be sure the removal is for good
reasons. :-)  Then, the build fails because the ’sanity-check’ phase:

--8<---------------cut here---------------start------------->8---
starting phase `sanity-check'                                                   
validating 'google-api-python-client' /gnu/store/…-python2-google-api-client-1.\
6.7/lib/python2.7/site-packages                                                 
...checking requirements: OK                                                    
...trying to load module apiclient: OK                                          
...trying to load module googleapiclient: OK                                    
...trying to load module googleapiclient/discovery_cache: ERROR:                
Traceback (most recent call last):                                              
  File "/gnu/store/…-sanity-check.py", line 69, in <module>                     
    importlib.import_module(name)                                               
  File "/gnu/store/…-python2-2.7.18/lib/python2.7/importlib/__init__.py", line \
37, in import_module                                                            
    __import__(name)                                                            
ImportError: Import by filename is not supported.                               
error: in phase 'sanity-check': uncaught exception:                             
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/…-sanity-c\
heck.py" "/gnu/store/…-python2-google-api-client-1.6.7/lib/python2.7/site-packa\
ges") exit-status: 1 term-signal: #f stop-signal: #f>                           
phase `sanity-check' failed after 1.0 seconds
--8<---------------cut here---------------end--------------->8---

Because this ’sanity-check’ is new, IIUC, my question is: is it
expected?  And is it worth to fix such Python 2 packages or simply
remove them because ’sanity-check.py’ uses Python 3 only features?

Thanks in advance for any tips.

All the best,
simon



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [core-updates-frozen] python2-google-api-client and sanity-check
  2021-08-31  7:18 [core-updates-frozen] python2-google-api-client and sanity-check zimoun
@ 2021-08-31 12:39 ` Lars-Dominik Braun
  2021-08-31 13:01   ` zimoun
  0 siblings, 1 reply; 5+ messages in thread
From: Lars-Dominik Braun @ 2021-08-31 12:39 UTC (permalink / raw)
  To: zimoun; +Cc: Guix Devel


[-- Attachment #1.1: Type: text/plain, Size: 704 bytes --]

Hi zimoun,

> Because this ’sanity-check’ is new, IIUC, my question is: is it
> expected?  And is it worth to fix such Python 2 packages or simply
> remove them because ’sanity-check.py’ uses Python 3 only features?
setup.py of this package is broken, because the package list contains a slash.
See attached patch for a fix.

Can I simply push that to core-updates-frozen or is there anything else I should do?

Lars

-- 
Lars-Dominik Braun
Wissenschaftlicher Mitarbeiter/Research Associate

www.leibniz-psychology.org
ZPID - Leibniz-Institut für Psychologie /
ZPID - Leibniz Institute for Psychology
Universitätsring 15
D-54296 Trier - Germany
Tel.: +49–651–201-4964

[-- Attachment #1.2: patch --]
[-- Type: text/plain, Size: 884 bytes --]

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 91b68cf5f4..4763abce8b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4338,7 +4338,15 @@ Google search engine.  Its module is called @code{googlesearch}.")
          "1wpbbbxfpy9mwxdy3kn352cb590ladv574j1aa2l4grjdqw3ln05"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f)) ; tests require internet access
+     `(#:tests? #f ; tests require internet access
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-setup-py
+           (lambda _
+             (substitute* "setup.py"
+               (("googleapiclient/discovery_cache")
+                "googleapiclient.discovery_cache"))
+             #t)))))
     (native-inputs
      `(("python-httplib2" ,python-httplib2)
        ("python-six" ,python-six)

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [core-updates-frozen] python2-google-api-client and sanity-check
  2021-08-31 12:39 ` Lars-Dominik Braun
@ 2021-08-31 13:01   ` zimoun
  2021-08-31 16:41     ` Lars-Dominik Braun
  0 siblings, 1 reply; 5+ messages in thread
From: zimoun @ 2021-08-31 13:01 UTC (permalink / raw)
  To: Lars-Dominik Braun; +Cc: Guix Devel

Hi,

On Tue, 31 Aug 2021 at 14:39, Lars-Dominik Braun
<ldb@leibniz-psychology.org> wrote:

> See attached patch for a fix.

LGTM.


> Can I simply push that to core-updates-frozen or is there anything else I should do?

From my point of view, yes you can push because it is a fix.

Cheers,
simon


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [core-updates-frozen] python2-google-api-client and sanity-check
  2021-08-31 13:01   ` zimoun
@ 2021-08-31 16:41     ` Lars-Dominik Braun
  2021-08-31 17:00       ` zimoun
  0 siblings, 1 reply; 5+ messages in thread
From: Lars-Dominik Braun @ 2021-08-31 16:41 UTC (permalink / raw)
  To: zimoun; +Cc: Guix Devel

Hi,

> From my point of view, yes you can push because it is a fix.
pushed as bac072e09bb80c172672e13782e1ed25ce04d6d5. Please don’t
hesitate to ping me if there’s any other issuse with the sanity check
phase.

Cheers,
Lars



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [core-updates-frozen] python2-google-api-client and sanity-check
  2021-08-31 16:41     ` Lars-Dominik Braun
@ 2021-08-31 17:00       ` zimoun
  0 siblings, 0 replies; 5+ messages in thread
From: zimoun @ 2021-08-31 17:00 UTC (permalink / raw)
  To: Lars-Dominik Braun; +Cc: Guix Devel

Hi Lars,

On Tue, 31 Aug 2021 at 18:41, Lars-Dominik Braun <lars@6xq.net> wrote:

> pushed as bac072e09bb80c172672e13782e1ed25ce04d6d5. Please don’t
> hesitate to ping me if there’s any other issuse with the sanity check
> phase.

Thanks.  I will do. :-)  I am going to check if all the 'python2-'
packages on core-updates-frozen build or not.

Cheers,
simon


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-08-31 17:01 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-31  7:18 [core-updates-frozen] python2-google-api-client and sanity-check zimoun
2021-08-31 12:39 ` Lars-Dominik Braun
2021-08-31 13:01   ` zimoun
2021-08-31 16:41     ` Lars-Dominik Braun
2021-08-31 17:00       ` zimoun

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).