unofficial mirror of guix-devel@gnu.org 
 help / color / mirror / Atom feed
* Re: configure: error: A recent Guile-zlib could not be found; please install it.
@ 2021-04-07 14:37 Paul Garlick
  2021-04-07 14:41 ` Roel Janssen
  0 siblings, 1 reply; 3+ messages in thread
From: Paul Garlick @ 2021-04-07 14:37 UTC (permalink / raw)
  To: roel, guix-devel

Hi Roel,

> How can I get a working development environment to work on Guix?

A 'guix pull' within your profile will update the guile-zlib version
that is used by 'guix environment ...'.  Then the configure script
requirement will be met.

Best regards,

Paul.



^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: configure: error: A recent Guile-zlib could not be found; please install it.
  2021-04-07 14:37 configure: error: A recent Guile-zlib could not be found; please install it Paul Garlick
@ 2021-04-07 14:41 ` Roel Janssen
  0 siblings, 0 replies; 3+ messages in thread
From: Roel Janssen @ 2021-04-07 14:41 UTC (permalink / raw)
  To: Paul Garlick, guix-devel

On Wed, 2021-04-07 at 15:37 +0100, Paul Garlick wrote:
> Hi Roel,
> 
> > How can I get a working development environment to work on Guix?
> 
> A 'guix pull' within your profile will update the guile-zlib version
> that is used by 'guix environment ...'.  Then the configure script
> requirement will be met.
> 

Thanks!

Cheers,
Roel



^ permalink raw reply	[flat|nested] 3+ messages in thread

* configure: error: A recent Guile-zlib could not be found; please install it.
@ 2021-04-07  7:56 Roel Janssen
  0 siblings, 0 replies; 3+ messages in thread
From: Roel Janssen @ 2021-04-07  7:56 UTC (permalink / raw)
  To: guix-devel

Hi Guix,

I'm at version 2e5ac371e799cb91354ffafaf8af2da37d11fa3f, and when doing
this:
$ guix environment -C guix --ad-hoc guile-zlib
[env]$ ./configure --localstatedir=/var

.. then configure ends with:
checking whether Guile-zlib is available and recent enough... no
configure: error: A recent Guile-zlib could not be found; please
install it.

How can I get a working development environment to work on Guix?

Kind regards,
Roel Janssen



^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-04-07 14:42 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-07 14:37 configure: error: A recent Guile-zlib could not be found; please install it Paul Garlick
2021-04-07 14:41 ` Roel Janssen
  -- strict thread matches above, loose matches on Subject: below --
2021-04-07  7:56 Roel Janssen

unofficial mirror of guix-devel@gnu.org 

This inbox may be cloned and mirrored by anyone:

	git clone --mirror https://yhetil.org/guix-devel/0 guix-devel/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 guix-devel guix-devel/ https://yhetil.org/guix-devel \
		guix-devel@gnu.org
	public-inbox-index guix-devel

Example config snippet for mirrors.
Newsgroups are available over NNTP:
	nntp://news.yhetil.org/yhetil.gnu.guix.devel
	nntp://news.gmane.io/gmane.comp.gnu.guix.devel


AGPL code for this site: git clone http://ou63pmih66umazou.onion/public-inbox.git