unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#53197: wpewebkit: Fails to build (a required package was not found)
@ 2022-01-11 21:49 kiasoc5--- via Bug reports for GNU Guix
  2022-01-12  7:28 ` Liliana Marie Prikler
                   ` (4 more replies)
  0 siblings, 5 replies; 13+ messages in thread
From: kiasoc5--- via Bug reports for GNU Guix @ 2022-01-11 21:49 UTC (permalink / raw)
  To: 53197

```
-- Found ICU: /gnu/store/7sik9fp2ffvnr7l01s423x4r5pn75rf9-icu4c-69.1/include (found suitable version "69.1", minimum required is "60.2") 
-- Found JPEG: /gnu/store/vhxayydx3y9n2gi2sc0dam26p7k1aaj8-libjpeg-turbo-2.0.5/lib/libjpeg.so (found version "62")
-- Found LibEpoxy: /gnu/store/amq5psiagcz04lz4kil3yl553a9cj26b-libepoxy-1.5.5/include (found suitable version "1.5.5", minimum required is "1.4.0")
-- Found LibGcrypt: /gnu/store/5z3gh8yq8a8dzlhm7llx50cjf1vj1r2w-libgcrypt-1.8.8/lib/libgcrypt.so (found suitable version "1.8.8", minimum required is "1.6.0")
CMake Error at /gnu/store/aain9m7r37jlzd21kvgvrkhc2pm7mk1w-cmake-minimal-3.21.3/share/cmake-3.21/Modules/FindPkgConfig.cmake:562 (message):
  A required package was not found
Call Stack (most recent call first):
  /gnu/store/aain9m7r37jlzd21kvgvrkhc2pm7mk1w-cmake-minimal-3.21.3/share/cmake-3.21/Modules/FindPkgConfig.cmake:784 (_pkg_check_modules_internal)
  Source/cmake/FindLibSoup.cmake:35 (pkg_check_modules)
  Source/cmake/WebKitFindPackage.cmake:104 (_find_package)
  Source/cmake/OptionsWPE.cmake:29 (find_package)
  Source/cmake/WebKitCommon.cmake:58 (include)
  CMakeLists.txt:173 (include)


-- Configuring incomplete, errors occurred!
```





^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: wpewebkit: Fails to build (a required package was not found)
  2022-01-11 21:49 bug#53197: wpewebkit: Fails to build (a required package was not found) kiasoc5--- via Bug reports for GNU Guix
@ 2022-01-12  7:28 ` Liliana Marie Prikler
  2022-01-12 18:28   ` Leo Famulari
  2022-01-16  7:29 ` bug#53197: [PATCH 1/3] gnu: libwpe: Update to 1.12.0 Liliana Marie Prikler
                   ` (3 subsequent siblings)
  4 siblings, 1 reply; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-12  7:28 UTC (permalink / raw)
  To: kiasoc5, 53197

Am Dienstag, dem 11.01.2022 um 22:49 +0100 schrieb
kiasoc5@tutanota.com:
> ```
> -- Found ICU: /gnu/store/7sik9fp2ffvnr7l01s423x4r5pn75rf9-icu4c-
> 69.1/include (found suitable version "69.1", minimum required is
> "60.2") 
> -- Found JPEG: /gnu/store/vhxayydx3y9n2gi2sc0dam26p7k1aaj8-libjpeg-
> turbo-2.0.5/lib/libjpeg.so (found version "62")
> -- Found LibEpoxy: /gnu/store/amq5psiagcz04lz4kil3yl553a9cj26b-
> libepoxy-1.5.5/include (found suitable version "1.5.5", minimum
> required is "1.4.0")
> -- Found LibGcrypt: /gnu/store/5z3gh8yq8a8dzlhm7llx50cjf1vj1r2w-
> libgcrypt-1.8.8/lib/libgcrypt.so (found suitable version "1.8.8",
> minimum required is "1.6.0")
> CMake Error at /gnu/store/aain9m7r37jlzd21kvgvrkhc2pm7mk1w-cmake-
> minimal-3.21.3/share/cmake-3.21/Modules/FindPkgConfig.cmake:562
> (message):
>   A required package was not found
> Call Stack (most recent call first):
>   /gnu/store/aain9m7r37jlzd21kvgvrkhc2pm7mk1w-cmake-minimal-
> 3.21.3/share/cmake-3.21/Modules/FindPkgConfig.cmake:784
> (_pkg_check_modules_internal)
>   Source/cmake/FindLibSoup.cmake:35 (pkg_check_modules)
>   Source/cmake/WebKitFindPackage.cmake:104 (_find_package)
>   Source/cmake/OptionsWPE.cmake:29 (find_package)
>   Source/cmake/WebKitCommon.cmake:58 (include)
>   CMakeLists.txt:173 (include)
> 
> 
> -- Configuring incomplete, errors occurred!
> ```
wpewebkit seems to have been ignored in the core-updates merge.  It
still uses old-style inputs and (more importantly) libsoup now refers
to libsoup 3.0 which is incompatible with most packages that depend on
the old version.  libsoup-minimal-2 should be used in its place.

Cheers




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: wpewebkit: Fails to build (a required package was not found)
  2022-01-12  7:28 ` Liliana Marie Prikler
@ 2022-01-12 18:28   ` Leo Famulari
  2022-01-13  7:45     ` Liliana Marie Prikler
  0 siblings, 1 reply; 13+ messages in thread
From: Leo Famulari @ 2022-01-12 18:28 UTC (permalink / raw)
  To: Liliana Marie Prikler; +Cc: 53197, kiasoc5

On Wed, Jan 12, 2022 at 08:28:13AM +0100, Liliana Marie Prikler wrote:
> wpewebkit seems to have been ignored in the core-updates merge.  It
> still uses old-style inputs and (more importantly) libsoup now refers
> to libsoup 3.0 which is incompatible with most packages that depend on
> the old version.  libsoup-minimal-2 should be used in its place.

This is kind of off-topic for your message, but I pay attention to
webkitgtk because it's security-critical for the Epiphany "gnome-web"
browser and GNOME overall, but I never looked at wpewebkit.

It doesn't have any dependents in Guix. It was commented-out in the
inputs of gst-plugins-bad, but there was no contextual explanation in
the surrounding code or commit message, so I removed the comment.

The latest wpewebkit release is 2.34.3, according to this page:

https://wpewebkit.org/code/

It seems to be share a release pattern with webkitgtk:

https://webkitgtk.org/

I suggest we try to keep this package up to date or remove it from Guix.




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: wpewebkit: Fails to build (a required package was not found)
  2022-01-12 18:28   ` Leo Famulari
@ 2022-01-13  7:45     ` Liliana Marie Prikler
  2022-01-15 11:12       ` Liliana Marie Prikler
  0 siblings, 1 reply; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-13  7:45 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53197, kiasoc5

Am Mittwoch, dem 12.01.2022 um 13:28 -0500 schrieb Leo Famulari:
> On Wed, Jan 12, 2022 at 08:28:13AM +0100, Liliana Marie Prikler wrote:
> > wpewebkit seems to have been ignored in the core-updates merge.  It
> > still uses old-style inputs and (more importantly) libsoup now refers
> > to libsoup 3.0 which is incompatible with most packages that depend
> > on the old version.  libsoup-minimal-2 should be used in its place.
> 
> This is kind of off-topic for your message, but I pay attention to
> webkitgtk because it's security-critical for the Epiphany "gnome-web"
> browser and GNOME overall, but I never looked at wpewebkit.
> 
> It doesn't have any dependents in Guix. It was commented-out in the
> inputs of gst-plugins-bad, but there was no contextual explanation in
> the surrounding code or commit message, so I removed the comment.
WPEWebkit along with some hitherto unpackaged... package[1] would be
used to enable a source[2] that rendered a Web page inside GStreamer. 
Wild stuff.

> The latest wpewebkit release is 2.34.3, according to this page:
> 
> https://wpewebkit.org/code/
> 
> It seems to be share a release pattern with webkitgtk:
> 
> https://webkitgtk.org/
They share a release schedule, because both of them are ports of the
same rendering engine (Webkit), but they are adjusted towards different
contexts (GTK and embedded respectively), so their inputs and I expect
also parts of their build systems differ.

> I suggest we try to keep this package up to date or remove it from
> Guix.
I agree, but note that the above shows how we can't expect wpewebkit to
build fine when webkitgtk does.  For the record, I'd prefer keeping it
updated, even if there's no users currently.  Eventually, Guix will
overtake the embedded browsing market :)

[1] https://github.com/Igalia/WPEBackend-fdo
[2] https://gstreamer.freedesktop.org/documentation/wpe/wpesrc.html




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: wpewebkit: Fails to build (a required package was not found)
  2022-01-13  7:45     ` Liliana Marie Prikler
@ 2022-01-15 11:12       ` Liliana Marie Prikler
  0 siblings, 0 replies; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-15 11:12 UTC (permalink / raw)
  To: Liliana Marie Prikler, Leo Famulari; +Cc: 53197, kiasoc5

Am Donnerstag, dem 13.01.2022 um 08:45 +0100 schrieb Liliana Marie
Prikler:
> some hitherto unpackaged... package[1]
> [1] https://github.com/Igalia/WPEBackend-fdo
It turns out we actually do have wpebackend-fdo and are even using it
in our webkitgtk build.  I'll try updating the wpe libs to 1.12.0 and
wpewebkit to 2.34.3, with a libsoup-2 variant thrown in if need be.




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 1/3] gnu: libwpe: Update to 1.12.0.
  2022-01-11 21:49 bug#53197: wpewebkit: Fails to build (a required package was not found) kiasoc5--- via Bug reports for GNU Guix
  2022-01-12  7:28 ` Liliana Marie Prikler
@ 2022-01-16  7:29 ` Liliana Marie Prikler
  2022-01-16  7:29 ` bug#53197: [PATCH 2/3] gnu: wpebackend-fdo: " Liliana Marie Prikler
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-16  7:29 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53197, kiasoc5

* gnu/packages/webkit.scm (libwpe): Update to 1.12.0.
[build-system]: Use meson-build-system.
---
 gnu/packages/webkit.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 8e9aa2b1b5..582adaddda 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages webkit)
   #:use-module (guix utils)
   #:use-module (guix build utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
@@ -70,7 +71,7 @@ (define-module (gnu packages webkit)
 (define-public libwpe
   (package
     (name "libwpe")
-    (version "1.6.0")
+    (version "1.12.0")
     (source
      (origin
        (method url-fetch)
@@ -78,8 +79,8 @@ (define-public libwpe
         (string-append "https://wpewebkit.org/releases/libwpe-"
                        version ".tar.xz"))
        (sha256
-        (base32 "141w35b488jjhanl3nrm0awrbcy6hb579fk8n9vbpx07m2wcd1rm"))))
-    (build-system cmake-build-system)
+        (base32 "13618imck69w7fbmljlh62j4gnlspb9zfqzv9hlkck3bi8icmvp8"))))
+    (build-system meson-build-system)
     (arguments
      `(#:tests? #f))                    ;no tests
     (native-inputs
-- 
2.34.0





^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 2/3] gnu: wpebackend-fdo: Update to 1.12.0.
  2022-01-11 21:49 bug#53197: wpewebkit: Fails to build (a required package was not found) kiasoc5--- via Bug reports for GNU Guix
  2022-01-12  7:28 ` Liliana Marie Prikler
  2022-01-16  7:29 ` bug#53197: [PATCH 1/3] gnu: libwpe: Update to 1.12.0 Liliana Marie Prikler
@ 2022-01-16  7:29 ` Liliana Marie Prikler
  2022-01-16  7:31 ` bug#53197: [PATCH 3/3] gnu: wpewebkit: Update to 2.34.3 Liliana Marie Prikler
  2022-01-16  7:36 ` bug#53197: [PATCH 0/3] Update WPEWebkit " Liliana Marie Prikler
  4 siblings, 0 replies; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-16  7:29 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53197, kiasoc5

* gnu/packages/webkit.scm (wpebackend-fdo): Update to 1.12.0.
[build-system]: Use meson-build-system.
[inputs]: Add libepoxy.
---
 gnu/packages/webkit.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 582adaddda..fc5172cfd7 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -99,21 +99,21 @@ (define-public libwpe
 (define-public wpebackend-fdo
   (package
     (name "wpebackend-fdo")
-    (version "1.6.1")
+    (version "1.12.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://wpewebkit.org/releases/"
                                   "wpebackend-fdo-" version ".tar.xz"))
               (sha256
                (base32
-                "1jdi43gciqjgvhnqxs160f3hmp1hkqhrllb0hhmldyxc4wryw3kl"))))
-    (build-system cmake-build-system)
+                "1b3l02dns1yxw3rq18cv00qan4hp95mxw5b3ssc0fh93ap0wjfb2"))))
+    (build-system meson-build-system)
     (arguments
      `(#:tests? #f))                    ;no tests
     (native-inputs
      (list pkg-config))
     (inputs
-     (list glib libwpe mesa wayland))
+     (list glib libepoxy libwpe mesa wayland))
     (home-page "https://wpewebkit.org/")
     (synopsis "Wayland WPE backend")
     (description
-- 
2.34.0





^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 3/3] gnu: wpewebkit: Update to 2.34.3.
  2022-01-11 21:49 bug#53197: wpewebkit: Fails to build (a required package was not found) kiasoc5--- via Bug reports for GNU Guix
                   ` (2 preceding siblings ...)
  2022-01-16  7:29 ` bug#53197: [PATCH 2/3] gnu: wpebackend-fdo: " Liliana Marie Prikler
@ 2022-01-16  7:31 ` Liliana Marie Prikler
  2022-01-16  7:36 ` bug#53197: [PATCH 0/3] Update WPEWebkit " Liliana Marie Prikler
  4 siblings, 0 replies; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-16  7:31 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53197, kiasoc5

* gnu/packages/webkit.scm (wpewebkit): Update to 2.34.3.
[#:phases]: Add ‘patch-cmake’ phase to fix an error in the install directories
of the documentation.
[inputs]: Add lcms.
---
 gnu/packages/webkit.scm | 14 ++++++++++++--
 1 file changed, 12 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index fc5172cfd7..d7751095c7 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -124,7 +124,7 @@ (define-public wpebackend-fdo
 (define-public wpewebkit
   (package
     (name "wpewebkit")
-    (version "2.30.5")
+    (version "2.34.3")
     (source
      (origin
        (method url-fetch)
@@ -132,7 +132,7 @@ (define-public wpewebkit
         (string-append "https://wpewebkit.org/releases/"
                        name "-" version ".tar.xz"))
        (sha256
-        (base32 "16imr0kmzhs7dz6jva9750xbsdz9v50playnagabajy30x7pymsb"))))
+        (base32 "1z20bza01ld4jvi0qx8xsl5y4czaniwpi8hxdjyirj1mrszy8pf3"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (arguments
@@ -162,6 +162,15 @@ (define-public wpewebkit
                                   "/xml/dtd/docbook/docbookx.dtd"))))
               (find-files "Source" "\\.sgml$"))
              #t))
+         (add-after 'unpack 'patch-cmake
+           (lambda _
+             (substitute* "Source/PlatformWPE.cmake"
+               (("(Documentation/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
+                 all prefix)
+                (string-append prefix "${WPE_API_DOC_VERSION}"))
+               (("(html/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
+                 all prefix)
+                (string-append prefix "${WPE_API_DOC_VERSION}")))))
          (add-after 'install 'move-doc-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -194,6 +203,7 @@ (define-public wpewebkit
        ("gst-plugins-base" ,gst-plugins-base)
        ("harfbuzz" ,harfbuzz)
        ("icu" ,icu4c)
+       ("lcms" ,lcms)
        ("libepoxy" ,libepoxy)
        ("libgcrypt" ,libgcrypt)
        ("libjpeg" ,libjpeg-turbo)
-- 
2.34.0





^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 0/3] Update WPEWebkit to 2.34.3
  2022-01-11 21:49 bug#53197: wpewebkit: Fails to build (a required package was not found) kiasoc5--- via Bug reports for GNU Guix
                   ` (3 preceding siblings ...)
  2022-01-16  7:31 ` bug#53197: [PATCH 3/3] gnu: wpewebkit: Update to 2.34.3 Liliana Marie Prikler
@ 2022-01-16  7:36 ` Liliana Marie Prikler
  2022-01-16 18:30   ` Leo Famulari
  2022-01-16 18:55   ` Leo Famulari
  4 siblings, 2 replies; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-16  7:36 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53197, kiasoc5

Hi Leo, hi Guix,

the following patches update libwpe and wpebackend-fdo to 1.12.0 and
wpewebkit to 2.34.3.  I checked that all three of them build, but I so
far haven't
1. done a libsoup-minimal-2 variant -- there's no dependents of
   wpewebkit yet, so it's somewhat pointless.
2. checked whether the AVX patches from WebkitGTK need to be carried
   over, or
3. tested how this impacts our WebkitGTK builds.

I'd appreciate if someone could help me out here, because Webkit builds
have a high chance of killing whatever else is running on my machine at
the moment -- or my machine if that fails.

Cheers

Liliana Marie Prikler (3):
  gnu: libwpe: Update to 1.12.0.
  gnu: wpebackend-fdo: Update to 1.12.0.
  gnu: wpewebkit: Update to 2.34.3.

 gnu/packages/webkit.scm | 29 ++++++++++++++++++++---------
 1 file changed, 20 insertions(+), 9 deletions(-)

-- 
2.34.0





^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 0/3] Update WPEWebkit to 2.34.3
  2022-01-16  7:36 ` bug#53197: [PATCH 0/3] Update WPEWebkit " Liliana Marie Prikler
@ 2022-01-16 18:30   ` Leo Famulari
  2022-01-16 19:29     ` Liliana Marie Prikler
  2022-01-16 18:55   ` Leo Famulari
  1 sibling, 1 reply; 13+ messages in thread
From: Leo Famulari @ 2022-01-16 18:30 UTC (permalink / raw)
  To: Liliana Marie Prikler; +Cc: 53197, kiasoc5

On Sun, Jan 16, 2022 at 08:36:45AM +0100, Liliana Marie Prikler wrote:
> Hi Leo, hi Guix,
> 
> the following patches update libwpe and wpebackend-fdo to 1.12.0 and
> wpewebkit to 2.34.3.  I checked that all three of them build, but I so
> far haven't
> 1. done a libsoup-minimal-2 variant -- there's no dependents of
>    wpewebkit yet, so it's somewhat pointless.
> 2. checked whether the AVX patches from WebkitGTK need to be carried
>    over, or
> 3. tested how this impacts our WebkitGTK builds.
> 
> I'd appreciate if someone could help me out here, because Webkit builds
> have a high chance of killing whatever else is running on my machine at
> the moment -- or my machine if that fails.

Thanks, I'm testing the build of WebKitGtk now.

I noticed that GTK 4 depends on wpebackend-fdo. For now, we can change
GTK 4 on the master branch, but eventually wpebackend-fdo will be a
package that requires grafting to keep up to date.




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 0/3] Update WPEWebkit to 2.34.3
  2022-01-16  7:36 ` bug#53197: [PATCH 0/3] Update WPEWebkit " Liliana Marie Prikler
  2022-01-16 18:30   ` Leo Famulari
@ 2022-01-16 18:55   ` Leo Famulari
  1 sibling, 0 replies; 13+ messages in thread
From: Leo Famulari @ 2022-01-16 18:55 UTC (permalink / raw)
  To: Liliana Marie Prikler; +Cc: 53197, kiasoc5

On Sun, Jan 16, 2022 at 08:36:45AM +0100, Liliana Marie Prikler wrote:
> 3. tested how this impacts our WebkitGTK builds.

With these patches applied, Epiphany still works in the same way as
before. Epiphany is the major test of WebKitGTK functionality in Guix.




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 0/3] Update WPEWebkit to 2.34.3
  2022-01-16 18:30   ` Leo Famulari
@ 2022-01-16 19:29     ` Liliana Marie Prikler
  2022-01-29 21:42       ` Leo Famulari
  0 siblings, 1 reply; 13+ messages in thread
From: Liliana Marie Prikler @ 2022-01-16 19:29 UTC (permalink / raw)
  To: Leo Famulari; +Cc: 53197, kiasoc5

Hi,

Am Sonntag, dem 16.01.2022 um 13:30 -0500 schrieb Leo Famulari:
> I noticed that GTK 4 depends on wpebackend-fdo. For now, we can
> change GTK 4 on the master branch, but eventually wpebackend-fdo will
> be a package that requires grafting to keep up to date.
I'm fine with turning the wpebackend-fdo patch into a graft, I just
didn't notice the dependency.

> With these patches applied, Epiphany still works in the same way as
> before.
Great, so we got WebkitGTK working, meaning we only need to disable
SSE2 outside of x86-64.  I checked the file mentioned in webkitgtk's
disable-sse2 phase, and it seems wpewebkit mirrors that.  So if I read
this correctly you only need to copypasta your old code.

Anything else I'm missing?




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#53197: [PATCH 0/3] Update WPEWebkit to 2.34.3
  2022-01-16 19:29     ` Liliana Marie Prikler
@ 2022-01-29 21:42       ` Leo Famulari
  0 siblings, 0 replies; 13+ messages in thread
From: Leo Famulari @ 2022-01-29 21:42 UTC (permalink / raw)
  To: Liliana Marie Prikler; +Cc: 53197-done, kiasoc5

I pushed these patches as 07f45615c3600dd1405349a4f7c775394fbfd40d

Normally I don't push patches for other committers but this is security
sensitive.

On Sun, Jan 16, 2022 at 08:29:03PM +0100, Liliana Marie Prikler wrote:
> I'm fine with turning the wpebackend-fdo patch into a graft, I just
> didn't notice the dependency.

I don't think a graft is necessary in this case.

> Great, so we got WebkitGTK working, meaning we only need to disable
> SSE2 outside of x86-64.  I checked the file mentioned in webkitgtk's
> disable-sse2 phase, and it seems wpewebkit mirrors that.  So if I read
> this correctly you only need to copypasta your old code.

I'm not sure what old code of mine you were referring to. In any
case, wpewebkit doesn't build for us on i686-linux, so there can't be a
regression there:

https://ci.guix.gnu.org/search?query=spec%3Amaster+system%3Ai686-linux+wpewebkit




^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2022-01-29 21:43 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-01-11 21:49 bug#53197: wpewebkit: Fails to build (a required package was not found) kiasoc5--- via Bug reports for GNU Guix
2022-01-12  7:28 ` Liliana Marie Prikler
2022-01-12 18:28   ` Leo Famulari
2022-01-13  7:45     ` Liliana Marie Prikler
2022-01-15 11:12       ` Liliana Marie Prikler
2022-01-16  7:29 ` bug#53197: [PATCH 1/3] gnu: libwpe: Update to 1.12.0 Liliana Marie Prikler
2022-01-16  7:29 ` bug#53197: [PATCH 2/3] gnu: wpebackend-fdo: " Liliana Marie Prikler
2022-01-16  7:31 ` bug#53197: [PATCH 3/3] gnu: wpewebkit: Update to 2.34.3 Liliana Marie Prikler
2022-01-16  7:36 ` bug#53197: [PATCH 0/3] Update WPEWebkit " Liliana Marie Prikler
2022-01-16 18:30   ` Leo Famulari
2022-01-16 19:29     ` Liliana Marie Prikler
2022-01-29 21:42       ` Leo Famulari
2022-01-16 18:55   ` Leo Famulari

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).