unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#29736: i686: webkit not usable
@ 2017-12-15 21:53 Ricardo Wurmus
  2017-12-18  9:41 ` Ludovic Courtès
  2022-01-05  0:22 ` zimoun
  0 siblings, 2 replies; 13+ messages in thread
From: Ricardo Wurmus @ 2017-12-15 21:53 UTC (permalink / raw)
  To: 29736

Hi Guix,

on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
web engine crashed” when it loads a tab, and Epiphany displays nothing
at all after loading a page for a while.

Icecat works okay for the most part.

-- 
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC
https://elephly.net

^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2017-12-15 21:53 bug#29736: i686: webkit not usable Ricardo Wurmus
@ 2017-12-18  9:41 ` Ludovic Courtès
  2017-12-19 18:45   ` Ricardo Wurmus
  2022-01-05  0:22 ` zimoun
  1 sibling, 1 reply; 13+ messages in thread
From: Ludovic Courtès @ 2017-12-18  9:41 UTC (permalink / raw)
  To: Ricardo Wurmus; +Cc: 29736

Hi,

Ricardo Wurmus <rekado@elephly.net> skribis:

> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
> web engine crashed” when it loads a tab, and Epiphany displays nothing
> at all after loading a page for a while.

Are both grafted and ungrafted browsers affected?

Thanks,
Ludo’.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2017-12-18  9:41 ` Ludovic Courtès
@ 2017-12-19 18:45   ` Ricardo Wurmus
  2017-12-20 11:08     ` Ludovic Courtès
  0 siblings, 1 reply; 13+ messages in thread
From: Ricardo Wurmus @ 2017-12-19 18:45 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 29736


Hi Ludo,

> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
>> web engine crashed” when it loads a tab, and Epiphany displays nothing
>> at all after loading a page for a while.
>
> Are both grafted and ungrafted browsers affected?

Unfortunately, they both are affected.

It’s not just webkit: Icecat tabs also crash *a lot*.  Also here it’s
both grafted and ungrafted browsers.

I wonder if this is related to the Emacs crash (which only appears with
the grafted Emacs on i686).

-- 
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC
https://elephly.net

^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2017-12-19 18:45   ` Ricardo Wurmus
@ 2017-12-20 11:08     ` Ludovic Courtès
  2018-01-07 13:02       ` Ricardo Wurmus
  2018-01-07 14:09       ` Ricardo Wurmus
  0 siblings, 2 replies; 13+ messages in thread
From: Ludovic Courtès @ 2017-12-20 11:08 UTC (permalink / raw)
  To: Ricardo Wurmus; +Cc: 29736

Hi,

Ricardo Wurmus <rekado@elephly.net> skribis:

>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>
>>> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
>>> web engine crashed” when it loads a tab, and Epiphany displays nothing
>>> at all after loading a page for a while.
>>
>> Are both grafted and ungrafted browsers affected?
>
> Unfortunately, they both are affected.
>
> It’s not just webkit: Icecat tabs also crash *a lot*.  Also here it’s
> both grafted and ungrafted browsers.

Can you grab backtraces so we have an idea where this happens?  It could
be something in a support library like GTK+, Freetype, and whatnot.

Ludo’.

^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2017-12-20 11:08     ` Ludovic Courtès
@ 2018-01-07 13:02       ` Ricardo Wurmus
  2018-01-07 14:09       ` Ricardo Wurmus
  1 sibling, 0 replies; 13+ messages in thread
From: Ricardo Wurmus @ 2018-01-07 13:02 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 29736


Ludovic Courtès <ludo@gnu.org> writes:

> Can you grab backtraces so we have an idea where this happens?  It could
> be something in a support library like GTK+, Freetype, and whatnot.

Here’s a backtrace when running icecat in a gdb session.  The crash
reliably happens when visiting ctrip.com:

--8<---------------cut here---------------start------------->8---
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[Parent 1829] WARNING: pipe error (65): Connection reset by peer: file /tmp/guix-build-icecat-52.3.0-gnu1.drv-0/icecat-52.3.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322
[Parent 1829] WARNING: pipe error (62): Connection reset by peer: file /tmp/guix-build-icecat-52.3.0-gnu1.drv-0/icecat-52.3.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 322

###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0085,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

[Thread 0x8368eb40 (LWP 1942) exited]
[Thread 0x8378fb40 (LWP 1941) exited]
[Thread 0x95ffdb40 (LWP 1894) exited]
[Thread 0x81cdbb40 (LWP 1940) exited]
[Thread 0x993fdb40 (LWP 1869) exited]


[Thread 0x8a4ffb40 (LWP 1915) exited]
[New Thread 0x8378fb40 (LWP 1948)]
[New Thread 0x8a4ffb40 (LWP 1949)]
[New Thread 0x993fdb40 (LWP 1950)]
[Thread 0x8a4ffb40 (LWP 1949) exited]
[Thread 0x993fdb40 (LWP 1950) exited]
[New Thread 0x993fdb40 (LWP 1952)]
[New Thread 0x8a4ffb40 (LWP 1975)]
[Thread 0x89affb40 (LWP 1918) exited]
[New Thread 0x89affb40 (LWP 1980)]
[New Thread 0x81cdbb40 (LWP 1981)]
[New Thread 0x95ffdb40 (LWP 1982)]
[Thread 0x95ffdb40 (LWP 1982) exited]
[New Thread 0x77bf5b40 (LWP 1983)]
[New Thread 0x95ffdb40 (LWP 1984)]
[Thread 0x875ffb40 (LWP 1929) exited]
[Thread 0x89affb40 (LWP 1980) exited]
[Thread 0x77bf5b40 (LWP 1983) exited]
[Thread 0x8e4feb40 (LWP 1897) exited]
[Thread 0x81cdbb40 (LWP 1981) exited]
[New Thread 0x81cdbb40 (LWP 1991)]

Thread 8 "Socket Thread" received signal SIGPIPE, Broken pipe.
[Switching to Thread 0xa8ccfb40 (LWP 1838)]
0xb7fdad25 in __kernel_vsyscall ()
(gdb) bt
#0  0xb7fdad25 in __kernel_vsyscall ()
#1  0xb7fc8349 in send ()
   from /gnu/store/kzkgc8avgnanrv3ab2g3g8yj7l4bcavj-glibc-2.25/lib/libpthread.so.0
#2  0xb006f1b3 in pt_Send ()
   from /gnu/store/pczgaq117siqa4yjhbz80gkkr4rfrgck-nspr-4.17/lib/libnspr4.so
#3  0xafffe30e in ssl_DefSend ()
   from /gnu/store/a8bklxld5vb9gpm3v3j2q8s8dppq5rl0-nss-3.34/lib/nss/libssl3.so
#4  0xaffe7261 in ssl3_SendRecord ()
   from /gnu/store/a8bklxld5vb9gpm3v3j2q8s8dppq5rl0-nss-3.34/lib/nss/libssl3.so
#5  0xaffe7bc2 in SSL3_SendAlert ()
   from /gnu/store/a8bklxld5vb9gpm3v3j2q8s8dppq5rl0-nss-3.34/lib/nss/libssl3.so
#6  0xb0006f71 in ssl_SecureClose ()
   from /gnu/store/a8bklxld5vb9gpm3v3j2q8s8dppq5rl0-nss-3.34/lib/nss/libssl3.so
#7  0xb00112d0 in ssl_Close ()
   from /gnu/store/a8bklxld5vb9gpm3v3j2q8s8dppq5rl0-nss-3.34/lib/nss/libssl3.so
#8  0xb3a3e8a8 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#9  0xb3a3e94a in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#10 0xb004e39c in PR_Close ()
---Type <return> to continue, or q <return> to quit---
   from /gnu/store/pczgaq117siqa4yjhbz80gkkr4rfrgck-nspr-4.17/lib/libnspr4.so
#11 0xb222ec63 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#12 0xb223094f in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#13 0xb223107b in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#14 0xb222d039 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#15 0xb222f7ce in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#16 0xb222fd23 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#17 0xb21ad1b9 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#18 0xb21c9084 in ?? ()
---Type <return> to continue, or q <return> to quit---
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#19 0xb23d4de3 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#20 0xb23be0f6 in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#21 0xb23be1fc in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#22 0xb21abe5e in ?? ()
   from /gnu/store/g4qy921k4w2zgfp3fnfphs8kqjjd7d52-icecat-52.3.0-gnu1/lib/icecat-52.3.0/libxul.so
#23 0xb0072ecb in _pt_root ()
   from /gnu/store/pczgaq117siqa4yjhbz80gkkr4rfrgck-nspr-4.17/lib/libnspr4.so
#24 0xb7fbe25a in start_thread ()
   from /gnu/store/kzkgc8avgnanrv3ab2g3g8yj7l4bcavj-glibc-2.25/lib/libpthread.so.0
#25 0xb7cf76d6 in clone ()
   from /gnu/store/kzkgc8avgnanrv3ab2g3g8yj7l4bcavj-glibc-2.25/lib/libc.so.6
(gdb) 
--8<---------------cut here---------------end--------------->8---


-- 
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC
https://elephly.net

^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2017-12-20 11:08     ` Ludovic Courtès
  2018-01-07 13:02       ` Ricardo Wurmus
@ 2018-01-07 14:09       ` Ricardo Wurmus
  1 sibling, 0 replies; 13+ messages in thread
From: Ricardo Wurmus @ 2018-01-07 14:09 UTC (permalink / raw)
  To: Ludovic Courtès; +Cc: 29736


Ludovic Courtès <ludo@gnu.org> writes:

> Hi,
>
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>>> Ricardo Wurmus <rekado@elephly.net> skribis:
>>>
>>>> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
>>>> web engine crashed” when it loads a tab, and Epiphany displays nothing
>>>> at all after loading a page for a while.
>>>
>>> Are both grafted and ungrafted browsers affected?
>>
>> Unfortunately, they both are affected.
>>
>> It’s not just webkit: Icecat tabs also crash *a lot*.  Also here it’s
>> both grafted and ungrafted browsers.
>
> Can you grab backtraces so we have an idea where this happens?  It could
> be something in a support library like GTK+, Freetype, and whatnot.

This might be interesting: it seems that in Epiphany only pages with
non-trivial JavaScript are affected.  The tab does not crash when
visiting static pages like my blog.

This is the same in Epiphany and Icecat.

-- 
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC
https://elephly.net

^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2017-12-15 21:53 bug#29736: i686: webkit not usable Ricardo Wurmus
  2017-12-18  9:41 ` Ludovic Courtès
@ 2022-01-05  0:22 ` zimoun
  2022-01-05  6:41   ` Ricardo Wurmus
  1 sibling, 1 reply; 13+ messages in thread
From: zimoun @ 2022-01-05  0:22 UTC (permalink / raw)
  To: Ricardo Wurmus; +Cc: 29736

Hi Ricardo,

Is this old bug [1] still relevant?

1: <http://issues.guix.gnu.org/issue/29736>


On Fri, 15 Dec 2017 at 22:53, Ricardo Wurmus <rekado@elephly.net> wrote:

> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
> web engine crashed” when it loads a tab, and Epiphany displays nothing
> at all after loading a page for a while.
>
> Icecat works okay for the most part.

I guess that many things changed since 2017. ;-)  What is the situation
for you now?


Cheers,
simon




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2022-01-05  0:22 ` zimoun
@ 2022-01-05  6:41   ` Ricardo Wurmus
  2022-01-05  7:41     ` zimoun
  0 siblings, 1 reply; 13+ messages in thread
From: Ricardo Wurmus @ 2022-01-05  6:41 UTC (permalink / raw)
  To: zimoun; +Cc: 29736


zimoun <zimon.toutoune@gmail.com> writes:

> Hi Ricardo,
>
> Is this old bug [1] still relevant?
>
> 1: <http://issues.guix.gnu.org/issue/29736>
>
>
> On Fri, 15 Dec 2017 at 22:53, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
>> web engine crashed” when it loads a tab, and Epiphany displays nothing
>> at all after loading a page for a while.
>>
>> Icecat works okay for the most part.
>
> I guess that many things changed since 2017. ;-)  What is the situation
> for you now?

I can’t reproduce this because the only i686 laptop I have is used in
headless mode.  I’d say we should close this.

-- 
Ricardo




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2022-01-05  6:41   ` Ricardo Wurmus
@ 2022-01-05  7:41     ` zimoun
  2022-01-05 19:24       ` Konrad Hinsen
  0 siblings, 1 reply; 13+ messages in thread
From: zimoun @ 2022-01-05  7:41 UTC (permalink / raw)
  To: Ricardo Wurmus; +Cc: 29736-done

Hi,

On Wed, 05 Jan 2022 at 07:41, Ricardo Wurmus <rekado@elephly.net> wrote:
> zimoun <zimon.toutoune@gmail.com> writes:
>> On Fri, 15 Dec 2017 at 22:53, Ricardo Wurmus <rekado@elephly.net> wrote:
>>
>>> on my i686 laptop I cannot use Webkit browsers.  Eolie displays “WebKit
>>> web engine crashed” when it loads a tab, and Epiphany displays nothing
>>> at all after loading a page for a while.
>>>
>>> Icecat works okay for the most part.
>>
>> I guess that many things changed since 2017. ;-)  What is the situation
>> for you now?
>
> I can’t reproduce this because the only i686 laptop I have is used in
> headless mode.  I’d say we should close this.

Since the last message was from 2018 and, to my knowledge*, nothing
related was reported recently, I am closing.

*limited knowledge, the volume is becoming high and it is hard to follow
 all is going on. :-)

Thanks,
simon




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2022-01-05  7:41     ` zimoun
@ 2022-01-05 19:24       ` Konrad Hinsen
  2022-01-05 19:31         ` Leo Famulari
  0 siblings, 1 reply; 13+ messages in thread
From: Konrad Hinsen @ 2022-01-05 19:24 UTC (permalink / raw)
  To: 29736, zimon.toutoune, rekado

Am 05/01/2022 um 08:41 schrieb zimoun:
> Since the last message was from 2018 and, to my knowledge*, nothing
> related was reported recently, I am closing.

For information, here's a lengthy discussion of WebKit crashes in the 
Nyxt browser when built under Guix:


https://github.com/atlas-engineer/nyxt/issues/1883


TL;DR: you have to add the packages gst-plugins-good and gst-plugins-bad 
if you want WebKit-based browsers to work in Guix. Otherwise WebKit 
complains about lack of WebVTT handling on many Web sites and just gives 
up. Adding both packages as a propagated input to WebKit should work - 
but maybe some people would not be happy to have gst-plugins-bad as a 
dependency, and prefer to have crashes on some Web sites.

I have no idea if this is related to the 2018 bug of course!


Cheers,

   Konrad.





^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2022-01-05 19:24       ` Konrad Hinsen
@ 2022-01-05 19:31         ` Leo Famulari
  2022-01-06  8:59           ` Konrad Hinsen
  0 siblings, 1 reply; 13+ messages in thread
From: Leo Famulari @ 2022-01-05 19:31 UTC (permalink / raw)
  To: Konrad Hinsen; +Cc: rekado, 29736

On Wed, Jan 05, 2022 at 08:24:25PM +0100, Konrad Hinsen wrote:
> TL;DR: you have to add the packages gst-plugins-good and gst-plugins-bad if
> you want WebKit-based browsers to work in Guix. Otherwise WebKit complains
> about lack of WebVTT handling on many Web sites and just gives up. Adding
> both packages as a propagated input to WebKit should work - but maybe some
> people would not be happy to have gst-plugins-bad as a dependency, and
> prefer to have crashes on some Web sites.

We can use the gst-plugins/selection procedure to avoid propagating all
of gst-plugins-bad.




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2022-01-05 19:31         ` Leo Famulari
@ 2022-01-06  8:59           ` Konrad Hinsen
  2022-01-06 17:08             ` Leo Famulari
  0 siblings, 1 reply; 13+ messages in thread
From: Konrad Hinsen @ 2022-01-06  8:59 UTC (permalink / raw)
  To: Leo Famulari; +Cc: rekado, 29736

Leo Famulari <leo@famulari.name> writes:

> We can use the gst-plugins/selection procedure to avoid propagating all
> of gst-plugins-bad.

That sounds interesting. But we'd first have to know which plugins are
actually important to have. Is there a way to trace plugin loading?

Konrad




^ permalink raw reply	[flat|nested] 13+ messages in thread

* bug#29736: i686: webkit not usable
  2022-01-06  8:59           ` Konrad Hinsen
@ 2022-01-06 17:08             ` Leo Famulari
  0 siblings, 0 replies; 13+ messages in thread
From: Leo Famulari @ 2022-01-06 17:08 UTC (permalink / raw)
  To: Konrad Hinsen; +Cc: rekado, 29736

On Thu, Jan 06, 2022 at 09:59:24AM +0100, Konrad Hinsen wrote:
> Leo Famulari <leo@famulari.name> writes:
> 
> > We can use the gst-plugins/selection procedure to avoid propagating all
> > of gst-plugins-bad.
> 
> That sounds interesting. But we'd first have to know which plugins are
> actually important to have. Is there a way to trace plugin loading?

That, I don't know. But I just wanted to point out that there is a
tool available for avoiding the entire gst-plugins-bad in cases like
this.




^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2022-01-06 17:13 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-12-15 21:53 bug#29736: i686: webkit not usable Ricardo Wurmus
2017-12-18  9:41 ` Ludovic Courtès
2017-12-19 18:45   ` Ricardo Wurmus
2017-12-20 11:08     ` Ludovic Courtès
2018-01-07 13:02       ` Ricardo Wurmus
2018-01-07 14:09       ` Ricardo Wurmus
2022-01-05  0:22 ` zimoun
2022-01-05  6:41   ` Ricardo Wurmus
2022-01-05  7:41     ` zimoun
2022-01-05 19:24       ` Konrad Hinsen
2022-01-05 19:31         ` Leo Famulari
2022-01-06  8:59           ` Konrad Hinsen
2022-01-06 17:08             ` Leo Famulari

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).