unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / code / Atom feed
* bug#45280: qutebrowser has no audio
@ 2020-12-16 21:29 bdju via Bug reports for GNU Guix
  2020-12-16 23:25 ` Leo Famulari
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: bdju via Bug reports for GNU Guix @ 2020-12-16 21:29 UTC (permalink / raw)
  To: 45280

guix (GNU Guix) 91e35e32a4938e0e37499c64fa8ed3e7cf51dce3
qutebrowser v1.14.0
full :version output of qutebrowser:
https://paste.the-compiler.org/view/ea2d3602
Has been going on for months now, but I don't think I filed a bug.
Does not show up at all in pavucontrol.





^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#45280: qutebrowser has no audio
  2020-12-16 21:29 bug#45280: qutebrowser has no audio bdju via Bug reports for GNU Guix
@ 2020-12-16 23:25 ` Leo Famulari
  2021-02-01 20:49   ` Leo Famulari
  2021-02-02  1:28 ` bdju--- via Bug reports for GNU Guix
  2021-04-22 13:12 ` bug#45280: Qutebrowser doesn't display embedded mp4 jcguu95
  2 siblings, 1 reply; 7+ messages in thread
From: Leo Famulari @ 2020-12-16 23:25 UTC (permalink / raw)
  To: 45280

On Wed, Dec 16, 2020 at 03:29:42PM -0600, bdju via Bug reports for GNU Guix wrote:
> guix (GNU Guix) 91e35e32a4938e0e37499c64fa8ed3e7cf51dce3
> qutebrowser v1.14.0
> full :version output of qutebrowser:
> https://paste.the-compiler.org/view/ea2d3602
> Has been going on for months now, but I don't think I filed a bug.
> Does not show up at all in pavucontrol.

Is this on Guix System or another distro?

Could it be #40832 (alsa-lib cannot find its plugins)?
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40832

That bug breaks audio of Guix applications on foreign distros in many
cases.




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#45280: qutebrowser has no audio
  2020-12-16 23:25 ` Leo Famulari
@ 2021-02-01 20:49   ` Leo Famulari
  0 siblings, 0 replies; 7+ messages in thread
From: Leo Famulari @ 2021-02-01 20:49 UTC (permalink / raw)
  To: 45280; +Cc: 45280-done

On Wed, Dec 16, 2020 at 06:25:51PM -0500, Leo Famulari wrote:
> On Wed, Dec 16, 2020 at 03:29:42PM -0600, bdju via Bug reports for GNU Guix wrote:
> > guix (GNU Guix) 91e35e32a4938e0e37499c64fa8ed3e7cf51dce3
> > qutebrowser v1.14.0
> > full :version output of qutebrowser:
> > https://paste.the-compiler.org/view/ea2d3602
> > Has been going on for months now, but I don't think I filed a bug.
> > Does not show up at all in pavucontrol.
> 
> Is this on Guix System or another distro?
> 
> Could it be #40832 (alsa-lib cannot find its plugins)?
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40832
> 
> That bug breaks audio of Guix applications on foreign distros in many
> cases.

Closing due to lack of info. Please feel free to re-open if the bug
still occurs :)




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#45280: qutebrowser has no audio
  2020-12-16 21:29 bug#45280: qutebrowser has no audio bdju via Bug reports for GNU Guix
  2020-12-16 23:25 ` Leo Famulari
@ 2021-02-02  1:28 ` bdju--- via Bug reports for GNU Guix
  2021-04-21 23:44   ` bdju via Bug reports for GNU Guix
  2021-04-22 13:12 ` bug#45280: Qutebrowser doesn't display embedded mp4 jcguu95
  2 siblings, 1 reply; 7+ messages in thread
From: bdju--- via Bug reports for GNU Guix @ 2021-02-02  1:28 UTC (permalink / raw)
  To: 45280

Sorry I don't think I saw the previous reply. Absolutely still a
problem. I am on Guix System. It is not at all a system-wide issue. Most
things have sound working fine.





^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#45280: qutebrowser has no audio
  2021-02-02  1:28 ` bdju--- via Bug reports for GNU Guix
@ 2021-04-21 23:44   ` bdju via Bug reports for GNU Guix
  2022-06-14 23:50     ` bdju via Bug reports for GNU Guix
  0 siblings, 1 reply; 7+ messages in thread
From: bdju via Bug reports for GNU Guix @ 2021-04-21 23:44 UTC (permalink / raw)
  To: bdju, 45280

Here's some output when I launch qutebrowser from a terminal. It seems
like it may be using ALSA instead of pulse for some reason.
```
ALSA lib pcm_dmix.c:1075:(snd_pcm_dmix_open) unable to open slave
[14812:14812:0421/184051.727290:ERROR:alsa_util.cc(204)] PcmOpen:
default,No such file or directory
ALSA lib pcm_dmix.c:1075:(snd_pcm_dmix_open) unable to open slave
[14812:14812:0421/184051.728902:ERROR:alsa_util.cc(204)] PcmOpen:
plug:default,No such file or directory
[14656:13:0421/184058.289956:ERROR:batching_media_log.cc(38)]
MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
[14656:1:0421/184058.290464:ERROR:batching_media_log.cc(35)] MediaEvent:
{"pipeline_error":14}
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
ALSA lib pcm_dmix.c:1075:(snd_pcm_dmix_open) unable to open slave
[14812:14812:0421/184144.908489:ERROR:alsa_util.cc(204)] PcmOpen:
default,No such file or directory
ALSA lib pcm_dmix.c:1075:(snd_pcm_dmix_open) unable to open slave
[14812:14812:0421/184144.911093:ERROR:alsa_util.cc(204)] PcmOpen:
plug:default,No such file or directory
```




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#45280: Qutebrowser doesn't display embedded mp4.
  2020-12-16 21:29 bug#45280: qutebrowser has no audio bdju via Bug reports for GNU Guix
  2020-12-16 23:25 ` Leo Famulari
  2021-02-02  1:28 ` bdju--- via Bug reports for GNU Guix
@ 2021-04-22 13:12 ` jcguu95
  2 siblings, 0 replies; 7+ messages in thread
From: jcguu95 @ 2021-04-22 13:12 UTC (permalink / raw)
  To: 45280

Hello,

I'm on guix system with the latest `qutebrowser' from the official
channel. While reading this [site] I realize that embedded mp4 files do
not play well. Turning on qb again from the terminal allowed me to see
the complaints. I believe this could be related issues to OP, so decided
to post it here.

,----
| [5173:12:0421/182550.069329:ERROR:batching_media_log.cc(38)]
| MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
| [5173:1:0421/182550.373463:ERROR:batching_media_log.cc(35)]
| MediaEvent: {"pipeline_error":14}
| [5173:12:0421/182550.514768:ERROR:batching_media_log.cc(38)]
| MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
| [5173:12:0421/182550.516035:ERROR:batching_media_log.cc(38)]
| MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
| [5173:1:0421/182550.520021:ERROR:batching_media_log.cc(35)]
| MediaEvent: {"pipeline_error":14}
| [5173:1:0421/182550.528375:ERROR:batching_media_log.cc(35)]
| MediaEvent: {"pipeline_error":14}
| [5173:12:0421/182550.553097:ERROR:batching_media_log.cc(38)]
| MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
| [5173:1:0421/182550.553613:ERROR:batching_media_log.cc(35)]
| MediaEvent: {"pipeline_error":14}
| [5173:12:0421/182550.591314:ERROR:batching_media_log.cc(38)]
| MediaEvent: {"error":"FFmpegDemuxer: no supported streams"}
| [5173:1:0421/182550.591727:ERROR:batching_media_log.cc(35)]
| MediaEvent: {"pipeline_error":14}
| [5141:5156:0421/182557.327374:ERROR:ssl_client_socket_impl.cc(959)]
| handshake failed; returned -1, SSL error code 1, net_error -113
`----

-- Best, Jin


[site] <https://www.ramitmittal.com/blog/15-days-in-dired/>




^ permalink raw reply	[flat|nested] 7+ messages in thread

* bug#45280: qutebrowser has no audio
  2021-04-21 23:44   ` bdju via Bug reports for GNU Guix
@ 2022-06-14 23:50     ` bdju via Bug reports for GNU Guix
  0 siblings, 0 replies; 7+ messages in thread
From: bdju via Bug reports for GNU Guix @ 2022-06-14 23:50 UTC (permalink / raw)
  To: bdju, 45280-done

I have finally gotten sound working. I needed to enable an alsa service
(which also required the sound and possibly audio use-service-modules)
aplay and speaker-test were failing, which seemed to possibly be due to
a lack of /etc/asound.conf, and I found in the manual that the alsa
service creates this file. After enabling that service, I just had to
restart qutebrowser.
As an aside, I think if our qutebrowser package were built with the
optional pulseaudio support enabled, I would never have hit this issue.
Although you could argue that having broken alsa was probably not good
anyway.

I will finally close this issue.




^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-06-14 23:51 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-16 21:29 bug#45280: qutebrowser has no audio bdju via Bug reports for GNU Guix
2020-12-16 23:25 ` Leo Famulari
2021-02-01 20:49   ` Leo Famulari
2021-02-02  1:28 ` bdju--- via Bug reports for GNU Guix
2021-04-21 23:44   ` bdju via Bug reports for GNU Guix
2022-06-14 23:50     ` bdju via Bug reports for GNU Guix
2021-04-22 13:12 ` bug#45280: Qutebrowser doesn't display embedded mp4 jcguu95

Code repositories for project(s) associated with this inbox:

	https://git.savannah.gnu.org/cgit/guix.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).