unofficial mirror of bug-guix@gnu.org 
 help / color / mirror / Atom feed
* bug#50480: (current-guix) does not build
@ 2021-09-08 16:39 Dhruvin Gandhi via Bug reports for GNU Guix
  0 siblings, 0 replies; only message in thread
From: Dhruvin Gandhi via Bug reports for GNU Guix @ 2021-09-08 16:39 UTC (permalink / raw)
  To: 50480


During a conversation with maximed on irc, they suggested I could
possibly use (current-guix) to package latest guix with a VM image I was
creating for sourcehut builder.

I tried building (current-guix) with latest guix (after guix pull) as
well as tried building it with ./pre-install-env guix form a local guix
checkout (after git pull on master).

It did not build. Here are build logs:
https://paste.sr.ht/~dhruvin/0cd1993a8360bc5b69dd5aecb1fd62a637b4999e

The source does not seem to contain tests directory. When
'disable-failing-tests' phase tries to modify
'tests/syscalls.scm.XXXXXX' it fails, causing the build to fail too.

Let me know if there's anything I can do.




^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2021-09-09  8:32 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-08 16:39 bug#50480: (current-guix) does not build Dhruvin Gandhi via Bug reports for GNU Guix

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).